ISE and SMS integration, how to configure

Unanswered Question
Sep 3rd, 2012

Hello folks,

I wonder what I have to do in ISE to enable it sending SMS when activating a new guest account. I believe there must be a corresponding setting somewhere under Web Portal Management to configure SMS gateway neither under Global system settings.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
zheka_pefti Wed, 09/05/2012 - 10:30

What you referred me to is configuring the way it the SMS or email message will look like, i.e.template.

My problem is with connection settings. I can't even send the email from ISE not even sending SMS

Tarik Admani Wed, 09/05/2012 - 10:33

Hi,

I tried to look into this and it seems as if the smtp gateway is also the sms gateway also. I am thinking that somehow the exchange server will have to have an sms gateway configured to it, but I agree with you it isnt very clear as to how you an send the message with just the phone number, I would think you would need the domain also.

For better results you may want to open a TAC case to see if someone could shed more light on this for you.

Tarik Admani
*Please rate helpful posts*

descalante2007 Wed, 01/23/2013 - 13:50

Have you fixed the problem to send email to guest users? ... I receive an "Internal Error" message when I try to send email to a guest ... How can I troubleshoot and verify at least the ISE is trying to reach the SMTP server?

conleya Wed, 09/05/2012 - 10:42

On the page where you customize the SMS message there is a field for the Destination.  This is where you specify the SMS gateway e-mail address.  My ISE has this set to sms@example.com by default.  You would change this to whatever the e-mail address of your SMS gateway is.

zheka_pefti Wed, 09/05/2012 - 12:41

I'm wondering what kind of logic did ISE developers pursue to hide SMS gateway portal connection setting in the Language template. I'm still not able to send email to the user who is setup as a guest. ISE gives me an internal error even though I have configured the right SMTP server under ISE Administration->System->SMTP Server. ISE and SMTP server are in the same network and there are no relay restrictions on the mail server.

Andrey.Gulenko Fri, 12/14/2012 - 01:40

Faced with a similar problem (in Cisco ISE 1.1.2.142).

When editing a template (Administration->Web Portal Management->Settings->Sponsor->Language Template->English) "Configure SMS Text Message Notification", if the field "* Destination" set to "%mobilenumber%@sms.domainname.net", then there will be no change of the variable "%mobilenumber%" to the phone number entered in the "Guest Account->Phone Number:".

Whether it is possible to use variables "%mobilenumber%" in the "* Destination"?

zheka_pefti Wed, 01/23/2013 - 14:19

It looks there's a big gap between what's in Cisco documentation and in the real state of things. Anyone from Cisco support please disprove it. I would appreciate if there's a detailed guide covering just this portion. Why on earth mentioning this feature in the first place if it doesn't work.

ravsingh Mon, 08/05/2013 - 20:05

n Cisco ISE, Release 1.1 internalization (UTF-8)  and localization support is focused on the text and information that is  presented to end user (connecting to Cisco ISE) through the Sponsor,  Guest, and Client Provisioning portals. This support includes  internationalizing all text in the end user interfaces, such as labels,  messages, and input configured by the end user or Cisco ISE  administrator and displayed in the Sponsor, Guest, and Client  Provisioning portals. Guest account information that is notified through  email and SMS is also localized.

To confgiure ISE SMS notification for guest account please see the attached PDF file.

mbilgrav Tue, 09/24/2013 - 03:13

Has ANYONE succeed in getting ISE to sent SMS to a varialbe guest Mobilenumber ?

I need the ISE to sent SMS (Via email2SMSgateway service - i know) via the sponsor webpage to that number the sponsor types in. I:E. a variable mobile number

I can only get this work with FIXED mobile-numbers - not variable ones.

Any ideas ?

I use ISE1.2

I have read and tested the link and PDF in this thread. Did you manage to get your to work and how ?

Kind regards'

Martin

Andrey.Gulenko Tue, 09/24/2013 - 07:32

This issue has not been resolved ( %mobilenumber% variable is not inserted into address %mobilenumber%@domain.net).

We opened case on this issue, but it is not yet resolved .

But support working in this direction - is already fixed problems with subdomains (@sms.domain.net) and restrictions on the number of characters after symbol @.

This issue we have resolved as follows: all notifications are sent to corporate e-mail Microsoft Exchange Server, where rule is configured to process messages sent over e-mail/SMS gateway (based on field *Destination in template "Configure SMS Text Notification"). According to this rule, Microsoft Exchange sends these messages to another server that is running a regular "Microsoft SMTP Service" ( for receiving and storing messages in a local folder). The same connector is configured to send messages for @sms.domain.net back to the mail server Microsoft Exchange. In the scheduler is configured launch PowerShell script that "cuts" from the body of the message variable %mobilenumber% (which was previously defined in template "Configure SMS Text Notification") and inserts it into address %mobilenumber%@sms.domain.net.mobilenumber%@sms.domain.net.

When the problem is resolved, this server will not be used/needed, and SMS message will be forwarded directly to the gateway e-mail/SMS or in SMSC.

Sincerely,

Andrey

Actions

Login or Register to take actions

This Discussion

Posted September 3, 2012 at 10:26 AM
Stats:
Replies:12 Avg. Rating:5
Views:1858 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard