block specific incoming call number FXO

Unanswered Question
Sep 12th, 2012
User Badges:

I try to block incoming calls from specific number on fxo


here's what I did :



voice translation-rule 11000

rule 1 reject /**********/    (I enter my phone number)

!

!

voice translation-profile CALL_BLOCK

translate calling 11000



!

dial-peer voice 50 pots

description ** incoming dial peer **

incoming called-number ^AAAA$

port 0/1/0

!

dial-peer voice 51 pots

description ** incoming dial peer **

call-block translation-profile incoming CALL_BLOCK

call-block disconnect-cause incoming invalid-number

incoming called-number ^AAAA$

port 0/1/1

!

dial-peer voice 54 pots

description ** FXO pots dial-peer **

call-block translation-profile incoming CALL_BLOCK

call-block disconnect-cause incoming invalid-number

destination-pattern A0

port 0/1/0

no sip-register

!

dial-peer voice 55 pots

description ** FXO pots dial-peer **

destination-pattern A1

port 0/1/1

no sip-register

!


I tried 2 methods, one on my fxo port 0 and one of my fxo port 1,


when i call port 0 everything's normal but when I call port 1, it takes like 5 rings to get to the phone and it shows anonymous as the caller Id instead of my phone number


why it's not working ?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Wed, 09/12/2012 - 09:02
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Apply the translation-profile under voice-port, not dial-peer.

datak2011 Wed, 09/12/2012 - 11:11
User Badges:

in this ???


when i try to, i can't enter the cmd line

!

voice-port 0/1/0

trunk-group ALL_FXO 64

cptone CA

connection plar opx 296

description Configured by CCA 4 FXO-0/1/0-Custom-OP

caller-id enable

!

voice-port 0/1/1

trunk-group ALL_FXO 64

cptone CA

connection plar opx 296

description Configured by CCA 4 FXO-0/1/1-Custom-OP

caller-id enable

!

voice-port 0/1/2

trunk-group ALL_FXO 64

cptone CA

connection plar opx 296

description Configured by CCA 4 FXO-0/1/2-Custom-OP

caller-id enable

!

voice-port 0/1/3

trunk-group ALL_FXO 64

cptone CA

connection plar opx 296

description Configured by CCA 4 FXO-0/1/3-Custom-OP

caller-id enable

!

paolo bevilacqua Fri, 09/14/2012 - 23:49
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

I can tell you what works, then it's up to you  to try it or not.

datak2011 Mon, 09/17/2012 - 06:00
User Badges:

like I told you when I try to enter the command line under Voice-port cisco ios won't let me enter the command..

paolo bevilacqua Mon, 09/17/2012 - 10:53
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

That is what command?


Anyway that method of blocking call might not work with FXO at all.