Help with IPSec Android Connection

Unanswered Question
Apr 3rd, 2012

Hi, Hoping someone could help me setup IPSec on SA540 for use with Android HTC Wildfire S. I've setup my SA540 as below however the mobile is unable to connect. Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
not12bhere Fri, 04/06/2012 - 06:49

First question: which version of Android are you running and which client are you using to connect? ICS with built in? I have succesfully gotten an ICS tablet to connect to the SA520 using the built in stock ICS client. Sadly, I have never gotten the tunnel to pass actual traffic.

1) Change Exchange Mode from Agressive to Main

2) Uncheck dead peer detection (may not be an issue for your connection)

3) you will need a pre-shared key (I understand you may have it blank just for this post)

nsweetman Fri, 04/06/2012 - 08:00

Hi, Thank for you post I've given what you said a try (Changing to Main and disable Dead Peer) however no luck I've since found several posts in regards to Android Cisco VPN support seems I'm not the only one having the problem. There is a request for Android to support Group_ID untill then doesn't look like I will get it working.

However the same ipsec setup works great on iPhone/iPad


http://code.google.com/p/android/issues/detail?id=3902

With regards

Nick

Actions

Login or Register to take actions

This Discussion

Posted April 3, 2012 at 12:00 PM
Stats:
Replies:2 Avg. Rating:
Views:3700 Votes:0
Shares:0
Tags: ipsec, vpn, android, 540, htc
+

Related Content

Discussions Leaderboard