Cisco 2800 Router Physical and sub interface

Unanswered Question
Oct 26th, 2012
User Badges:

Hello All,


I have a pair of router Cisco 2800 running in HSRP, now I want to configure one sub interface with another subnet, Will my current IP on physical interface work or do I need to create two Sub interfaces for each network. Do i must need encapsulation on sub interface

Cureent Config:-

Router 1:-

interface FastEthernet0/1
description Connect to LAN_SW1 Gi1/0/1
ip address 192.168.1.13 255.255.255.0
no ip redirects
duplex auto
speed auto
standby 1 ip 192.168.1.1
standby 1 priority 90
standby 1 preempt


Router 2:-


interface FastEthernet0/1
description Connect to LAN_SW2 Gi1/0/1
ip address 192.168.1.3 255.255.255.0
no ip redirects
duplex auto
speed auto
standby 1 ip 192.168.1.1
standby 1 priority 110
standby 1 preempt



____________________________

For second network I do not require HSRP


Router 1:-

interface FastEthernet0/0
description Connect to LAN_SW1 Gi1/0/1
no ip address
duplex full
speed 100


interface FastEthernet0/0.100
description **VLAN1**
encapsulation dot1Q 100
ip address 192.168.1.13 255.255.255.0
no ip redirects
standby 1 ip 192.168.1.1
standby 1 priority 90
standby 1 preempt

!
interface FastEthernet0/0.200
description **VLAN2**
encapsulation dot1Q 200
ip address 172.16.1.13 255.255.255.0
no ip redirects


Router 2:-

interface FastEthernet0/0
description Connect to LAN_SW2 Gi1/0/1
no ip address
duplex full
speed 100


interface FastEthernet0/0.100
description **VLAN1**
encapsulation dot1Q 100
ip address 192.168.1.3 255.255.255.0
no ip redirects
standby 1 ip 192.168.1.1
standby 1 priority 90
standby 1 preempt

!
interface FastEthernet0/0.200
description **VLAN2**
encapsulation dot1Q 200
ip address 172.16.1.3 255.255.255.0
no ip redirects

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
SOcchiogrosso Fri, 10/26/2012 - 06:09
User Badges:
  • Bronze, 100 points or more

Creating Sub-Interfaces will be the correct way to go here also make sure you create you VLANs on the switch and tag the appropriate ports, You will also want delay the preempt on the master for the best results.  Might also want to look into tuning the HSRP timers for optimal failover times.


http://ccie-or-null.net/2012/05/24/lets-configure-hsrp-hot-standby-routing-protocol/


--

CCNP, CCIP, CCDP, CCNA: Security/Wireless
Blog: http://ccie-or-null.net/

jagdev.dhaliwal Fri, 10/26/2012 - 06:17
User Badges:

Can't i go like below config:-



Router 1:-
interface FastEthernet0/1
description Connect to LAN_SW1 Gi1/0/1
ip address 192.168.1.13 255.255.255.0
no ip redirects
duplex auto
speed auto
standby 1 ip 192.168.1.1
standby 1 priority 90
standby 1 preempt

interface FastEthernet0/0.200
description **VLAN2**
ip address 172.16.1.13 255.255.255.0
no ip redirects


Router 2:-

interface FastEthernet0/1
description Connect to LAN_SW2 Gi1/0/1
ip address 192.168.1.3 255.255.255.0
no ip redirects
duplex auto
speed auto
standby 1 ip 192.168.1.1
standby 1 priority 110
standby 1 preempt

interface FastEthernet0/0.200
description **VLAN2**
ip address 172.16.1.3 255.255.255.0
no ip redirects


Thanks

Jagdev

SOcchiogrosso Fri, 10/26/2012 - 06:49
User Badges:
  • Bronze, 100 points or more

You could, but you can also improve that deisgn, by tuning timers and delaying the preempt action.


--

CCNP, CCIP, CCDP, CCNA: Security/Wireless
Blog: http://ccie-or-null.net/

Actions

This Discussion

Related Content