TMS Scheduler wrong Time format

Answered Question
Jul 31st, 2012

Dear Support Community,

As you can see on the screenshot the problem with the german version of the scheduler is that the time is wrong shown, after 12:45 it shows 1:00 instead of 13:00, are you aware of this issue?

kind regards

christian

I have this problem too.
0 votes
Correct Answer by Magnus Ohm about 1 year 7 months ago

Hi This case has now been resolved

The issue was in the TMS server registery under HKEY_USER\.Default\Control Panel\International

These two fields was missing AM and PM once re-populated the AM PM problem went away.

This field was changed to HH:mm which initiated german time to show in 24 hour format.

Then the problem was resolved.

/Magnus

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (5 ratings)
Kjetil Ree Tue, 07/31/2012 - 01:50

It looks good in my TMS if the user language is set to German. I'm not sure if you see a language-specific problem here.

-Kjetil

christianfroehlich Tue, 07/31/2012 - 06:44

Dear Support Community,

Please let me clarify the problem description. Scheduling the dates with the english version works fine, because of the 24h time format. But if you use the german version you have a 2x 12h time format, as you can see on the screenshot after 12:45 comes 01:00. There are 2x 3o'clocks without AM or PM and when choosing either of them the following error is appearing, it is not possible to schedule meeting in the past. The Time it has been tested was 02:00 PM.

kind regards

christian

christianfroehlich Wed, 08/01/2012 - 00:28

Dear Support Community,

the settings were changed from “Local Time” to “Server Time”. The error still occurs.

Martin Koch Wed, 08/01/2012 - 00:51

Hi Christian!

Could you define "use the german version"?

When I use TMS and switch the laguage / sprache of a specific user to german:

I get the scheduler automatically in german as well as the 24h time format.

The scheduler is accessed via:

http://tms/tms/Tandberg/TMS/UI/TandbergScheduler/Default.aspx

What TMS version do you run? I tested this with 13.2.1 and 13.1.2, both react the same and

as I would expect and how Kjetill also had reported it.

christianfroehlich Wed, 08/01/2012 - 03:13

Hi Martin,

Thank you for answer.

so here are time formats and test time:

1) in english version time is 24h format (14:45 indicates that).

2) in german version time is 12h format (but there is not AM or PM next to clock).

3) this is time when i was testing it.

4) choosing first 3 o'clock and that second 3 o'clock.

5) error that came up in both situation.

Martin Koch Wed, 08/01/2012 - 03:58

You still kept it a secret which TMS version you run and how you configure / access "english vs. german".

You have to do this in the user setting (see my screenshot) and there are even three different english

versions, uk uses for example 24h, us 12h am/pm.

Did you do any modifications to your TMS?

Do you use an external db? Is the colation of the SQL database proper set to SQL_ Latin1_General_Cp1_CI_AS or SQL_Latin1_General_Cp1_CS_AS.

christianfroehlich Wed, 08/01/2012 - 06:12

Hi Martin,

Thanks for your investigation.

The Software Version of TMS is 13.2.1 and we are switching between languages in exactly the same way you did in user preferences. There are no modifications. Just the TMS and TMSPE are installed.

It’s an internal SQL Server on the TMS.

Can you please clarify what you mean here:

"Is the colation of the SQL database proper set to SQL_ Latin1_General_Cp1_CI_AS or SQL_Latin1_General_Cp1_CS_AS"

Martin Koch Wed, 08/01/2012 - 08:46

If you never heard about it its most likely not an issue, especially if you use the internal mssql express server

installed during the TMS install. Just googled for it the first hit how to check it was:

http://blog.sqlauthority.com/2007/08/30/sql-server-2005-find-database-collation-using-t-sql-and-ssms/

What I would recomend, try a different browser and best computer / operating system

to access TMS, try for example a remote desktop session to the TMS and use IE.

To see that its not a local issue with a specific browser (what do you use currently?)

If this does not show any change and you do not get a better answer here, escalate it as

a service request to Cisco TAC. At least with what Kjetil and I see, your result is different.

Please update this discussion afterwards on how you solved it!

Viel Erfolg!

Martin

Christian: bitte bewerte die Postings durch anklicken der Sterne unter den Nachrichten!

Correct Answer
Magnus Ohm Tue, 08/28/2012 - 04:44

Hi This case has now been resolved

The issue was in the TMS server registery under HKEY_USER\.Default\Control Panel\International

These two fields was missing AM and PM once re-populated the AM PM problem went away.

This field was changed to HH:mm which initiated german time to show in 24 hour format.

Then the problem was resolved.

/Magnus

Actions

Login or Register to take actions

This Discussion

Posted July 31, 2012 at 1:35 AM
Stats:
Replies:9 Avg. Rating:5
Views:783 Votes:0
Shares:0

Related Content

Discussions Leaderboard