SIP INCOMING CALLS NOT WORKING

Unanswered Question
Nov 13th, 2012

Hi

Setup:

ISP SIP--> VG SIP--> CUCM- Extensions

Sip Trunk in CUCM: Destination Port 5080 (Requested by ISP)

Below is the trace

Calling number:22551286

Called number:00302155203740

Extension:2803

CUCMs: 192.168.1.241 , 192.168.1.242

ISP network:10.224.71.68

In my interface connected with ISP modem:192.168.10.253

Problem::

Incoming calls never going to the extension number:

If i try to bind SIP  media and call control then i lose the registration with ISP.

So i dont use sip binds

Nov 13 10:41:56.577: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

INVITE sip:00302155203740@192.168.10.253:5080 SIP/2.0

Max-Forwards: 8

Via: SIP/2.0/UDP 10.224.71.68:5060;branch=z9hG4bKexvdikw6s2mon6c83x7hbdxw7

To: "ICT LOGICOM SOLUTIONS AE" <sip:00302155203740@fmc.cyta.com.gr>;cscf

From: <sip:22551286@anonymous.invalid;user=phone>;tag=h7g4Esbg_1305616646-1352803356905-

Call-ID: BW124236905131112-787426872@10.224.74.10

CSeq: 1018071157 INVITE

Contact: <sip:sgc_c@10.224.71.68;transport=udp>

Record-Route: <sip:10.224.71.68;transport=udp;lr>

Min-Se: 600

Privacy: none

Session-Expires: 1800

Supported: 100rel

Content-Type: application/sdp

Content-Length: 490

Allow: ACK, BYE, CANCEL, INVITE, OPTIONS, PRACK, REFER, NOTIFY, INFO, UPDATE

Accept: application/sdp

Accept: application/media_control+xml

Accept: multipart/mixed

v=0

o=BroadWorks 820925148 1 IN IP4 10.224.71.68

s=-

c=IN IP4 10.224.71.5

t=0 0

m=audio 31494 RTP/AVP 8 18 100

a=rtpmap:8 PCMA/8000

a=rtpmap:18 G729/8000

a=fmtp:18 annexb=yes

a=rtpmap:100 telephone-event/8000

a=fmtp:100 0-15

a=sqn: 0

a=cdsc: 1 audio RTP/AVP 8 18 100

a=cpar: a=rtpmap:8 PCMA/8000

a=cpar: a=rtpmap:18 G729/8000

a=cpar: a=fmtp:18 annexb=yes

a=cpar: a=rtpmap:100 telephone-event/8000

a=cpar: a=fmtp:100 0-15

a=cdsc: 4 image udptl t38

a=sendrecv

a=ptime:20

Nov 13 10:41:56.593: //5019/94729857823C/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 100 Trying

Via: SIP/2.0/UDP 10.224.71.68:5060;branch=z9hG4bKexvdikw6s2mon6c83x7hbdxw7

From: <sip:22551286@anonymous.invalid;user=phone>;tag=h7g4Esbg_1305616646-1352803356905-

To: "ICT LOGICOM SOLUTIONS AE" <sip:00302155203740@fmc.cyta.com.gr>;cscf

Date: Tue, 13 Nov 2012 10:41:56 GMT

Call-ID: BW124236905131112-787426872@10.224.74.10

CSeq: 1018071157 INVITE

Allow-Events: telephone-event

Server: Cisco-SIPGateway/IOS-15.2.4.M1

Content-Length: 0

Nov 13 10:41:56.597: //5020/94729857823C/SIP/Msg/ccsipDisplayMsg:

Sent:

INVITE sip:2803@192.168.1.241:5060 SIP/2.0

Via: SIP/2.0/UDP 192.168.10.253:5080;branch=z9hG4bK12D32260

From: <sip:22551286@fmc.cyta.com.gr>;tag=E574B00-240E

To: <sip:2803@192.168.1.241>

Date: Tue, 13 Nov 2012 10:41:56 GMT

Call-ID: 94750990-2CB511E2-8242CD61-D98E522@fmc.cyta.com.gr

Supported: 100rel,timer,resource-priority,replaces,sdp-anat

Min-SE:  1800

Cisco-Guid: 2490538071-0750064098-2185022817-0228123938

User-Agent: Cisco-SIPGateway/IOS-15.2.4.M1

Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER

CSeq: 101 INVITE

Timestamp: 1352803316

Contact: <sip:22551286@192.168.10.253:5080>

Expires: 60

Allow-Events: telephone-event

Max-Forwards: 7

Session-Expires:  1800

Content-Type: application/sdp

Content-Disposition: session;handling=required

Content-Length: 288

v=0

o=CiscoSystemsSIP-GW-UserAgent 8250 565 IN IP4 192.168.10.253

s=SIP Call

c=IN IP4 192.168.10.253

t=0 0

m=audio 16694 RTP/AVP 8 18 101

c=IN IP4 192.168.10.253

a=rtpmap:8 PCMA/8000

a=rtpmap:18 G729/8000

a=fmtp:18 annexb=yes

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-15

Nov 13 10:41:56.709: //5020/94729857823C/SIP/Msg/ccsipDisplayMsg:

Received:

SIP/2.0 183 Session Progress

Via: SIP/2.0/UDP 192.168.10.253:5080;received=10.93.7.245;branch=z9hG4bK12D32260

To: <sip:2803@192.168.1.241>;tag=h7g4Esbg_16990-1352803357044

From: <sip:22551286@fmc.cyta.com.gr>;tag=E574B00-240E

Call-ID: 94750990-2CB511E2-8242CD61-D98E522@fmc.cyta.com.gr

CSeq: 101 INVITE

Contact: <sip:sgc_c@10.224.71.68;transport=udp>

Record-Route: <sip:10.224.71.68;transport=udp;lr>

Require: 100rel

RSeq: 1018071226

Content-Type: application/sdp

Content-Length: 224

Session: Media

Allow: ACK, BYE, CANCEL, INVITE, OPTIONS, PRACK, REFER, NOTIFY, UPDATE, INFO

v=0

o=BroadWorks 820925158 1 IN IP4 10.224.71.68

s=-

c=IN IP4 10.224.71.15

t=0 0

m=audio 11750 RTP/AVP 8 101

c=IN IP4 10.224.71.15

a=rtpmap:8 PCMA/8000

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-15

a=ptime:20

Nov 13 10:41:56.713: //5020/94729857823C/SIP/Msg/ccsipDisplayMsg:

Sent:

PRACK sip:sgc_c@10.224.71.68;transport=udp SIP/2.0

Via: SIP/2.0/UDP 192.168.10.253:5080;branch=z9hG4bK12D4E9

From: <sip:22551286@fmc.cyta.com.gr>;tag=E574B00-240E

To: <sip:2803@192.168.1.241>;tag=h7g4Esbg_16990-1352803357044

Date: Tue, 13 Nov 2012 10:41:56 GMT

Call-ID: 94750990-2CB511E2-8242CD61-D98E522@fmc.cyta.com.gr

CSeq: 102 PRACK

RAck: 1018071226 101 INVITE

Route: <sip:10.224.71.68;transport=udp;lr>

Allow-Events: telephone-event

Max-Forwards: 70

Content-Length: 0

Nov 13 10:41:56.717: //5019/94729857823C/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 183 Session Progress

Via: SIP/2.0/UDP 10.224.71.68:5060;branch=z9hG4bKexvdikw6s2mon6c83x7hbdxw7

From: <sip:22551286@anonymous.invalid;user=phone>;tag=h7g4Esbg_1305616646-1352803356905-

To: "ICT LOGICOM SOLUTIONS AE" <sip:00302155203740@fmc.cyta.com.gr>;cscf;tag=E574B78-1C5A

Date: Tue, 13 Nov 2012 10:41:56 GMT

Call-ID: BW124236905131112-787426872@10.224.74.10

CSeq: 1018071157 INVITE

Require: 100rel

RSeq: 8409

Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER

Allow-Events: telephone-event

Contact: <sip:00302155203740@192.168.10.253:5080>

Record-Route: <sip:10.224.71.68;transport=udp;lr>

Supported: sdp-anat

Server: Cisco-SIPGateway/IOS-15.2.4.M1

Content-Type: application/sdp

Content-Disposition: session;handling=required

Content-Length: 252

v=0

o=CiscoSystemsSIP-GW-UserAgent 3041 881 IN IP4 192.168.10.253

s=SIP Call

c=IN IP4 192.168.10.253

t=0 0

m=audio 16692 RTP/AVP 8 100

c=IN IP4 192.168.10.253

a=rtpmap:8 PCMA/8000

a=rtpmap:100 telephone-event/8000

a=fmtp:100 0-15

a=ptime:20

Nov 13 10:41:56.757: //5020/94729857823C/SIP/Msg/ccsipDisplayMsg:

Received:

SIP/2.0 200 OK

Via: SIP/2.0/UDP 192.168.10.253:5080;received=10.93.7.245;branch=z9hG4bK12D4E9

To: <sip:2803@192.168.1.241>;tag=h7g4Esbg_16990-1352803357044

From: <sip:22551286@fmc.cyta.com.gr>;tag=E574B00-240E

Call-ID: 94750990-2CB511E2-8242CD61-D98E522@fmc.cyta.com.gr

CSeq: 102 PRACK

Content-Length: 0

Nov 13 10:41:56.833: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

PRACK sip:00302155203740@192.168.10.253:5080 SIP/2.0

Max-Forwards: 8

Via: SIP/2.0/UDP 10.224.71.68:5060;branch=z9hG4bK6x44d917ejxu6pkeo1u9l898f

To: "ICT LOGICOM SOLUTIONS AE" <sip:00302155203740@fmc.cyta.com.gr>;tag=E574B78-1C5A;cscf

From: <sip:22551286@anonymous.invalid;user=phone>;tag=h7g4Esbg_1305616646-1352803356905-

Call-ID: BW124236905131112-787426872@10.224.74.10

CSeq: 1018071158 PRACK

RAck: 8409 1018071157 INVITE

Content-Length: 0

Nov 13 10:41:56.833: //5019/94729857823C/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 200 OK

Via: SIP/2.0/UDP 10.224.71.68:5060;branch=z9hG4bK6x44d917ejxu6pkeo1u9l898f

From: <sip:22551286@anonymous.invalid;user=phone>;tag=h7g4Esbg_1305616646-1352803356905-

To: "ICT LOGICOM SOLUTIONS AE" <sip:00302155203740@fmc.cyta.com.gr>;cscf;tag=E574B78-1C5A

Date: Tue, 13 Nov 2012 10:41:56 GMT

Call-ID: BW124236905131112-787426872@10.224.74.10

Server: Cisco-SIPGateway/IOS-15.2.4.M1

CSeq: 1018071158 PRACK

Content-Length: 0

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Paolo Bevilacqua Tue, 11/13/2012 - 03:55

Trace shows that CM takes and ansewr the calls, so you should  look what's happening there.

Nov 13 10:41:56.757: //5020/94729857823C/SIP/Msg/ccsipDisplayMsg:

Received:

SIP/2.0 200 OK

Via: SIP/2.0/UDP 192.168.10.253:5080;received=10.93.7.245;branch=z9hG4bK12D4E9

To: ;tag=h7g4Esbg_16990-1352803357044

From: 22551286@fmc.cyta.com.gr>;tag=E574B00-240E

Call-ID: 94750990-2CB511E2-8242CD61-D98E522@fmc.cyta.com.gr

CSeq: 102 PRACK

Content-Length: 0

chrysostomos1980 Tue, 11/13/2012 - 04:08

Hi Paolo

I saw that , but the calls never coming to the extension.This is the strange

In the sip trunk config in CUCM i have 4 significant digits and the CSS include the PT for my extension

When i shut the sip dial peers in VG and no shut to the h323 dial peers then the phone ringing

(With H323 we have other problem and this is the reason that i tried to check the sip

With H323 when i answer the call its stay active ONLY for 10 sec.And then its going down

Any ideas FOR all ?

Paolo Bevilacqua Tue, 11/13/2012 - 04:16

Are using NAT somewhere ? What is 10.93.7.245 ?

Nov 13 10:41:56.709: //5020/94729857823C/SIP/Msg/ccsipDisplayMsg:

Received:

SIP/2.0 183 Session Progress

Via: SIP/2.0/UDP 192.168.10.253:5080;received=10.93.7.245;branch=z9hG4bK12D32260

To: ;tag=h7g4Esbg_16990-1352803357044

From: 22551286@fmc.cyta.com.gr>;tag=E574B00-240E

Call-ID: 94750990-2CB511E2-8242CD61-D98E522@fmc.cyta.com.gr

CSeq: 101 INVITE

Contact:

Record-Route:

Require: 100rel

RSeq: 1018071226

Content-Type: application/sdp

Content-Length: 224

Session: Media

Allow: ACK, BYE, CANCEL, INVITE, OPTIONS, PRACK, REFER, NOTIFY, UPDATE, INFO

v=0

o=BroadWorks 820925158 1 IN IP4 10.224.71.68

s=-

c=IN IP4 10.224.71.15

t=0 0

m=audio 11750 RTP/AVP 8 101

c=IN IP4 10.224.71.15

a=rtpmap:8 PCMA/8000

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-15

a=ptime:20

chrysostomos1980 Tue, 11/13/2012 - 04:41

Hi

10.93.7.245 is the voice ip in the ISP Modem

Nov 13 10:41:56.757: //5020/94729857823C/SIP/Msg/ccsipDisplayMsg:

Received:

SIP/2.0 200 OK

Via: SIP/2.0/UDP 192.168.10.253:5080;received=10.93.7.245;branch=z9hG4bK12D4E9

To: ;tag=h7g4Esbg_16990-1352803357044

Paolo Bevilacqua Tue, 11/13/2012 - 05:14

10.93.7.245 is not in the same subnet as 192.168.10.253. I suspect there is NAT in there. Is that your router or their ?

Also, I don't understand why there is session progress coming in after invite.

chrysostomos1980 Tue, 11/13/2012 - 05:22

192.168.10.0 subnet is in the modem site(ISP) for private ip

192.168.10.253 in in my interface .254 is in the modem side

The above is a private network that gives the ISP throught the modem

Now they have also configure in their modem 10.93.7.0.245 which is the voice ip.In this connection they will pass internet and also voice

So they have different subnets configured for that

ip route 10.93.7.0 255.255.255.0 192.168.10.254

ip route 10.199.0.0 255.255.255.0 10.100.0.4

ip route 10.224.50.0 255.255.255.0 192.168.10.254

ip route 10.224.64.0 255.255.255.0 192.168.10.254

ip route 10.224.71.0 255.255.255.0 192.168.10.254

ip route 10.224.75.0 255.255.255.0 192.168.10.254

ip route 192.168.10.0 255.255.255.0 192.168.10.254

I spoke with the ISP and they said that they see the invite for my extension

Is it normal?

i am not sure about that

Paolo Bevilacqua Tue, 11/13/2012 - 05:35

In my expereince, one has to focus on the very first message that doesn't look normal, and that is the session progress above.

In CUCM, what is the address of SIP trunk, or H.323 GW ?

chrysostomos1980 Tue, 11/13/2012 - 05:41


For sip trunk i used 10.110.0.3 :

Also 10.110.0.3 is binding in this router for the h323 communication (existing setup)

!

interface Loopback0

ip address 10.110.0.3 255.255.255.255

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.110.0.3

!

Paolo Bevilacqua Tue, 11/13/2012 - 05:45

Please replace that with VG local interface address. Also  please configure VG for media flow-throgh, not flow-around.

chrysostomos1980 Tue, 11/13/2012 - 07:41

Hi

Thank you for the replies

i used the voice subinterface but the same results..

!

interface GigabitEthernet0/2.20

description ##### VOICE Vlan #####

encapsulation dot1Q 20

ip address 10.17.20.1 255.255.255.0

ip flow ingress

ip flow egress

!

Do you have any ideas?

Its really very strange

Paolo Bevilacqua Tue, 11/13/2012 - 08:36

You should have a router interface on subnet common to CM LAN interface.

Please use that and configure the corresponding address in CM.

Ayodeji oladipo... Tue, 11/13/2012 - 09:20

I also noticed in your trace that there is no "Trying" received from cucm before the "session progress".....

When CUBE sent an invite to cucm, the first response should be "trying" Thats how cucm says i am going to look for the number....Are you sending the full trace? If you are then something is wrong with the way CUCM is processing the sip invite

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

chrysostomos1980 Tue, 11/13/2012 - 10:05

Paolo and Aok Hi

Its the full trace from VG.Yes i noticed also that its  missing the trying message

below is the config .Any thoughts?

ip inspect name IOS_FIREWALL tcp

ip inspect name IOS_FIREWALL udp

ip inspect name IOS_FIREWALL icmp

ip inspect name IOS_FIREWALL h323

ip inspect name IOS_FIREWALL sip

!

ip cef

ip wccp 61 redirect-list To-WAAS

no ipv6 cef

!

voice-card 0

dspfarm

dsp services dspfarm

!

!

voice call send-alert

voice rtp send-recv

!

voice service voip

ip address trusted list

  ipv4 0.0.0.0 0.0.0.0

  ipv4 192.168.10.0 255.255.255.0

dtmf-interworking rtp-nte

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

supplementary-service h450.12

no supplementary-service sip moved-temporarily

no supplementary-service sip refer

fax protocol none

no fax-relay sg3-to-g3

sip

  registrar server

  localhost dns:fmf.cyta.com.gr

  outbound-proxy dns:sbhgt.fmdf.cyta.gr

  no update-callerid

  listen-port non-secure 5080

  early-offer forced

!

!

!

interface Loopback0

ip address 10.110.0.3 255.255.255.255

h323-gateway voip interface

  h323-gateway voip bind srcaddr 10.110.0.3

!

interface Tunnel0

bandwidth 1000

ip address 10.100.0.3 255.255.255.0

no ip redirects

ip mtu 1400

ip wccp 62 redirect in

ip flow ingress

ip nhrp authentication VsQP4=+_

ip nhrp map multicast 195.14.145.217

ip nhrp map 10.100.0.1 195.14.145.217

ip nhrp network-id 99

ip nhrp holdtime 600

ip nhrp nhs 10.100.0.1

ip tcp adjust-mss 1360

delay 1000

qos pre-classify

tunnel source GigabitEthernet0/1

tunnel mode gre multipoint

tunnel key 100000

tunnel protection ipsec profile LGCOMprofile

!

!

interface GigabitEthernet0/0

Description**SIP TRUNK**

ip address 192.168.10.253 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 62.169.34.67 255.255.255.240

ip flow ingress

ip flow egress

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

service-policy output QoS

!

interface GigabitEthernet0/2.10

description ##### DATA Vlan #####

encapsulation dot1Q 10

ip address 10.17.10.1 255.255.255.0

ip wccp 61 redirect in

ip flow ingress

ip flow egress

ip nat inside

ip inspect IOS_FIREWALL in

ip virtual-reassembly in

!

interface GigabitEthernet0/2.19

!

interface GigabitEthernet0/2.20

description ##### VOICE Vlan #####

encapsulation dot1Q 20

ip address 10.17.20.1 255.255.255.0

ip flow ingress

ip flow egress

ip flow egress

!

router eigrp 1

network 10.17.0.0 0.0.255.255

network 10.100.0.0 0.0.0.255

network 10.110.0.3 0.0.0.0

!

dial-peer voice 1001 voip

description **SIP Trunk to CYTA**

translation-profile incoming SIP-INCOMING

translation-profile outgoing OUTGOING

destination-pattern 10T

session protocol sipv2

session target sip-server

incoming called-number .

voice-class codec 2 

voice-class sip dtmf-relay force rtp-nte

dtmf-relay rtp-nte

ip qos dscp cs5 media

ip qos dscp cs4 signaling

no vad

!

dial-peer voice 3 voip

description * TO CUCM1 with SIP*

preference 1

destination-pattern 28[01].

monitor probe icmp-ping

session protocol sipv2

session target ipv4:192.168.1.241

incoming called-number .

voice-class codec 3 

voice-class sip dtmf-relay force rtp-nte

dtmf-relay rtp-nte

no vad  

!

dial-peer voice 4 voip

description * TO CUCM1 with SIP*

destination-pattern 28[0-1].

monitor probe icmp-ping

session protocol sipv2

session target ipv4:192.168.1.242

voice-class codec 3 

voice-class sip dtmf-relay force rtp-nte

dtmf-relay rtp-nte

no vad

!

sip-ua

credentials username 6789 PAssword htrfkmc8 realm fmf.cyta.com.gr

authentication username 6789@fmf.cyta.com.gr password htrfkmc8

no remote-party-id

retry invite 2

retry register 3

retry options 2

timers expires 60000

timers connect 100

timers register 1000

registrar dns:fm.cyta.com.gr expires 110

sip-server dns:fm.cyta.com.gr

connection-reuse

host-registrar

!

!

call-manager-fallback

secondary-dialtone 9

max-conferences 8 gain -6

transfer-system full-consult

timeouts interdigit 3

ip source-address 10.110.0.3 port 2000

max-ephones 42

max-dn 144

system message primary **HQ PBX SYSTEM IS DOWN**

moh "flash0:/music-on-hold.au"

!

For the sip trunk in cucm i use the voice interface:

10.17.20.1

Note:

The ISP say that the see in the invite message my extension.Is it normal?

Ayodeji oladipo... Wed, 11/14/2012 - 07:33

Chrys,

Sorry I dont have any idea why CUCM is not sending a trying to CUBE. Maybe its firewall related

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

chrysostomos1980 Tue, 11/13/2012 - 08:43

Paolo

Its a remote site (SRST SITE) which the phones registered to cucm.The communcation is via tunnel

Paolo Bevilacqua Tue, 11/13/2012 - 08:49

It seems to me there is some confusion, You would have to include a diagram with all the circuits, devices and addresses.

Actions

Login or Register to take actions

This Discussion

Posted November 13, 2012 at 3:48 AM
Stats:
Replies:17 Avg. Rating:
Views:1436 Votes:0
Shares:0

Related Content

Discussions Leaderboard