dmvpn eigrp neighour flapping

Unanswered Question
Nov 14th, 2012

my company config dmvpn and use eigrp as route , now the problem is the tunnel interface flapping  , and log:

*Nov 15 05:26:46.899: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 192.168.96.1 (Tunnel100) is down: Peer Termination received

*Nov 15 05:27:01.695: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 192.168.96.1 (Tunnel100) is up: new adjacency

*Nov 15 05:27:21.271: %ADJ-5-PARENT: Midchain parent maintenance for IP midchain out of Tunnel100, addr 192.168.96.1 - looped chain attempting to stack

     

*Nov 15 05:26:46.899: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 192.168.96.1 (Tunnel100) is down: Peer Termination received
*Nov 15 05:27:01.695: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 192.168.96.1 (Tunnel100) is up: new adjacency
*Nov 15 05:27:21.271: %ADJ-5-PARENT: Midchain parent maintenance for IP midchain out of Tunnel100, addr 192.168.96.1 - looped chain attempting to stack

how to deal with it ,top players ,thank you very much~~~~

config:

interface Tunnel100

description to_ShenYang

bandwidth 10000

ip address 192.168.96.137 255.255.255.0

no ip redirects

ip mtu 1400

ip hello-interval eigrp 100 15

ip hold-time eigrp 100 45

ip nhrp map 192.168.96.1 210.83.25.66

ip nhrp map multicast 210.83.25.66

ip nhrp network-id 1234

ip nhrp holdtime 60

ip nhrp nhs 192.168.96.1

ip nhrp shortcut

ip summary-address eigrp 100 10.19.100.0 255.255.255.0

ip summary-address eigrp 100 172.16.1.64 255.255.255.248

qos pre-classify

tunnel source GigabitEthernet0/0

tunnel mode gre multipoint

tunnel key 1234

tunnel protection ipsec profile myprofile

!

interface Tunnel101

description to_ShenYang_Backup

bandwidth 10000

ip address 192.168.97.137 255.255.255.0

no ip redirects

ip mtu 1400

ip hello-interval eigrp 100 15

ip hold-time eigrp 100 45

ip nhrp map multicast 59.44.43.217

ip nhrp map 192.168.97.129 59.44.43.217

ip nhrp network-id 5678

ip nhrp holdtime 60

ip nhrp nhs 192.168.97.129

ip nhrp shortcut

ip summary-address eigrp 100 10.19.100.0 255.255.255.0

ip summary-address eigrp 100 172.16.1.64 255.255.255.248

qos pre-classify

tunnel source GigabitEthernet0/0

tunnel mode gre multipoint

tunnel key 5678

tunnel protection ipsec profile myprofile1

!

router eigrp 100

network 10.19.100.0 0.0.0.255

network 172.16.1.64 0.0.0.7

network 192.168.96.0

network 192.168.97.0

          

interface Tunnel100

description to_ShenYang

bandwidth 10000

ip address 192.168.96.137 255.255.255.0

no ip redirects

ip mtu 1400

ip hello-interval eigrp 100 15

ip hold-time eigrp 100 45

ip nhrp map 192.168.96.1 210.83.25.66

ip nhrp map multicast 210.83.25.66

ip nhrp network-id 1234

ip nhrp holdtime 60

ip nhrp nhs 192.168.96.1

ip nhrp shortcut

ip summary-address eigrp 100 10.19.100.0 255.255.255.0

ip summary-address eigrp 100 172.16.1.64 255.255.255.248

qos pre-classify

tunnel source GigabitEthernet0/0

tunnel mode gre multipoint

tunnel key 1234

tunnel protection ipsec profile myprofile

!

interface Tunnel101

description to_ShenYang_Backup

bandwidth 10000

ip address 192.168.97.137 255.255.255.0

no ip redirects

ip mtu 1400

ip hello-interval eigrp 100 15

ip hold-time eigrp 100 45

ip nhrp map multicast 59.44.43.217

ip nhrp map 192.168.97.129 59.44.43.217

ip nhrp network-id 5678

ip nhrp holdtime 60

ip nhrp nhs 192.168.97.129

ip nhrp shortcut

ip summary-address eigrp 100 10.19.100.0 255.255.255.0

ip summary-address eigrp 100 172.16.1.64 255.255.255.248

qos pre-classify

tunnel source GigabitEthernet0/0

tunnel mode gre multipoint

tunnel key 5678

tunnel protection ipsec profile myprofile1

ip route 0.0.0.0 0.0.0.0 112.230.206.77

!
router eigrp 100
network 10.19.100.0 0.0.0.255
network 172.16.1.64 0.0.0.7
network 192.168.96.0
network 192.168.97.0

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Harish Balakrishnan Wed, 11/14/2012 - 23:40

Hello

Can you post the complete configuration.. Also another question is whether this was working earlier or since when you started seeing this issue

regards

Harish

Chetankumar Phu... Thu, 11/15/2012 - 04:07

Hi Zhuo Zhao,

This issue usually occurs if there is a routing loop for destination physical address, 210.83.25.66 in your case. Can you please check if there are any routing issues for this particular destination?

Regards,

Chetan

Actions

This Discussion

Related Content