WLC 2504, Multicast Stub & Apple TV

Unanswered Question
Dec 17th, 2012

Hi,

I was hoping that someone has come across the same issues we are experiencing with the Apple TV and WLC.

We currently have a Apple TV and iPhone same subnet connecting via Lightweight AP (different subnet) which connects to a Cisco3750 running IP Base. This connects to WAN routers managed by third party over a WAN and connects to far end Managed routers, these connect to other Cisco3750 IP Base and onto a 2504 Wireless LAN controller. We have used the the following document for WLC configuration;

http://www.cisco.com/en/US/products/hw/wireless/ps4570/products_tech_note09186a0080bb1d7c.shtml

We turn on Multicast globaly, with IGMP snooping enabled also enable Multicast Multicast under controller (only option available on 2504) and give the device  MCast address 239.21.1.150 . The P2P blocking action is disabled. Going to Monitor Multicast we can see the Report for 224.0.0.251

and MGID. However the issue is at the Sender Receiver side the iPhone cannot see the Airplay on the iPhone that should be seen if the end to end stream is working.

My focus is now on the Cisco3750's, allthough I do not totally understand why the device needs Multicast enabled as the Multicast Join and Group Traffic is encapsulated in the CAPWAP Tunnel is it not?

Anyway I have enabled the only option "ip multicast routing distributed" and under the Vlans that connect to WLC and AP's the only option available is the "ip pim passive" there is no "ip pim sparese-dense mode"

Any help and assitance on this would be greatly appreciated. I am sure the WLC is configured correctly, but I suspect that this will not work due to the IP Base image on the 3750's not being able to run full multicast or we need to use unicast for this solution that the 2504 does not support.

Regards

Darren

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
darren.frowen@me.com Tue, 12/18/2012 - 00:32

Ok,

After further reading, I think I now understand. I previously thought that the CAPWAP protocol would encapsulate the Multicast inside of a unicast packet, however this seems not to be the case as with the following statement from the same URL in the previous update;

"The Cisco Unified Wireless Network (CUWN) supports two methods of multicast distribution to access

points (APs) associated with the controller. In both modes, the original multicast packet from the wired

network is encapsulated inside a Layer 3 CAPWAP packet sent via either CAPWAP Unicast or Multicast to

the AP. Since the traffic is CAPWAP encapsulated, APs do not have to be on the same VLAN as the client

Bonjour traffic."

Therefore as we only have the Multicast Multicast Option using the 2504 WLC the CAPWAP will be a Multicast Packet and requires the Network to support Multicast from Controller to LWAP. As we have IP Base and a WAN to consider we would probably need to implement some kind of tunneling GRE and RP's etc.

Regards

Darren

darren.frowen@me.com Fri, 12/21/2012 - 00:09

Hi All,

Just as an update, this issue has now been solved. To confirm we have successfully sent the CAPWAP Multicast destined for apple TV via Airplay from source Apple iPad to a Apple TV and displayed Video from Internet on Large Screen TV. We used the well known GRE encapsulation to be able to send the traffic over a IP Enabled MPLS WAN. See the configuration below, this has been tried and tested;

Wireless Client and LWAP End

----------------------------

ip multicast routing distributed

!

interface Loopback0

description GRE Tunnel Source Interface

ip address 1.1.1.1 255.255.255.255

no shutdown

!

interface Tunnel0

description CAPWAP Multicast Traffic Encapsulation

ip address 192.168.1.1 255.255.255.252

tunnel source loopback 0

tunnel destination 2.2.2.2

ip pim sparse-dense-mode

no shutdown

!

interface vlan [LWAP_Vlan]

ip pim passive

!

ip mroute [WLC_Management_IP] 255.255.255.255 Tunnel0 [Reverse_Path_Chk_MCast_Source]

ip mroute 2.2.2.2 255.255.255.255 Tunnel0 [Reverse_Path_Chk_Tunnel_Source]

Wireless LAN Controller End

----------------------------

ip multicast routing distributed

!

interface Loopback0

description GRE Tunnel Source Interface

ip address 2.2.2.2 255.255.255.255

no shutdown

!

interface Tunnel0

description CAPWAP Multicast Traffic Encapsulation

ip address 192.168.1.2 255.255.255.252

tunnel source loopback 0

tunnel destination 1.1.1.1

ip pim sparse-dense-mode

no shutdown

!

interface vlan [WLC_Vlan]

ip pim passive

!

ip mroute [LWAP_Managemnt_IP] 255.255.255.0 Tunnel0 [Reverse_Path_Chk_AP_Source]

ip mroute 1.1.1.1 255.255.255.255 Tunnel0 [Reverse_Path_Chk_Tunnel_Source]

darren.frowen@me.com Fri, 12/21/2012 - 00:11

All,

Also to confirm this was applied on Cisco 3750X's running IP Base Licence and hence Multicast Stub.

Regards

art-barrera Fri, 12/21/2012 - 07:52

Cool - just curious.....who was the carrier with the MPLS offering? I know a couple of the big ones have their own Multicast support offering (for additional cost) and that would certainly break the path for your multicast tree.  I've used GRE tunnels in the past to "insert" my own routing protocols and get around carrier limitations but never thought about multicast until now.  Thanks!  //art

darren.frowen@me.com Thu, 12/27/2012 - 06:45


Hi Art,

It was Excell the provider. As time constraints was a limitation factor we had to get in the fix quickly so negotiation with the provider was not an option at that time.

Regards

Sent from Cisco Technical Support iPad App

Actions

Login or Register to take actions

This Discussion

Posted December 17, 2012 at 2:23 PM
Stats:
Replies:5 Avg. Rating:
Views:1412 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard