cannot configure IP SLA on 2911

Answered Question
Dec 28th, 2012

Hy Guys, I have one router 2911 with the following image

c2900-universalk9-mz.SPA.151-4.M4.bin

I have two IPS on this routers and I tried to configure the IP SLA on this and I`m not able to do it and I don´t know why.

I can configure almost everything but not the IP SLA command.

this is the config:

track 10 ip sla 1 reachability

delay down 10 up 1

!

track 20 ip sla 2 reachability

delay down 10 up 1

!

!

interface GigabitEthernet0/0

no ip address

no ip route-cache

duplex full

speed 1000

!

interface GigabitEthernet0/0.10

description LAN DATOS INT

encapsulation dot1Q 10

ip address 192.168.13.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

no ip route-cache

ip policy route-map PBR

!

interface GigabitEthernet0/0.20

description VOICE VLAN INT

encapsulation dot1Q 20

ip address 192.168.14.1 255.255.255.0

no ip route-cache

!

interface GigabitEthernet0/1

description WAN TO METROTEL

ip address 190.104.197.90 255.255.255.248

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

no cdp enable

!

interface GigabitEthernet0/2

description WAN2 TO SION

ip address 216.244.210.26 255.255.255.248

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

no cdp enable

!

ip forward-protocol nd

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip nat inside source route-map METROTEL interface GigabitEthernet0/1 overload

ip nat inside source route-map SION interface GigabitEthernet0/2 overload

ip route 0.0.0.0 0.0.0.0 190.104.197.89 track 10

ip route 0.0.0.0 0.0.0.0 216.244.210.25 track 20

!

ip sla key-chain 1

access-list 10 permit 192.168.13.0 0.0.0.255

access-list 23 permit 10.10.10.0 0.0.0.7

access-list 100 permit ip any any

!

route-map SION permit 10

match ip address 10

match interface GigabitEthernet0/2

!

route-map METROTEL permit 10

match ip address 10

match interface GigabitEthernet0/1

!

route-map PBR permit 10

match ip address 100

set ip next-hop verify-availability 216.244.210.25 1 track 20

!

route-map PBR permit 30

match ip address 100

set ip next-hop verify-availability 190.104.197.89 2 track 10

and when I try to configure the IP SLA shows this:

RTLATCOM(config)#ip sla 1

                        ^

% Invalid input detected at '^' marker.

and this followings options:

RTLATCOM(config)#ip sla ?

  key-chain  Use MD5 Authentication for IP SLAs Control Messages

  responder  Enable IP SLAs Responder

  server     IPPM server configuration

What I need to do in this case? or why cannot configure the IP SLA?

Thanks in advance

gonzalo

I have this problem too.
0 votes
Correct Answer by pnalamwa about 1 year 3 months ago

Hi Gonzalo,

Here is the link which provides the details about the licnese and the featured supported by the different licenses on the ISRG2 routers.

http://www.cisco.com/en/US/prod/collateral/routers/ps10616/white_paper_c11_556985.html

You can check the license activated on the router using "sh ver" it will show you at the end of the show version output or you can check "sh license all".

You can enable the evaluation data license using the below mentioned command in the config mode.

license boot module c2900 technology-package datak9

But it will get expire after 60 days the details are there in the above links.

You need to boot the router after configuring the above comand to activate the specified license.

Regards

Paresh

Correct Answer by John Blakley about 1 year 3 months ago

You'll need a data license for it to support sla. Can you post "show version"? There's a chart at the bottom that will show you what you're licensed for. You'll want to see a "permanent" status in the data row.

Technology Package License Information for Module:'c2900'

-----------------------------------------------------------------

Technology    Technology-package           Technology-package

              Current       Type           Next reboot

------------------------------------------------------------------

ipbase        ipbasek9      Permanent      ipbasek9

security      None          None           None

uc            None          None           None

data          datak9        Permanent      datak9

HTH,
John

*** Please rate all useful posts ***

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (3 ratings)
Correct Answer
John Blakley Fri, 12/28/2012 - 12:43

You'll need a data license for it to support sla. Can you post "show version"? There's a chart at the bottom that will show you what you're licensed for. You'll want to see a "permanent" status in the data row.

Technology Package License Information for Module:'c2900'

-----------------------------------------------------------------

Technology    Technology-package           Technology-package

              Current       Type           Next reboot

------------------------------------------------------------------

ipbase        ipbasek9      Permanent      ipbasek9

security      None          None           None

uc            None          None           None

data          datak9        Permanent      datak9

HTH,
John

*** Please rate all useful posts ***

goplansrl Fri, 12/28/2012 - 12:59

Hi John, thanks for your answer, this is the chart.

Technology Package License Information for Module:'c2900'

-----------------------------------------------------------------

Technology    Technology-package           Technology-package

              Current       Type           Next reboot

------------------------------------------------------------------

ipbase        ipbasek9      Permanent      ipbasek9

security      None          None           None

uc            None          None           None

data          None          None           None

so, I need the DATA license, I need pay for this? or is a change in the cisco license portal? I`m reading a post right now but i cannot understand if it´s with cost.

Thank you very much for your help.

Correct Answer
pnalamwa Fri, 12/28/2012 - 12:58

Hi Gonzalo,

Here is the link which provides the details about the licnese and the featured supported by the different licenses on the ISRG2 routers.

http://www.cisco.com/en/US/prod/collateral/routers/ps10616/white_paper_c11_556985.html

You can check the license activated on the router using "sh ver" it will show you at the end of the show version output or you can check "sh license all".

You can enable the evaluation data license using the below mentioned command in the config mode.

license boot module c2900 technology-package datak9

But it will get expire after 60 days the details are there in the above links.

You need to boot the router after configuring the above comand to activate the specified license.

Regards

Paresh

John Blakley Fri, 12/28/2012 - 15:10

Yes there will be a cost for it. I had to do the same exact thing recently :) I don't remember how much it was, but your reseller should be able to help you out.



Sent from Cisco Technical Support iPhone App

Actions

Login or Register to take actions

This Discussion

Posted December 28, 2012 at 12:29 PM
Stats:
Replies:5 Avg. Rating:5
Views:864 Votes:0
Shares:0
Tags: ip_sla, 2911
+
Categories: Routers, IP SLA
+

Related Content

Discussions Leaderboard