Outbound calls from UCM not possible to pstn gateway (lab)

Answered Question
Jan 12th, 2013

I'm not able to place outbound calls to my pstn gateway, as far as i know i configured everything properly:

To make everything short:

I configured my branch2 router as a mgcp gateway

Bottom - up

sh isdn status => multiple frame esthablised

sh ccm-manager=>

MGCP Domain Name: BR1-RTR.proctorlabs.com

Priority        Status                   Host

============================================================

Primary         Registered               10.10.210.10

Current active Call Manager:    10.10.210.10

Backhaul/Redundant link port:   2428

Failover Interval:              30 seconds

Keepalive Interval:             15 seconds

Last keepalive sent:            21:41:24 UTC Jan 12 2013 (elapsed time: 00:00:08)

Last MGCP traffic time:         21:41:24 UTC Jan 12 2013 (elapsed time: 00:00:08)

Last failover time:             None

Last switchback time:           None

Switchback mode:                Immediate

MGCP Fallback mode:             Not Selected

Last MGCP Fallback start time:  None

Last MGCP Fallback end time:    None

MGCP Download Tones:            Disabled

TFTP retry count to shut Ports: 2

In callmanager i created a route pattern ( 91617.XXXXXXX) and i'v pointed it out to the gateway (MGCP)

My mgcp gateway in callmanager is also registered

I want to call to my pstn gateway to this number 16178632683 it has to go via the branch 1 gateway.

When i debug isdn q931 it says unallocated /unassigned number

(The 9 is an outside prefix)

Backwards i'm able to call from my pstn phone to my branch phones that part is fine.

Is there something i missed?

Branch1 gateway config:

Building configuration...

Current configuration : 2916 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname BR1-RTR

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

enable secret 5 $1$wNOA$XSwMLgrwkVM.XnurXmwyJ.

!

no aaa new-model

network-clock-participate wic 2

dot11 syslog

ip source-route

!

!

!

!

ip cef

ip domain name proctorlabs.com

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!        

isdn switch-type primary-ni

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

voice-card 0

!

!

!

!

!

archive

log config

  hidekeys

!

!

!

!

!        

controller T1 0/2/0

pri-group timeslots 1-3,24 service mgcp

!

controller T1 0/2/1

!

!

!

!

!

interface Loopback0

ip address 10.10.110.2 255.255.255.255

ip ospf network point-to-point

!

interface FastEthernet0/0

ip address 10.10.210.16 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1/0

switchport trunk native vlan 130

switchport mode trunk

switchport voice vlan 240

!

interface FastEthernet0/1/1

switchport trunk native vlan 130

switchport mode trunk

switchport voice vlan 240

!

interface FastEthernet0/1/2

switchport trunk native vlan 130

switchport mode trunk

switchport voice vlan 240

!

interface FastEthernet0/1/3

switchport trunk native vlan 130

switchport mode trunk

switchport voice vlan 240

!

interface Serial0/2/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

interface Serial0/3/0

ip address 10.10.111.2 255.255.255.0

encapsulation ppp

ip ospf mtu-ignore

!

interface Serial0/3/1

no ip address

clock rate 2000000

!

interface Vlan1

no ip address

!        

interface Vlan130

ip address 10.10.101.1 255.255.255.0

!

interface Vlan240

ip address 10.10.201.1 255.255.255.0

ip helper-address 10.10.210.10

!

router ospf 1

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 0

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

!

disable-eadi

!

!

!

!

!

!

!

control-plane

!

!

!

voice-port 0/2/0:23

!

ccm-manager switchback immediate

ccm-manager redundant-host 10.10.210.10

ccm-manager mgcp

ccm-manager fax protocol cisco

!

mgcp

mgcp call-agent 10.10.210.10 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp bind control source-interface Loopback0

mgcp bind media source-interface Loopback0

!

mgcp profile default

!

!

!

dial-peer voice 91617 pots

destination-pattern 91617.8632683

port 0/2/0:23

forward-digits 10

!

!

!

!

gatekeeper

shutdown

!

!

line con 0

exec-timeout 0 0

password cisco

login

line aux 0

line vty 0 4

exec-timeout 0 0

privilege level 15

password cisco

login

transport preferred none

transport input telnet

line vty 5 15

exec-timeout 0 0

privilege level 15

logging synchronous

no login

transport preferred none

!

scheduler allocate 20000 1000

end

I have this problem too.
0 votes
Correct Answer by Ayodeji oladipo... about 1 year 3 months ago

The question is on the PSTN CCME gateway, do you have an ephone-dn with extension "8632683"

The PSTN gateway is saying that htere is no extension with that number on it. You didnt sent the sh run on your PSTN gateway. Does that extension exist on your PSTN gateway...

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (3 ratings)
yahsiel2004 Sat, 01/12/2013 - 13:05

What is your carrier expecting a 9? You have configured route pattern 91617.XXXXXXX which strips 91617 before going out the GW. If the carrier is not expecting a 9 you should configure your route pattern as 9.1617XXXXXXX and if 617 is a local number you shouldn't include a 1.

Regards,

Yosh

Ayodeji oladipo... Sat, 01/12/2013 - 14:15

Hi,

The first place to start is to send the output of  "debug isdn q93"

We need to see what the CUCM is sending to the gateway.The second this is have you configured any digit strip option on your route pattern in cucm? Are you stripping pre dot or you are not stripping at all...If you are not stripping any digit, then you are sending the full 91617XXXXXX to your provider and as such you need to strip the 9...

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

monasir81 Sun, 01/13/2013 - 10:48

@ yahsiel 2004:

to make everything clear this is for lab purposes not in a real live environment.

The task is that i have to create a route pattern as mentioned ( 9 is a prefix then 1617) then 7 further digits.

@ aokanlawon:

I am stripping predot as stripping option in cucm.

So that means 91617 is going to be stripped (.) everything afhter the . is 7 further digits.

I did a debug isdn q931

The result is there isn't  "unassigned/unallocated number"

You can see that the call is trying to send out of the gateway but afhter that you hear busy tone.

Backwards from my pstn voicegateway i am able to call to the branch1 phones.

Somehowe something is going wrong??

Jaime Valencia Sun, 01/13/2013 - 10:56

The other end doesn't know how to route the call, check your DP config if H323, and inbound CSS in GW config.

Sent from Cisco Technical Support iPad App

Ayodeji oladipo... Sun, 01/13/2013 - 11:09

Like Jamie suggested,

You need to look at the terminating gateway in your lab..

Do a debug isdn q931 on that side...Does the call arrive on that gateway...

Is there a phone configured with that number on that gateway..

The pstn gateway I believe is a ccme gateway. Have a look there...If you want to send us the config and the debug..

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

monasir81 Wed, 01/16/2013 - 04:06

Hi there,

That's right, the pstn gateway is CME based.

The goal is to make an outgoing call to the pstn gateway " but true the BR1 gateway "

The Br2 gateway needs to be mgcp protocol based.

I have that part configured, the only problem what is left is that the call is not arriving at the gateway.

First i thought i have to make an dial-peer, but i already created a routepattern in cucm.

My pstn is provided with the necessary dial-peers for incoming and outgoing calls.

91617.XXXXXXX is also defined for the br1 gateway on this routepattern.

digitstrip option is:Predot

The 9 would be leading

Ayodeji oladipo... Wed, 01/16/2013 - 07:56

You want to make outbound calls to the pstn through Br1 gateway? Are the Br1 phones registered to cucm? If they are all they need is to have access to the RP on cucm and cucm will send the calls to the PSTN gateway if you have configured it like that

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

monasir81 Thu, 01/17/2013 - 02:28

Hi aokanlawon,

All of my br1 phones are registered.

I have a routepattern created.

=>901617.XXXXXXX

Still no phones go outbound (unallocated/unassigned number) by debug isdn q931

I have to troubleshoot to find more.

I get back on this

Ayodeji oladipo... Thu, 01/17/2013 - 03:10

From the PSTN gateway, ( I assume this is a h323 gateway on cucm)

send the ff debug:

debug isdn q931...

debug voip ccapi inout

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

monasir81 Thu, 01/17/2013 - 03:51

Hi aokanlawon,

This is not a h323 gateway.

This is callmanager express based

Ayodeji oladipo... Thu, 01/17/2013 - 03:55

So I believe this is your call flow then,....

CUCM---->Br1----E1/PSTN----PSTN Gateway..

SO call go from CUCM to Br1 Gw and then to PSTN..

OK..

How is the br1 gateway cofigured. is it h323 gateway in cucm?

So go to br1 gateway..sebd debug isdn q931 and debug voip ccapi inout..

go to PSTN gateway send debug isdn q931

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

monasir81 Fri, 01/18/2013 - 11:48

Hi aonkanlawon,

That's right that's the call flow.

The call has to be sent to the PSTN router via the Branch1 router.

The Branch router isn't configured as h323 gateway in cucm but as MGCP.

Here is my output generation of the branch 1 router:

Jan 18 19:59:49.175: ISDN Se0/2/0:23 Q931: TX -> SETUP pd = 8  callref = 0x0002

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech 

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98381

Exclusive, Channel 1

Display i = 'BR1 Phone 1'

Calling Party Number i = 0x0081, '6178631001'

Plan:Unknown, Type:Unknown

Called Party Number i = 0x80, '8632683'

Plan:Unknown, Type:Unknown

*Jan 18 19:59:49.207: ISDN Se0/2/0:23 Q931: RX <- CALL_PROC pd = 8  callref = 0x8002

Channel ID i = 0xA98381

Exclusive, Channel 1

*Jan 18 19:59:49.215: ISDN Se0/2/0:23 Q931: RX <- DISCONNECT pd = 8  callref = 0x8002

Cause i = 0x8281 - Unallocated/unassigned number

*Jan 18 19:59:49.643: ISDN Se0/2/0:23 Q931: TX -> RELEASE pd = 8  callref = 0x0002

*Jan 18 19:59:49.651: ISDN Se0/2/0:23 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x8002

Here is my output of my PSTN router when i call to a pstn number:

Jan 18 21:02:52.931: ISDN Se0/1/0:23 Q931: RX <- SETUP pd = 8  callref = 0x0002

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech 

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98381

Exclusive, Channel 1

Display i = 'BR1 Phone 1'

Calling Party Number i = 0x0081, '6178631001'

Plan:Unknown, Type:Unknown

Called Party Number i = 0x80, '8632683'

Plan:Unknown, Type:Unknown

Jan 18 21:02:52.935: ISDN Se0/1/0:23 Q931: Received SETUP  callref = 0x8002 callID = 0x0002 switch = primary-ni interface = Network

Jan 18 21:02:52.955: ISDN Se0/1/0:23 Q931: TX -> CALL_PROC pd = 8  callref = 0x8002

Channel ID i = 0xA98381

Exclusive, Channel 1

Jan 18 21:02:52.959: ISDN Se0/1/0:23 Q931: TX -> DISCONNECT pd = 8  callref = 0x8002

Cause i = 0x8281 - Unallocated/unassigned number

Jan 18 21:02:53.391: ISDN Se0/1/0:23 Q931: RX <- RELEASE pd = 8  callref = 0x0002

Jan 18 21:02:53.395: ISDN Se0/1/0:23 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8002

Here is output of debug voip ccapi inout:

Jan 18 20:03:24.463: //-1/xxxxxxxxxxxx/CCAPI/ccIFCallSetupRequestPrivate:

   Interface=0x6855E404, Interface Type=6, Destination=, Mode=0x9,

   Call Params(Calling Number=,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),

   Called Number=(TON=Unknown, NPI=Unknown), Calling Translated=FALSE,

   Subscriber Type Str=, FinalDestinationFlag=FALSE, Outgoing Dial-peer=0, Call Count On=FALSE,

   Source Trkgrp Route Label=, Target Trkgrp Route Label=, tg_label_flag=0, Application Call Id=D000000001e65248000000F500000003)

*Jan 18 20:03:24.463: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Jan 18 20:03:24.463: :cc_get_feature_vsa malloc success

*Jan 18 20:03:24.463: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Jan 18 20:03:24.463:  cc_get_feature_vsa count is 1

*Jan 18 20:03:24.463: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Jan 18 20:03:24.463: :FEATURE_VSA attributes are: feature_name:0,feature_time:1762501704,feature_id:11

*Jan 18 20:03:24.463: //11/F340FB1A8007/CCAPI/ccIFCallSetupRequestPrivate:

   SPI Call Setup Request Is Success; Interface Type=6, FlowMode=1

*Jan 18 20:03:24.463: //11/F340FB1A8007/CCAPI/ccCallSetContext:

   Context=0x68D0E9D8

*Jan 18 20:03:24.467: //-1/xxxxxxxxxxxx/CCAPI/ccIFCallSetupRequestPrivate:

   Interface=0x67FA7A50, Interface Type=9, Destination=0.0.0.0, Mode=0x9,

   Call Params(Calling Number=,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),

   Called Number=(TON=Unknown, NPI=Unknown), Calling Translated=FALSE,

   Subscriber Type Str=, FinalDestinationFlag=FALSE, Outgoing Dial-peer=0, Call Count On=TRUE,

   Source Trkgrp Route Label=, Target Trkgrp Route Label=, tg_label_flag=0, Application Call Id=D000000001e65248000000F500000003)

*Jan 18 20:03:24.467: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Jan 18 20:03:24.467: :cc_get_feature_vsa malloc success

*Jan 18 20:03:24.467: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Jan 18 20:03:24.467:  cc_get_feature_vsa count is 2

*Jan 18 20:03:24.467: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Jan 18 20:03:24.467: :FEATURE_VSA attributes are: feature_name:0,feature_time:1762501480,feature_id:12

*Jan 18 20:03:24.467: //12/F340FB1A8007/CCAPI/ccIFCallSetupRequestPrivate:

   SPI Call Setup Request Is Success; Interface Type=9, FlowMode=1

*Jan 18 20:03:24.467: //12/F340FB1A8007/CCAPI/ccCallSetContext:

   Context=0x68D0E7C8

*Jan 18 20:03:24.471: //12/F340FB1A8007/CCAPI/cc_api_call_connected:

   Interface=0x67FA7A50, Data Bitmask=0x0, Progress Indication=NULL(0),

   Connection Handle=0

*Jan 18 20:03:24.471: //12/F340FB1A8007/CCAPI/cc_api_call_connected:

   Call Entry(Connected=TRUE, Responsed=TRUE, Retry Count=0)

*Jan 18 20:03:24.471: //11/F340FB1A8007/CCAPI/cc_api_call_proceeding:

   Interface=0x6855E404, Progress Indication=NULL(0)

*Jan 18 20:03:24.475: //11/F340FB1A8007/CCAPI/cc_api_call_connected:

   Interface=0x6855E404, Data Bitmask=0x1, Progress Indication=DESTINATION IS NON ISDN(2),

   Connection Handle=0

*Jan 18 20:03:24.475: //11/F340FB1A8007/CCAPI/cc_api_call_connected:

   Call Entry(Connected=TRUE, Responsed=TRUE, Retry Count=0)

*Jan 18 20:03:24.475: //11/F340FB1A8007/CCAPI/ccCallModify:

   Nominator=0x1000, Params=0x689B3628, Call Id=11

*Jan 18 20:03:24.475: //11/xxxxxxxxxxxx/CCAPI/ccCallReportDigits:

   (callID=0xB, digit_event=0x1, enable=TRUE, consume=FALSE)

*Jan 18 20:03:24.475: //11/F340FB1A8007/CCAPI/ccCallReportDigits:

   Enabled=TRUE, Call Id=11

*Jan 18 20:03:24.475: //11/xxxxxxxxxxxx/CCAPI/cc_api_call_report_digits_done:

   (vdbPtr=0x6855E404, callID=0xB, disp=0, digit_event=0x1, enable=TRUE, consume=FALSE)

*Jan 18 20:03:24.475: //11/F340FB1A8007/CCAPI/cc_api_call_report_digits_done:

   Enabled=TRUE, Disposition=0x0, Interface=0x6855E404, Call Id=11

*Jan 18 20:03:24.475: //11/F340FB1A8007/CCAPI/cc_api_call_report_digits_done:

   Call Entry(Initial Digit Timeout=15000(ms), Inter Digit Timeout=10000(ms))

*Jan 18 20:03:24.475: //11/xxxxxxxxxxxx/CCAPI/ccConferenceCreate:

   (confID=0x689B383C, callID1=0xB, callID2=0xC, tag=0x0)

*Jan 18 20:03:24.475: //11/xxxxxxxxxxxx/CCAPI/ccConferenceCreate:

   (confID=0x689B383C, callID1=0xB, gcid=0-0-0-0, tag=0x0)

*Jan 18 20:03:24.475: //12/xxxxxxxxxxxx/CCAPI/ccConferenceCreate:

   (confID=0x689B383C, callID2=0xC, gcid=0-0-0-0, tag=0x0)

*Jan 18 20:03:24.475: //11/F340FB1A8007/CCAPI/ccConferenceCreate:

   Conference Id=0x689B383C, Call Id1=11, Call Id2=12, Tag=0x0

*Jan 18 20:03:24.479: //11/xxxxxxxxxxxx/CCAPI/cc_api_bridge_done:

   Conference Id=0x6, Source Interface=0x6855E404, Source Call Id=11,

   Destination Call Id=12, Disposition=0x0, Tag=0xFFFFFFFF

*Jan 18 20:03:24.479: //12/xxxxxxxxxxxx/CCAPI/cc_api_bridge_done:

   Conference Id=0x6, Source Interface=0x67FA7A50, Source Call Id=12,

   Destination Call Id=11, Disposition=0x0, Tag=0x0

*Jan 18 20:03:24.479: //11/F340FB1A8007/CCAPI/cc_generic_bridge_done:

   Conference Id=0x6, Source Interface=0x67FA7A50, Source Call Id=12,

   Destination Call Id=11, Disposition=0x0, Tag=0x0

*Jan 18 20:03:24.479: //11/F340FB1A8007/CCAPI/ccConferenceCreate:

   Call Entry(Conference Id=0x6, Destination Call Id=12)

*Jan 18 20:03:24.479: //12/F340FB1A8007/CCAPI/ccConferenceCreate:

   Call Entry(Conference Id=0x6, Destination Call Id=11)

*Jan 18 20:03:24.479: //11/F340FB1A8007/CCAPI/cc_api_caps_ind:

   Destination Interface=0x67FA7A50, Destination Call Id=12, Source Call Id=11,

   Caps(Codec=0x1, Fax Rate=0x1, Vad=0x1,

   Modem=0x2, Codec Bytes=20, Signal Type=3)

*Jan 18 20:03:24.479: //11/F340FB1A8007/CCAPI/cc_api_caps_ind:

   Caps(Playout Mode=1, Playout Initial=60(ms), Playout Min=40(ms),

   Playout Max=1000(ms), Fax Nom=300(ms))

*Jan 18 20:03:24.479: //12/F340FB1A8007/CCAPI/cc_api_caps_ind:

   Destination Interface=0x6855E404, Destination Call Id=11, Source Call Id=12,

   Caps(Codec=0x4, Fax Rate=0x2, Vad=0x1,

   Modem=0x0, Codec Bytes=20, Signal Type=2)

*Jan 18 20:03:24.479: //12/F340FB1A8007/CCAPI/cc_api_caps_ind:

   Caps(Playout Mode=1, Playout Initial=60(ms), Playout Min=40(ms),

   Playout Max=1000(ms), Fax Nom=300(ms))

*Jan 18 20:03:24.479: //12/F340FB1A8007/CCAPI/cc_api_caps_ack:

   Destination Interface=0x6855E404, Destination Call Id=11, Source Call Id=12,

   Caps(Codec=g729r8(0x4), Fax Rate=FAX_RATE_VOICE(0x2), Vad=OFF(0x1),

   Modem=OFF(0x0), Codec Bytes=20, Signal Type=2, Seq Num Start=4386)

*Jan 18 20:03:24.483: //11/F340FB1A8007/CCAPI/cc_api_caps_ack:

   Destination Interface=0x67FA7A50, Destination Call Id=12, Source Call Id=11,

   Caps(Codec=g729r8(0x4), Fax Rate=FAX_RATE_VOICE(0x2), Vad=OFF(0x1),

   Modem=OFF(0x0), Codec Bytes=20, Signal Type=2, Seq Num Start=4386)

*Jan 18 20:03:24.483: //11/F340FB1A8007/CCAPI/cc_api_call_modify_done:

   Result=0, Interface=0x6855E404, Call Id=11

*Jan 18 20:03:24.483: //11/F340FB1A8007/CCAPI/cc_api_voice_mode_event:

   Call Id=11

*Jan 18 20:03:24.487: //11/F340FB1A8007/CCAPI/cc_api_voice_mode_event:

   Call Entry(Context=0x68D0E9D8)

*Jan 18 20:03:24.487: //11/F340FB1A8007/CCAPI/cc_process_notify_bridge_done:

   Conference Id=0x6, Call Id1=11, Call Id2=12

*Jan 18 20:03:24.487: //11/F340FB1A8007/CCAPI/ccSetDigitTimeouts:

   Initial Digit Timeout=4000(ms), Inter Digit Timeout=4000(ms)

*Jan 18 20:03:24.487: //11/F340FB1A8007/CCAPI/ccSetDigitTimeouts:

   Call Entry(Inter Digit Timeout=4000(ms), Initial Digit Timeout=4000(ms))

*Jan 18 20:03:24.491: //11/F340FB1A8007/CCAPI/ccRestartDigitTimeoutMsec:

   Digit Timeout=0, Call Id=11

*Jan 18 20:03:24.491: //11/xxxxxxxxxxxx/CCAPI/ccCallReportDigits:

   (callID=0xB, digit_event=0x1, enable=TRUE, consume=FALSE)

*Jan 18 20:03:24.491: //11/F340FB1A8007/CCAPI/ccCallReportDigits:

   Enabled=TRUE, Call Id=11

*Jan 18 20:03:24.491: //11/xxxxxxxxxxxx/CCAPI/cc_api_call_report_digits_done:

   (vdbPtr=0x6855E404, callID=0xB, disp=0, digit_event=0x1, enable=TRUE, consume=FALSE)

*Jan 18 20:03:24.491: //11/F340FB1A8007/CCAPI/cc_api_call_report_digits_done:

   Enabled=TRUE, Disposition=0x0, Interface=0x6855E404, Call Id=11

*Jan 18 20:03:24.491: //11/F340FB1A8007/CCAPI/cc_api_call_report_digits_done:

   Call Entry(Initial Digit Timeout=4000(ms), Inter Digit Timeout=4000(ms))

*Jan 18 20:03:24.663: //11/F340FB1A8007/CCAPI/ccCallModifyExtended:

   Nominator=0x689B3558, Params=0x689B27A8, Call Id=11

*Jan 18 20:03:24.667: //12/F340FB1A8007/CCAPI/ccCallModify:

   Nominator=0x18E30, Params=0x689B29A8, Call Id=12

*Jan 18 20:03:24.667: //11/F340FB1A8007/CCAPI/cc_api_call_modify_done:

   Result=0, Interface=0x6855E404, Call Id=11

*Jan 18 20:03:24.667: //12/F340FB1A8007/CCAPI/cc_api_call_modify_done:

   Result=0, Interface=0x67FA7A50, Call Id=12

*Jan 18 20:03:24.831: //11/F340FB1A8007/CCAPI/ccCallModifyExtended:

   Nominator=0x689B3558, Params=0x689B27A8, Call Id=11

*Jan 18 20:03:24.835: //12/F340FB1A8007/CCAPI/ccCallModify:

   Nominator=0x80000800, Params=0x689B29A8, Call Id=12

*Jan 18 20:03:24.835: //11/F340FB1A8007/CCAPI/cc_api_call_modify_done:

   Result=0, Interface=0x6855E404, Call Id=11

*Jan 18 20:03:24.835: //12/F340FB1A8007/CCAPI/cc_api_call_modify_done:

   Result=0, Interface=0x67FA7A50, Call Id=12

*Jan 18 20:03:24.903: //11/xxxxxxxxxxxx/CCAPI/ccCallReportDigits:

   (callID=0xB, digit_event=0x0, enable=FALSE, consume=FALSE)

*Jan 18 20:03:24.903: //11/F340FB1A8007/CCAPI/ccCallReportDigits:

   Enabled=TRUE, Call Id=11

*Jan 18 20:03:24.903: //11/xxxxxxxxxxxx/CCAPI/cc_api_call_report_digits_done:

   (vdbPtr=0x6855E404, callID=0xB, disp=0, digit_event=0x0, enable=FALSE, consume=FALSE)

*Jan 18 20:03:24.903: //11/F340FB1A8007/CCAPI/cc_api_call_report_digits_done:

   Enabled=TRUE, Disposition=0x0, Interface=0x6855E404, Call Id=11

*Jan 18 20:03:24.903: //11/F340FB1A8007/CCAPI/cc_api_call_report_digits_done:

   Call Entry(Initial Digit Timeout=4000(ms), Inter Digit Timeout=4000(ms))

*Jan 18 20:03:24.903: //12/F340FB1A8007/CCAPI/ccGetCallStatistics:

   Call Stats=0x68D1E73C, Call Id=12

*Jan 18 20:03:24.903: //11/F340FB1A8007/CCAPI/ccConferenceDestroy:

   Conference Id=0x6, Tag=0x0

*Jan 18 20:03:24.903: //11/xxxxxxxxxxxx/CCAPI/cc_api_bridge_drop_done:

   Conference Id=0x6, Source Interface=0x6855E404, Source Call Id=11,

   Destination Call Id=12, Disposition=0x0, Tag=0x0

*Jan 18 20:03:24.907: //12/xxxxxxxxxxxx/CCAPI/cc_api_bridge_drop_done:

   Conference Id=0x6, Source Interface=0x67FA7A50, Source Call Id=12,

   Destination Call Id=11, Disposition=0x0, Tag=0x0

*Jan 18 20:03:24.907: //11/F340FB1A8007/CCAPI/cc_generic_bridge_done:

   Conference Id=0x6, Source Interface=0x67FA7A50, Source Call Id=12,

   Destination Call Id=11, Disposition=0x0, Tag=0x0

*Jan 18 20:03:24.907: //11/F340FB1A8007/CCAPI/ccCallDisconnect:

   Cause Value=16, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)

*Jan 18 20:03:24.907: //11/F340FB1A8007/CCAPI/ccCallDisconnect:

   Cause Value=16, Call Entry(Responsed=TRUE, Cause Value=16)

*Jan 18 20:03:24.907: //11/F340FB1A8007/CCAPI/cc_api_get_transfer_info:

   Transfer Number Is Null

*Jan 18 20:03:24.907: //12/F340FB1A8007/CCAPI/ccCallDisconnect:

   Cause Value=16, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)

*Jan 18 20:03:24.907: //12/F340FB1A8007/CCAPI/ccCallDisconnect:

   Cause Value=16, Call Entry(Responsed=TRUE, Cause Value=16)

*Jan 18 20:03:24.915: //12/F340FB1A8007/CCAPI/cc_api_call_disconnect_done:

   Disposition=0, Interface=0x67FA7A50, Tag=0x0, Call Id=12,

   Call Entry(Disconnect Cause=16, Voice Class Cause Code=0, Retry Count=0)

*Jan 18 20:03:24.915: //12/F340FB1A8007/CCAPI/cc_api_call_disconnect_done:

   Call Disconnect Event Sent

*Jan 18 20:03:24.915: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

*Jan 18 20:03:24.915: :cc_free_feature_vsa freeing 690DA360

*Jan 18 20:03:24.915: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

*Jan 18 20:03:24.915:  vsacount in free is 1

*Jan 18 20:03:24.927: //11/F340FB1A8007/CCAPI/cc_api_call_disconnect_done:

   Disposition=0, Interface=0x6855E404, Tag=0x0, Call Id=11,

   Call Entry(Disconnect Cause=16, Voice Class Cause Code=0, Retry Count=0)

*Jan 18 20:03:24.927: //11/F340FB1A8007/CCAPI/cc_api_call_disconnect_done:

   Call Disconnect Event Sent

*Jan 18 20:03:24.927: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

*Jan 18 20:03:24.927: :cc_free_feature_vsa freeing 690DA440

*Jan 18 20:03:24.927: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

*Jan 18 20:03:24.927:  vsacount in free is 0

Ayodeji oladipo... Fri, 01/18/2013 - 12:12

So the call arrives o n the PSTN router, but it doesnt match any number..is there a phone configured with this extension?

The PSTN is disconnecting the call and sying that it doesnt have any extension with this number 6178631001.

Please check your config. You can send a sh run here

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

monasir81 Fri, 01/18/2013 - 12:42

Hi,

The extension which i'm trying to call is +16178632683. (pstn phone at PSTN site)

I am calling from one of my ucm phones that are all registered.

By example from hq phone with extension ( 2123945001) to pstn phone with extension +16178632683.

I created a routepattern like i mentioned ( 91617.XXXXXXX) digitstrip is Predot

So that means 91617 will be stripped of , so in this case the called number will be 8632683 instead of (+1617862683)

Calling number is 6178631002 from one of my cucm phones.

i am going to send you the neccary info of my pstn & branch config

PSTN-WAN#sh run | b voice trans

voice translation-rule 1

rule 2 /^\(2123942123\)$/ /\1/ type any subscriber plan any isdn

rule 3 /^6178632683$/ /\0/ type any national plan any isdn

rule 4 /^32141891$/ /34\0/ type any international plan any isdn

rule 5 /^6745738932$/ /91\0/ type any international plan any isdn

rule 6 /^9004522138$/ /\0/ type any national plan any isdn

!

voice translation-rule 2

rule 1 /^911$/ /\0/ type any unknown plan any unknown

rule 2 /^2123942123$/ /\0/ type any national plan any isdn

rule 3 /^617\(8632683\)$/ /\1/ type any subscriber plan any isdn

rule 4 /^32141891$/ /34\0/ type any international plan any isdn

rule 5 /^6745738932$/ /91\0/ type any international plan any isdn

rule 6 /^9004522138$/ /\0/ type any national plan any isdn

!

voice translation-rule 3

rule 1 /^911$/ /999/ type any unknown plan any unknown

rule 2 /^2123942123$/ /1\0/ type any international plan any isdn

rule 3 /^6178632683$/ /1\0/ type any international plan any isdn

rule 4 /^32141891$/ /\0/ type any national plan any isdn

rule 5 /^6745738932$/ /91\0/ type any international plan any isdn

rule 6 /^9004522138$/ /1\0/ type any international plan any isdn

!

voice translation-rule 34

rule 1 /^011/ /1234/

rule 2 /^911$/ /1234/

rule 3 /^1617/ /1234/

rule 4 /^1212/ /1234/

rule 5 /^212/ /1234/

rule 6 /^394/ /1234/

rule 7 /^617/ /1234/

rule 8 /^863/ /1234/

!

voice translation-rule 212

rule 1 /^1212/ /1234/

rule 2 /^1/ /\0/

rule 3 /^394/ /\0/

rule 4 /^011/ /\0/

rule 5 /^212/ /\0/

rule 6 /^911$/ /\0/

rule 9 /./ /1234/

!

voice translation-rule 617

rule 1 /^1617/ /1234/

rule 2 /^1/ /\0/

rule 3 /^863/ /\0/

rule 4 /^011/ /\0/

rule 5 /^617/ /\0/

rule 6 /^911$/ /\0/

rule 9 /./ /1234/

!

!

voice translation-profile block-call-into-BR1

translate called 617

!

voice translation-profile block-call-into-BR2

translate called 34

!

voice translation-profile block-call-into-HQ

translate called 212

!

voice translation-profile display-proper-ani-into-BR1

translate calling 2

!

voice translation-profile display-proper-ani-into-BR2

translate calling 3

!

voice translation-profile display-proper-ani-into-HQ

translate calling 1

!        

!

voice-card 0

!

!

!

!

!

archive

log config

  hidekeys

!

!

!

!

!

controller E1 0/0/0

clock source internal

pri-group timeslots 1-3,16

description ** E1 VOICE CONNECTION TO BR2-RTR **

!

controller T1 0/1/0

clock source internal

pri-group timeslots 1-3,23-24

description ** T1 VOICE CONNECTION TO HQ-RTR **

!

controller T1 0/1/1

clock source internal

channel-group 0 timeslots 1-24

description ** SERIAL DATA CONNECTION TO HQ-RTR **

!

controller T1 0/3/0

clock source internal

pri-group timeslots 1-3,23-24

description ** T1 VOICE CONNECTION TO BR1-RTR **

!

controller T1 0/3/1

clock source internal

channel-group 0 timeslots 1-24

description ** SERIAL DATA CONNECTION TO BR1-RTR **

PSTN-WAN#sh run | s dial-peer

dial-peer voice 100 pots

incoming called-number .

direct-inward-dial

dial-peer voice 201 voip

voice-class codec 1

incoming called-number .

dtmf-relay h245-alphanumeric

no vad

dial-peer voice 3 pots

destination-pattern 9T

port 0/0/0:15

dial-peer voice 103 pots

destination-pattern 32143...

port 0/0/0:15

forward-digits 8

dial-peer voice 104 pots

destination-pattern 32143...

no digit-strip

port 0/0/0:15

prefix +34

dial-peer voice 101 pots

destination-pattern 2123945...

port 0/1/0:23

forward-digits 10

dial-peer voice 102 pots

destination-pattern 6178631...

port 0/1/0:23

forward-digits 10

BR1-RTR#sh run

Building configuration...

Current configuration : 2818 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname BR1-RTR

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

enable secret 5 $1$wNOA$XSwMLgrwkVM.XnurXmwyJ.

!

no aaa new-model

network-clock-participate wic 2

dot11 syslog

ip source-route

!

!

!

!

ip cef

ip domain name proctorlabs.com

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!        

isdn switch-type primary-ni

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

voice-card 0

!

!

!

!

!

archive

log config

  hidekeys

!

!

!

!

!        

controller T1 0/2/0

pri-group timeslots 1-3,24 service mgcp

!

controller T1 0/2/1

!

!

!

!

!

interface Loopback0

ip address 10.10.110.2 255.255.255.255

ip ospf network point-to-point

!

interface FastEthernet0/0

ip address 10.10.210.16 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1/0

switchport trunk native vlan 130

switchport mode trunk

switchport voice vlan 240

!

interface FastEthernet0/1/1

switchport trunk native vlan 130

switchport mode trunk

switchport voice vlan 240

!

interface FastEthernet0/1/2

switchport trunk native vlan 130

switchport mode trunk

switchport voice vlan 240

!

interface FastEthernet0/1/3

switchport trunk native vlan 130

switchport mode trunk

switchport voice vlan 240

!

interface Serial0/2/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

interface Serial0/3/0

ip address 10.10.111.2 255.255.255.0

encapsulation ppp

ip ospf mtu-ignore

!

interface Serial0/3/1

no ip address

clock rate 2000000

!

interface Vlan1

no ip address

!        

interface Vlan130

ip address 10.10.101.1 255.255.255.0

!

interface Vlan240

ip address 10.10.201.1 255.255.255.0

ip helper-address 10.10.210.10

!

router ospf 1

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 0

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

!

disable-eadi

!

!

!

!

!

!

!

control-plane

!

!

!

voice-port 0/2/0:23

!

ccm-manager switchback immediate

ccm-manager redundant-host 10.10.210.10

ccm-manager mgcp

ccm-manager fax protocol cisco

!

mgcp

mgcp call-agent 10.10.210.10 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp bind control source-interface Loopback0

mgcp bind media source-interface Loopback0

!

mgcp profile default

!

!

!

!

!

!

gatekeeper

shutdown

!

!

line con 0

exec-timeout 0 0

password cisco

login

line aux 0

line vty 0 4

exec-timeout 0 0

privilege level 15

password cisco

login

transport preferred none

transport input telnet

line vty 5 15

exec-timeout 0 0

privilege level 15

logging synchronous

no login

transport preferred none

!

scheduler allocate 20000 1000

end


Correct Answer
Ayodeji oladipo... Fri, 01/18/2013 - 15:47

The question is on the PSTN CCME gateway, do you have an ephone-dn with extension "8632683"

The PSTN gateway is saying that htere is no extension with that number on it. You didnt sent the sh run on your PSTN gateway. Does that extension exist on your PSTN gateway...

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

monasir81 Sat, 01/19/2013 - 12:10

I'm still struggling with this awful translation rules.

It's good that you mentioned about your last response.

You are right my pstn phone hasn't got an extension with 8632683.

It has an ephone - dn with 16178632683.

if i create a routepattern in cucm with 1617XXXXXXX then the call gets routed.

But what is the best way to get this construction work....

In cucm i have a routerpattern with 91617.XXXXXXX (want to call at pstn site phone with ephone-dn 16178632683

What is the best way to utilize this.

So that when i call from one of my cucm phones to the "called number 8632683" the call will be translate to 16178632683

What is the best way to make this voice translation rule in my pstn gateway

Ayodeji oladipo... Sat, 01/19/2013 - 18:30

You can configure translation rule on the PSTN gateway like this...

voice translation-rule 4

rule 1 /^8632683/ /16178632683/

voice translation-profile br2CLI

translate called 4

then apply it on the dial-peer 100

dial-peer voice 100 pots

translation-profile incoming br2CLI

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

monasir81 Sun, 01/20/2013 - 12:26

Hi aonkanlawon,

Unfortunately the configurations didn't work.

I think that some translation rules in my pstn gateway are overlapping.

Because from the pstn site i am able to call to all of my ucm phones.

Ayodeji oladipo... Sun, 01/20/2013 - 13:34

Ok. Send the sh run of your PSTN gateway. try and attach it in a text file

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Harmit Singh Mon, 01/21/2013 - 08:04

+5 for my friend Deji for the excellent advice.

Hi Mohamed,

Here is what I see from the debug you posted for the PSTN gateway:

Jan 18 21:02:52.931: ISDN Se0/1/0:23 Q931: RX <- SETUP pd = 8  callref = 0x0002

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98381

Exclusive, Channel 1

Display i = 'BR1 Phone 1'

Calling Party Number i = 0x0081, '6178631001'

Plan:Unknown, Type:Unknown

Called Party Number i = 0x80, '8632683'

Plan:Unknown, Type:Unknown

Jan 18 21:02:52.935: ISDN Se0/1/0:23 Q931: Received SETUP  callref = 0x8002 callID = 0x0002 switch = primary-ni interface = Network

Jan 18 21:02:52.955: ISDN Se0/1/0:23 Q931: TX -> CALL_PROC pd = 8  callref = 0x8002

Channel ID i = 0xA98381

Exclusive, Channel 1

Jan 18 21:02:52.959: ISDN Se0/1/0:23 Q931: TX -> DISCONNECT pd = 8  callref = 0x8002

Cause i = 0x8281 - Unallocated/unassigned number

Jan 18 21:02:53.391: ISDN Se0/1/0:23 Q931: RX <- RELEASE pd = 8  callref = 0x0002

Jan 18 21:02:53.395: ISDN Se0/1/0:23 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8002

The number 8632683 needs to be mapped to an ephone-dn on your PSTN phone or it needs to be translated to 16178632683 which is already on your PSTN phone. Then the call would work. Based on the Route Pattern you mentioned -

91617.XXXXXXX, if you predot digit strip, then only 8632683 would go to the PSTN gateway. However, if you set it to

9.1617XXXXXXX, then the call should go through fine since your PSTN phone has 16178632683 as a DN.

HTH.

--
Regards,
Harmit.

monasir81 Mon, 01/21/2013 - 10:26

Hi guys,

Finally it worked!

I've changed the routepattern to 9.1617XXXXXXX

Nowe the call gets sent out t the pstn....

pfff i'm very thankful to all of you .

@aokanlawon thanks for your patience.

As we can see patience is the key to success.

There is definetely a mistake in the ipexpert workbook.

Because it is not correct.

Ayodeji oladipo... Mon, 01/21/2013 - 13:33

Monasir,

I have rated Harmit post for you. Its very important to appreciate the help we recieve on the forum. +5 Harmit.

Harmit suggestion is one way it can work. The way you have configured can also work. And I suggest you learn it also. It shows that your translation rule is not configured properly. Take some time to leanr that because its important too.

Good luck

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Actions

Login or Register to take actions

This Discussion

Posted January 12, 2013 at 12:39 PM
Stats:
Replies:22 Avg. Rating:
Views:622 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 21,026
2 15,047
3 10,314
4 7,999
5 4,856
Rank Username Points
120
90
67
65
51