vpn Multicast traffic over MPLS

Unanswered Question
Jan 16th, 2013

I am try to get a vpn multicast traffic across the MPLS cloud so sources/clients in each region have connectivity. The MSDP peer between the two region is "up" but mroute is showing NULL interface as follows:

(10.1.1.31, 224.28.28.28), 00:01:23/00:01:36, flags: PA

  Incoming interface: Ethernet0/2, RPF nbr 10.10.2.2

  Outgoing interface list: Null

So we need to enable multicast routing over the MPLS??

Some config is as follows:

one side:

R7#sh run | i multi|rp|bsr|pim

ip multicast-routing vrf site-b

multilink bundle-name authenticated

ip pim sparse-dense-mode

ip pim sparse-dense-mode

ip pim vrf site-b send-rp-announce Loopback100 scope 16

ip pim vrf site-b send-rp-discovery Loopback100 scope 16


R7#sh run in lo100

Building configuration...

Current configuration : 149 bytes

!

interface Loopback100

ip vrf forwarding site-b

ip address 172.1.1.7 255.255.255.255

ip pim sparse-dense-mode

ip igmp join-group 224.1.1.1

end

!

interface Ethernet0/1

ip address 172.10.12.37 255.255.255.252

mpls ip

end

The other side

MSDP is not configured on PE. Infect its on CE but i will paste the PE and CE config:

CE;

ip pim bsr-candidate Loopback0 0

ip pim rp-candidate Loopback0

R23#sh run int e0/0

Building configuration...

Current configuration : 221 bytes

!

interface Ethernet0/0

ip address 10.10.1.18 255.255.255.252

ip pim sparse-mode

PE:

R8#sh run | i multi|rp|bsr|pim

ip multicast-routing vrf site-b

multilink bundle-name authenticated

ip pim sparse-mode

R8#sh run int e0/2

Building configuration...

Current configuration : 247 bytes

!

interface Ethernet0/2

ip vrf forwarding site-b

ip address 10.10.1.17 255.255.255.252

ip pim sparse-mode

=======================================================

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Nagendra Kumar ... Thu, 01/17/2013 - 02:32

Hi Rajesh,

Do you have the MDT tunnel between PEs up? and do you have PIM neighborship over the MDT tunnel?.

You need MDT tunnel and PIM neighborship (over MDT tunnel) between PE devices to propagate the cusotmer control plane packets (like PIM joins for c-s,c-g) to build the tree.

Below is a link for MVPN configuration guide. You can use it as a start,

http://www.cisco.com/en/US/docs/ios/ipmulti/configuration/guide/imc_cfg_mc_vpn.pdf

Regards,

Nagendra

Actions

Login or Register to take actions

This Discussion

Posted January 16, 2013 at 7:05 AM
Stats:
Replies:1 Avg. Rating:
Views:912 Votes:0
Shares:0
Tags: multicast, pim, ldp, rp, msdp
+

Related Content

Discussions Leaderboard