Cisco Aironet Site Survey Utility CB21AG Drivers for Windows 7

Unanswered Question
Jun 14th, 2011
User Badges:

Hey everyone,


I know these are hard to find so I thought I would post them for you all. The driver for the Cisco Aironet 802.11a/b/g CardBus Wireless LAN Client Adapter (CB21AG) for Windows 7 doesn't work with the Cisco Aironet Site Survey Utility, so we need these older drivers from Atheros to get it working. The drivers are attached to this post. Download the drivers and follow these steps:


1) Uninstall the current driver downloaded by Windows update by going into Device Manager, locating the device, right-click and Uninstall.

2) Turn off all internet connections.

3) Remove the card.

4) Plug the card back in. Automatic driver install will fail so choose to browse for the driver.

5) Select the drivers you downloaded from this post.

6) Once driver is installed, launch the Cisco Aironet Site Survey Utility and it will be working!


This solution is credited to user Bobby4Hire who posted this link originally on his website:

http://bobby4hire.com/Forum/index.php?topic=75.0


Enjoy!


John

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (5 ratings)
Loading.
Leo Laohoo Wed, 06/15/2011 - 15:46
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Thanks for that.  Can you please make a comment so I can rate this post. 

Leo Laohoo Wed, 06/15/2011 - 16:44
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Gotcha!  Rated you, 

Vinay Sharma Fri, 06/17/2011 - 05:56
User Badges:
  • Gold, 750 points or more

@Neocec thanks alot for posting this important and useful information. I have posted a blog with this informaiton.


Thanks for your contribution on CSC and helping Cisco customer and partners .


https://supportforums.cisco.com/community/netpro/wireless-mobility/begin-wireless/blog/2011/06/17/cisco-aironet-site-survey-utility-cb21ag-drivers-for-windows-7



Regards,

Vinay

Giovanni Ceci Fri, 06/17/2011 - 07:39
User Badges:

Thank you Vinay. I'm always glad to help a community that helps me out so much.

peterkuric Mon, 06/27/2011 - 18:20
User Badges:

Unfortunately does not seem to work with Win7 64-Bit


"The folder you specified doesn't contain a compatible  software driver for your device. If the folder contains a driver, make  sure it is designed to work with Windows for x64-based systems."


I'm using card AIR-CB21AG-A-K9

Giovanni Ceci Mon, 06/27/2011 - 21:02
User Badges:

Hey Peter,


I've uploaded some 64-Bit drivers that may work. Try them out and let me know if they work.


Thanks,


Neocec

jmarshman Thu, 12/01/2011 - 10:42
User Badges:

Hello,


I was just wondering if anyone was having the same problem as I when I install the new drivers.  I noticed that in the Site Survey Utility, I can't uncheck "Display in percent" its greyed out.  Does anyone have this issue?

wireless wlc Sun, 11/25/2012 - 02:21
User Badges:

Hi,

  Its nto working for me. I am trying to install on windows 7 64-bit, but it shows all drivers are not compatible. i tried the ones you posted. My system is recognizing the CB21AG as a ethernet controller and when i try to update the driver, it says its not compatible. Please help


regards

Joe

Giovanni Ceci Wed, 12/19/2012 - 21:20
User Badges:

Hey 'wireless wlc', Did you try the 64-Bit Drivers that I uploaded?

wireless wlc Sun, 01/13/2013 - 09:03
User Badges:

Hi,

  Yes i tried the same driver. it says not compatible. Is there any other way out ?


regards

Joe

George Stefanick Mon, 01/21/2013 - 09:09
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, October 2015

I always hate to see this myself, as I run a blog and have been counterfeited myself, word for word. However I have learned, sometimes people do their own independent testing and problem solving without knowing about other published data and publish their results without knowing.


In any case, cheers to you Bobby for sharing your findings as well. +5




__________________________________________________________________________________________
"Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin
__________________________________________________________________________________________
‎"I'm in a serious relationship with my Wi-Fi. You could say we have a connection."

Giovanni Ceci Mon, 01/21/2013 - 09:33
User Badges:

Hey Bobby,


When I posted this (about a year and a half ago), if I recall your website wasn't working. So I put this up because I had downloaded the drivers from your post and wanted to make them available to people to help them out. But even before I put this up this post, I quoted your link on another post:


https://supportforums.cisco.com/message/3219410#3219410


I'll edit this post and quote you as the source.


Thanks,


John

dwtcp Thu, 10/02/2014 - 23:10
User Badges:

Hi,

i have just installed the windows vista latest driver on my windows 7 32Bit greek OK.

I have make the PCMCIA wireless card to work (configure ssid and key via windows) but there is no software installed!

Only a cisco aironet file with a folder icons in it!

As far as i understand, all you had the problem to make the driver work but i have no Desktop Utility or Site Survey Utility.

Cheers

Antonios

Giovanni Ceci Thu, 10/02/2014 - 23:55
User Badges:

Hi Antonio,

I would ask that you read the steps I have given and follow them exactly. I think you are most likely using the drivers that Windows automatically installs. If you unistall that driver, TURN OFF ALL YOUR INTERNET CONNECTIONS, then install the attached drivers, I am certain it will work. 

Thanks

John

dwtcp Fri, 10/03/2014 - 01:14
User Badges:

Hi John,

thanks a lot for your immediate reply.

but my problem is that there is no software installed to run!

Replacing the drivers will not make the software (Desktop utility and Site Survey Utility) to appear installed!

Let me tell you the steps i took:

1. Run WinClient-802.11a-b-g-Vista-Ins-Wizard-v1.1a.exe with the card inserted (or not)

2. when it finished, the utilities were NOT installed! (only a folder Cisco Aironet under "Αρχεία Εφαρμογών"==Program Files with a folder in it named Icon Files which has one image inside) and nothing else!

What am i missing so far?

Could the problem be the non english windows version?

Cheers

Antonios

 

P.S. I am running Windows 7 32bit, SP1

Giovanni Ceci Fri, 10/03/2014 - 10:32
User Badges:

Actions

This Discussion

Related Content

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode