DHCP IP assignment avaya phone

Answered Question
Feb 1st, 2013

We have this config set up on our switches

ip dhcp pool VOIP

   network 10.51.203.0 255.255.255.0

   default-router 10.51.203.254

   option 242 ascii "MCIPADD=10.51.203.250,MCPORT=1719,HTTPSRVR=10.51.3.6"

   lease 10

interface GigabitEthernet0/3

switchport mode access

no logging event link-status

no snmp trap link-status

spanning-tree portfast

interface GigabitEthernet0/40

description phone station 8613 mac 001b.4f31.cae1

switchport access vlan 40

switchport mode access

speed 100

duplex full

So the data vlan is default 1 on a seperate port.

And the avaya phone is on another port set to vlan 40.

I would like to use one port for both worksta and phone but how do I tell phone where its dhcp scope is and where dhcp is for the workstation?

if I need helper address where do I set it?

This is a L3 switch

interface Vlan1

ip address 10.51.3.237 255.255.255.0

ip helper-address 10.51.203.254

no ip route-cache cef

no ip route-cache

!

interface Vlan40

ip address 10.51.203.254 255.255.255.0

!

ip default-gateway 10.51.3.254

ip classless

ip route 0.0.0.0 0.0.0.0 10.51.3.254

ip http server

I have this problem too.
0 votes
Correct Answer by Gabriel Hill about 2 years 4 months ago

Hello John,

You would have to configure a voice vlan on the switchport.

interface GigabitEthernet0/3

switchport mode access

switchport voice vlan 40

no logging event link-status

no snmp trap link-status

spanning-tree portfast

The data vlan on the DHCP server has option 176 (for 46XX phones) and option 242 (96XX) phone. Since the avaya phone cannot learn about the "voice vlan" via CDP, DHCP must tell it where to go.

The 176/242 scope is setup as follows (ON THE DATA VLAN): L2Q=1,L2QVLAN=XXX (XX being the voice vlan)

Which will punt the request over to the voice vlan scope, where you have your 242 scope telling the phone where to contact the call server.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Correct Answer
Gabriel Hill Fri, 02/01/2013 - 06:45

Hello John,

You would have to configure a voice vlan on the switchport.

interface GigabitEthernet0/3

switchport mode access

switchport voice vlan 40

no logging event link-status

no snmp trap link-status

spanning-tree portfast

The data vlan on the DHCP server has option 176 (for 46XX phones) and option 242 (96XX) phone. Since the avaya phone cannot learn about the "voice vlan" via CDP, DHCP must tell it where to go.

The 176/242 scope is setup as follows (ON THE DATA VLAN): L2Q=1,L2QVLAN=XXX (XX being the voice vlan)

Which will punt the request over to the voice vlan scope, where you have your 242 scope telling the phone where to contact the call server.

john.wright@kao... Fri, 02/01/2013 - 07:04

Gabriel

So I need to add the voice vlan 40 to the port config. I got that.

But not sure where or how to add this.

L2Q=1,L2QVLAN=XXX (XX being the voice vlan)?

As you see the current setting  of op 242 is this:

option 242 ascii "MCIPADD=10.51.203.250,MCPORT=1719,HTTPSRVR=10.51.3.6"

Gabriel Hill Fri, 02/01/2013 - 07:08

Najaf has a good example. The way I've set this up in the past I only use "L2Q=1,L2QVLAN=40" (40 being your voice vlan) on the 242 DHCP option on the data dhcp scope.

Example:

ip dhcp pool DATA

  option 242 ascii "L2Q=1,L2QVLAN=40"

NOTE: I didn't type out all your data scope, just showing you what you would need added to it.

Of course you can use the full scope option, I just never found it necessary.

Add the 242 option to your DATA DHCP scope.

kcnajaf@25070 Fri, 02/01/2013 - 06:54

Hi John,

Modify your conffiguration as below.

First you need to define data vlan. There use option 176 to define voice vlan using option 179 and 242

ip dhcp pool DATA

   network 10.51.3.0 255.255.255.0

   default-router 10.51.3.257

   option 179 ascii "MCIPADD=10.51.203.250,MCPORT=1719,HTTPSRVR=10.51.3.6,L2Q=1,L2QVLAN=40

  option 242 ascii "MCIPADD=10.51.203.250,MCPORT=1719,HTTPSRVR=10.51.3.6,L2Q=1,L2QVLAN=40"

   lease 10

ip dhcp pool VOIP

   network 10.51.203.0 255.255.255.0

   default-router 10.51.203.254

   option 242 ascii "MCIPADD=10.51.203.250,MCPORT=1719,HTTPSRVR=10.51.3.6"  

  option 179 ascii "MCIPADD=10.51.203.250,MCPORT=1719,HTTPSRVR=10.51.3.6"

   lease 10

Configure the switch port as below to define data and voice vlan

interface GigabitEthernet0/40

description phone station 8613 mac 001b.4f31.cae1

switchport mode access

switchport access vlan 1

switchport voice vlan 40

speed 100

duplex full

Also exclude the address which you are using for gateway

ip dhcp excluded-address 10.51.203.254

ip dhcp excluded-address 10.51.3.257

You dont need the dhcp helper in your case  since the dhcp client connected to the same switch. In normal case the DHCP helper would be on the L3 interface

Hope this helps.

Regards

Najaf

Please rate when applicable or helpful !!!

john.wright@kao... Fri, 02/01/2013 - 07:17

KC

I am unclear about why there are two dhcp scopes in your answer.

This location gets its IP for data from a server.

but the phones get their ip from the switch.

Would this work?

ip dhcp pool VOIP

   option 242 ascii L2Q=1,L2QVLAN=40,MCIPADD=10.51.203.250,MCPORT=1719,HTTPSRVR=10.51.3.6  

    network 10.51.203.0 255.255.255.0

    default-router 10.51.203.254

    lease 10

kcnajaf@25070 Fri, 02/01/2013 - 07:23

Hi John,

Forgot to mention that the phone initially pick up ip address from data vlan. Then with option 179/242 it will understand about the voice vlan and they pick up the correct ip from voice vlan

If you are not running data vlan on this switch you can configure the option 179/242 on where ever you are running the dhcp scope for data vlan even if it's on Microsoft dhcp sever.

Hope that helps

Regards
Najaf

Sent from Cisco Technical Support iPhone App

john.wright@kao... Fri, 02/01/2013 - 07:42

KC

I forgot to mention the following in my initial problem description.

The current config of seperate ports for phone and data must remain.

But any additonal phone will be configed as phone and data on one port.

Will the existing phones have a problem if I make this change?

And just to be clear; you are saying put both of these IP pool scopes in the switch config and the data IP's will still be handed out by our dhcp server?

ip dhcp pool DATA

   network 10.51.3.0 255.255.255.0

   default-router 10.51.3.257

   option 179 ascii "MCIPADD=10.51.203.250,MCPORT=1719,HTTPSRVR=10.51.3.6,L2Q=1,L2QVLAN=40"

  option 242 ascii "MCIPADD=10.51.203.250,MCPORT=1719,HTTPSRVR=10.51.3.6,L2Q=1,L2QVLAN=40"

   lease 10

ip dhcp pool VOIP

   network 10.51.203.0 255.255.255.0

   default-router 10.51.203.254

   option 242 ascii "MCIPADD=10.51.203.250,MCPORT=1719,HTTPSRVR=10.51.3.6" 

  option 179 ascii "MCIPADD=10.51.203.250,MCPORT=1719,HTTPSRVR=10.51.3.6"

   lease 10

kcnajaf@25070 Fri, 02/01/2013 - 07:55

Hi,

One phone on separate data and voice vlan and others Phone on same port of data and voice vlan will not have pbm.

But having 2 data vlan will be a problem. You will have choose one data vlan and configure option 179/242 on it.

Regards
Najaf

Sent from Cisco Technical Support iPhone App

john.wright@kao... Fri, 02/01/2013 - 08:10

KC

I don't think I am making this clear.

The data vlan will not change. it is vlan 1 the default for all data.

here is what we have running as the config for ports on all the switches:

If the connected device is a workstation we have this set:

nterface GigabitEthernet0/6
switchport mode access
no logging event link-status
no snmp trap link-status
spanning-tree portfast

If the connected device is a phone we have this:

interface GigabitEthernet0/31
switchport access vlan 40
switchport mode access
speed 100

duplex full

The above port config will remain as you see it.

But

I want to add this port config in additon to what you see above so that we only have to use one port when a new person starts.

nterface GigabitEthernet0/40

description phone station 8613 mac 001b.4f31.cae1

switchport mode access

switchport access vlan 1

switchport voice vlan 40

speed 100

duplex full


Will this work providing that we use the config you mentioned in previous response?

kcnajaf@25070 Fri, 02/01/2013 - 08:25

Hi,

Your port configuration looks fine.. That will work as expected..

My point was different. I was referring to where you place the data dhcp scope. You can have only one dhcp scope either on switch or on server. You cannot have one data scope on switch and other on server. Where ever you decide to run the dhcp scope there you need to mention the option 179/242 and tell what is the voice vlan. Otherwise phone is not going to know about voice vlan to pick the ip address from voice dhcp scope.

Hope your are clear now.

Regards
Najaf

Sent from Cisco Technical Support iPhone App

john.wright@kao... Fri, 02/01/2013 - 08:49

KC

Thanks for all the reponses but I am still unclear.

The DHCP for DATA has always been on one of our servers and it is not changing.

The DHCP for PHONE has always been on the Cisco switch and it is not changing.

What do I need to add to my current VioP dhcp scope on the cisco switch so that the phones know how to get an IP?

This is what I have right now.

ip dhcp pool VOIP
network 10.51.203.0 255.255.255.0
default-router 10.51.203.254
option 242 ascii "MCIPADD=10.51.203.250,MCPORT=1719,HTTPSRVR=10.51.3.6"
lease 10

This is what you provided earlier.

ip dhcp pool VOIP

   network 10.51.203.0 255.255.255.0

   default-router 10.51.203.254

   option 242 ascii "MCIPADD=10.51.203.250,MCPORT=1719,HTTPSRVR=10.51.3.6"

  option 179 ascii "MCIPADD=10.51.203.250,MCPORT=1719,HTTPSRVR=10.51.3.6"

   lease 10

is this what I need to add to me cisco switch so that phones can get an IP?

kcnajaf@25070 Fri, 02/01/2013 - 08:57

Hi,

Use the configuration I have provided for dhcp voice pool.

On the data dhcp scope for vlan1 enable option 176/242 as per below URL

http://www.ipofficeassistance.com/HOWTO_DHCP_IP_Phones.html

And give a try with the connecting Avaya phone to one switch port and verify if it picks ip address

Regards
Najaf
Sent from Cisco Technical Support iPhone App

john.wright@kao... Fri, 02/01/2013 - 11:11

KC

I just got my server support team to look at this.

He pointed out that the instructions indicate a change needs to be made to the IP phone scope on the server.

However, the phone scope is not on the server. It is on the switch.

Should that part of the instructions be ignored?

Thanks for your help

kcnajaf@25070 Fri, 02/01/2013 - 12:29

Hi,

We cannot ignore this. The data document clearly shows this need to be done on the data vlan... As far as you said saw far you are running the data vlan on the server and not on the switch.

For voice vlan we have already done this as per my recommended configuration.

Hope that helps

Regards

Najaf

Sent from Cisco Technical Support iPhone App

john.wright@kao... Fri, 02/08/2013 - 09:41

Since these were Avaya 9620 model phone the resolve for this was to add opt 242 to the data dhcp server.

engrmuradpk1 Thu, 01/30/2014 - 01:10

i have 4 avaya switch and 1 pbx , dhcp and also have 36 phone and 92 pc . my ip 192.168.x.x is that i am want to creat two vlan one for voice and one for data.i am not work on avaya switch ples help me how i configur the switch .and also internaly configuratin of switch for dhcp

1 how i creat the vlan

2 how i configure the dhcp on switch

Actions

Login or Register to take actions

This Discussion

Posted February 1, 2013 at 6:07 AM
Stats:
Replies:16 Overall Rating:4
Views:8039 Votes:0
Shares:0
Tags: No tags.