Nexus 7k vPC to Catalyst 3750

Unanswered Question
Feb 4th, 2013

All,

I am having trouble getting a port-channel to come up.  I have two Nexus 7ks connected to one Catalyst 3750.  Please lend me some assistance.  Here are the relavant configs for each:

Nexus7k-1# sh ru int po48

interface port-channel48  

description uplink to Catalyst3750  

switchport  

switchport mode trunk  

switchport trunk native vlan 666  

switchport trunk allowed vlan 2050  

vpc 48

Nexus7k-2# sh ru int po48 

interface port-channel48  

description uplink to Catalyst3750  

switchport  

switchport mode trunk  

switchport trunk native vlan 666  

switchport trunk allowed vlan 2050  

vpc 48

Nexus7k-1# sh ru int e1/2

interface Ethernet1/2  

switchport  

switchport mode trunk  

switchport trunk native vlan 666  

switchport trunk allowed vlan 2050  

channel-group 48 mode active  

no shutdown 



Nexus7k-2# sh ru int e1/2

interface Ethernet1/2  

switchport  

switchport mode trunk  

switchport trunk native vlan 666  

switchport trunk allowed vlan 2050  

channel-group 48 mode active  

no shutdown 

PHCSW11-37673-SC44#sh ru int po48

! interface Port-channel48

description Uplink to EBU

switchport trunk encapsulation dot1q

switchport trunk native vlan 666

switchport trunk allowed vlan 2050

switchport mode trunk

switchport nonegotiate

Catalyst3750#sh ru int t1/1/1

! interface TenGigabitEthernet1/1/1

description to Nexus7k-1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2050

switchport mode trunk

channel-protocol lacp

channel-group 48 mode active

end

Catalyst3750#sh ru int t1/1/2

! interface TenGigabitEthernet1/1/2

description Nexus7k-2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2050

switchport mode trunk

channel-protocol lacp

channel-group 48 mode active

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (1 ratings)
mshatkus1 Mon, 02/04/2013 - 07:19

Nexus7k-1# sh vpc 48 vPC status ---------------------------------------------------------------------- id  Port  Status Consistency Reason                    Active vlans --  ----  ------ ----------- ------                    ------------ 48  Po48  down*  success    success                    - Nexus7k-1# show vpc consistency-parameters vpc 48     Legend:         Type 1 : vPC will be suspended in case of mismatch Name                        Type  Local Value            Peer Value -------------              ----  ---------------------- ----------------------- STP Port Type              1    Default                Default STP Port Guard              1    None                  None STP MST Simulate PVST      1    Default                Default Allowed VLANs              -    2050                  2050 Local suspended VLANs      -    -                      - Nexus7k-2# sho vpc 48 vPC status ---------------------------------------------------------------------- id  Port  Status Consistency Reason                    Active vlans --  ----  ------ ----------- ------                    ------------ 48  Po48  down*  Not        Consistency Check Not      -                   Applicable  Performed Nexus7k-2# show vpc consistency-parameters vpc 48     Legend:         Type 1 : vPC will be suspended in case of mismatch Name                        Type  Local Value            Peer Value -------------              ----  ---------------------- ----------------------- STP Port Type              1    Default                Default STP Port Guard              1    None                  None STP MST Simulate PVST      1    Default                Default Allowed VLANs              -    2050                  2050 Local suspended VLANs      -    -                      -

mshatkus1 Mon, 02/04/2013 - 08:08

That's the same command output as posted the post earlier except cleaner.  Cannot stand how text copies into the editor, so I pasted it into notepad and made it an image to read easier.  Can anyone help me as to why the port-channel will not come up?  Do you need any more information?

Matt

onestero Mon, 02/04/2013 - 08:42

Hi Matt

Can you please show:

sh vpc

sh port-cha summ | grep 48

sh int eth 1/2

sh int po48

from both n7k.

Thanks

Alex

onestero Mon, 02/04/2013 - 23:10

Hi Matthew

Andras is right. From the output - both physical interfaces suspended and port-chanel is down due to abscence of operational members.

Usually links are suspended due to inconsistency of configuration on LACP peers.

If you check the log on n7k (show log log) and catalyst (sh log) you should see the reason why the links are suspended.

But most likely it's due to native vlan mismatch.

Alex

vismishr Sat, 02/09/2013 - 22:50

Mat,

I will suggest to check 2 things to narrow it down.

1.Remove the ports from port channel and confirm they are coming up/up as trunk ports to narrow down issue with LACP .

2.Is native vlan 666  up ? i dont see that on the VPC peer link if that is up i should see that,this could be due to the fact that you have L2  inconsistency (Type-2 inconsistency reason       : VTP type-2 configuration incompatible ) fix this as well.

Vishwa..

Actions

Login or Register to take actions

This Discussion

Posted February 4, 2013 at 6:47 AM
Stats:
Replies:7 Avg. Rating:
Views:3013 Votes:0
Shares:0

Related Content

Discussions Leaderboard