C220 M3 problem recognizing HDD disks

Unanswered Question
Feb 8th, 2013
User Badges:

Hi,

We recently have bought a UCS C220 M3 Server, in order to install a virtual environment through ESXi. When trying to install EXSi 4.1; the hard disks are not recognized and listed.

When connecting to the Web GUI (CIMC), in the inventory, the disks are not displayed...

We use 3 disks (A03-D500GC3)


cisco.JPG

What can i do in this situation?


Edit: the ESXi installation was tried with RAID and without RAID, same problem. when configuring RAID, the disks are recognized

Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
b.moakhar Tue, 02/12/2013 - 01:58
User Badges:

Hi Padma,

Thanks for your response.

Concerning your first question the answer is yes, the server lists the disks when booting and sees the LSI RAID as shown in this picture:

But the weird thing here is that i cannot access the Webbios interface. as you see, we are not prompted to access it through the "ctrl + h" command...we can only access the LSI RAID interface using "ctrl+m" (in that interface the disks are seen and ready)

here some information about the server:

The RAID cables seem to be correctly connected.

David McFarland Tue, 02/12/2013 - 08:35
User Badges:
  • Cisco Employee,

Bilel,


From the POST screen shot, you have the embeded Intel Patsbug SCU (Storage Control Unit) software raid array. It is software based and will not show up in the hardware storage inventory in CIMC.


It is also not supported by VMWare, so, there are no drivers available for ESXi. You will not see the software raid device to install on.


In order to be supported, you can either use the SD Flexflash, or potentially upgrade to either a mezzanine or PCIe array controller.


Dave

b.moakhar Wed, 02/13/2013 - 00:06
User Badges:

Thanks Dave,

So unless upgrading the server, we cannot install VMware..


We even met this problem when installing Windows Server 2008 (in order to install Hyper-V), with and without RAID 5 config. See below when the RAID is online:


In this case, the disks are not seen.(see screenshot)


Now, and this wasn't the case before, we have this screen when booting:



This is kind of frustrating, we have a server but we can't install any OS on it...

Thanks for your help

padramas Wed, 02/13/2013 - 04:19
User Badges:
  • Cisco Employee,

Hello Bilel,

Hypervisors do not support embedded RAID controller.


http://www.cisco.com/en/US/docs/unified_computing/ucs/c/hw/C220/install/raid.html#wp1028426


------------------

VMware  ESX/ESXi or any other virtualized environments are not supported for  use with the embedded MegaRAID controller. Hypervisors such as Hyper-V,  Xen, or KVM are also not supported for use with the embedded MegaRAID  controller.

-----------------


However, you can install OS with installing appropriate drivers.


For W2K8 R2, the driver is available under  \Windows\Storage\Intel\C600\W2K8R2\x64


http://www.cisco.com/en/US/docs/unified_computing/ucs/os-install-guides/windows/CSERIES-WINDOWS_chapter_011.html


Padma

b.moakhar Thu, 02/14/2013 - 07:19
User Badges:

Thanks Padma for your response



I downloaded The Cisco UCS C-Series Drivers DVD ISO image from cisco site (ucs-cxxx-drivers.1.4.7.a.iso), following the link you gave me (\Windows\Storage\Intel\C600\W2K8R2\x64).


after that, I mapped the file and the installation iso file of win2K8R2, and I began installing windows server. when I try to use the driver in order to see disks, and when I uncheck "hide drivers not compatible with this computer", the installer shows many drivers:





however, when i check it, no driver is shown:

i'm desperate here!

jose-lara Fri, 03/08/2013 - 04:37
User Badges:

Hello  Bilel!


I have the same problem whit that server. How could you solve it?


thanks in advance for you time!

b.moakhar Fri, 03/08/2013 - 05:12
User Badges:

Hi,

We are still working on this case with Cisco support team, but it seems to be a hardware issue (motherboard maybe). I advice you to contact them...

Leonid.Arkhipov_2 Wed, 07/24/2013 - 17:41
User Badges:

Hi David,


I found the guide on creating partitions for VMware on FlexFlash at the link below:

http://www.cisco.com/en/US/solutions/collateral/ns340/ns517/ns224/ns944/white_paper_c11-718938.html


However it's not quite clear whether the ESXi hypervisor will be able to see SW on-board RAID once ESXi is installed on SD Flexflash with properly created partitions. Could you clarify this?


SKU for FlexFlash mentioned above is UCSC-SD-16G-C220.


Many thanks


Leo





pkada2105 Thu, 06/20/2013 - 22:11
User Badges:

Folks


I am facing similar issue, Appreciate if anyone respond to this.



I was able to install the ESXi5.1 server on C22 M3 UCS. I am seeing the problem where HD is not recognized by the bios. I keep getting the following message all the time in a loop. Hard disk is seen during the boot. I have not configured any RAID and the Server has only 1 Hard-drive. I include the HD in the configured boot order and power-cycle or reboot the server, it comes up with only the PXE & EFI option for actual boot order. I was able to successfully install ESXi5.1 thorough external CDROM drive on the hard-drive. However, when I try to boot it from the HD where the ESXi server is installed, it does not work.


Can you pls advice how to proceed and if you have seen this problem before?







Thanks

smcquerr Fri, 06/21/2013 - 07:14
User Badges:
  • Cisco Employee,

Pramod,


Based on your screenshots it looks as though your C22 is using the embedded controller.  In order for the server BIOS to see the drive you must create a Virtual Drive using the Ctrl-M feature shown in your second screen capture, the server BIOS will not be able to recognize the drive as a pass-through (JBOD) device.


Once you do this however ESXi will not be able to see the drive for install because the onboard controller and associated software are not certified on the ESX HCL.  Note table 5 located on page 18 in the C22 Spec Sheet states that there is no VMWare support for the embedded controller.


http://www.cisco.com/en/US/prod/collateral/ps10265/ps10493/c22m3_sff_specsheet.pdf



Abdulhadi ettwijiri Thu, 05/23/2013 - 00:08
User Badges:

I also have the same problem, since a week   I'm trying to fix the problem without success, if you solve it please tell me what can i do to fix these problem

b.moakhar Thu, 05/23/2013 - 04:51
User Badges:

Hi,

After consulting Cisco Support team, the problem was located on the motherboard... they had replace it and then we were able to install OS on the server

dhani.irwan Tue, 05/28/2013 - 18:35
User Badges:


Same problem with me in Cisco C22 M3, is it problem with the motherboard or HDD ? how to replaced the motherboard?

iam using Windows 2008 Standard Edition X86

b.moakhar Wed, 05/29/2013 - 00:22
User Badges:

Hi,

in our case, the problem didn't come from HDD but from motherboard. the server was under warranty, so cisco support replaced it for us.

jose-lara Wed, 05/29/2013 - 05:02
User Badges:

Hello Dhani,


You have configured a RAID in your system? If so usually, if the additional adapter is not recognize by  the windows installer, it means that the driver is not included or the  windows binaries are custom (built without those drivers). Try with a new version of win 2008



Below the compatibles OS for the embedded Raid Controller LSI MegaSR (Software controller)


•             Microsoft Windows Server 2008R2

•             RedHat Enterprise Linux RHEL 5.7, 6.1 and 6.2

•             SLES 11 SP1 and Sp2



Hope it works for you!

dhani.irwan Tue, 06/04/2013 - 02:56
User Badges:

Thanks..the problem has been solved. Cisco UCS C22 M3 that we had only support Windows Server 2008 R2 64bit not 32bit


:-)

faisal.almasaabi Thu, 02/06/2014 - 04:01
User Badges:

Thanks Dhani Irwan for the tip. I was installing Windows server 2008 x86 and when I load  the driver from C600 folder it was telling me that it's not supporting,  but after using 64-bit windows it detects the HHD and installation is in  progress now.

bechara abou rahal Thu, 06/06/2013 - 22:50
User Badges:

I cant see the HDD in the BIOS, neither in the Inventory of CIMC


what should be done in this situation?


I have  LSI 9265CV-8i MegaRAID SAS HBA

Keny Perez Fri, 06/07/2013 - 07:42
User Badges:
  • Blue, 1500 points or more

Bechara,


Can you attach screenshots and describe what you have done/tried so we do not begin with basic troubleshooting?  Also, screenshots, CIMC/BIOS version will help.





-Kenny

bechara abou rahal Fri, 06/07/2013 - 08:18
User Badges:

After removing the cables then plug them back to the motherboard, i was able to go to lsi configuration by using CTL+M key, then i have configured the virtual disks,


Is it possible that the only supported os is 2008 R2?

I couldnt also install 2012 or esx 5.0

smcquerr Fri, 06/07/2013 - 08:42
User Badges:
  • Cisco Employee,

The 9265CV-8i should see the disks and you should be able to install on that.  It if everything was cabled and the option ROM was enabled that should have worked.  I would suggest you open a case with TAC if that controller is not working.


By connecting the cables on the motherboard you are now using the RAID on Motherboard option (ROMB).  This is the C600 controller on board the system using the LSI software RAID.  This is supported for Win2K8 and Win2k12.  It is NOT supported for ESXi.


CIMC will not show the drives in the inventory when using the onboard controller, this is expected behavior.


To see the drives for a windows install you will need to mount the drivers ISO (avalible from cisco.com), choose the Intel C600 folder from the mounted ISO and then scan the drives for install.  See the attached screenshots:

Alagusundaram s... Wed, 06/04/2014 - 03:35
User Badges:

Hi All,

 

I have experienced the same issue on UCS C220 M3 server. Tried below steps to get it back,

  1. Upgrade the RAID card firmware version.

    Please check the documentation in order to perform the action: http://tools.cisco.com/squish/01aC9

  2. Factory reset the server (Before do this make sure somebody is available onsite to take console & assign CIMC IP again)

  3. To confirm the status(Presence) of HDD, Please check the SEL logs 

    # 17 02 00 00 01 02 00 00 7D 9B 79 53 20 00 04 0D 42 00 00 00 6F 00 FF FF # 217 | 05/19/2014 05:49:49 | CIMC | Drive slot(Bay) HDD1_STATUS #0x42 | Drive Presence | Asserted

    # 18 02 00 00 01 02 00 00 7D 9B 79 53 20 00 04 0D 43 00 00 00 6F 00 FF FF # 218 | 05/19/2014 05:49:49 | CIMC | Drive slot(Bay) HDD2_STATUS #0x43 | Drive Presence | Asserted

    Slot:  2

      Description:  LSI 6G MegaRAID SAS 9271-8i card with Supercap (RAID 0,1,5,6; RAID spans 10,50,60) - External mini-SAS connectors

      PID:  UCS-RAID9271-8i

      Vendor: 0x1000

      Device: 0x005b

      SubVendor: 0x1000

      SubDevice: 0x9271

  4. Check on the link below how the cables should be connected:

    “ Cable Routing” http://www.cisco.com/c/en/us/td/docs/unified_computing/ucs/c/hw/C220/install/C220.pdf   page 127

  5. If still not working, its time to replace RAID Controller Card.

 

Cheers,

Alag

Actions

This Discussion