CUIC UCCX 9.0.1 Real Time reports

Answered Question
Feb 20th, 2013

Hi, I have a problem with importing Real time reports.

Release notes state that appropriate Data source should be configured before importing Real Time report templetes.

CUIC user guide  states that UCCE Historical and UCCE Real Time data sources exist by  default upon fresh installation. However, in my case, there are only CUIC and UCCX datasouces configured by default (UCCX pointing to db_cra). Should I create a UCCE Real Time Data source? What database/user should it use? 

I'm running CUIC as a part of UCCX, not on standalone server.

Kind Regards,

Davor

I have this problem too.
0 votes
Correct Answer by Graham Old about 1 year 3 weeks ago

You have to create your report on a premium version of CUIC, you can then export it and import it into CCX.

Are you trying to create a wallboard type display? this is from my lab system not a customer.

If you import the attached zip you will be able to create this display. This reads the rtCSQssummary table so remember to enable it it in "Real Time Snapshot Config"

Graham

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (2 ratings)
Gergely Szabo Wed, 02/20/2013 - 08:22

Hi,

why do you want to integrate your CUIC with UCCE if you don't have UCCE? Can you please give us more details.

G.

davor.vragovic Wed, 02/20/2013 - 10:26

Hi,

I don't want to integrate it wiith CCE, but it is the only thing that I found in CUIC documentation related to my problem.

Basically, what I want to do is use Real time reporting capability of CUIC to set up a wallboard for our Call Centar. If I understood correctly, this is possible (Plase correct me if I'm wrong).  Since there were no Real Time reporting templates available in CUIC when I initially installed it, i figured I could download report templates from cisco site and install them, but now that we're talking about them, they are CCE templates actually (there were no CCX templates available for download). So perhaps the main question is can I use CUIC for real time reporting if I have CCX?

Aaron Harrison Wed, 02/20/2013 - 10:28

Hi Davor

My understanding is that the ability to auto-refresh reports (i.e for a wallboard or any other realtime type thing) isn't in 9.0, but will be in a future release.

Aaron

Gergely Szabo Wed, 02/20/2013 - 10:34

Hi,

well, you can certainly integrate CUIC with UCCX, but why would you do that. I mean, the UCCX database schema is available and documented, and you can easily create your wallboard solution without CUIC, just by talking to the UCCX database.

G.

davor.vragovic Wed, 02/20/2013 - 10:47

Hi,

I am aware of that but I'm not that good at coding. Also, I figured that if  real time reports already exist for CUIC and you can configure them  with permalinks etc. it would be better to use something that already exists rather than something you need to develop.

Still can I configure them on CCX? I would cetainly like to set them up if it is possible, regardless of auto-refresh disability.

Gergely Szabo Wed, 02/20/2013 - 10:59

Hi,

well, never did that, but technically, yes, it might be possible. I mean, CUIC can talk to an Informix database, and UCCX is sitting on a top of an Informix database, so... well, yes, but I might be wrong. Aaron, Anthony, your opinion, please.

A quick search returned this thread: https://supportforums.cisco.com/message/3426248#3426248 but there isn't a yes or no either.

G.

Aaron Harrison Wed, 02/20/2013 - 13:57

Hi Gergely

I think what the OP is getting at is that in 9.x they have introduced CUIC as a built in feature to replace the legacy HRC app with UCCX.

I've not personally played with CUIC, but I believe if you want something other than the canned reports you must purchase the lab (customer) or NFR (partner) CUIC Premium for $100 or whatever it is - you then built reports on that, export, and import to UCCX CUIC.

If the realtime stuff isn't in what Cisco provide, then that's probably what you need to do.

And the realtime 'stuff' is basically two tables - rtcsqssummary and rticdstatistics that are in db_cra, so if you are attached to that you should be able to query those as you do anything else.

In future with some sort of auto-refresh capability you might be able to build a pretty effective, on-box wallboard.

Aaron

davor.vragovic Fri, 02/22/2013 - 01:10

Yes, I was reffering to CUIC as a built in feature of UCCX. In the meantime I installed CUIC as a standalone server on ESX. Data sources which I mentioned in first post (UCCE Historical and UCCE Real Time) exist by default as documentation stated but they are not configured and type of connection cannnot be changed - they are set up for SQL, not Informix.

I set up new data source with the following configuration:

database name: db_cra

user id: uccxhruser

pass: password I set up in UCCX->Tools->Password Management for Historical Reporting user

Connection to database was ok, data source was marked online but import of Real time reports template failed. I also tried using uccxwallboard user instead of uccxhruser but without success.

davor.vragovic Fri, 03/15/2013 - 06:57

In the meantime I got information from TAC that Real Time reports are not available for CUIC with UCCX 9.x. It is planned to be supported in UCCX 10.

Correct Answer
Graham Old Fri, 03/15/2013 - 13:09

You have to create your report on a premium version of CUIC, you can then export it and import it into CCX.

Are you trying to create a wallboard type display? this is from my lab system not a customer.

If you import the attached zip you will be able to create this display. This reads the rtCSQssummary table so remember to enable it it in "Real Time Snapshot Config"

Graham

davor.vragovic Thu, 03/21/2013 - 07:57

Hi Graham,

This is what I was looking for. Thank you!

I was trying to create a wallboard type display. So if I got this right, if I don't have a premium version I can't create report definitions? Was this created from the scratch or you used avaliable template from cisco site and modified it?

Graham Old Thu, 03/21/2013 - 08:12

That is correct you can only create a report definition (SQL) using the premium version.

This was created from scratch on a premium CUIC and then exported.

You can get a 60 day trial license of the premium version from the usual licensing web site.

Graham

rcrumm_2 Sat, 08/03/2013 - 21:35

HI,

I have enhanced licensing and tried to import this zip file but it failed.

Import could not be completed: 1 Report failed to import. Please check  the logs - Query validation failed - The specified table (rtcsqssummary)  is not in the database.

Is this because i do not have premium licensing?

I am using UCCX 9.0.2

Thanks,

Randall

sarbarnes Wed, 07/17/2013 - 08:48

Hi Graham, I have downloaded your wallboard zip file, and whilst it works in our lab great, when I have imported it into the customer enviroment, the QueueName is blank andthe refresh list does not work!

Any ideas?

Graham Old Wed, 07/17/2013 - 08:56

Have you enabled the "Real Time Snapshot Config" to update the rtCSQssummary table.

Appadmin then Tools/Real Time Snapshot Config"

Graham

sarbarnes Wed, 07/17/2013 - 12:52

Thanks Graham for your help,

I am sort of at a half way house now, which I am hoping you help me with.

1st I downloaded your report - straight to the customer site and it does not show any CSQ names.

2nd I downloaded onto our lab system, used premium CUIC to make some changes and then tried to import to the customer site and I get jsp.sync error message.

3rd I then created the whole report copying in your SQL, however I add in Key Criteria field as Queue and when I have imported to the customer site I can see the CSQs, however I then get Dataset failed when  I try to run it.

Either way I cut it I get an error :-(

basically what I am trying to do is create a wallboard that will show the total of all CSQs, showing calls Waiting, handled, Abandoned, number of agents Ready & not ready, & Avg Wait time.

If you can help in anyway at all I would be most grateful.



jeroenhermans Fri, 11/08/2013 - 13:14

Hi Graham,

Thanks for your report. I was able to import it but it is not showing any data in our environment.

I have enabled the Real Time Snapshot Config. It was asking me about the server name in that config aswell so I entered the IP address of the UCCX server.

ANy ideas on how to get it to work?

Thanks,

Jeroen

Graham Old Fri, 11/08/2013 - 14:04

Hi Jeroen

Do you have a HA system as the rtcsqssummary table is only written on the active server.

Run this command from the cli to see if you have any data in the table:

run uccx sql db_cra select * from rtcsqssummary

Regards

Graham

jeroenhermans Sat, 11/09/2013 - 02:06

Hi Graham,

Thanks for your fast response.

Indeed, we have a HA system. When I run the command on the active server in the CLI I indeed get results. When I run it on the inactive server there are no results.

I have now changed the IP address of the server name in the Real Time Snapshot Config to the ip address of the active server, but i still cannot run the CUIC report.

These are the errors I get when I try to run the report:

Please correct the validation errors for the following fields and try again: QueueName (@QueueName)

The value list cannot be blank. Please pick one or more values from the value list

Thanks in advance to help me out.

Rgds,

Jeroen

Graham Old Sat, 11/09/2013 - 11:17

Hi Jeroen

There are two SQL queries going on here, the first get the queue names and the second gets the data based on the queue names.

Force a change over between the active and standby servers so the csqssummary tables on both servers have data in. If you want the original to be active then force it back once it has written the queue names.

If your display is not updating then you are looking at the wrong server.

If you add (or delete) queues you will need to force a change over so both csqssummary tables have the same queue names in.

Regards

Graham

Actions

Login or Register to take actions

This Discussion

Posted February 20, 2013 at 6:42 AM
Stats:
Replies:20 Avg. Rating:5
Views:5083 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard