Mobility Service Engine 7.4.100.0 ova WEB Services problem

Unanswered Question
Mar 4th, 2013

Hello,

We have sucessfully installed MSE-VA-7-4-100-0.ova file in our Lab, and after installation we can't open https session with MSE.

When we type <https://mymseipaddress> we are getting these message:

Error 404 - Not Found.

No service matched or handled this  request.

Known services are:

http://my server:8880/hs/

http://my server:8880/mdp/

http://my server:8880/admin/

http://my server:8880/wips/

http://my server:8880/location/

http://my server:8880/subscription/

http://my server:8880/aaa/

http://127.0.0.1:8180/localadmin/

https://127.0.0.1:8443/localadmin/

https://my server:8843/mdp/

https://my server:8843/wips/

https://my server:8843/hs/

https://my server:8843/admin/

https://my server:8843/location/

https://my server:8843/subscription/

https://my server:8843/aaa/

We are able to import MSE to Cisco Prime Infrastructure 1.3 and we have communication with WLC. We have tried proposed solution explained in link below:

https://supportforums.cisco.com/message/3656441#3656441

but we are are unable to import server certificate  becouse our certificate vallidation is falling. We don't know how we should append private key to the signed certificate in order to get our MSE web services up and running.

Any help in solving this problem would be much appreciated.

Regards,

Jelena

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Jelena1987 Mon, 03/04/2013 - 00:42

Here is the output from getserverinfo:

[root@MDS-MSE-LAB ~]# getserverinfo

Health Monitor is running

Starting MSE Platform, Waiting to check the status.

MSE services are up, getting the status

-------------

Server Config

-------------

Product name: Cisco Mobility Service Engine

Version: 7.4.100.0

Health Monitor Ip Address: 1.1.1.1

High Availability Role: 1

Hw Version: V01

Hw Product Identifier: AIR-MSE-VA-K9

Hw Serial Number: MDS-MSE-LAB.mds.rs_3287d770-825b-11e2-8bd8-00505692612a

Use HTTP: false

Legacy HTTPS: false

Legacy Port: 8001

Log Modules: -1

Log Level: INFO

Days to keep events: 2

Session timeout in mins: 30

DB backup in days: 2

-------------

Services

-------------

Service Name: Context Aware Service

Service Version: 7.4.0.38

Admin Status: Enabled

Operation Status: Up

Service Name: WIPS

Service Version: 1.0.4041.0

Admin Status: Disabled

Operation Status: Down

Service Name: Mobile Concierge Service

Service Version: 2.0.0.37

Admin Status: Enabled

Operation Status: Up

Service Name: Location Analytics Service

Service Version: 1.0.0.12

Admin Status: Enabled

Operation Status: Up

--------------

Server Monitor

--------------

Server start time: Fri Mar 01 15:59:43 CET 2013

Server current time: Mon Mar 04 09:39:45 CET 2013

Server timezone: Europe/Ljubljana

Server timezone offset: 3600000

Restarts: 6

Used Memory (bytes): 66655704

Allocated Memory (bytes): 133169152

Max Memory (bytes): 477233152

DB virtual memory (kbytes): 0

DB virtual memory limit (bytes): 0

DB disk memory (bytes): 2137466496

DB free size (kbytes): 0

---------------

Active Sessions

---------------

Session ID: 16978

Session User ID: 1

Session IP Address: 10.13.7.15

Session start time: Mon Mar 04 09:38:17 CET 2013

Session last access time: Mon Mar 04 09:38:19 CET 2013

----------------------------

Default Trap Destinations

----------------------------

Trap Destination - 1

-----------------

IP Address: 10.13.7.5

Last Updated: Fri Mar 01 11:43:04 CET 2013

-------------

Context Aware Service

-------------

Total Active Elements(Wireless Clients, Tags, Rogue APs, Rogue Clients, Interferers, Wired Clients): 25

Active Wireless Clients: 13

Active Tags: 0

Active Rogue APs: 11

Active Rogue Clients: 1

Active Interferers: 0

Active Wired Clients: 0

Active Elements(Wireless Clients, Rogue APs, Rogue Clients, Interferers, Wired Clients, Tags) Limit: 100

Active Sessions: 1

Wireless Clients Not Tracked due to the limiting: 0

Tags Not Tracked due to the limiting: 0

Rogue APs Not Tracked due to the limiting: 0

Rogue Clients Not Tracked due to the limiting: 0

Interferers Not Tracked due to the limiting: 0

Wired Clients Not Tracked due to the limiting: 0

Total Elements(Wireless Clients, Rogue APs, Rogue Clients, Interferers, Wired Clients) Not Tracked due to the limiting: 0

-------------------------

Context Aware Sub Services

-------------------------

Subservice Name: Aeroscout Tag Engine

Admin Status: Disabled

Operation Status: Down

Subservice Name: Cisco Tag Engine

Admin Status: Enabled

Operation Status: Up

Regards,

Jelena

ddavies016 Wed, 03/06/2013 - 18:52

I was under the impression that you don't interface directly with MSE, all configuration/monitoring activities with MSE are done through WCS/NCS once you have successfully bound the two together? 

Someone correct me if I am wrong in this assumption.....

Scott Fella Wed, 03/06/2013 - 18:54

You are correct, but I think it was an initial error that they were seeing and wanted to know what's wrong.

Sent from Cisco Technical Support iPhone App

Jelena1987 Wed, 03/06/2013 - 23:04

Hello,

We are able to manage MSE trough Prime Infrastructure 1.3, but we would like to see Location Analytics user interface.

In guide

http://www.cisco.com/en/US/docs/wireless/mse/3350/7.4/Location_Analytics_Service/Guide/Location_Analytics_service.pdf

says:

To log into Location Analytics user interface through a web browser, follow these steps:

In the address line of browser, enter https://location-analytics-ip-address, where location-analytics-ip-address is the IP address of the Location Analytics server. Location Analytics user interface displays the User Login page.

But when we do that we are getting error that I have posted earlier.

We have tried to import certificate in MSE but when we are importing server certificate we are getting message that private key is not find in folder /root/TestFolder/sertificate.cer. (Please see picture below)


We have followed procedures explained in

https://supportforums.cisco.com/docs/DOC-12775 to append private key to the signed certificate ,and we have also tried these commands:

Combine the CA.pem certificate with the private key, and then convert the file to a .pem file.

Issue this command in the OpenSSL application:

openssl> pkcs12 -export -in CA.pem -inkey ' mykey.pem ' -out "  CA.p12   " -clcerts    -passin pass:check123 -passout pass:check123

openssl> pkcs12             -in                      '  CA.p12   ' -out " final.pem "                    -passin pass:check123 -passout pass:check123

for appending private key to the certificate but we are still getting the same message when importing certificate.

When we type http://mseipaddress:8080/ui we are able to see login page but we can't authentificate.

Is there something that we should do to get Location Analytics web services up and running.

Thank you for replays.


Regards,

Jelena

cbeswick Wed, 03/13/2013 - 00:53

Hi,

I am having the exact same problem when trying to import the Server certificate. In addition I am unable to even get MSE talking to Prime Infrastructure 1.3 - I have tried re-installing both MSE and Prime Infrastructure several times but to no avail. Prime Infrastructure 1.2 and MSE 7.3 worked fine.

Jelena1987 Wed, 03/13/2013 - 01:57

Hello,

We have managed to login with MSE.

http://:8080/ui

We couldn't login with default user admin so we have defined new user in Prime and with that user we have managed to login to Location Analytics, but it is working only in Chrome browser, in any other we can see login page but when we enter username and password we don't get anything, login page is just refreshed and that's all. We have got the same behavior when we tried to log in with default admin user.

So after defining new user in Prime and enabling legacy HTTPS we can now login to MSE but only from chrome browser.

Regards,

Jelena

DigitalAirWireless Wed, 03/13/2013 - 01:24

Jelena,

     what credentials are you trying to use when you login in? http://:8080/ui  ??

try username: admin and password: admin as this is the default.

Post Back...

Mark

Actions

Login or Register to take actions

This Discussion

Posted March 4, 2013 at 12:08 AM
Stats:
Replies:8 Avg. Rating:
Views:1338 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard