DHCPD: there is no address pool

Unanswered Question
Mar 20th, 2013

Cisco 1811W router, IOS 15.1(4)M6, DHCP server not working on internal VLAN but configuration looks OK to me.

C1811W#sh run int vl252

!

interface Vlan252

ip address 192.168.252.252 255.255.255.0

ip nat inside

ip virtual-reassembly

!

C1811W#sh run | section dhcp pool

ip dhcp pool VLAN252

   network 192.168.252.0 255.255.255.0

   subnet prefix-length 24

   dns-server 192.168.252.252

   default-router 192.168.252.252

C1811W#sh ip dhcp pool

Pool VLAN252 :

Utilization mark (high/low)    : 100 / 0

Subnet size (first/next)       : 0 / 0

Total addresses                : 256

Leased addresses               : 0

Pending event                  : none

1 subnet is currently in the pool :

Current index        IP address range                    Leased addresses

192.168.252.0        192.168.252.0    - 192.168.252.255   0

C1811W#debug ip dhcp server event

DHCP server event debugging is on.

*Mar 20 15:46:23.437: DHCPD: Sending notification of DISCOVER:

*Mar 20 15:46:23.437:   DHCPD: htype 1 chaddr 0019.9d07.e0d0

*Mar 20 15:46:23.437:   DHCPD: remote id 020a0000c0a8fcfc040000fc

*Mar 20 15:46:23.437:   DHCPD: circuit id 00000000

*Mar 20 15:46:23.437: DHCPD: Seeing if there is an internally specified pool class:

*Mar 20 15:46:23.437:   DHCPD: htype 1 chaddr 0019.9d07.e0d0

*Mar 20 15:46:23.437:   DHCPD: remote id 020a0000c0a8fcfc040000fc

*Mar 20 15:46:23.437:   DHCPD: circuit id 00000000

*Mar 20 15:46:23.441: DHCPD: there is no address pool for 192.168.252.252.

I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
johnnylingo Wed, 03/20/2013 - 09:10

C1811W(config)#ip dhcp pool VLAN252

C1811W(dhcp-config)#no subnet prefix-length

Mar 20 16:09:00.966: DHCPD: Adding binding to radix tree (192.168.252.1)

Mar 20 16:09:00.966: DHCPD: Adding binding to hash tree

Mar 20 16:09:00.966: DHCPD: assigned IP address 192.168.252.1 to client 0100.199d.07e0.d0.

bkennedy15 Sat, 09/21/2013 - 13:33

Thank you for posting your solution. This helped me resolve my problem.  Though i'm not quite sure how/why the subnet prefix-length would cause this issue.  Can anyone explain?

Leo Laohoo Sat, 09/21/2013 - 16:52
subnet prefix-lenIgth 24

I agree, this shouldn't be there.

It's an old command that once had a place but now it's irrelevant.

Actions

Login or Register to take actions

This Discussion

Posted March 20, 2013 at 8:52 AM
Updated March 20, 2013 at 8:53 AM
Stats:
Replies:3 Overall Rating:
Views:3347 Votes:1
Shares:0
Tags: dhcp, server
+

Related Content