×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Incoming SIP calls get silent voicemail

Answered Question
Apr 26th, 2013
User Badges:

I'm curious if anyone has a good idea about this UC320W problem.  Cisco phone support already failed. 


The problem is this.  Incoming SIP callers, when transferred to any extension's voicemail, get silence.  No voicemail greeting -- nothing at all.  When the call disconnects, the user receives a voicemail notification for a new message but the actual recorded message is missing (or perhaps zero seconds long).  This only affects voicemail.  The auto attendant works fine.  Extensions ring and pick up just fine.  It doesn't matter how the caller was transferred to voicemail, human or auto attendant, the voicemail greeting won't play.


Incoming calls via an FXO line work fine.  They can be transferred to voicemail, hear a greeting, and record a message successfully.

Internal calls work just fine too.  Again, they can be transferred to voicemail, hear a greeting, and record a message successfully.

Only incoming SIP calls have this problem.


The UC320W firmware version is 2.3.2(6) with an NTP PMF.  Cisco support tried some sort of PMF and also tried downgrading to version 2.2.2.  No luck.  We haven't yet tried a factory reset and restore from backup -- that's probably next.  We REALLY don't want to try rebuilding the configuration by hand -- an aweful lot of work went into the current configuration.


Any suggestions are welcome.

--Ben

Correct Answer by wenyang about 4 years 3 months ago

Hi Ben,


We have another customer who had exactly the same issue with Sonicwall firewall. I am not familier with it. But I did a brief search at google.com and think you may need to enable SIP Transformations. Please check the following link:

http://help.mysonicwall.com/sw/eng/general/ui1/6600/Access/Services.htm


Best regards,

Wendy

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
wenyang Fri, 04/26/2013 - 17:45
User Badges:
  • Bronze, 100 points or more

Hi Ben,


Could you please check what the codec is configured at SIP Trunk page in the configure utility? Also please collect SIP trunk syslog to see what the codec is supported by SIP service provider. Please let me know the case number and send the syslog to attach@cisco.com with case number in the subject.


Best regards,

Wendy Yang

bwahlquist Mon, 04/29/2013 - 09:01
User Badges:

Hi Wendy --

Thanks for responding.  The codec is G711u.  Case number 625683687.  I'll send along some syslog shortly.

Best Regards,

Ben

bwahlquist Mon, 04/29/2013 - 09:24
User Badges:

I just noticed that the Cisco tech didn't actually open a case for me last week, just left it in "draft" form.  I've now finished opening the case, but it gave me a new number, 625729487.  The syslog and an example voicemail WAV file should be attached to that new case number.  Thanks for the help.

Best Regards,

Ben

wenyang Mon, 04/29/2013 - 10:30
User Badges:
  • Bronze, 100 points or more

Hi Ben,


Please check if there is any firewall in your network. It may block the RTP traffic.


Best regards,

Wendy

bwahlquist Mon, 04/29/2013 - 11:30
User Badges:

Hi Wendy,


The UC320W is connected to a Sonicwall TZ200 firewall device, which is configured to allow only UDP ports 5060 and 5061 inbound traffic and all outbound traffic. If you can tell me the kinds of things to look for I can check the firewall logs.


Regarding codecs, the SIP provider should be using whatever codec is advertised by the UC320W during registration (or whatever it is that goes on for negotiation).  The UC320W's SIP codec settings are set for G711u, so in theory we shouldn't be seeing any G729 in the logs?


Thanks,

Ben

Correct Answer
wenyang Mon, 04/29/2013 - 12:02
User Badges:
  • Bronze, 100 points or more

Hi Ben,


We have another customer who had exactly the same issue with Sonicwall firewall. I am not familier with it. But I did a brief search at google.com and think you may need to enable SIP Transformations. Please check the following link:

http://help.mysonicwall.com/sw/eng/general/ui1/6600/Access/Services.htm


Best regards,

Wendy

bwahlquist Mon, 04/29/2013 - 12:29
User Badges:

That was it, Wendy!  Thank you!  I don't know why the system worked before, but enabling SIP transformations in the Sonicwall did the trick this time.


For future reference, there is a VOIP configuration section in the Sonicwall software.  It has a checkbox for "enable SIP transformations".  This feature lets the Sonicwall get involved with the SIP connections, exchanging the internal NAT IP with the external firewall/gateway IP address.


Thank you for your help!  I'll go close-out the case.


Best Regards,

Ben

Actions

This Discussion

Related Content