×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Cisco ASA Hairpinning

Unanswered Question
Jul 1st, 2013
User Badges:

HI,


Cisco ASA 5520 has connected two fortigate wirewall with dynamic VPN.

i required that bothe firewall inside network should talk to eachother.


can i use HAIRPIN for this if yes how does it configure on ASA.



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jouni Forss Mon, 07/01/2013 - 03:27
User Badges:
  • Super Bronze, 10000 points or more

Hi,


I am not 100% sure on the setup.


But generally you will atleast have to make sure of the following things


  • Have the "same-security-traffic permit intra-interface" configured on the firewall so connections can enter and leave the same interface on the ASA which I presume is the "outside" interface in your case.
  • You will also need to have NAT0 configured on the "outside" interface to make sure that NO NAT is performed between the 2 remote networks that are connected to the ASA.
  • You will have to make sure that there are no access rules preventing these connections. Generally there is nothing preventing this as by default the ASA allows the traffic coming from VPN connection to bypass the interface ACLs


Other than that I am not sure I can say more with the information given.


- Jouni

Jouni Forss Mon, 07/01/2013 - 23:35
User Badges:
  • Super Bronze, 10000 points or more

Hi,


Would need to see the current configurations to be able to help with this.


- Jouni

suhas_syndrome Tue, 07/02/2013 - 01:55
User Badges:

Hi Jouni,


please find the configuration below,


Result of the command: "sho run"


: Saved

:

ASA Version 8.2(4)

!

hostname ciscoasa

enable password 2KFQnbNIdI.2KYOU encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

name 10.71.11.0 VPN_Add

name 10.96.11.0 lan_10.96.11.0

name 10.19.1.0 vpn_pool

!

interface GigabitEthernet0/0

nameif outside

security-level 0

ip address 115.114.107.11 255.255.255.248

!

interface GigabitEthernet0/1

nameif inside

security-level 100

ip address 10.21.5.240 255.255.255.0

!

interface GigabitEthernet0/2

shutdown

no nameif

no security-level

no ip address

!

interface GigabitEthernet0/3

shutdown

no nameif

no security-level

no ip address

!

interface Management0/0

shutdown

no nameif

no security-level

no ip address

!

boot system disk0:/asa824-k8.bin

ftp mode passive

dns domain-lookup outside

dns domain-lookup inside

object-group network DM_INLINE_NETWORK_1

network-object VPN_Add 255.255.255.0

network-object lan_10.96.11.0 255.255.255.0

object-group network DM_INLINE_NETWORK_2

network-object VPN_Add 255.255.255.0

network-object lan_10.96.11.0 255.255.255.0

access-list outside_cryptomap_65535.1 extended permit ip 10.21.0.0 255.255.0.0 object-group DM_INLINE_NETWORK_1

access-list inside_nat0_outbound extended permit ip 10.21.0.0 255.255.0.0 VPN_Add 255.255.255.0

access-list inside_nat0_outbound extended permit ip 10.21.0.0 255.255.0.0 lan_10.96.11.0 255.255.255.0

access-list inside_nat0_outbound extended permit ip 10.21.0.0 255.255.0.0 host vpn_pool

access-list inside_nat0_outbound extended permit ip 10.21.5.0 255.255.255.0 vpn_pool 255.255.255.0

access-list inside_access_in extended permit ip any any

access-list inside_access_in extended permit ip 10.21.0.0 255.255.0.0 any

access-list inside_cryptomap_65535.1 extended permit ip 10.21.0.0 255.255.0.0 object-group DM_INLINE_NETWORK_2

access-list cnk standard permit 10.21.0.0 255.255.0.0

access-list outside_access_in extended permit icmp any any

access-list outside_nat0_outbound extended permit ip VPN_Add 255.255.255.0 lan_10.96.11.0 255.255.255.0

access-list outside_nat0_outbound extended permit ip lan_10.96.11.0 255.255.255.0 VPN_Add 255.255.255.0

access-list ipsce_vpn_splitTunnelAcl standard permit 10.21.5.0 255.255.255.0

access-list smart-tunnel webtype permit tcp 10.21.0.0 255.255.0.0 eq telnet log default

pager lines 24

logging enable

logging asdm informational

mtu outside 1500

mtu inside 1500

ip local pool vpn_cnk_ssl 10.19.1.1-10.19.1.254 mask 255.255.255.0

no failover

icmp unreachable rate-limit 1 burst-size 1

asdm image disk0:/asdm-641.bin

no asdm history enable

arp timeout 14400

nat (inside) 0 access-list inside_nat0_outbound

access-group outside_access_in in interface outside

access-group inside_access_in in interface inside

route outside 0.0.0.0 0.0.0.0 115.114.107.9 1

route inside 10.21.0.0 255.255.0.0 10.21.5.6 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

dynamic-access-policy-record DfltAccessPolicy

http server enable

http 0.0.0.0 0.0.0.0 inside

http 0.0.0.0 0.0.0.0 outside

no snmp-server location

no snmp-server contact

crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac

crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac

crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac

crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac

crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac

crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac

crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto dynamic-map outside_dyn_map 1 match address outside_cryptomap_65535.1

crypto dynamic-map outside_dyn_map 1 set transform-set ESP-3DES-SHA

crypto dynamic-map outside_dyn_map 1 set nat-t-disable

crypto dynamic-map inside_dyn_map 10 match address inside_cryptomap_65535.1

crypto dynamic-map inside_dyn_map 10 set transform-set ESP-3DES-SHA

crypto dynamic-map inside_dyn_map 10 set nat-t-disable

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5

crypto map outside_map 65534 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP

crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map

crypto map outside_map interface outside

crypto map inside_map 65535 ipsec-isakmp dynamic inside_dyn_map

crypto map inside_map interface inside

crypto isakmp enable outside

crypto isakmp policy 10

authentication pre-share

encryption 3des

hash sha

group 2

lifetime 28800

telnet 0.0.0.0 0.0.0.0 inside

telnet timeout 5

ssh timeout 5

console timeout 0

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

enable outside

svc image disk0:/anyconnect-linux-3.1.03103-k9.pkg 1

svc image disk0:/anyconnect-win-3.1.03103-k9.pkg 2

svc image disk0:/anyconnect-macosx-i386-3.1.03103-k9.pkg 3

svc enable

tunnel-group-list enable

smart-tunnel list server 1 telnet platform windows

smart-tunnel list server 1 tcp/telnet platform windows

smart-tunnel auto-signon serverlist ip 10.21.5.0 255.255.255.0

group-policy GroupPolicy1 internal

group-policy GroupPolicy1 attributes

vpn-tunnel-protocol IPSec l2tp-ipsec

group-policy ipsce_vpn internal

group-policy ipsce_vpn attributes

dns-server value 8.8.8.8 4.2.2.2

vpn-tunnel-protocol IPSec svc

split-tunnel-policy tunnelspecified

split-tunnel-network-list value ipsce_vpn_splitTunnelAcl

group-policy cnk_ssl internal

group-policy cnk_ssl attributes

dns-server value 8.8.8.8 4.2.2.2

vpn-tunnel-protocol svc webvpn

split-tunnel-policy tunnelspecified

split-tunnel-network-list value cnk

default-domain none

webvpn

  filter value smart-tunnel

  smart-tunnel auto-start server

username user1 password Ttlh3sZkia0/P8q. encrypted privilege 15

username cisco password 3USUcOPFUiMCO4Jk encrypted privilege 15

tunnel-group ckgs_goa type ipsec-l2l

tunnel-group ckgs_goa ipsec-attributes

pre-shared-key *****

tunnel-group ckgs-indr type ipsec-l2l

tunnel-group ckgs-indr ipsec-attributes

pre-shared-key *****

tunnel-group cnk_ssl type remote-access

tunnel-group cnk_ssl general-attributes

address-pool vpn_cnk_ssl

default-group-policy cnk_ssl

tunnel-group cnk_ssl webvpn-attributes

group-alias cnk_ssl enable

group-url https://115.114.107.11/cnk_ssl enable

tunnel-group ipsce_vpn type remote-access

tunnel-group ipsce_vpn general-attributes

address-pool vpn_cnk_ssl

default-group-policy ipsce_vpn

tunnel-group ipsce_vpn ipsec-attributes

pre-shared-key *****

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect ip-options

  inspect netbios

  inspect rsh

  inspect rtsp

  inspect skinny 

  inspect esmtp

  inspect sqlnet

  inspect sunrpc

  inspect tftp

  inspect sip 

  inspect xdmcp

  inspect icmp

!

service-policy global_policy global

prompt hostname context

call-home

profile CiscoTAC-1

  no active

  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService

  destination address email [email protected]

  destination transport-method http

  subscribe-to-alert-group diagnostic

  subscribe-to-alert-group environment

  subscribe-to-alert-group inventory periodic monthly

  subscribe-to-alert-group configuration periodic monthly

  subscribe-to-alert-group telemetry periodic daily

Cryptochecksum:1fcc67ce02f2725ffe22b11fe134d3d2

: end



Suhas B.

Jouni Forss Tue, 07/02/2013 - 03:25
User Badges:
  • Super Bronze, 10000 points or more

Hi,


Your crypto ACLs both have same destination networks?


Essentially the below ACLs are identical


outside_cryptomap_65535.1

inside_cryptomap_65535.1



object-group network DM_INLINE_NETWORK_1

network-object VPN_Add 255.255.255.0

network-object lan_10.96.11.0 255.255.255.0

object-group network DM_INLINE_NETWORK_2

network-object VPN_Add 255.255.255.0

network-object lan_10.96.11.0 255.255.255.0



access-list outside_cryptomap_65535.1 extended permit ip 10.21.0.0 255.255.0.0 object-group DM_INLINE_NETWORK_1


access-list inside_cryptomap_65535.1 extended permit ip 10.21.0.0 255.255.0.0 object-group DM_INLINE_NETWORK_2



These should to my understanding be different. Perhaps the remote sites are opening the connections and its working because of that. But they should really only contain the destination network which are behind the connections.


Can you clarify the above configuration I mentioned?


- Jouni

suhas_syndrome Sun, 07/07/2013 - 19:16
User Badges:

hi,


does it make any difference with this configuration for two remote location communication.


as per this configuration ASA can communicate with both remote location. I required hairpin for remote location to communicate without create tunnel.


Re

Suhas B.

Actions

This Discussion