Unable top delete Agent

Unanswered Question
Jul 3rd, 2013

I am unable to delete a certain agent. I keep getting "Failed to update the database. Delete of SkillGroupMember failed. SG count for Agent 5891 is invalid."


I have looked in almost all the tables on the AW but am unable to find out what is wrong.


Anyone have any ideas?


Thanks in advance.error.png

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
david.macias Wed, 07/03/2013 - 12:15

Have you cleared your deleted items?  Do you see any reference to this agent there?  Are you trying to delete this agent via config manager?


david

rhobab Thu, 07/04/2013 - 01:24

Hello David


Yes I have cleared the delete items. The deleted items is empty so no chance of it being referenced there. I am trying to delete the agent via Config Manager that is where I get the error.


Thanks

Victor

Gergely Szabo Thu, 07/04/2013 - 04:26

Hi.

Is there any chance that someone or something was poking some configuration tables in the ICM AW DB?

G.

Chavdar_Baramov Tue, 02/14/2017 - 23:29

In my case it deleted the agent as i stated before - this solution is my own, but at least sorts the problem without downtime.

If you want to "risk" use them (i strongly advise taking system backups before that), if you don`t - wait for TAC.

DJ Kulkarni Thu, 02/16/2017 - 12:11

Hi,


I did the exit_router and it fixed it however if you are on 10.5.1 ES or 10.5.2 they are saying its fixed in 10.5.3 but need to confirm with cisco TAC


Regards,

DJ

Igor1906 Thu, 02/25/2016 - 07:00

Dear Victor,

I've faced the same issue. If you managed to solve it i'd be very grateful to see the solution.

Thank you in advance,
Igor.

Chavdar_Baramov Fri, 02/26/2016 - 02:19

Get SkillTargetID from t_Agent table in ucce_sideA schema of the problematic agent by his peripherial ID

"select SkillTargetID from ucce_sideA.dbo.t_Agent where PeripherialNumber = x"

Get all the rows from t_Skill_Group_Member with a criteria of this SkillTargetID from the above table and delete them.

"select * from ucce_sideA.dbo.t_Skill_Group_Member where SkillTargetID = x" - to see how much skill groups that agent is in and to be sure that your where clause is working fine

"delete from ucce_sideA.dbo.t_Skill_Group_Member where SkillTargetID = x"

Go to your ADSA and do the same - delete those rows in t_Skill_Group_Member that match the agent id 

"delete from ucce_awdb.dbo.t_Skill_Group_Member where SkillTargetID = x"

After that go to config manager and just delete the agent - it will invoke an error but the agent will be deleted. Don't forget to go to deleted objects and remove it from there.

This is not the recommended by CISCO way to do it, but at least it works. Your other choice is to wait TAC to solve the issue but if you are in a hurry as was I - this sorts the problem. 

NB: In case something fails miserably you can insert those values back to those tables. Just in case write them down.

Igor1906 Fri, 02/26/2016 - 05:17

Dear Chavdar_Baramov, 

Thank you for your prompt reply.
I've already opened the case, thus I'll wait for an official TAC recommendation. But I'll keep your suggestion in my mind, thank you.

--
Best regards,
Igor Zatsarevnyy

Ping Liu Wed, 07/10/2013 - 21:34

From pop-up, it soulds like the problem releates to SkillGroup. but assigned SkillGroup will not stop you to delete agent. it could be something else. I would do:


1. Try to run the SQL Query from awdb.dbo.t_Skill_Group/t_Skill_Group_Member/t_Agent, find out if is any connection between the agent and SkillGroup;

2. if agent is supervisor agent, make sure remote it from supervisor list;

3. remove agent from Agent Team;

4. of cause, make sure agent has logged off. use procmon  for ctisvr with la; dagent commandto find out;

Chavdar_Baramov Wed, 02/17/2016 - 02:03

I had same problem recently - got it solved in radical but decisive way.

Deleted from awdb the lines with the problematic agent id in t_skill_group_member. Did the same in logger db.

After that i was able to delete the agent. Do it on your own risk ;)

Igor1906 Wed, 03/02/2016 - 00:08

Hi, everyone. 

We had the same issue.
It was solved after TAC recommendation to reset router:

1)      On the Router server in a command window run the rttest utility.
C:\Users\Administrator>rttest /cust CustomerInstance You will see a prompt similar to the following RTTEST Release 9.0.1.0 , Build 1454
rttest:
2)      At the rttest: prompt run the command "exit_router".

PS. Be careful, this restarts both routers simultaneously and therefore call center is dead for about a minute.

Actions

This Discussion