×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Cisco 892: Priorisierung/QoS

Unanswered Question
Jul 17th, 2013
User Badges:

Hallo,


Ich habe mich hier bei dem Forum registriert, da ich ein Problem mit der Priorisierung habe.

Ich möchte erreichen, dass ich, bei einer komplett ausgelasteten Leitung durch einen Teilnehmer aus dem 192er Netz, immer aus dem 172er Netz priorisiert werde. Wenn ich die IP-Adresse 172.27.39.210 habe, dann soll ich 70% der Bandbreite von 1Mbit erhalten.


Ich verwende drei Netze, das eine Netz (10er Netz) ist am GI0 angeschlossen, das 192er Netz an FE7 und 172er Netz an FE0.


am GI0 ist ein Rechner mit iperf angeschlossen, die Verbindung habe ich mit einer Netzwerkbremse auf 1 MBit heruntergedreht, dem Interface mit Bandwidth 1000 mitgeteilt, dass er ein 1MBit Anschluss hat.


Ich habe eine Policy-Map mit entsprechenden Class-Maps eingerichtet, mit show policy-map POLICY-NAME sehe ich auch, wie die jeweiligen Classes greifen


Allerdings ist der Traffic der angezeigt wird, nicht mit den Prozentwerten, die ich konfiguriert habe, identisch. Sondern er teilt es 50:50 auf..


Könnt ihr mir helfen, was ich falsch mache?



Zum Test habe ich je ein iperf aus dem 192er und dem 172.er Netz gestartet, die sich mit dem Server, welcher an GI0 angeschlossen ist, verbindet.


Ich erwarte eigentlich, dass die class-default mindestens die 100kbps bekommt, meine CLASS1 mindestens die 700kbps.




config-router:

class-map match-all CLASS1

match access-group 100

class-map match-all CLASS2

match access-group 101

class-map match-any INTERNETWORK-CONTROL

match access-group 102

!

!

policy-map POLICY

class CLASS1

  priority percent 70

  set ip dscp ef

class CLASS2

  bandwidth percent 10

  set ip dscp cs1

class INTERNETWORK-CONTROL

  bandwidth percent 5

  set ip dscp cs6

class class-default

  bandwidth percent 10

  queue-limit 16 packets

....

interface GigabitEthernet0

bandwidth 1000

bandwidth qos-reference 1000

ip address 10.254.5.249 255.255.255.248

load-interval 30

duplex auto

speed auto

service-policy output POLICY

!

interface Vlan1

ip address 172.27.39.1 255.255.255.0

!

interface Vlan2

ip address 192.168.1.1 255.255.255.0


.....


access-list 100 permit ip host 172.27.39.210 any

access-list 101 permit ip 172.27.39.0 0.0.0.255 any

access-list 102 permit udp any any eq isakmp dscp cs6






qos-test#sho policy-map interface gi0

GigabitEthernet0


  Service-policy output: POLICY


    queue stats for all priority classes:


      queue limit 64 packets

      (queue depth/total drops/no-buffer drops) 0/0/0

      (pkts output/bytes output) 17291/25799893


    Class-map: CLASS1 (match-all)

      17291 packets, 25799893 bytes

      30 second offered rate 502000 bps, drop rate 0 bps

      Match: access-group 100

      Priority: 70% (700 kbps), burst bytes 17500, b/w exceed drops: 0


      QoS Set

        dscp ef

          Packets marked 17291


    Class-map: CLASS2 (match-all)

      0 packets, 0 bytes

      30 second offered rate 0 bps, drop rate 0 bps

      Match: access-group 101

      Queueing

      queue limit 64 packets

      (queue depth/total drops/no-buffer drops) 0/0/0

      (pkts output/bytes output) 0/0

      bandwidth 10% (100 kbps)

      QoS Set

        dscp cs1

          Packets marked 0


    Class-map: INTERNETWORK-CONTROL (match-any)

      0 packets, 0 bytes

      30 second offered rate 0 bps, drop rate 0 bps

      Match: access-group 102

        0 packets, 0 bytes

        30 second rate 0 bps

      Queueing

      queue limit 64 packets

      (queue depth/total drops/no-buffer drops) 0/0/0

      (pkts output/bytes output) 0/0

      bandwidth 5% (50 kbps)

      QoS Set

        dscp cs6

          Packets marked 0


    Class-map: class-default (match-any)

      16657 packets, 24837656 bytes

      30 second offered rate 466000 bps, drop rate 0 bps

      Match: any

      Queueing

      queue limit 16 packets

      (queue depth/total drops/no-buffer drops) 0/0/0

      (pkts output/bytes output) 16657/24837656

      bandwidth 10% (100 kbps)








Danke im Voraus

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion