×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Nexus 5000 Mac Address Issue

Unanswered Question
Aug 2nd, 2013
User Badges:

Hello,


I have an issue on switches mac address table.

I have started ping to a server connected to a Nexus 5000 from a host that also conected to Nexus 5000.

Ping results are always succeed.

However, when I check server's mac address on Nexus 5000 mac address table with "show mac address-table"; the mac-address of server RANDOMLY APPEARS AND DISAPPEARS on the mac address list. However, as I said before pinging is still succesfull, there is no problem in operation level.

I have check the cpu (%33) and mac address count (around 1000), everything looks like usual.


What can cause this issue?

Is that possible that "show mac address-table" does not shows up-to-date mac address table and there is a delay between "show mac address-table" and the mac address table that is used by switch?


Thanks in advance.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
nate fitzgerald Fri, 08/02/2013 - 09:20
User Badges:

Are you using vPC or even just regular Port-channel ??

in the running config you can add the command " mac address-table notification mac-move  "  then either turn on term mon and see if the mac is bouncing between 2 interfaces or port-channels. Or check the logs

Do you have 2 Nexus Switches and one acting as the peer switch??

Also is this server Vmware with multiple nics with a vswitch config ?? I have seen behavior with this, where vmware will have the nics teamed in a port group, But if the cisco switch is not setup as port channel the mac addresses can change from one interface to another.


Ned to know a little more about the switching and server environment to better answer your question

yalin.can.ates Mon, 08/05/2013 - 06:12
User Badges:

Yes, we have two Nexus witch vpc confic and server is Vmware with mutiple nics.

Let me check if the problem occur again, when port-channel is used .

I will be back with the results.


**********By the way, thanks for "mac address-table notification mac-move" very usefulll command.********



Many Thanks,

Actions

This Discussion