×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

srr-queue bandwidth & qos on a 3560

Answered Question
Aug 2nd, 2013
User Badges:

Hello,


I have a WS-C3560C-8PC-S running c3560c405-universalk9-mz.122-55.EX3 (ipbaase licence) and have the below qos configured:


interface FastEthernet0/5

description Q-in-Q to <cust-network>

switchport access vlan 20

switchport mode dot1q-tunnel

speed 100

duplex full

mls qos cos 1

mls qos cos override

!

interface FastEthernet0/1

description facing eth-WAN-link-to-far-end

switchport trunk encapsulation dot1q

switchport mode trunk

speed 100

duplex full

srr-queue bandwidth share 12 5 1 2

mls qos trust cos

!

mls qos srr-queue output cos-map queue 1 threshold 1 1

mls qos srr-queue output cos-map queue 2 threshold 1 2

mls qos srr-queue output cos-map queue 3 threshold 1 0 4 6 7

mls qos srr-queue output cos-map queue 4 threshold 1 5

!

mls qos queue-set output 1 buffers 60 25 5 10

!


I have marked a customer in a particular cos value for all packets coming into my switch, and then mapped that cos value to a queue and threshold within that queue-set (assigned 60% of available buffers). I have then applied SRR share output queueing on the uplink to ensure the customer gets 60% of bandwidth effectively in times of congestion (it gets served 12 times out of every 20 packets if all queues are full).Nothing else is on the switch currently, just this one end customer.


Before applying QoS I could run an ethernet tester at 80m through the link to the far end with no loss of perfomance issues (80m seen at far end). Now I have applied the above QoS config however, the QoS settings kick in immediately, with the tester dropping down to 4m max. The threshold is being hit and dropping packets on the egress queue on the uplink.


My questions are:


1) why is QoS kicking in anyway given the link isnt congested?

2) why is is reducing it to 4m only given the buffers/srr-queue bandwidth are set to 60%?


Help much appreciated, thanks


Phil

Correct Answer by Joseph W. Doherty about 4 years 2 weeks ago

Disclaimer


The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.


Liability Disclaimer


In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.


Posting


Is the default shaping enabled for Q1, at 4%?


PS:

Trying adding


srr-queue bandwidth shape 0 0 0 0


to your interface.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
phil_carter Fri, 08/02/2013 - 08:21
User Badges:

Also - if I place the customer in cos 4 (for instance), and into another output queue, it runs at 80m fine with no drops.... seems to be a problem with queue 1 only....


Any help/advice appreciated.

Correct Answer
Joseph W. Doherty Fri, 08/02/2013 - 08:45
User Badges:
  • Super Bronze, 10000 points or more

Disclaimer


The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.


Liability Disclaimer


In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.


Posting


Is the default shaping enabled for Q1, at 4%?


PS:

Trying adding


srr-queue bandwidth shape 0 0 0 0


to your interface.

Actions

This Discussion

Related Content