×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Very low throughput on CSR1000v

Unanswered Question
Aug 8th, 2013
User Badges:

Hi,


I've downloaded the R3.10.0S for evaluation. The Eula is accepted and the premium eval license is active. The throughput is set to 50MBit, but I only get about 99 Kbits/s with Iperf between two CentOS VMs (non bi-directional).


The router has basic configuration. Same with R3.9.0aS a few weeks ago.



Kind regards,


Marco

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sullivan.p Thu, 08/15/2013 - 21:56
User Badges:

Hi Marco,


I've deployed two of these in an end-to-end scenario across an IP network between two cities, I'm seeing exactly the same thing.


Throughput doesn't appear to increase above the default 2500Kbit/s despite accepting the agreement, and increasing platform throughput.


Did you get a resolution?

Marco Luecke Fri, 08/16/2013 - 00:56
User Badges:

Hi Patrick,


my solution at the moment is switching the vNICs from vmxnet3 to e1000. After that, I get a throughput of about 48MBit/s. But this is not the recommended setting from the docs. What vSphere version do you have? I've tested it on 5.1 and 5.1 Update 1.


Regards,


Marco

sullivan.p Fri, 08/16/2013 - 04:20
User Badges:

Same as you, vSphere 5.1 update 1.


That worked for me as well. Throughput back closer to 50Mbit/s now.


I didn't even bother doing that before because as you say the doc recommends using VMXNET3.


Have you tried putting your NICs back to VMXNET3 after setting them at E1000?


Wondering if it's just something to do with the rate-limit getting stuck after deployment and the change of NICs resets something or whether it's inherent to the VMXNET3 adapters on vSphere 5.1...

Actions

This Discussion