PC's not getting DHCP through Phone+Desktop Smartort role, but Phones are.

Answered Question
Aug 8th, 2013
User Badges:

Hello,


I'm having a problem and am asking for an extra set of eyes on this one.  We have an old 24-port 2950 non-PoE switch on a floor of a building with separate voice and data vlans.  The ports on the switch I have are set using network assistant with Vlan 512 (voice) and 612 (data).  The phones are grabbing DHCP properly, but the PC's are trying to retain addresses from default vlan 1 and will not grab from vlan 612.  We use a stack of 3750 switches as our core set of switches and does basic static routing, and provides Vlans to other switches via VTP server mode.  On that core stack, I do have the 'ip-helper address' set for the data vlan having problems.  By the time it gets to this closet switch, the connection looks like this:


3750 Stack > 3560 Switch > 2950 Switch.


I ran over there and plugged a laptop in directly to the switch port and I get an address fine on the Data Vlan 612.  If I plug the laptop in through the PC port of the 7945G IP Phone, I don't get an address.  The DHCP scope's appear fine, especially if I get and address.


Where do I check next?


Rory

Correct Answer by Arsen Gharibyan about 4 years 1 week ago

Check VLAN settings in the IP-Phone , some phones are tagging packets that passes thru,if there is any VLAN assighment just turn it off and the packets will be untagged

Correct Answer by jawad-mukhtar about 4 years 1 week ago

Implement these settings for testing in any one port to check if ti works with this settings.


interface tx/x

switchport trunk encapsulation dot1q

switchport trunk native vlan 612

switchport mode trunk

switchport voice vlan512

spanning-tree portfast



Jawad

Correct Answer by cadet alain about 4 years 1 week ago

Hi,

on the 2950 the data vlan is untagged so it is the native vlan when it goes through the trunk to 3750.

Is this the native Vlan on the 3750s ?


Regards


Alain



Don't forget to rate helpful posts.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Correct Answer
cadet alain Thu, 08/08/2013 - 09:30
User Badges:
  • Purple, 4500 points or more

Hi,

on the 2950 the data vlan is untagged so it is the native vlan when it goes through the trunk to 3750.

Is this the native Vlan on the 3750s ?


Regards


Alain



Don't forget to rate helpful posts.

rory.schmitz Thu, 08/08/2013 - 10:16
User Badges:

Hi,


Thanks for the reply.  They should actually be untagged all the way from the 3750's to the 2950.  Am I correct in stating they are then tagged using the Phone + Desktop smartport role on the 2950?


I use Network Assistant for 99% of the configuration and set Switch Smartport roles with default Vlan 1 for the switch uplinks.  The 3750's and 3560's have the MM Fiber SFP's and the 2950 is uplinked to the 3560 via copper.  Default Vlan 1 is set as the native Vlan for those smarports.


Here is the VTP config for the 2950 and the Port config:


VTP Stat-


Clay4121#sh vtp stat

VTP Version                     : 2

Configuration Revision          : 100

Maximum VLANs supported locally : 250

Number of existing VLANs        : 52

VTP Operating Mode              : Client

VTP Domain Name                 : clayco

VTP Pruning Mode                : Disabled

VTP V2 Mode                     : Disabled

VTP Traps Generation            : Disabled

MD5 digest                      : 0xDB 0x74 0x64 0xBE 0xB2 0xC7 0x81 0x2B

Configuration last modified by 172.25.0.10 at 4-8-11 20:54:50



Interface Config-


!

interface FastEthernet0/1

switchport access vlan 612

switchport mode access

switchport voice vlan 512

switchport port-security

switchport port-security maximum 2

switchport port-security aging time 2

switchport port-security violation restrict

switchport port-security aging type inactivity

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

macro description cisco-phone

spanning-tree portfast

spanning-tree bpduguard enable

!



Here's the VTP Status for the Core 3750 Stack:


ClayCore01#sh vtp stat
VTP Version capable             : 1 to 3
VTP version running             : 1
VTP Domain Name                 : clayco
VTP Pruning Mode                : Disabled
VTP Traps Generation            : Disabled
Device ID                       : d48c.b56c.9780
Configuration last modified by 172.25.0.10 at 4-8-11 20:54:50
Local updater ID is 172.25.0.10 on interface Vl1 (lowest numbered VLAN interface
found)

Feature VLAN:
--------------
VTP Operating Mode                : Server
Maximum VLANs supported locally   : 1005
Number of existing VLANs          : 52
Configuration Revision            : 100
MD5 digest                        : 0xDB 0x74 0x64 0xBE 0xB2 0xC7 0x81 0x2B
                                    0xCE 0x7D 0x2F 0x3E 0xE2 0x94 0xB9 0xEF
ClayCore01#



I did notice the VTP versions are different from the core stack and on the 2950.  Maybe that would cause something like this?


Thanks for your help.


Rory

jawad-mukhtar Thu, 08/08/2013 - 13:36
User Badges:
  • Silver, 250 points or more

define ip-helper address under data vlan on all swithes.



***Do Rate Helpful posts***


Jawad

rory.schmitz Thu, 08/08/2013 - 19:17
User Badges:

Hello Jawad,


I have the ip-helper address on data vlan 612 on the core 3750 stack.  I am able to get an address through dhcp when only a PC is plugged into the port, but not when the PC is behind an IP Phone.  In that scenario, the phone is the only device which gets a DHCP address.  I'm using VTP server mode on the core stack, then client mode on the distribution switches to attain the Vlan information.  I've done this many times with our distribution switches and I've never had a problem until now.  Most of our other distributution switches are 3560's and we have just a couple 2950's still in production.  Banging my head on this one...


Thanks for the help.


Rory

Correct Answer
jawad-mukhtar Fri, 08/09/2013 - 10:32
User Badges:
  • Silver, 250 points or more

Implement these settings for testing in any one port to check if ti works with this settings.


interface tx/x

switchport trunk encapsulation dot1q

switchport trunk native vlan 612

switchport mode trunk

switchport voice vlan512

spanning-tree portfast



Jawad

Correct Answer
Arsen Gharibyan Fri, 08/09/2013 - 16:03
User Badges:

Check VLAN settings in the IP-Phone , some phones are tagging packets that passes thru,if there is any VLAN assighment just turn it off and the packets will be untagged

rory.schmitz Tue, 08/13/2013 - 06:11
User Badges:

Hello,


Was away for the weekend, but it appears things are working now.  The VLAN/port settings on the IP-Phones were set to none, or auto, whichever the default was.


Our current port config on the 2950 in question is now this:


!

interface GigabitEthernet0/1

switchport mode trunk




We previously had it as this:


!

interface GigabitEthernet0/2

switchport mode trunk

switchport nonegotiate

mls qos trust cos

auto qos voip trust

macro description cisco-switch

spanning-tree link-type point-to-point




I'm not certain why we had to remove most of the config, but it's now working...  We believe it has something to do with upgrading our 3750G Stack to IOS 15.x a few months back.  Before the IOS upgrade, the previous setting would work fine.  Any particular reason in v15.x why this wouldn't work?


Thanks for all of your help.

Actions

This Discussion