×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Connecting device to cisco 1900 series router no internet connection

Answered Question
Aug 9th, 2013
User Badges:

hi i have a cisco 1941 series router which i am trying to connect but need help setting it up.

I have my netgear modem router which is connected to the internet and i the cisco router connected to the netgear modem router on port GigabitEthernet0/0 which i have assigned the ip address 192.168.0.10.
this can be seen below in the show ip interface brief command

Interface                  IP-Address      OK? Method Status                Prot
ocol
Embedded-Service-Engine0/0 unassigned      YES NVRAM  administratively down down

GigabitEthernet0/0         192.168.0.10    YES NVRAM  up                    up

GigabitEthernet0/1         unassigned      YES NVRAM  administratively down down

FastEthernet0/0/0          unassigned      YES unset  administratively down down

FastEthernet0/0/1          unassigned      YES unset  administratively down down

FastEthernet0/0/2          unassigned      YES unset  administratively down down

FastEthernet0/0/3          unassigned      YES unset  up                    up

NVI0                       192.168.0.10    YES unset  up                    up

Vlan1                      192.168.0.29    YES NVRAM  down                  down

Vlan2                      192.168.0.31    YES NVRAM  up                    up

I am trying to connect a device to fast ethernet port 0/0/3. as were unable to assign ip address directly to the fastethernet port i have assigned VLAN 2 to this port and have set up DHCP. When attaching a device to the port it retrieves an ip address, default router and dns server settings based on the DHCP settings set but there is no internet connection available.

I have set the default gateway to the router 192.168.0.1
From the console i can ping google site as can be seen in the following results.

amana#ping www.google.com
Translating "www.google.com"...domain server (46.33.128.49) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 74.125.195.147, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms

so this means there is internet connection going to the device but not passing through to the fastethernet port 0/0/3 which i have the device attached to.

my running config file is below if this helps

amana#sh running-config
Building configuration...

Current configuration : 4463 bytes
!
! Last configuration change at 08:44:55 UTC Fri Aug 9 2013
! NVRAM config last updated at 08:44:59 UTC Fri Aug 9 2013
! NVRAM config last updated at 08:44:59 UTC Fri Aug 9 2013
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname amana
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$qSJx$.6165BLa.LrDM7DCMXcUi1
enable password letmein
!
no aaa new-model
no process cpu extended history
no process cpu autoprofile hog
!
no ipv6 cef
no ip routing
!
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.0.1 192.168.0.99
!
ip dhcp pool DHCP_POOL
network 192.168.0.0 255.255.255.0
default-router 192.168.0.1
dns-server 46.33.128.49 46.33.128.50
!
!
ip name-server 46.33.128.49
ip name-server 46.33.128.50
no ip cef
login on-failure log
login on-success log
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-2112039246
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2112039246
revocation-check none
rsakeypair TP-self-signed-2112039246
!
!
crypto pki certificate chain TP-self-signed-2112039246
certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32313132 30333932 3436301E 170D3133 30383031 31353234
  31315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 31313230
  33393234 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100C333 0665C623 1F7C5E3A 1131B8BF EF067A17 DFAC7229 6DAE4A6D 7E1507F9
  56B90C2B 27CD29A7 4DDF4E11 4B49438D FAF7E455 6C9231D3 82344C9E D4782AD5
  38F0D8EE 6ACF7E02 709A0863 ABA8AC3C CD032902 9969F744 4B492877 34E94B46
  29A1F902 5EEE2B9C CC71E5F8 DEE48586 5292998F 3E582707 FAB30D5E 1FC31B9B
  18A50203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 1401CEF2 DA12AA7E 601A1267 265EF23C 771F5D91 E7301D06
  03551D0E 04160414 01CEF2DA 12AA7E60 1A126726 5EF23C77 1F5D91E7 300D0609
  2A864886 F70D0101 05050003 81810028 26DF209C 0D7FF01D CB9CAE57 9DF6B0EA
  5319A290 29BBD0EA F38FE438 AE006F73 0BAB2679 EBD55116 2D6BE24A B5F193E6
  1D322E2E 4F8987C8 9B59BA9F FD94B234 80DB98AC BD90050B 60EED482 ACCCE2CA
  4B2AA75B 8F2CED96 C1E423CA 2913AD00 F428F759 A3B44408 4716EF37 EC57FC86
  FDAA69B8 02F4206B 4FE8B87C 7ECDC0
        quit
license udi pid CISCO1941/K9 sn FCZ160992RN
!
!
username admin privilege 15 password 0 911-Turbo
!
!
ip ssh version 2
ip scp server enable
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
no ip route-cache
shutdown
no cdp enable
!
interface GigabitEthernet0/0
ip address 192.168.0.10 255.255.255.0
no ip route-cache
duplex auto
speed auto
no cdp enable
no mop enabled
!
interface GigabitEthernet0/1
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
no cdp enable
!
interface FastEthernet0/0/0
switchport mode trunk
no ip address
shutdown
no cdp enable
!
interface FastEthernet0/0/1
no ip address
shutdown
no cdp enable
no mop enabled
!
interface FastEthernet0/0/2
no ip address
shutdown
no cdp enable
!
interface FastEthernet0/0/3
switchport access vlan 2
no ip address
speed 10
no cdp enable
no mop enabled
!
interface Vlan1
ip address 192.168.0.29 255.255.255.0
no ip route-cache
!
interface Vlan2
ip address 192.168.0.31 255.255.255.0
!
ip default-gateway 192.168.0.1
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
!
ip nat inside source list 1 interface FastEthernet0/0/3 overload
ip route 0.0.0.0 0.0.0.0 192.168.0.1
!
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 20 permit 94.30.54.14
access-list 20 permit 192.168.0.0 0.0.0.255
access-list 20 permit 46.33.128.0 0.0.0.255
access-list 20 permit 46.33.129.0 0.0.0.15
access-list 20 permit 46.33.158.0 0.0.0.3
!
no cdp run
!
snmp-server community public RO
snmp-server enable traps entity-sensor threshold
!
control-plane
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
access-class 20 in
privilege level 15
password 911-Turbo
login local
transport input ssh
!
scheduler allocate 20000 1000
end


Please can someone help in advising what i am doing wrong in the setup as i can not find the reason why there is no internet connection going to the device connected to the cisco router on fast ethernet port 0/0/3.
any assistance would be appreciated.

Thanks

Rehan Miah

Correct Answer by jawad-mukhtar about 4 years 6 days ago

if your modem with ip 192.168.0.1 is responsible for natting do simple config for option 2:


disable ip routing by


no ip routing


set default ip gateway by


ip-default gateway 1921.68.0.1


Now After This Your Interface should be like that

Embedded-Service-Engine0/0 unassigned      YES NVRAM  administratively down down

GigabitEthernet0/0         unassignled    YES NVRAM  down                    down

GigabitEthernet0/1         unassigned      YES NVRAM  administratively down down

FastEthernet0/0/0          unassigned      YES unset  administratively up up (connected to 192.168.0.1 and will be in vlan 1)

FastEthernet0/0/1          unassigned      YES unset  administratively down down

FastEthernet0/0/2          unassigned      YES unset  administratively down down

FastEthernet0/0/3          unassigned      YES unset  up                    up

Vlan1                      192.168.0.10   YES NVRAM  down                  down



ip dhcp excluded-address 192.168.0.1 192.168.0.99
!
ip dhcp pool DHCP_POOL
network 192.168.0.0 255.255.255.0
default-router 192.168.0.1
dns-server 46.33.128.49 46.33.128.50
!
!
ip name-server 46.33.128.49
ip name-server 46.33.128.50
no ip cef
login on-failure log
login on-success log
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-2112039246
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2112039246
revocation-check none
rsakeypair TP-self-signed-2112039246
!
!
crypto pki certificate chain TP-self-signed-2112039246
certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32313132 30333932 3436301E 170D3133 30383031 31353234
  31315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 31313230
  33393234 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100C333 0665C623 1F7C5E3A 1131B8BF EF067A17 DFAC7229 6DAE4A6D 7E1507F9
  56B90C2B 27CD29A7 4DDF4E11 4B49438D FAF7E455 6C9231D3 82344C9E D4782AD5
  38F0D8EE 6ACF7E02 709A0863 ABA8AC3C CD032902 9969F744 4B492877 34E94B46
  29A1F902 5EEE2B9C CC71E5F8 DEE48586 5292998F 3E582707 FAB30D5E 1FC31B9B
  18A50203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 1401CEF2 DA12AA7E 601A1267 265EF23C 771F5D91 E7301D06
  03551D0E 04160414 01CEF2DA 12AA7E60 1A126726 5EF23C77 1F5D91E7 300D0609
  2A864886 F70D0101 05050003 81810028 26DF209C 0D7FF01D CB9CAE57 9DF6B0EA
  5319A290 29BBD0EA F38FE438 AE006F73 0BAB2679 EBD55116 2D6BE24A B5F193E6
  1D322E2E 4F8987C8 9B59BA9F FD94B234 80DB98AC BD90050B 60EED482 ACCCE2CA
  4B2AA75B 8F2CED96 C1E423CA 2913AD00 F428F759 A3B44408 4716EF37 EC57FC86
  FDAA69B8 02F4206B 4FE8B87C 7ECDC0
        quit
license udi pid CISCO1941/K9 sn FCZ160992RN
!
!
username admin privilege 15 password 0 911-Turbo
!
!
ip ssh version 2
ip scp server enable
!
!
!
!


!
interface GigabitEthernet0/0

no ip address
no ip route-cache
duplex auto
speed auto
no cdp enable
no mop enabled
!
interface GigabitEthernet0/1
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
no cdp enable
!
interface FastEthernet0/0/0


des *** Will be connted to 192.168.0.1 Modem ***

switchport mode access


switch port access vlan 1

no ip address
shutdown
no cdp enable
!
interface FastEthernet0/0/1

switchport mode access

switchport access vlan 1

no ip address
shutdown
no cdp enable
no mop enabled
!
interface FastEthernet0/0/2

switchport mode access

switchport access vlan 1

no ip address
shutdown
no cdp enable
!
interface FastEthernet0/0/3
switchport access vlan 1
no ip address
speed 10
no cdp enable
no mop enabled
!
interface Vlan1
ip address 192.168.0.10 255.255.255.0
no ip route-cache

!

ip http server
ip http authentication local
ip http secure-server
!





Jawad

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
rais Fri, 08/09/2013 - 07:49
User Badges:
  • Silver, 250 points or more

You haven't designated the Outside interface. Your F0/0/3 is a switchport, so it can't be used as overload in the nat statement.


HTH.

khiladhi_420 Fri, 08/09/2013 - 07:52
User Badges:

Could you tell me what the correct command is that i need to run to fix this


Thanks


Rehan Miah

rais Fri, 08/09/2013 - 09:14
User Badges:
  • Silver, 250 points or more

For network 192.168.0.X, your NAT and DHCP should already be taken care of by the Netgear. So you may treat all ports as switchports on 1941 [including G0/0] and use your 1941 as a switch. I am not sure how you assigned G0/0 and vlan2 the same IP subnets.


Otherwise, if the host has an IP other than 192.168.0.X, you need to NAT all addresses to your G0/0 address in 'ip nat' statement.


Make sure the device on F0/0/3 is getting an IP address or assign it statically or leave it to Netgear as well.


HTH.

kmccourt Fri, 08/09/2013 - 09:50
User Badges:
  • Bronze, 100 points or more

You also need to get rid of:


no ip routing

jawad-mukhtar Fri, 08/09/2013 - 15:59
User Badges:
  • Silver, 250 points or more

wat i understand your

GigabitEthernet0/0  is connected to externet modem 192.168.0.1 and that internet modem is responsible for natting.


If this is that case no natting or ip access list ie required for that just default route is required to 192.168.0.1


don't disable ip routing in that case


no ip nat inside source list 1 interface FastEthernet0/0/3 overload

Other thing what i noticed




GigabitEthernet0/0         192.168.0.10  

interface Vlan1

ip address 192.168.0.29 255.255.255.0

no ip route-cache

!

interface Vlan2

ip address 192.168.0.31 255.255.255.0

!

I dont think you can Assign the same subnetwork addesses on interfaces



2nd OPTION



GigabitEthernet0/0  is connected to externet modem 192.168.0.1 and that internet modem is responsible for natting.

if that is the case

disable ip routing on router


no ip routing


remove all ips


connected your modde to siwtch interface like fe 0/0/0


create singe vlan


interface vlan 1

ip address 192.168.0.x


put all all interface in vlan 1



configure ip default gateway

ip default gateway 192.168.0.1


dhcp configuration will reamain same.



*** DO RATE HELPFUL POSTS ****




Jawad

khiladhi_420 Mon, 08/12/2013 - 02:04
User Badges:

2nd OPTION


GigabitEthernet0/0 is connected to externet modem 192.168.0.1 and that internet modem is responsible for natting.

if that is the case

disable ip routing on router

no ip routing

remove all ips

connected your modde to siwtch interface like fe 0/0/0

create singe vlan

interface vlan 1

ip address 192.168.0.x

put all all interface in vlan 1

configure ip default gateway

ip default gateway 192.168.0.1

dhcp configuration will reamain same.


Jawad


Hi Jawad i am trying to implement the 2nd option you described but need more assistance please. you say remove all ips which ip are you talking about the only ip addresses i assigned is the ip address for GigabitEthernet0/0 port and vlan 1 and vlan 2 are you reffering to remove all ip addresses from these devices. secondly how would ip disable ip routing is it not already disabled but the command no ip routing or do i need to run another command to disabel ip routing default gateway is alreeady set as 192.168.0.1 and i shall keep the dhcp configuration the same. your assistance would be very helpful.


thanks


Rehan Miah



Correct Answer
jawad-mukhtar Mon, 08/12/2013 - 10:10
User Badges:
  • Silver, 250 points or more

if your modem with ip 192.168.0.1 is responsible for natting do simple config for option 2:


disable ip routing by


no ip routing


set default ip gateway by


ip-default gateway 1921.68.0.1


Now After This Your Interface should be like that

Embedded-Service-Engine0/0 unassigned      YES NVRAM  administratively down down

GigabitEthernet0/0         unassignled    YES NVRAM  down                    down

GigabitEthernet0/1         unassigned      YES NVRAM  administratively down down

FastEthernet0/0/0          unassigned      YES unset  administratively up up (connected to 192.168.0.1 and will be in vlan 1)

FastEthernet0/0/1          unassigned      YES unset  administratively down down

FastEthernet0/0/2          unassigned      YES unset  administratively down down

FastEthernet0/0/3          unassigned      YES unset  up                    up

Vlan1                      192.168.0.10   YES NVRAM  down                  down



ip dhcp excluded-address 192.168.0.1 192.168.0.99
!
ip dhcp pool DHCP_POOL
network 192.168.0.0 255.255.255.0
default-router 192.168.0.1
dns-server 46.33.128.49 46.33.128.50
!
!
ip name-server 46.33.128.49
ip name-server 46.33.128.50
no ip cef
login on-failure log
login on-success log
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-2112039246
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2112039246
revocation-check none
rsakeypair TP-self-signed-2112039246
!
!
crypto pki certificate chain TP-self-signed-2112039246
certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32313132 30333932 3436301E 170D3133 30383031 31353234
  31315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 31313230
  33393234 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100C333 0665C623 1F7C5E3A 1131B8BF EF067A17 DFAC7229 6DAE4A6D 7E1507F9
  56B90C2B 27CD29A7 4DDF4E11 4B49438D FAF7E455 6C9231D3 82344C9E D4782AD5
  38F0D8EE 6ACF7E02 709A0863 ABA8AC3C CD032902 9969F744 4B492877 34E94B46
  29A1F902 5EEE2B9C CC71E5F8 DEE48586 5292998F 3E582707 FAB30D5E 1FC31B9B
  18A50203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 1401CEF2 DA12AA7E 601A1267 265EF23C 771F5D91 E7301D06
  03551D0E 04160414 01CEF2DA 12AA7E60 1A126726 5EF23C77 1F5D91E7 300D0609
  2A864886 F70D0101 05050003 81810028 26DF209C 0D7FF01D CB9CAE57 9DF6B0EA
  5319A290 29BBD0EA F38FE438 AE006F73 0BAB2679 EBD55116 2D6BE24A B5F193E6
  1D322E2E 4F8987C8 9B59BA9F FD94B234 80DB98AC BD90050B 60EED482 ACCCE2CA
  4B2AA75B 8F2CED96 C1E423CA 2913AD00 F428F759 A3B44408 4716EF37 EC57FC86
  FDAA69B8 02F4206B 4FE8B87C 7ECDC0
        quit
license udi pid CISCO1941/K9 sn FCZ160992RN
!
!
username admin privilege 15 password 0 911-Turbo
!
!
ip ssh version 2
ip scp server enable
!
!
!
!


!
interface GigabitEthernet0/0

no ip address
no ip route-cache
duplex auto
speed auto
no cdp enable
no mop enabled
!
interface GigabitEthernet0/1
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
no cdp enable
!
interface FastEthernet0/0/0


des *** Will be connted to 192.168.0.1 Modem ***

switchport mode access


switch port access vlan 1

no ip address
shutdown
no cdp enable
!
interface FastEthernet0/0/1

switchport mode access

switchport access vlan 1

no ip address
shutdown
no cdp enable
no mop enabled
!
interface FastEthernet0/0/2

switchport mode access

switchport access vlan 1

no ip address
shutdown
no cdp enable
!
interface FastEthernet0/0/3
switchport access vlan 1
no ip address
speed 10
no cdp enable
no mop enabled
!
interface Vlan1
ip address 192.168.0.10 255.255.255.0
no ip route-cache

!

ip http server
ip http authentication local
ip http secure-server
!





Jawad

jawad-mukhtar Mon, 08/12/2013 - 10:11
User Badges:
  • Silver, 250 points or more

Remember to no shut Interfaces range  fa 0/0/0 - fa 0/0/3



Jawad

khiladhi_420 Wed, 08/14/2013 - 02:21
User Badges:

Thanks Jawad.

I connected the internet modem to interface FastEthernet0/0/0 and assigned switchport access VLAN 1 to all ports. I had default gateway already configured and DHCP configured. Now when i connect a device to another port i am able to get internet access.


Thanks


Rehan Miah

Actions

This Discussion