Cant update Cisco Catalyst 2960 IOS

Unanswered Question
Aug 14th, 2013
User Badges:

Hello.


I have a Cisco Catalyst 2960-8TC-L running IOS Version 15.0(2)SE2.


Im currently trying to update to the SE4 version, but when i enter the webinterface for the switch, and try to upgrade it just getting stucked at "Loading the tar file to the switch":


IOS1.PNG                 


I have tried from Windows server 2003 - 2008R2 and Windows server 2012 / Windows 8 with the different IE version attached to the OSes and also tried with Google Chrome.


This is the tar file:


IOS2.PNG


               


Why is this not working?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
InayathUlla Sharieff Wed, 08/14/2013 - 01:45
User Badges:
  • Cisco Employee,

Can you delete the file which are on the system and download the fresh file and try to upgrade?


Second option can you also try upgrading the switch directly from the switch?


HTH

Regards

Inayath

*Plz rate all usefull posts.

Kristian Leth Wed, 08/14/2013 - 01:53
User Badges:

Hello.


I have never updated the switch from the CLI, only from the Webinterface.


Should i load the .tar file to a TFTP server?


And what are the commands for updating it, and can a .tar file be used for upgrading the IOS from the CLI?

Leo Laohoo Wed, 08/14/2013 - 16:02
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Please check this:

http://www.dslreports.com/faq/10854

Oh no.  Not the "archive tar /x" command. 


Geez.  I wouldn't recommend that for newbies.


Before you go any further, make sure the IOS file MD5 hash is exactly the same as the MD5 hash found in the Cisco website.  If they don't match, then your IOS file is corrupt.


Ok, try this, slightly simpler:


1.  What is the Management IP address of your switch?

2.  What is the IP address of the PC directly connected to your switch?  Note this down.

3.  Can this PC, which also has the IOS file (hopefully a TAR), ping the switch?  If yes, proceed to #4.

4.  Do you have a TFTP server running on the PC which is has the IOS file?  If no, use TFTPd32/TFTPd64.  It's easy to use.  Just make sure you point the TFTP to the location/folder where the IOS is located.  Alternatively, you can put the IOS file into the default folder of the TFTP.

5.  Make sure your switch has ample room to store the new IOS.

6.  The command to un-pack the IOS into your switch is:  archive download-sw tftp:///IOS.tar


NOTE:  You can use the option "/overwrite", between the "download-sw" and "tftp", and this will erase your old IOS.

Actions

This Discussion

Related Content