Dynamic DNS behind NAT

Unanswered Question
Aug 16th, 2013
User Badges:

Hello Community!,

i just configured my Cisco 1841 to works as modem/router with my Italian ISP that provide only dynamic IP to end users, for this reason, in user to use VPN etc, i need to configure a Dynamic DNS service on it.


The configuration is the following:


Cisco 1841 with WIC-1ADSL - FE0/0 configured with my private network IP and FE0/1 shutted down because i don't need it...


if i configure DDNS service on my router, it updates DynDNS or No-IP with my private Fe0/0 IP address; i followed a lot of guides that explain how to configure a DDNS service with dynamic IP without success.


Can i have more support by you?...


Thank you,

Riccardo

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
mfurnival Fri, 08/16/2013 - 02:33
User Badges:
  • Silver, 250 points or more

Hello, can you post your config please? You should have the ddns config on your dialer interface, not your f0/0 interface.

Riccardo Margiotta Fri, 08/16/2013 - 02:43
User Badges:

Hello,

Thanks for you quick response, below my config:


Current configuration : 3077 bytes

!

version 12.4

service timestamps debug uptime

service timestamps log datetime msec

service password-encryption

!

hostname RA1-ITSOVI-1-1

!

boot-start-marker

boot-end-marker

!

logging buffered 4096 debugging

!

no aaa new-model

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 10.200.36.1 10.200.36.10

!

ip dhcp pool RMSI_D_POOL

   network 10.200.36.0 255.255.255.0

   default-router 10.200.36.1

   dns-server 10.200.36.1 8.8.8.8 85.37.17.7

   domain-name RMSI.loc

!

ip dhcp pool S_NAS1

   host 10.200.36.7 255.255.255.0

   hardware-address 0090.a9ba.f4da

   client-name NAS1-RMSI-1-1

!

ip dhcp pool S_TimeCapsule

   host 10.200.36.9 255.255.255.0

   hardware-address 20c9.d013.7176

   client-name TC1-RMSI-1-1

!

ip dhcp pool S_NAS2

   host 10.200.36.8 255.255.255.0

   hardware-address 0090.a9bb.1c22

   client-name NAS2-RMSI-1-2

!

ip dhcp pool S_WS1

   host 10.200.36.2 255.255.255.0

   hardware-address 0025.6106.56c0

   client-name WS1-RMSI-1-1

!

ip dhcp pool S_RA2

   host 10.200.36.3 255.255.255.0

   hardware-address a493.4cc2.99c8

   default-router 10.200.36.1

   domain-name gns.rmsi.loc

   client-name RA2-ITSOVI-1-2

!

!

ip ftp source-interface FastEthernet0/0

ip ftp username cisco

ip ftp password 7

ip domain list storage.rmsi.loc

ip domain list gns.rmsi.loc

ip domain name RMSI.loc

ip host RA1-ITSOVI-1-1 10.200.36.1

ip host NAS2-RMSI-1-2 10.200.36.8

ip host NAS1-RMSI-1-1 10.200.36.7

ip host TC-RMSI-1-1 10.200.36.9

ip host WS1-ITSOVI-1-1 10.200.36.2

ip name-server 8.8.8.8

ip name-server 8.8.4.4

ip name-server 10.200.36.1

ip ddns update method no-ip

HTTP

  add http://rikixx90:@dynupdate.no-ip.com/nic/update?hostname=rmsi.no-ip.biz&myip=

interval maximum 0 0 5 0

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

description LAN interface

ip address 10.200.36.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface ATM0/0/0

no ip address

no ip mroute-cache

load-interval 30

no atm ilmi-keepalive

dsl operating-mode auto

pvc 8/35

  pppoe-client dial-pool-number 1

!

!

interface Dialer0

ip ddns update hostname rmsi.no-ip.biz

ip ddns update no-ip

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

ppp chap hostname aliceadsl

ppp chap password 7 03055702050A20485D05

!

ip route 0.0.0.0 0.0.0.0 Dialer0

!

ip dns server

!

ip http server

no ip http secure-server

ip nat inside source list 1 interface Dialer0 overload

!

access-list 1 permit 10.200.36.0 0.0.0.255

!

!

!

!

control-plane

!

!        

banner motd ^Ctod ^

=================== "UNAUTHORIZED ACCESS IS STRICTLY PROHIBITED" ===================

All Unauthorized access will be logged and prosecuted to the fullest extent of the law^C

!

line con 0

exec-timeout 5 30

password 7

login

line aux 0

line vty 0 4

password 7

login

!

scheduler allocate 20000 1000

end

mfurnival Fri, 08/16/2013 - 03:27
User Badges:
  • Silver, 250 points or more

Looks OK to me. Can you do:


#ter mon

#debug ip ddns update


and then shut / no shut your dialer interface?

Riccardo Margiotta Fri, 08/16/2013 - 03:36
User Badges:

Here you go:


RA1-ITSOVI-1-1#term mon

RA1-ITSOVI-1-1#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

RA1-ITSOVI-1-1(config)#int dialer0

RA1-ITSOVI-1-1(config-if)#shut


*Aug 16 12:31:28.875: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di0

00:16:32: Di0 DDR: dialer shutdown complete

*Aug 16 12:31:28.879: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down

*Aug 16 12:31:29.891: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to down

*Aug 16 12:31:51.083: %DIALER-6-BIND: Interface Vi1 bound to profile Di0

*Aug 16 12:31:51.087: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

*Aug 16 12:31:52.695: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up



*Aug 16 12:32:30.891: %LINK-5-CHANGED: Interface Dialer0, changed state to administratively down

RA1-ITSOVI-1-1(config-if)#no shut


*Aug 16 12:32:41.367: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di0

*Aug 16 12:32:41.371: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down

*Aug 16 12:32:42.375: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to down

*Aug 16 12:32:43.363: %LINK-3-UPDOWN: Interface Dialer0, changed state to up

*Aug 16 12:33:03.587: %DIALER-6-BIND: Interface Vi1 bound to profile Di0

*Aug 16 12:33:03.591: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

*Aug 16 12:33:05.195: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up


After shut/no shut operation, the IP address on No-IP address has been updated correctly....

mfurnival Fri, 08/16/2013 - 03:45
User Badges:
  • Silver, 250 points or more

So it is working then?

Did you turn the debug on? I don't see any DDNS debug in the output.

Riccardo Margiotta Fri, 08/16/2013 - 04:18
User Badges:

You're right, i'm sorry.. the debug loggins was turned off..


RA1-ITSOVI-1-1#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

RA1-ITSOVI-1-1(config)#int dialer0

RA1-ITSOVI-1-1(config-if)#shut


*Aug 16 13:12:58.483: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di0

00:01:53: Di0 DDR: dialer shutdown complete

00:01:53: DYNUPD: SWIF goingdown 'Dialer0'

00:01:53: DYNDNSUPD: Removing DNS mapping for rmsi.no-ip.biz <=> 79.20.166.102

00:01:53: HTTPDNS: Update remove called for rmsi.no-ip.biz <=> 79.20.166.102

*Aug 16 13:12:58.487: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down

00:01:53: DYNUPD: SWIF goingdown 'Virtual-Access1'

*Aug 16 13:12:59.499: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to down

*Aug 16 13:13:01.903: %DHCPD-4-PING_CONFLICT: DHCP address conflict:  server pinged 10.200.36.11.

*Aug 16 13:13:02.903: %DHCPD-4-PING_CONFLICT: DHCP address conflict:  server pinged 10.200.36.12.

*Aug 16 13:13:20.703: %DIALER-6-BIND: Interface Vi1 bound to profile Di0

*Aug 16 13:13:20.707: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

*Aug 16 13:13:22.299: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up

00:02:16: DYNUPD: SWIF comingup 'Virtual-Access1'

00:02:19: DYNDNSUPD: Adding DNS mapping for rmsi.no-ip.biz <=> 79.11.140.56

00:02:19: HTTPDNS: Update add called for rmsi.no-ip.biz <=> 79.11.140.56

00:02:19: HTTPDNSUPD: Session ID = 0x3

00:02:19: HTTPDNSUPD: URL = 'http://rikixx90:@dynupdate.no-ip.com/nic/update?hostname=rmsi.no-ip.biz&myip=
@dynupdate.no-ip.com/nic/update?hostname=rmsi.no-ip.biz&myip='

00:02:19: HTTPDNSUPD: Sending request

00:02:20: HTTPDNSUPD: Response for update rmsi.no-ip.biz <=> 79.11.140.56


00:02:20: HTTPDNSUPD: DATA START

good 79.11.140.56

00:02:20: HTTPDNSUPD: DATA END, Status is Response data recieved, successfully

00:02:20: HTTPDNSUPD: Call returned SUCCESS for update rmsi.no-ip.biz <=> 79.11.140.56

00:02:20: DYNDNSUPD: Another update completed (outstanding=0, total=0)

00:02:20: HTTPDNSUPD: Clearing all session 3 info

RA1-ITSOVI-1-1(config-if)#

00:02:53: DYNUPD: SWIF goingdown 'Dialer0'

00:02:53: DYNDNSUPD: Removing DNS mapping for rmsi.no-ip.biz <=> 79.11.140.56

00:02:53: HTTPDNS: Update remove called for rmsi.no-ip.biz <=> 79.11.140.56

*Aug 16 13:14:00.483: %LINK-5-CHANGED: Interface Dialer0, changed state to administratively down

RA1-ITSOVI-1-1(config-if)#no shut


*Aug 16 13:15:23.583: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di0

00:04:18: DYNUPD: SWIF comingup 'Dialer0'

*Aug 16 13:15:23.587: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down

00:04:18: DYNUPD: SWIF goingdown 'Virtual-Access1'

*Aug 16 13:15:24.591: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to down

*Aug 16 13:15:25.583: %LINK-3-UPDOWN: Interface Dialer0, changed state to up

00:04:20: DYNUPD: SWIF comingup 'Dialer0'

*Aug 16 13:15:45.915: %DIALER-6-BIND: Interface Vi1 bound to profile Di0

*Aug 16 13:15:45.919: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

*Aug 16 13:15:47.711: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up

00:04:42: DYNUPD: SWIF comingup 'Virtual-Access1'

00:04:44: DYNDNSUPD: Adding DNS mapping for rmsi.no-ip.biz <=> 79.16.153.108

00:04:44: HTTPDNS: Update add called for rmsi.no-ip.biz <=> 79.16.153.108

00:04:44: HTTPDNSUPD: Session ID = 0x4

00:04:44: HTTPDNSUPD: URL = 'http://rikixx90:
@dynupdate.no-ip.com/nic/update?hostname=rmsi.no-ip.biz&myip=
@dynupdate.no-ip.com/nic/update?hostname=rmsi.no-ip.biz&myip='

00:04:44: HTTPDNSUPD: Sending request

00:04:54: HTTPDNSUPD: Response for update rmsi.no-ip.biz <=> 79.16.153.108


00:04:54: HTTPDNSUPD: DATA START

good 79.16.153.108

00:04:54: HTTPDNSUPD: DATA END, Status is Response data recieved, successfully

00:04:54: HTTPDNSUPD: Call returned SUCCESS for update rmsi.no-ip.biz <=> 79.16.153.108

00:04:54: DYNDNSUPD: Another update completed (outstanding=0, total=0)

00:04:54: HTTPDNSUPD: Clearing all session 4 info


i already checked on No-IP website and the new IP address is correctly updated, i tried many times and always it update it as well...


i would like to try also with DynDNS (my preferred service) and check if also with this DDNS system it works fine.

paolo bevilacqua Fri, 08/16/2013 - 04:22
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

First of all, you should give a public IP address to the Cisco router, making it the router directly facing the internet.


If you cannot do that, remove "myip". from ddns configuration. The DDNS service will use the IP the request is received from.

mfurnival Fri, 08/16/2013 - 04:27
User Badges:
  • Silver, 250 points or more

I have used dyndns on my 1841 in a similar setup and had no problems.

Riccardo Margiotta Fri, 08/16/2013 - 05:33
User Badges:

Ok, thank you guys for your responsed, they solved my problems and dubs with DDNS on Cisco 1841.


let's try with DynDNS.


Thanks,

RIccardo

paolo bevilacqua Fri, 08/16/2013 - 05:59
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Please remember to rate useful posts clicking on the stars below.

Riccardo Margiotta Fri, 08/16/2013 - 09:48
User Badges:

just FYI and for support to this community, i just configured the DDNS update with my account DynDNS with the following config and it works very very good!.


ip ddns update method dyndns

HTTP

  add http://:@members.dyndns.org/nic/update?system=dyndns&hostname=&myip=

interval maximum 1 0 0 0


Thanks a lot for all the support received in this discussion!


Bye,

Riccardo Margiotta

Actions

This Discussion