×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Can we build OSPF adajacency between P2P & P2M network type by having maping between Spoke-Hub & to spoke....

Unanswered Question
Aug 17th, 2013
User Badges:

Hi all,


I was trying mismatch OSPF NBMA netwotk type adjacency build scenarios were i have found one problematic scence:

Scenario:

Hub router is running with Point to multipoint, mapping is done with both spoke router.

Both Spoke router running with Point to Point and frame-relay mapping was done only with Hub router then OSPF adj bulid and working fine.

--> if we done Mapping with Hub router and another spoke router  then OSPF adj starts to flap.


If anyone knows the exact theory behind the scene please let me know...


Below is the running configuration:


Hub Router:


interface Serial1/0

description ** Connectivity to R17 ***

ip address 172.31.0.8 255.255.255.0

encapsulation frame-relay

ip ospf network point-to-multipoint

ip ospf hello-interval 10

serial restart-delay 0

no arp frame-relay

frame-relay map ip 172.31.0.4 804 broadcast

frame-relay map ip 172.31.0.5 805 broadcast

!

interface Loopback0

ip address 172.16.8.8 255.255.255.0

end

!

router ospf 1

log-adjacency-changes

network 172.16.8.0 0.0.0.255 area 0

network 172.31.0.0 0.0.0.255 area 0


Spoke -1 Router

-----------

!

interface Serial1/0

description ** Connectivity to R17 ***

ip address 172.31.0.5 255.255.255.0

encapsulation frame-relay

ip ospf network point-to-point

serial restart-delay 0

no arp frame-relay

frame-relay map ip 172.31.0.4 504 broadcast

frame-relay map ip 172.31.0.8 508 broadcast

no frame-relay inverse-arp

end

!

interface Loopback0

ip address 172.16.5.5 255.255.255.0

end

!

router ospf 1

network 172.16.5.0 0.0.0.255 area 0

network 172.31.0.0 0.0.0.255 area 0


Spoke -2 router

------------------------

!

interface Serial1/0

description *** Connectivity to Frame-relay switch-R17 ***

ip address 172.31.0.4 255.255.255.0

encapsulation frame-relay

ip ospf network point-to-point

serial restart-delay 0

no arp frame-relay

frame-relay map ip 172.31.0.5 405 broadcast

frame-relay map ip 172.31.0.8 408 broadcast

no frame-relay inverse-arp

end

!

interface Loopback0

ip address 172.16.4.4 255.255.255.0

end

!

outer ospf 1

network 172.16.4.0 0.0.0.255 area 0

network 172.31.0.0 0.0.0.255 area 0



Log for referece:


*Mar  1 04:56:46.458: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.4.4 on Serial1/0 from INIT to DOWN, Neighbor Down: Adjacency forced to reset

*Mar  1 04:56:46.826: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.8.8 on Serial1/0 from LOADING to FULL, Loading Done

*Mar  1 04:56:47.186: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.8.8 on Serial1/0 from FULL to DOWN, Neighbor Down: Adjacency forced to reset

*Mar  1 04:56:47.578: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.4.4 on Serial1/0 from LOADING to FULL, Loading Done

*Mar  1 04:56:54.246: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.4.4 on Serial1/0 from FULL to DOWN, Neighbor Down: Adjacency forced to reset

*Mar  1 04:56:54.354: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.8.8 on Serial1/0 from EXSTART to DOWN, Neighbor Down: Adjacency forced to reset


Mar  1 04:56:08.558: OSPF: 2 Way Communication to 172.16.4.4 on Serial1/0, state 2WAY

*Mar  1 04:56:08.562: OSPF: Send DBD to 172.16.4.4 on Serial1/0 seq 0x2 opt 0x52 flag 0x7 len 32

*Mar  1 04:56:08.674: OSPF: Rcv DBD from 172.16.4.4 on Serial1/0 seq 0x5DB opt 0x52 flag 0x7 len 32  mtu 1500 state EXSTART

*Mar  1 04:56:08.678: OSPF: First DBD and we are not SLAVE

*Mar  1 04:56:08.678: OSPF: Rcv DBD from 172.16.4.4 on Serial1/0 seq 0x2 opt 0x52 flag 0x2 len 52  mtu 1500 state EXSTART

*Mar  1 04:56:08.682: OSPF: NBR Negotiation Done. We are the MASTER

*Mar


  1 04:56:08.686: OSPF: Send DBD to 172.16.4.4 on Serial1/0 seq 0x3 opt 0x52 flag 0x1 len 32

*Mar  1 04:56:08.802: OSPF: Build router LSA for area 0, router ID 172.16.5.5, seq 0x80000001, process 1

*Mar  1 04:56:08.866: OSPF: Rcv DBD from 172.16.4.4 on Serial1/0 seq 0x3 opt 0x52 flag 0x0 len 32  mtu 1500 state EXCHANGE

*Mar  1 04:56:08.870: OSPF: Exchange Done with 172.16.4.4 on Serial1/0

*Mar  1 04:56:08.874: OSPF: Send LS REQ to 172.16.4.4 length 12 LSA count 1

*Mar  1 04:56:09.078: OSPF: Rcv LS UPD from 172.16.4.4 on Serial1/0 length 88 LSA count 1

*Mar  1 04:56:09.082: OSPF: Synchronized with 172.16.4.4 on Serial1/0, state FULL

*Mar  1 04:56:09.082: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.4.4 on Serial1/0 from LOADING to FULL, Loading Done

*Mar  1 04:56:09.854: OSPF: Rcv DBD from 172.16.4.4 on Serial1/0 seq 0x26F7 opt 0x52 flag 0x7 len 32  mtu 1500 state FULL

*Mar  1 04:56:09.858: OSPF: Bad seq received from 172.31.0.4 on Serial1/0

*Mar  1 04:56:09.862: OSPF: Send DBD to 1

72.16.4.4 on Serial1/0 seq 0x17BC opt 0x52 flag 0x7 len 32

*Mar  1 04:56:09.946: OSPF: Cannot see ourself in hello from 172.16.4.4 on Serial1/0, state INIT

*Mar  1 04:56:09.950: OSPF: Rcv DBD from 172.16.4.4 on Serial1/0 seq 0x322 opt 0x52 flag 0x2 len 52  mtu 1500 state INIT

*Mar  1 04:56:09.954: OSPF: 2 Way Communication to 172.16.4.4 on Serial1/0, state 2WAY

*Mar  1 04:56:09.958: OSPF: Send DBD to 172.16.4.4 on Serial1/0 seq 0x7E1 opt 0x52 flag 0x7 len 32

*Mar  1 04:56:09.962: OSPF: Unrecognized dbd for EXSTART

*Mar  1 04:56:10.038: OSPF: Rcv DBD from 172.16.4.4 on Serial1/0 seq 0x323 opt 0x52 flag 0x0 len 32  mtu 1500 state EXSTART

*Mar  1 04:56:10.042: OSPF: Unrecognized dbd for EXSTART

*Mar  1 04:56:10.278: OSPF: Rcv DBD from 172.16.4.4 on Serial1/0 seq 0x324 opt 0x52 flag 0x0 len 32  mtu 1500 state EXSTART

*Mar  1 04:56:10.282: OSPF: Unrecognized dbd for EXSTART


*Mar  1 04:56:14.954: OSPF: Send DBD to 172.16.4.4 on Serial1/0 seq 0x7E1 opt 0x52 flag 0x7 len 32

*Mar  1 04:56:14.958: OSPF: Retransmitting DBD to 172.16.4.4 on Serial1/0 [1]

*Mar  1 04:56:15.282: OSPF: 172.16.4.4 address 172.31.0.4 on Serial1/0 is dead, state DOWN


*Mar  1 04:56:15.286: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.4.4 on Serial1/0 from EXSTART to DOWN, Neighbor Down: Adjacency forced to reset


*Mar  1 04:56:17.694: OSPF: 2 Way Communication to 172.16.8.8 on Serial1/0, state 2WAY

*Mar  1 04:56:17.698: OSPF: Send DBD to 172.16.8.8 on Serial1/0 seq 0x1883 opt 0x52 flag 0x7 len 32

*Mar  1 04:56:17.702: OSPF: Rcv DBD from 172.16.8.8 on Serial1/0 seq 0x2063 opt 0x52 flag 0x7 len 32  mtu 1500 state EXSTART

*Mar  1 04:56:17.706: OSPF: NBR Negotiation Done. We are the SLAVE

*Mar  1 04:56:17.710: OSPF: Send DBD to 172.16.8.8 on Serial1/0 seq 0x2063 opt 0x52 flag 0x2 len 72

*Mar  1 04:56:17.778: OSPF: Rcv DBD from 172.16.8.8 on Serial1/0 seq 0x2064 opt 0x52 flag 0x3 len 72  mtu 1500 state EXCHANGE

*Mar  1 04:56:17.782: OSPF: Send DBD to 172.16.8.8 on Serial1/0 seq 0x2064 opt 0x52 flag 0x0 len 32

*Mar  1 04:56:17.830: OSPF: OSPF: Rcv pkt from Serial1/0 src 172.31.0.4 dst 224.0.0.5 id 172.16.4.4 type 2 if_state 4 : ignored due to unknown neighbor

*Mar  1 04:56:17.906: OSPF: Rcv DBD from 172.16.8.8 on Serial1/0 seq 0x2065 opt 0x52 flag 0x1 len 32  mtu 1500 state EXCHANGE

*Mar

1 04:56:17.910: OSPF: Exchange Done with 172.16.8.8 on Serial1/0

*Mar  1 04:56:17.914: OSPF: Send LS REQ to 172.16.8.8 length 24 LSA count 2

*Mar  1 04:56:17.914: OSPF: Send DBD to 172.16.8.8 on Serial1/0 seq 0x2065 opt 0x52 flag 0x0 len 32

*Mar  1 04:56:17.938: OSPF: Rcv LS REQ from 172.16.8.8 on Serial1/0 length 36 LSA count 1

*Mar  1 04:56:17.942: OSPF: Send UPD to 172.31.0.8 on Serial1/0 length 52 LSA count 1

*Mar  1 04:56:17.954: OSPF: OSPF: Rcv pkt from Serial1/0 src 172.31.0.4 dst 224.0.0.5 id 172.16.4.4 type 2 if_state 4 : ignored due to unknown neighbor

*Mar  1 04:56:17.958: OSPF: OSPF: Rcv pkt from Serial1/0 src 172.31.0.4 dst 224.0.0.5 id 172.16.4.4 type 2 if_state 4 : ignored due to unknown neighbor

*Mar  1 04:56:17.962: OSPF: Rcv LS UPD from 172.16.8.8 on Serial1/0 length 148 LSA count 2

*Mar  1 04:56:17.970: OSPF: Synchronized with 172.16.8.8 on Serial1/0, state FULL

*Mar  1 04:56:17.970: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.8.8 on Serial1/0 from LOADING to FULL, Loading Done

*Mar  1 04:56:18.398: OSPF: Rcv LS UPD from 172.16.8.8 on Serial1/0 length 88 LSA count 1

*Mar  1 04:56:18.478: OSPF: Build router LSA for area 0, router ID 172.16.5.5, seq 0x80000002, process 1

*Mar  1 04:56:19.582: OSPF: 172.16.8.8 address 172.31.0.8 on Serial1/0 is dead, state DOWN

*Mar  1 04:56:19.586: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.8.8 on Serial1/0 from FULL to DOWN, Neighbor Down: Adjacency forced to reset

*Mar  1 04:56:19.594: OSPF: 2 Way Communication to 172.16.4.4 on Serial1/0, state 2WAY

*Mar  1 04:56:19.598: OSPF: Send DBD to 172.16.4.4 on Serial1/0 seq 0x7EE opt 0x52 flag 0x7 len 32

*Mar  1 04:56:19.682: OSPF: 172.16.4.4 address 172.31.0.4 on Serial1/0 is dead, state DOWN

*Mar  1 04:56:19.686: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.4.4 on Serial1/0 from EXSTART to DOWN, Neighbor Down: Adjacency forced to reset

*Mar  1 04:56:19.690: OSPF: 2 Way Communication to 172.16.8.8 on Serial1/0, state 2WAY

*Mar  1 04:56:19.694: OSPF: Send DBD to 172.16.8.8 on Serial1/0 seq 0x1BBF opt 0x52 flag 0x7 len 32

*Mar  1 04:56:19.698: OSPF: Rcv DBD from 172.16.8.8 on Serial1/0 seq 0x4A0 opt 0x52 flag 0x7 len 32  mtu 1500 state EXSTART

*Mar  1 04:56:19.702: OSPF: NBR Negotiation Done. We are the SLAVE

*Mar  1 04:56:19.706: OSPF: Send DBD to 172.16.8.8 on Serial1/0 seq 0x4A0 opt 0x52 flag 0x2 len 92

*Mar  1 04:56:19.734: OSPF: OSPF: Rcv pkt from Serial1/0 src 172.31.0.4 dst 224.0.0.5 id 172.16.4.4 type 2 if_state 4 : ignored due to unknown neighbor

*Mar  1 04:56:19.862: OSPF: OSPF: Rcv pkt from Serial1/0 src 172.31.0.4 dst 224.0.0.5 id 172.16.4.4 type 2 if_state 4 : ignored due to unknown neighbor

*Mar  1 04:56:19.882: OSPF: Rcv DBD from 172.16.8.8 on Serial1/0 seq 0x4A1 opt 0x52 flag 0x3 len 92  mtu 1500 state EXCHANGE

*Mar  1 04:56:19.886: OSPF: Send DBD to 172.16.8.8 on Serial1/0 seq 0x4A1 opt 0x52 flag 0x0 len 32

*Mar  1 04:56:19.958: OSPF: Rcv DBD from 172.16.8.8 on Serial1/0 seq 0x4A2 opt 0x52 flag 0x1 len 32  mtu 1500 state EXCHANGE

*Mar  1 04:56:19.962: OSPF: Exchange Done with 172.16.8.8 on Serial1/0

*Mar  1 04:56:19.962: OSPF: Synchronized with 172.16.8.8 on Serial1/0, state FULL

*Mar  1 04:56:19.966: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.8.8 on Serial1/0 from LOADING to FULL, Loading Done

*Mar  1 04:56:19.970: OSPF: Send DBD to 172.16.8.8 on Serial1/0 seq 0x4A2 opt 0x52 flag 0x0 len 32

*Mar  1 04:56:24.682: OSPF: OSPF: Rcv pkt from Serial1/0 src 172.31.0.4 dst 224.0.0.5 id 172.16.4.4 type 2 if_state 4 : ignored due to unknown neighbor

*Mar  1 04:56:25.278: OSPF: OSPF: Rcv pkt from Serial1/0 src 172.31.0.4 dst 224.0.0.5 id 172.16.4.4 type 2 if_state 4 : ignored due to unknown neighbor

*Mar  1 04:56:25.338: OSPF: 172.16.8.8 address 172.31.0.8 on Serial1/0 is dead, state DOWN

*Mar  1 04:56:25.342: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.8.8 on Serial1/0 from FULL to DOWN, Neighbor Down: Adjacency forced to reset

*Mar  1 04:56:25.846: OSPF: Build router LSA for area 0, router ID 172.16.5.5, seq 0x80000003, process 1

*Mar  1 04:56:26.930: OSPF: 172.16.4.4 address 172.31.0.4 on Serial1/0 is dead, state DOWN

*Mar  1 04:56:26.934: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.4.4 on Serial1/0 from INIT to DOWN, Neighbor Down: Adjacency forced to reset

*Mar  1 04:56:26.938: OSPF: 2 Way Communication to 172.16.8.8 on Serial1/0, state 2WAY

*Mar  1 04:56:26.942: OSPF: Send DBD to 172.16.8.8 on Serial1/0 seq 0x860 opt 0x52 flag 0x7 len 32

*Mar  1 04:56:26.966: OSPF: OSPF: Rcv pkt from Serial1/0 src 172.31.0.4 dst 224.0.0.5 id 172.16.4.4 type 2 if_state 4 : ignored due to unknown neighbor

*Mar  1 04:56:26.978: OSPF: Rcv DBD from 172.16.8.8 on Serial1/0 seq 0x1CFE opt 0x52 flag 0x7 len 32  mtu 1500 state EXSTART

*Mar  1 04:56:26.986: OSPF: NBR Negotiation Done. We are the SLAVE

*Mar  1 04:56:26.990: OSPF: Send DBD to 172.16.8.8 on Serial1/0 seq 0x1CFE opt 0x52 flag 0x2 len 92

*Mar  1 04:56:27.002: OSPF: OSPF: Rcv pkt from Serial1/0 src 172.31.0.4 dst 224.0.0.5 id 172.16.4.4 type 2 if_state 4 : ignored due to unknown neighbor

*Mar  1 04:56:27.150: OSPF: Rcv DBD from 172.16.8.8 on Serial1/0 seq 0x1CFF opt 0x52 flag 0x3 len 92  mtu 1500 state EXCHANGE

*Mar  1 04:56:27.154: OSPF: Send DBD to 172.16.8.8 on Serial1/0 seq 0x1CFF opt 0x52 flag 0x0 len 32

*Mar  1 04:56:27.170: OSPF: OSPF: Rcv pkt from Serial1/0 src 172.31.0.4 dst 224.0.0.5 id 172.16.4.4 type 2 if_state 4 : ignored due to unknown neighbor

*Mar  1 04:56:27.222: OSPF: Rcv DBD from 172.16.8.8 on Serial1/0 seq 0x1D00 opt 0x52 flag 0x1 len 32  mtu 1500 state EXCHANGE

*Mar  1 04:56:27.226: OSPF: Exchange Done with 172.16.8.8 on Serial1/0

*Mar  1 04:56:27.230: OSPF: Synchronized with 172.16.8.8 on Serial1/0, state FULL

*Mar  1 04:56:27.230: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.8.8 on Serial1/0 from LOADING to FULL, Loading Done

*Mar  1 04:56:27.234: OSPF: Send DBD to 172.16.8.8 on Serial1/0 seq 0x1D00 opt 0x52 flag 0x0 len 32

*Mar  1 04:56:27.238: OSPF: Rcv LS REQ from 172.16.8.8 on Serial1/0 length 36 LSA count 1

*Mar  1 04:56:27.242: OSPF: Send UPD to 172.31.0.8 on Serial1/0 length 52 LSA count 1

*Mar  1 04:56:28.670: OSPF: 172.16.8.8 address 172.31.0.8 on Serial1/0 is dead, state DOWN

*Mar  1 04:56:28.674: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.8.8 on Serial1/0 from FULL to DOWN, Neighbor Down: Adjacency forced to reset

*Mar  1 04:56:28.678: OSPF: 2 Way Communication to 172.16.4.4 on Serial1/0, state 2WAY

*Mar  1 04:56:28.682: OSPF: Send DBD to 172.16.4.4 on Serial1/0 seq 0x4F opt 0x52 flag 0x7 len 32

*Mar  1 04:56:28.802: OSPF: OSPF: Rcv pkt from Serial1/0 src 172.31.0.8 dst 172.31.0.5 id 172.16.8.8 type 2 if_state 4 : ignored due to unknown neighbor

*Mar  1 04:56:28.854: OSPF: Rcv DBD from 172.16.4.4 on Serial1/0 seq 0x4F opt 0x52 flag 0x2 len 72  mtu 1500 state EXSTART

*Mar  1 04:56:28.858: OSPF: NBR Negotiation Done. We are the MASTER

*Mar  1 04:56:28.862: OSPF: Send DBD to 172.16.4.4 on Serial1/0 seq 0x50 opt 0x52 flag 0x3 len 92

*Mar  1 04:56:28.974: OSPF: Rcv DBD from 172.16.4.4 on Serial1/0 seq 0x50 opt 0x52 flag 0x0 len 32  mtu 1500 state EXCHANGE

*Mar  1 04:56:28.978: OSPF: Send DBD to 172.16.4.4 on Serial1/0 seq 0x51 opt 0x52 flag 0x1 len 32

*Mar  1 04:56:28.982: OSPF: Send LS REQ to 172.16.4.4 length 12 LSA count 1

*Mar  1 04:56:29.142: OSPF: Rcv LS REQ from 172.16.4.4 on Serial1/0 length 48 LSA count 2

*Mar  1 04:56:29.146: OSPF: Send UPD to 172.31.0.4 on Serial1/0 length 112 LSA count 2

*Mar  1 04:56:29.302: OSPF: Rcv DBD from 172.16.4.4 on Serial1/0 seq 0x51 opt 0x52 flag 0x0 len 32  mtu 1500 state EXCHANGE

*Mar  1 04:56:29.306: OSPF: Exchange Done with 172.16.4.4 on Serial1/0

*Mar  1 04:56:29.310: OSPF: Rcv LS UPD from 172.16.4.4 on Serial1/0 length 76 LSA count 1

*Mar  1 04:56:29.314: OSPF: Synchronized with 172.16.4.4 on Serial1/0, state FULL

*Mar  1 04:56:29.314: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.4.4 on Serial1/0 from LOADING to FULL, Loading Done

*Mar  1 04:56:29.754: OSPF: Rcv LS UPD from 172.16.4.4 on Serial1/0 length 88 LSA count 1

*Mar  1 04:56:29.830: OSPF: OSPF: Rcv pkt from Serial1/0 src 172.31.0.8 dst 172.31.0.5 id 172.16.8.8 type 5 if_state 4 : ignored due to unknown neighbor

*Mar  1 04:56:30.850: OSPF: Build router LSA for area 0, router ID 172.16.5.5, seq 0x80000004, process 1

*Mar  1 04:56:33.694: OSPF: OSPF: Rcv pkt from Serial1/0 src 172.31.0.8 dst 172.31.0.5 id 172.16.8.8 type 2 if_state 4 : ignored due to unknown neighbor

*Mar  1 04:56:35.026: OSPF: 172.16.4.4 address 172.31.0.4 on Serial1/0 is dead, state DOWN

*Mar  1 04:56:35.030: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.4.4 on Serial1/0 from FULL to DOWN, Neighbor Down: Adjacency forced to reset

*Mar  1 04:56:35.034: OSPF: 2 Way Communication to 172.16.8.8 on Serial1/0, state 2WAY

*Mar  1 04:56:35.038: OSPF: Send DBD to 172.16.8.8 on Serial1/0 seq 0x2E5 opt 0x52 flag 0x7 len 32

*Mar  1 04:56:35.054: OSPF: OSPF: Rcv pkt from Serial1/0 src 172.31.0.4 dst 224.0.0.5 id 172.16.4.4 type 2 if_state 4 : ignored due to unknown neighbor

*Mar  1 04:56:35.166: OSPF: 172.16.8.8 address 172.31.0.8 on Serial1/0 is dead, state DOWN

*Mar  1 04:56:35.170: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.8.8 on Serial1/0 from EXSTART to DOWN, Neighbor Down: Adjacency forced to reset

*Mar  1 04:56:35.846: OSPF: Build router LSA for area 0, router ID 172.16.5.5, seq 0x80000005, process 1

*Mar  1 04:56:36.654: OSPF: 172.16.4.4 address 172.31.0.4 on Serial1/0 is dead, state DOWN

*Mar  1 04:56:36.658: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.4.4 on Serial1/0 from INIT to DOWN, Neighbor Down: Adjacency forced to reset

*Mar  1 04:56:36.662: OSPF: 2 Way Communication to 172.16.8.8 on Serial1/0, state 2WAY

*Mar  1 04:56:36.666: OSPF: Send DBD to 172.16.8.8 on Serial1/0 seq 0xBC6 opt 0x52 flag 0x7 len 32

*Mar  1 04:56:36.714: OSPF: OSPF: Rcv pkt from Serial1/0 src 172.31.0.4 dst 224.0.0.5 id 172.16.4.4 type 2 if_state 4 : ignored due to unknown neighbor

*Mar  1 04:56:36.722: OSPF: Rcv DBD from 172.16.8.8 on Serial1/0 seq 0x59D opt 0x52 flag 0x7 len 32  mtu 1500 state EXSTART

*Mar  1 04:56:36.726: OSPF: NBR Negotiation Done. We are the SLAVE

*Mar  1 04:56:36.730: OSPF: Send DBD to 172.16.8.8 on Serial1/0 seq 0x59D opt 0x52 flag 0x2 len 92

*Mar  1 04:56:36.742: OSPF: u OSPF: Rcv pkt from Serial1/0 src 172.31.0.4 dst 224.0.0.5 id 172.16.4.4 type 2 if_state 4 : ignored due to unknown neighbor

*Mar  1 04:56:36.858: OSPF: Rcv DBD from 172.16.8.8 on Serial1/0 seq 0x59E opt 0x52 flag 0x3 len 92  mtu 1500 state EXCHANGE

*Mar  1 04:56:36.862: OSPF: Send DBD to 172.16.8.8 on Serial1/0 seq 0x59E opt 0x52 flag 0x0 len 32

*Mar  1 04:56:36.874: OSPF: OSPF: Rcv pkt from Serial1/0 src 172.31.0.4 dst 224.0.0.5 id 172.16.4.4 type 2 if_state 4 : ignored due to unknown neighbor

*Mar  1 04:56:36.946: OSPF: Rcv DBD from 172.16.8.8 on Serial1/0 seq 0x59F opt 0x52 flag 0x1 len 32  mtu 1500 state EXCHANGE

*Mar  1 04:56:36.950: OSPF: Exchange Done with 172.16.8.8 on Serial1/0

*Mar  1 04:56:36.954: OSPF: Send LS REQ to 172.16.8.8 length 12 LSA count 1

*Mar  1 04:56:36.958: OSPF: Send DBD to 172.16.8.8 on Serial1/0 seq 0x59F opt 0x52 flag 0x0 len 32

*Mar  1 04:56:36.962: OSPF: Rcv LS REQ from 172.16.8.8 on Serial1/0 length 48 LSA count 2

*Mar  1 04:56:36.966: OSPF: u Send UPD to 172.31.0.8 on Serial1/0 length 112 LSA count 2

*Mar  1 04:56:37.022: OSPF: Rcv LS UPD from 172.16.8.8 on Serial1/0 length 76 LSA count 1

*Mar  1 04:56:37.026: OSPF: Synchronized with 172.16.8.8 on Serial1/0, state FULL

*Mar  1 04:56:37.026: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.8.8 on Serial1/0 from LOADING to FULL, Loading Done

*Mar  1 04:56:37.622: OSPF: Rcv LS UPD from 172.16.8.8 on Serial1/0 length 88 LSA count 1

*Mar  1 04:56:37.866: OSPF: 172.16.8.8 address 172.31.0.8 on Serial1/0 is dead, state DOWN

*Mar  1 04:56:37.870: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.8.8 on Serial1/0 from FULL to DOWN, Neighbor Down: Adjacency forced to reset

*Mar  1 04:56:37.874: OSPF: 2 Way Communication to 172.16.4.4 on Serial1/0, state 2WAY

*Mar  1 04:56:37.878: OSPF: Send DBD to 172.16.4.4 on Serial1/0 seq 0x1842 opt 0x52 flag 0x7 len 32

*Mar  1 04:56:37.990: OSPF: OSPF: Rcv pkt from Serial1/0 src 172.31.0.8 dst 172.31.0.5 id 172.16.8.8 type 2 if_state 4 : ignored due to unknowu n neighbor

*Mar  1 04:56:37.998: OSPF: Rcv DBD from 172.16.4.4 on Serial1/0 seq 0x1842 opt 0x52 flag 0x2 len 92  mtu 1500 state EXSTART

*Mar  1 04:56:38.002: OSPF: NBR Negotiation Done. We are the MASTER

*Mar  1 04:56:38.002: OSPF: Send DBD to 172.16.4.4 on Serial1/0 seq 0x1843 opt 0x52 flag 0x3 len 92

*Mar  1 04:56:38.170: OSPF: Rcv DBD from 172.16.4.4 on Serial1/0 seq 0x1843 opt 0x52 flag 0x0 len 32  mtu 1500 state EXCHANGE

*Mar  1 04:56:38.174: OSPF: Send DBD to 172.16.4.4 on Serial1/0 seq 0x1844 opt 0x52 flag 0x1 len 32

*Mar  1 04:56:38.178: OSPF: Send LS REQ to 172.16.4.4 length 12 LSA count 1

*Mar  1 04:56:38.270: OSPF: Rcv LS REQ from 172.16.4.4 on Serial1/0 length 48 LSA count 2

*Mar  1 04:56:38.274: OSPF: Send UPD to 172.31.0.4 on Serial1/0 length 112 LSA count 2

*Mar  1 04:56:38.374: OSPF: Rcv DBD from 172.16.4.4 on Serial1/0 seq 0x1844 opt 0x52 flag 0x0 len 32  mtu 1500 state EXCHANGE

*Mar  1 04:56:38.378: OSPF: Exchange Done with 172.16.4.4 on Serial1/0

*Mar  1

u 04:56:38.382: OSPF: Rcv LS UPD from 172.16.4.4 on Serial1/0 length 76 LSA count 1

*Mar  1 04:56:38.386: OSPF: Synchronized with 172.16.4.4 on Serial1/0, state FULL

*Mar  1 04:56:38.386: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.4.4 on Serial1/0 from LOADING to FULL, Loading Done

*Mar  1 04:56:39.642: OSPF: OSPF: Rcv pkt from Serial1/0 src 172.31.0.8 dst 172.31.0.5 id 172.16.8.8 type 5 if_state 4 : ignored due to unknown neighbor

*Mar  1 04:56:40.590: OSPF: Rcv LS UPD from 172.16.4.4 on Serial1/0 length 88 LSA count 1

u

*Mar  1 04:56:40.850: OSPF: Build router LSA for area 0, router ID 172.16.5.5, seq 0x80000006, process 1

u all

*Mar  1 04:56:42.850: OSPF: OSPF: Rcv pkt from Serial1/0 src 172.31.0.8 dst 172.31.0.5 id 172.16.8.8 type 2 if_state 4 : ignored due to unknown neighbor

*Mar  1 04:56:44.534: OSPF: 172.16.4.4 address 172.31.0.4 on Serial1/0 is dead, state DOWN

*Mar  1 04:56:44.538: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.4.4 on Serial1/0 from FULL to DOWN, Neighbor Down: Adjacency forced to reset

*Mar  1 04:56:44.542: OSPF: 2 Way Communication to 172.16.8.8 on Serial1/0, state 2WAY

*Mar  1 04:56:44.546: OSPF: Send DBD to 172.16.8.8 on Serial1/0 seq 0x75D opt 0x52 flag 0x7 len 32

*Mar  1 04:56:44.562: OSPF: OSPF: Rcv pkt from Serial1/0 src 172.31.0.4 dst 224.0.0.5 id 172.16.4.4 type 2 if_state 4 : ignored due to unknown neighbor

*Mar  1 04:56:44.650: OSPF: 172.16.8.8 address 172.31.0.8 on Serial1/0 is dead, state DOWN

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Rolf Fischer Sat, 08/17/2013 - 09:21
User Badges:
  • Blue, 1500 points or more

Spoke1#show ip ospf interface s1/0

Serial1/0 is up, line protocol is up

Internet Address 172.31.0.5/24, Area 0

Process ID 1, Router ID 172.16.5.5, Network Type POINT_TO_POINT, Cost: 64

Transmit Delay is 1 sec, State POINT_TO_POINT,

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

oob-resync timeout 40

Hello due in 00:00:00

Supports Link-local Signaling (LLS)

Index 2/2, flood queue length 0

Next 0x0(0)/0x0(0)

Last flood scan length is 1, maximum is 1

Last flood scan time is 0 msec, maximum is 0 msec

Neighbor Count is 1, Adjacent neighbor count is 1

Adjacent with neighbor 172.16.8.8

Suppress hello for 0 neighbor(s)

!

!

*Mar  1 00:06:55.395: OSPF: Rcv hello from 172.16.4.4 area 0 from Serial1/0 172.31.0.4

*Mar  1 00:06:55.399: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.8.8 on Serial1/0 from EXCHANGE to DOWN, Neighbor Down: Adjacency forced to reset

*Mar  1 00:06:55.403: OSPF: Immediate hellos sent on Serial1/0 limited by number non-full neighbors 1

Rolf Fischer Sat, 08/17/2013 - 11:06
User Badges:
  • Blue, 1500 points or more

I guess you added the spoke-to-spoke mapping in order to enable connectivity between 172.31.0.4 and 172.31.0.5?


So the first question is: Why can't they communicate directly with those addresses?


Spoke2#show ip interface brief s0/0

Interface                  IP-Address      OK? Method Status                Protocol

Serial0/0                  172.31.0.4      YES manual up                    up


Spoke2#show ip route 172.31.0.5

Routing entry for 172.31.0.0/24

Known via "connected", distance 0, metric 0 (connected, via interface)

Routing Descriptor Blocks:

* directly connected, via Serial0/0

Route metric is 0, traffic share count is 1


With an Ethernet interface we wouldn't have any problem here (ARP: Who is 172.31.0.5?), but with frame relay it's different. Frame relay doesn't assume transitive connectivity, so the Layer-2 solution would be to map the other spoke's IP to the hub's DLCI:

Spoke1(config-if)#frame-relay map ip 172.31.0.4 508

(This woudn't result in an undesired OSPF neighborship.)


However, OSPF also has a build-in solution: The network type Point-to-Multipoint injects a hostroute of it's IP address:


Spoke1(config-if)#do show ip ospf database router self-orig | i Link ID|Link Data

(Link ID) Network/subnet number: 172.31.0.0

(Link Data) Network Mask: 255.255.255.0

(Link ID) Network/subnet number: 172.16.5.0

(Link Data) Network Mask: 255.255.255.0


Spoke1(config-if)#ip ospf network point-to-multipoint


Spoke1(config-if)#do show ip ospf database router self-orig | i Link ID|Link Data

(Link ID) Network/subnet number: 172.31.0.5

(Link Data) Network Mask: 255.255.255.255

(Link ID) Network/subnet number: 172.16.5.0

(Link Data) Network Mask: 255.255.255.0


This changes the other spoke's routing-table:

Spoke2#show ip route 172.31.0.5

Routing entry for 172.31.0.5/32

Known via "ospf 1", distance 110, metric 128, type intra area

Last update from 172.31.0.8 on Serial0/0, 00:00:12 ago

Routing Descriptor Blocks:

* 172.31.0.8, from 172.16.5.5, 00:00:12 ago, via Serial0/0

Route metric is 128, traffic share count is 1

The host route is more precise than the connected network and now we have a reachable next hop.


The OSPF Point-to-Point network type doesn't inject host routes for reachability because there is no need for that on a P-2-P link.

If you really need reachability between the spoke IPs, you could configure static hostroutes or just add the frame-relay mappings to the hub as descirbed above.



Hope that helps

Rolf

Rolf Fischer Sat, 08/17/2013 - 08:56
User Badges:
  • Blue, 1500 points or more

Hi,


P2P and P2MP are compatible when you adjust the timers (as you did) and they are often combined in Hub-and-Spoke topologies because P2P doesn't inject a hostroute for it's IP address of the common link (but this leads to a connecitity problem with the spoke's IP addresses, maybe you wanted to solve that by the spoke-to-spoke DLCI?).


The problem with your scenario is that your Frame-Relay config rather looks like a full mesh than a hub-and-spoke topology:


Spoke -1 Router

-----------

interface Serial1/0

ip address 172.31.0.5 255.255.255.0

frame-relay map ip 172.31.0.4 504 broadcast

frame-relay map ip 172.31.0.8 508 broadcast


Spoke -2 router

------------------------

interface Serial1/0

ip address 172.31.0.4 255.255.255.0

frame-relay map ip 172.31.0.5 405 broadcast

frame-relay map ip 172.31.0.8 408 broadcast


The Spokes seem to have Layer-2 connectivity but the OSPF network type is point-to-point.

This network type expects by definition exactly one neighbor but in your scenario the Spokes will receive OSPF hellos from two different neighbors on the same link.

So eihter change the layer-2 topology into hub-and-spoke or use a multiaccess network type.


Hope that helps

Rolf

dilnaazhum Mon, 08/19/2013 - 22:54
User Badges:

Thanks Rolf,


Yeh exactly, i was misconfigured to to have direct neighborship with Spokes with Point to point & neighborship with hub as Point to multipoint to know the reason of why OSPF adjacency flap. Your answer may be correct:


" The Spokes seem to have Layer-2 connectivity but the OSPF network type is point-to-point.

This  network type expects by definition exactly one neighbor but in your  scenario the Spokes will receive OSPF hellos from two different  neighbors on the same link. So eihter change the layer-2 topology into hub-and-spoke or use a multiaccess network type. "


Regards


Afeez

Rolf Fischer Tue, 08/20/2013 - 00:03
User Badges:
  • Blue, 1500 points or more

Afeez,


you're welcome.

Feel free to ask further if something still appears vague.


Regars

Rolf

dilnaazhum Tue, 08/27/2013 - 00:45
User Badges:

Hi Rolf,


I have one more Question to you..


As i studied in books.. ASB-Summary LSA will not be  generate in  its own area, but while doing some practice i have found one  more  observation:


ASB Summary LSA will not be generate if it has only one  Area, but it will genrate ASB-Summary LSA if it has more than one  area...


Below is the scenario log: and can u help me out why ASB-Summary LSA is generated with some document


Log

---------

Connectivity between two router with 2 links belongs to saperate OSPF area.

-----------------------------------------------------------------------------------

18-CAP-1#sh ip int brief | incl up

FastEthernet0/0            192.168.68.8    YES NVRAM  up                    up     

FastEthernet0/1            192.168.86.8    YES NVRAM  up                    up     

Loopback0                  172.16.8.8      YES NVRAM  up                    up     

18-CAP-1#sh run | sec ospf

router ospf 1

network 192.168.68.0 0.0.0.255 area 2

network 192.168.86.0 0.0.0.255 area 22

alias exec cop clear ip ospf process



16-CAP-1#sh ip int brief | incl up

FastEthernet0/0            192.168.68.6    YES NVRAM  up                    up     

FastEthernet0/1            192.168.86.6    YES NVRAM  up                    up     

Loopback0                  172.16.6.6      YES manual up                    up     

Loopback16                 16.16.16.16     YES manual up                    up     

16-CAP-1#sh run | sec ospf

router ospf 1

log-adjacency-changes

redistribute connected subnets route-map OSPF-RED

network 192.168.68.0 0.0.0.255 area 2

network 192.168.86.0 0.0.0.255 area 22


16-CAP-1#sh route-map OSPF-RED

route-map OSPF-RED, permit, sequence 10

  Match clauses:

    interface Loopback16


16-CAP-1#sh ip ospf neighbor


Neighbor ID     Pri   State           Dead Time   Address         Interface

172.16.8.8        1   FULL/BDR        00:00:31    192.168.68.8    FastEthernet0/0

172.16.8.8        1   FULL/DR         00:00:32    192.168.86.8    FastEthernet0/1



16-CAP-1#sh ip ospf database asbr-summary


            OSPF Router with ID (172.16.6.6) (Process ID 1)


        Summary ASB Link States (Area 2)


  LS age: 114

  Options: (No TOS-capability, DC, Upward)

  LS Type: Summary Links(AS Boundary Router)

  Link State ID: 172.16.6.6 (AS Boundary Router address)

  Advertising Router: 172.16.8.8

  LS Seq Number: 80000001

  Checksum: 0x861F

  Length: 28

  Network Mask: /0

    TOS: 0     Metric: 1



        Summary ASB Link States (Area 22)


  LS age: 144

  Options: (No TOS-capability, DC, Upward)

  LS Type: Summary Links(AS Boundary Router)

  Link State ID: 172.16.6.6 (AS Boundary Router address)

  Advertising Router: 172.16.8.8

  LS Seq Number: 80000001

  Checksum: 0x861F

  Length: 28

  Network Mask: /0

    TOS: 0     Metric: 1



Connectivity between two router with 1/2 link belongs to same OSPF area.

-------------------------------------------------------------------------------------------


18-CAP-1#sh ip int brief | incl up

FastEthernet0/0            192.168.68.8    YES NVRAM  up                    up     

Serial1/2                  192.168.48.8    YES NVRAM  up                    up     

Loopback0                  172.16.8.8      YES NVRAM  up                    up 


16-CAP-1#sh ip int brief | incl up

FastEthernet0/0            192.168.68.6    YES NVRAM  up                    up     

Loopback0                  172.16.6.6      YES manual up                    up     

Loopback16                 16.16.16.16     YES manual up                    up     

16-CAP-1#sh ip ospf ne


Neighbor ID     Pri   State           Dead Time   Address         Interface

172.16.8.8        1   FULL/BDR        00:00:31    192.168.68.8    FastEthernet0/0

16-CAP-1#sh ip ospf databa as


            OSPF Router with ID (172.16.6.6) (Process ID 1)

Rolf Fischer Tue, 08/27/2013 - 04:33
User Badges:
  • Blue, 1500 points or more

Hi Afeez,


I'd like to start with some concepts of the OSPF hierarchy:


Within an OSPF Area the LSDBs of all routers have to be identical, so summarization or filtering is not possible.

Between areas we have distance vector mechanisms, so the scope of the SPF algorithm ends at area borders. The routing-table entries installed by Type-1/Type-2 LSAs in one Area are translated to Type-3 (Network Summary) by the ABR (area border router) and re-injected automatically into the other Area(s). Here, on the ABR, we can also filter or summarize those Type-3 LSAs manually.


In contrast, external routes are injected with the redistribute command and the role of such routers is called ASBR (autonomous system boundary router). This Type-5 external LSAs are flooded AS-wide (with the exception of stub-areas, where they are replaced by default-routes) and we cannot filter or summarize them at area borders. For the reachability to the ASBR, another type of LSA is generated by the ABRs: A Type-4 Summary AS-boundary LSA.


Both, Type-3 and Type-4 are called summary LSAs, and I think you just mixed them up. The show ip ospf database command provides the options summary (Type-3) and asbr-summary (Type-4).


Does that help?

Regards,

Rolf



Added:

(RFC 2328)


LS Type   LSA description

____________________________


3 or 4    These are the summary-LSAs.

They describe inter-area routes,

and enable the condensation of

routing information at area

borders. Originated by area border

routers, the Type 3 summary-LSAs

describe routes to networks while the

Type 4 summary-LSAs describe routes to

AS boundary routers.

Rolf Fischer Tue, 08/27/2013 - 05:37
User Badges:
  • Blue, 1500 points or more

One more thing:

router ospf 1

  network 192.168.68.0 0.0.0.255 area 2

  network 192.168.86.0 0.0.0.255 area 22


By definition, an ABR needs to have at least one interface in the backbone area (0).

Actions

This Discussion