×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

C2651 Unknown Protocol Drops

Unanswered Question
Aug 17th, 2013
User Badges:

Please help and advise. I am unable to connect any device on both my fa0/0 and fa0/1. Is it a hardware failure?


FastEthernet0/0 is up, line protocol is up

  Hardware is AmdFE, address is 0013.7f8e.3660 (bia 0013.7f8e.3660)

  Internet address is 192.168.1.1/24

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, 100BaseTX/FX

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:02, output 00:00:02, output hang never

  Last clearing of "show interface" counters 00:44:24

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     2112 packets input, 429469 bytes

     Received 2112 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog

     0 input packets with dribble condition detected

     315 packets output, 32310 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     2105 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ldengming Sat, 08/17/2013 - 11:45
User Badges:

My packets are entirely dropped including ICMP Echo and ARP not just DTP, CDP packets.

     6142 packets input, 1255543 bytes

     Received 6142 broadcasts, 0 runts, 0 giants, 0 throttles

     6124 unknown protocol drops


I  directly connected a laptop to the port and ping but the pings were dropped as well.

Reza Sharifi Sat, 08/17/2013 - 14:20
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

Can you post "sh run" from the router?

ldengming Sat, 08/17/2013 - 19:18
User Badges:

Thanks Reza. For your reference


Current configuration : 1216 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname

!

boot-start-marker

boot-end-marker

!

enable secret 5

enable password

!

no aaa new-model

memory-size iomem 30

clock save interval 8

no network-clock-participate slot 1

no network-clock-participate wic 0

ip cef

!

!

!

!

no ip domain lookup

!

multilink bundle-name authenticated

!

!

!

!

!

archive

log config

  hidekeys

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 10.0.1.3 255.255.255.0

duplex auto

speed auto

no mop enabled

!

interface Serial0/0

no ip address

shutdown

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

!

!

!

!

!

!

control-plane

!

!

!

line con 0

exec-timeout 0 0

password

logging synchronous

login

speed 115200

line aux 0

line vty 0 4

exec-timeout 0 0

password

logging synchronous

login

line vty 5 15

exec-timeout 0 0

password

logging synchronous

login

!

!

end

Reza Sharifi Sat, 08/17/2013 - 19:27
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

On your first post you have:


Internet address is 192.168.1.1/24


On your last post you have:


interface FastEthernet0/0

ip address 10.0.1.3 255.255.255.0

are these both from the same router?

If yes, try this command

interface FastEthernet0/0

mop enabled

and test again

HTH

ldengming Wed, 08/21/2013 - 17:31
User Badges:

Thanks but I found an anomaly that suggests its a main board issues.


I debug arp and saw the ping address alway show incomplete. I used wireshark to capture the ping packet and found 2 of the bits always set as 1.


For broadcast to 0000.0000.0000, the packet destination is 0002.0000.0002. I tried to key in static arp entry and observed the following:


For mac target 4F6D became 4F6F but 4F6B is correctly transmitted. I think the 2nd least significant bit of the 4th hex value is always 1.


Likewise if mac end with A, its transmitted correctly but 0 changes to 2 and 9 become B. Hence, the 2nd bit in the last hex is again always 1.


Unfortunately I think my router is defective. Repair is probably not worth it.

Actions

This Discussion