×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Catalyst and SG300-52 - Native VLAN mismatch detected

Unanswered Question
Aug 23rd, 2013
User Badges:

Dear all,

I have 3 switch:

     1 core is C3750x-24 ports
     1 access is C2960s-24 ports
     1 access is SG300-52 ports


I have 1 question about NATIVE VLAN configuaration on trunk port between Catalyst 3750x-24 and SG300-52:

I config Native VLAN 999 in all of switch but only SG300 say this message:



03-May-2013 03:53:59 %CDP-W-NATIVE_VLAN_MISMATCH: Native VLAN mismatch det

ected on interface gi52.

03-May-2013 03:54:01 %CDP-W-NATIVE_VLAN_MISMATCH: Native VLAN mismatch detected

on interface gi51.


How to fix it?


Below is my configuration in Port-Channel in all of switch:


The configuaration of Port-Channel 1 (Gi1/0/11-12) in C3750x, this is connect to C2960s

Core3750x#show interfaces po1 switchport
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 999 (Trap)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: 10,20,30,40,50,60,70,80,99
Pruning VLANs Enabled: 2-1001

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none
Core3750x#

************************************
The configuaration of Port-Channel 2 (Gi1/0/13-14) in C3750x, this is connect to SG300

Core3750x#show interfaces po2 switchport
Name: Po2
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 999 (Trap)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: 10,20,30,40,50,60,70,80,99
Pruning VLANs Enabled: 2-1001

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none
Core3750x#

************************************
The configuaration of Port-Channel 1 (Gi1/0/47-48) in C2960s, this connect to C3750x

C2960s#show interfaces po1 switchport
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 999 (Trap)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: 10,20,30,40,50,60,70,80,99
Pruning VLANs Enabled: 2-1001

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none
C2960s#

************************************
The configuaration of Port-Channel 2 (Gi51-52) in SG300, this connect to C3750x

SG300#show interfaces switchport po2
Port : Po2
Port Mode: Trunk
Gvrp Status: enabled
Ingress Filtering: true
Acceptable Frame Type: admitAll
Ingress UnTagged VLAN ( NATIVE ): 999

Port is member in:

Vlan               Name               Egress rule Port Membership Type
---- -------------------------------- ----------- --------------------
10                 10                  Tagged           Static
20                 20                  Tagged           Static
30                 30                  Tagged           Static
40                 40                  Tagged           Static
50                 50                  Tagged           Static
60                 60                  Tagged           Static
70                 70                  Tagged           Static
80                 80                  Tagged           Static
99                 99                  Tagged           Static
999                999                 Untagged          Static


Forbidden VLANS:
Vlan               Name
---- --------------------------------


Classification rules:

Mac based VLANs:
  Group ID   Vlan ID
------------ -------

SG300#

************************************
Then CDP message on SG300 is:


SG300#03-May-2013 03:53:59 %CDP-W-NATIVE_VLAN_MISMATCH: Native VLAN mismatch det
ected on interface gi52.
03-May-2013 03:54:01 %CDP-W-NATIVE_VLAN_MISMATCH: Native VLAN mismatch detected
on interface gi51.


Best regards,

Truoc

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Tom Watts Sat, 08/24/2013 - 07:10
User Badges:
  • Green, 3000 points or more

Hi Truoc, can you provide the show run for the ports of the catalysts? Native vlan mismatch means the untagged members don't match up and the Catalyst behaves differently than the sx300.



-Tom
Please mark answered for helpful posts

truocphamvan Sat, 08/24/2013 - 17:54
User Badges:

Dear Mr. Tom,

Thank you for your answer!


This is the running ports:

This PO1 connect to C2960s

!

interface Port-channel1

description Connect To MO01

switchport trunk encapsulation dot1q

switchport trunk native vlan 999

switchport trunk allowed vlan 10,20,30,40,50,60,70,80,99

switchport mode trunk

switchport nonegotiate

storm-control broadcast level 10.00


This PO2 connect to SG300

!

interface Port-channel2

description Connect To MO02

switchport trunk encapsulation dot1q

switchport trunk native vlan 999

switchport trunk allowed vlan 10,20,30,40,50,60,70,80,99

switchport mode trunk

switchport nonegotiate

storm-control broadcast level 10.00


This is 2 ports connect to C2960s

!

interface GigabitEthernet1/0/11

switchport trunk encapsulation dot1q

switchport trunk native vlan 999

switchport trunk allowed vlan 10,20,30,40,50,60,70,80,99

switchport mode trunk

switchport nonegotiate

storm-control broadcast level 10.00

channel-group 1 mode active

!

interface GigabitEthernet1/0/12

switchport trunk encapsulation dot1q

switchport trunk native vlan 999

switchport trunk allowed vlan 10,20,30,40,50,60,70,80,99

switchport mode trunk

switchport nonegotiate

storm-control broadcast level 10.00

channel-group 1 mode active


This is 2 ports connect to SG300

!

interface GigabitEthernet1/0/13

switchport trunk encapsulation dot1q

switchport trunk native vlan 999

switchport trunk allowed vlan 10,20,30,40,50,60,70,80,99

switchport mode trunk

switchport nonegotiate

storm-control broadcast level 10.00

channel-group 2 mode active

!

interface GigabitEthernet1/0/14

switchport trunk encapsulation dot1q

switchport trunk native vlan 999

switchport trunk allowed vlan 10,20,30,40,50,60,70,80,99

switchport mode trunk

switchport nonegotiate

storm-control broadcast level 10.00

channel-group 2 mode active

!


Best regards,

Truoc

Tom Watts Sun, 08/25/2013 - 05:45
User Badges:
  • Green, 3000 points or more

Hi Truoc, can you show the cdp neighbor detail from each switch (catalyst and smb)?



-Tom
Please mark answered for helpful posts

truocphamvan Sun, 08/25/2013 - 07:48
User Badges:

Dear Mr. Tom,

Actually I have 1 Catalyst 3750x-24, 1 Catalyst 2960s-48, 4 Cisco SG300-52 and some Linksys Cisco SRW2024.

Then I show 2 CDP neighbor on 2 swith to you, can you view this detail and help me how to fix my issue.

I saw the detail in Catalyst say Native VLAN in my SG300 is #1 but I already switch port-channel in SW300 to Native VLAN999!

Then now I can't switch manual port member channel to Native VLAN 999, the message as below:


MO02(config)#int gi49
MO02(config-if)#switchport trunk native vlan 999
Port gi49 belongs to a port-channel


Thank you so much!

Truoc.


Here is detail of CDP:

Catalyst C3750x

Core3750x#show cdp neighbors detail
-------------------------
Device ID: 70105c122f75
Entry address(es):
  IP address: 172.16.16.19
Platform: Cisco SG300-52 (PID:SRW2048-K9)-VSD,  Capabilities: Switch IGMP
Interface: GigabitEthernet1/0/22,  Port ID (outgoing port): gi50
Holdtime : 170 sec

Version :
1.3.0.62

advertisement version: 2
Native VLAN: 1
Duplex: full
Power Available TLV:

    Power request id: 0, Power management id: 19500, Power available: 0, Power m
anagement level: -1
Management address(es):

-------------------------
Device ID: 70105c122f75
Entry address(es):
  IP address: 172.16.16.19
Platform: Cisco SG300-52 (PID:SRW2048-K9)-VSD,  Capabilities: Switch IGMP
Interface: GigabitEthernet1/0/21,  Port ID (outgoing port): gi49
Holdtime : 170 sec

Version :
1.3.0.62

advertisement version: 2
Native VLAN: 1
Duplex: full
Power Available TLV:

    Power request id: 0, Power management id: 8397, Power available: 0, Power ma
nagement level: -1
Management address(es):

-------------------------
Device ID: C2960s
Entry address(es):
  IP address: 172.16.16.11
  IP address: 172.16.16.11
Platform: cisco WS-C2960S-48TS-L,  Capabilities: Switch IGMP
Interface: GigabitEthernet1/0/11,  Port ID (outgoing port): GigabitEthernet1/0/4
8
Holdtime : 129 sec

Version :
Cisco IOS Software, C2960S Software (C2960S-UNIVERSALK9-M), Version 15.0(2)SE4,
RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2013 by Cisco Systems, Inc.
Compiled Wed 26-Jun-13 02:59 by prod_rel_team

advertisement version: 2
Protocol Hello:  OUI=0x00000C, Protocol ID=0x0112; payload len=27, value=0AA7278
0000000000102270170105CA7278070105CA72780000000
VTP Management Domain: 'tmi.com'
Native VLAN: 999
Duplex: full
Power Available TLV:

    Power request id: 0, Power management id: 1, Power available: 0, Power manag
ement level: -1
Management address(es):
  IP address: 172.16.16.11
  IP address: 172.16.16.11

-------------------------
Device ID: C2960s
Entry address(es):
  IP address: 172.16.16.11
  IP address: 172.16.16.11
Platform: cisco WS-C2960S-48TS-L,  Capabilities: Switch IGMP
Interface: GigabitEthernet1/0/12,  Port ID (outgoing port): GigabitEthernet1/0/4
7
Holdtime : 129 sec

Version :
Cisco IOS Software, C2960S Software (C2960S-UNIVERSALK9-M), Version 15.0(2)SE4,
RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2013 by Cisco Systems, Inc.
Compiled Wed 26-Jun-13 02:59 by prod_rel_team

advertisement version: 2
Protocol Hello:  OUI=0x00000C, Protocol ID=0x0112; payload len=27, value=0AA7278
0000000000102270170105CA7278070105CA72780000000
VTP Management Domain: 'tmi.com'
Native VLAN: 999
Duplex: full
Power Available TLV:

    Power request id: 0, Power management id: 1, Power available: 0, Power manag
ement level: -1
Management address(es):
  IP address: 172.16.16.11
  IP address: 172.16.16.11

-------------------------
Device ID: 54781ae8dcf3
Entry address(es):
  IP address: 172.16.16.12
Platform: Cisco SG300-52 (PID:SRW2048-K9)-VSD,  Capabilities: Switch IGMP
Interface: GigabitEthernet1/0/13,  Port ID (outgoing port): gi49
Holdtime : 122 sec

Version :
1.3.0.62

advertisement version: 2
Native VLAN: 1
Duplex: full
Power Available TLV:

    Power request id: 0, Power management id: 14202, Power available: 0, Power m
anagement level: -1
Management address(es):

-------------------------
Device ID: 54781ae8dcf3
Entry address(es):
  IP address: 172.16.16.12
Platform: Cisco SG300-52 (PID:SRW2048-K9)-VSD,  Capabilities: Switch IGMP
Interface: GigabitEthernet1/0/14,  Port ID (outgoing port): gi50
Holdtime : 122 sec

Version :
1.3.0.62

advertisement version: 2
Native VLAN: 1
Duplex: full
Power Available TLV:

    Power request id: 0, Power management id: 531, Power available: 0, Power man
agement level: -1
Management address(es):

-------------------------
Device ID: 70105c121f1a
Entry address(es):
  IP address: 172.16.16.15
Platform: Cisco SG300-52 (PID:SRW2048-K9)-VSD,  Capabilities: Switch IGMP
Interface: GigabitEthernet1/0/18,  Port ID (outgoing port): gi51
Holdtime : 179 sec

Version :
1.3.0.62

advertisement version: 2
Native VLAN: 1
Duplex: full
Power Available TLV:

    Power request id: 0, Power management id: 32174, Power available: 0, Power m
anagement level: -1
Management address(es):

-------------------------
Device ID: 70105c121f1a
Entry address(es):
  IP address: 172.16.16.15
Platform: Cisco SG300-52 (PID:SRW2048-K9)-VSD,  Capabilities: Switch IGMP
Interface: GigabitEthernet1/0/17,  Port ID (outgoing port): gi52
Holdtime : 179 sec

Version :
1.3.0.62

advertisement version: 2
Native VLAN: 1
Duplex: full
Power Available TLV:

    Power request id: 0, Power management id: 14080, Power available: 0, Power m
anagement level: -1
Management address(es):

-------------------------
Device ID: 70105c1218af
Entry address(es):
  IP address: 172.16.16.17
Platform: Cisco SG300-52 (PID:SRW2048-K9)-VSD,  Capabilities: Switch IGMP
Interface: GigabitEthernet1/0/20,  Port ID (outgoing port): gi50
Holdtime : 127 sec

Version :
1.2.9.44

advertisement version: 2
Native VLAN: 1
Duplex: full
Power Available TLV:

    Power request id: 0, Power management id: 8954, Power available: 0, Power ma
nagement level: -1
Management address(es):

-------------------------
Device ID: 70105c1218af
Entry address(es):
  IP address: 172.16.16.17
Platform: Cisco SG300-52 (PID:SRW2048-K9)-VSD,  Capabilities: Switch IGMP
Interface: GigabitEthernet1/0/19,  Port ID (outgoing port): gi49
Holdtime : 127 sec

Version :
1.2.9.44

advertisement version: 2
Native VLAN: 1
Duplex: full
Power Available TLV:

    Power request id: 0, Power management id: 22873, Power available: 0, Power m
anagement level: -1
Management address(es):

Core3750x#


****************************

Cisco SG300:

MO02#show cdp neighbors detail
---------------------------------------------
Device-ID: Core3750x
Advertisement version: 2
Platform: cisco WS-C3750X-24
Capabilities: Router Switch IGMP
Interface: gi49, Port ID (outgoing port): GigabitEthernet1/0/13
Holdtime: 138
Version: Cisco IOS Software, C3750E Software (C3750E-UNIVERSALK9-M), Version 15.
0(2)SE4, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Cop
Duplex: full
Native VLAN: 999
SysObjectID: 0.0
VTP Management Domain: tmi.com
Primary Management Address: IP 192.168.0.1,
Secondary Management Address: IP 192.168.0.1,
Addresses:
          IP 192.168.0.1
          IP 192.168.0.1
---------------------------------------------
Device-ID: Core3750x
Advertisement version: 2
Platform: cisco WS-C3750X-24
Capabilities: Router Switch IGMP
Interface: gi50, Port ID (outgoing port): GigabitEthernet1/0/14
Holdtime: 138
Version: Cisco IOS Software, C3750E Software (C3750E-UNIVERSALK9-M), Version 15.
0(2)SE4, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Cop
Duplex: full
Native VLAN: 999
SysObjectID: 0.0
VTP Management Domain: tmi.com
Primary Management Address: IP 192.168.0.1,
Secondary Management Address: IP 192.168.0.1,
Addresses:
          IP 192.168.0.1
          IP 192.168.0.1
MO02#

Tom Watts Sun, 08/25/2013 - 11:33
User Badges:
  • Green, 3000 points or more

Hi Truoc, so it is the problem, your smb switch native vlan is 1 when it should be 999. How to fix it would be to delete the link aggregation on the smb switch then recreate it. Before making other commands for vlans you need to use the command


switchport mode trunk

switchport trunk native vlan 999


then you may do your additional vlans


switchport trunk allowed vlan add .... .... .... ....


When you create a LAG on the smb switch it cannot be a member of any vlan so it will default to vlan 1 which is where your untag packet resides. So once the lag has been created you need to modify the default vlan first then tag your packets.


Also if you don't want to delete the lag I believe you can remove all vlans off the lag then modify the default vlan

switchport trunk allowed vlan remove ....


-Tom
Please mark answered for helpful posts

truocphamvan Mon, 08/26/2013 - 03:08
User Badges:

Dear Mr. Tom,

I try to do as your guide for step by step but still can't.

1. If I setup 1 port to native vlan 999, is it work. I saw PVID in web config of this port displayed 999

2. If I setup LAG to native vlan 999 after that I setup 2 port to LAG, I saw the PVID in web config is: LAG have PVID 999, port have PVID 1. Still have same CDP message.


Now, I try to setup default vlan to 999 and reboot the switch, all is work. No CDP message showing...


So I don't know this setup good or not?! Please advise!


Thank and best regards,

Truoc

Tom Watts Mon, 08/26/2013 - 17:34
User Badges:
  • Green, 3000 points or more

Hi Truoc, the default vlan should not make any difference.


Here is how I configured my switch-


config t

vlan database

vlan 999

int fa01

channel-group 1 mode on

int fa02

channel-group 1 mode on

int po1

switchport trunk native vlan 999

end

wr mem



This makes my etherchannel vlan 999 untagged without error.



-Tom
Please mark answered for helpful posts

truocphamvan Tue, 08/27/2013 - 02:15
User Badges:

Dear Mr. Tom,


I reset my SG300 to default and do the setting same as your config, result is: po1 untagged vlan 999 but interface gi1 and gi2 still untagged vlan 1.


Best regards,

Truoc

amatczynski Fri, 05/30/2014 - 02:12
User Badges:

I have the same situation, but all vlan is the same. Could you help me?

switch42f189#show interfaces switchport ge52
Port : gi52
Port Mode: Trunk
Gvrp Status: disabled
Ingress Filtering: true
Acceptable Frame Type: admitAll
Ingress UnTagged VLAN ( NATIVE ): 1

Port is member in:

Vlan               Name               Egress rule Port Membership Type
---- -------------------------------- ----------- --------------------
 1                  1                  Untagged          Static
 2               Name 2                 Tagged           Static
 40              Name 3                 Tagged           Static
 50              Name 3                 Tagged           Static
 51              Name 4                 Tagged           Static
 52              Name 5                 Tagged           Static
 53              Name 6                 Tagged           Static
 54              Name 7                 Tagged           Static

 

Forbidden VLANS:
Vlan               Name
---- --------------------------------


Classification rules:
switch42f189#12-Jan-2014 18:24:35 %CDP-W-NATIVE_VLAN_MISMATCH: Native VLAN mismatch detected on interface gi52.

 

kevinmelka1 Fri, 08/21/2015 - 07:50
User Badges:

Everybody find a solution to this problem ?

In fact, i have the same problem.

ahoendervanger Thu, 08/04/2016 - 05:29
User Badges:

anyone found a solution? have a similar problem but on a sg350 -> 3750

Actions

This Discussion

Related Content