×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

mx200 - no upgrade works from tc4.2 on

Unanswered Question
Aug 26th, 2013
User Badges:

Hi.

I have trouble updateing a MX200 unit that is currently on tc 4.2.0. Anything higher (tried it with 4.2.4 and 5) gives me this kind of info in the log


[     0] [*             ] Obtaining lock

[     1] [**            ] Determining base directory

[     2] [***           ] Determining install directory

[     2] [****          ] Running early product-specific tasks

[     8] [*****         ] Cleaning install directory

[     9] [******        ] Extracting software

[   105] [*******       ] Verifying data integrity

[   105] [********      ] Copying user data

[   109] [*********     ] Copying release key file

[   109] [**********    ] Running product-specific tasks

Copy packet to endeavour

Waiting for ACK from endeavour

Endeavour reply: NACK

/share/installimage/hooks.d/installimage-endeavour failed to run!


Is there a decent way to find out why it fails really?

Thanks for a hint.

Regards

Danny

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Dharmesh Nandoria Mon, 08/26/2013 - 06:45
User Badges:
  • Cisco Employee,

Hi Danny,


This issue is related to CSCud92375.


If you have any spare touch panle then connect it to MX 300 and try to upgrade . If issue is resolved then it confirms we are hitting same bug .



https://tools.cisco.com/bugsearch/bug/CSCud92375/?referring_site=ss

=======


Installimage-endeavour failed to run!


CSCud92375



Symptom: During upgrading you will see  this error message in the console log .
[     0] [**            ] Determining base directory
[     0] [***           ] Determining install directory
[     0] [****          ] Running early product-specific tasks
[     7] [*****         ] Cleaning install directory
[     8] [******        ] Extracting software
[    65] [*******       ] Verifying data integrity
[    65] [********      ] Copying user data
[    67] [*********     ] Copying release key file
[    67] [**********    ] Running product-specific tasks
/share/installimage/hooks.d/installimage-endeavour failed to run!
Conditions: The reason this message jump up , is that thesoftware isn't supported to the connected touch device
Workaround: During this time RMA the touch device.


=============


hth.


Kind regards,

Dharmmesh

Danny Meyer Mon, 08/26/2013 - 06:58
User Badges:

Hi.


Thanks for your reply.

Unfortunately, I have no spare touch and this unit is in one of my remote places.

So you think it relates to a touch firmware issue?


Regards

Danny 


Barry Woods Mon, 08/26/2013 - 11:33
User Badges:

Is your MTU size set below 1500? Upgrades to several of my units in remote offices failed, where we use smaller MTU sizes to optmize the video experience (upgrades elsewhere were fine). When I moved the MTU back to 1500, the upgrades worked.

Danny Meyer Tue, 08/27/2013 - 07:13
User Badges:

Barry.

Interesting point, thanks for this.

No, I checked it and it works with 1492, so no fragmentation etc. I have the impression it is a touch hardware/firmware issue. Hope to get a hint how to fix this without RMA.


Cheers

Danny

Martin Koch Tue, 08/27/2013 - 09:32
User Badges:
  • Red, 2250 points or more

At your own risk, I can not guarantee that this would not break something:


I never deeper debugged a MX system, but can you simply

* factory reset the touchpanel,

* turn of the endpoint

* disconnect the touchpanel

* turn on the endpoint,

* try the upgrade without the touchpanel being connected

* power off the endpoint

* connect the touch panel again

* and power it on again.


and see if it upgrades / pairs again.


That's at least what I would try, but sure, you can also make it worse if the touchpanel did not

like that, but ... that would also be a RMA, ... :-)


Also as Cisco TAC themselfs say, no workaround besides RMA the touchpanel, there might be a high

chance that there is no workaround besides RMA the touchpanel.


If there is not service contract, try to get one, or ask your Cisco partner / Cisco contacts, especially if the system is

recently purchased as it seems to be a bug which you hit.


Sure I do not know where your endpoint is located and how hard it is to handle the RMA, but the longer you wait

it could have already been fixed by the RMA ;-)



Please remember to rate helpful responses and identify helpful or correct answers.

Actions

This Discussion

Related Content