×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Mix of RIP Ver 1 and Ver 2 in network

Answered Question
Aug 29th, 2013
User Badges:

Hi ,


i have two routers connected back to back as below


Router  1(loopback 1.1.1.1) --------------- Router 5  (loopback 5.5.5.5)


Now router has rip ver 1 enabled and router 5 has rip ver 2 enabled


My understanding was eventhough rip ver 1 can recieve ver 2 updates still communication wont happen between Router 1 and Router 5  because rip ver 1 is not capable of sending ver 2 updates


But i am able to ping from Router 1 to Router 5 loopback i.e 5.5.5.5



Router 1

-------------


R1#sh ip route rip

     5.0.0.0/32 is subnetted, 1 subnets

R       5.5.5.5 [120/1] via 15.0.0.5, 00:00:07, Serial0/1

     25.0.0.0/24 is subnetted, 1 subnets

R       25.0.0.0 [120/1] via 15.0.0.5, 00:00:07, Serial0/1


Router 5

------------


R5#sh ip route rip


(No routes learned)


Also when i check Router 5 routing table it is blank .... so i cant understand eventhoug Router 5's routing table is empty still how is Router 1 getting 5.5.5.5 entry



config's which i did

------------ ---------------


Router 1

-------------


router rip

network 1.0.0.0

network 12.0.0.0

network 13.0.0.0

network 15.0.0.0

no auto-summary


Router 5

-------------



router rip

version 2

network 5.0.0.0

network 15.0.0.0

network 25.0.0.0

network 192.0.0.0

no auto-summary



Even if i consider that Router 1 (enabled with ver 1) can learn 5.5.5.5 because it can learn ver 2 updates and Router 5 (enabled with ver 2) can't learn 1.1.1.1 because it cannot learn ver 1 updates , but as a basic rule since routing table of Router 5 is totally empty ....how come Router 1 is still getting 5.5.5.5


Ping response

---------------------

R1#ping 5.5.5.5



Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/23/36 ms

R1#



Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

R5#

Correct Answer by John Blakley about 3 years 11 months ago

RIP, by default, sends version 1 out of the interface and receives 1 and 2 updates. In this case, if you have version 1 on one router (sending/receiving v1 updates) and version 2 on another router (sending/receiving v2 updates), they cannot communicate because you're specifically configuring the router to send and receive only that version.


For example, if you have version 2 specified on one router, it expects to receive the updates in a version 2 format. On the other router, if you have the default specified, it sends version 1 out of the interface and receives 1 and 2 on the interface. This is why you're receiving the routes on your one router, but you're not seeing them on the other. You can change this behavior per interface with "ip rip send version " or "ip rip receive version ". So, you could receive 1 and send 2 if you needed. Without this stipulation on the interface though, the default is to send version 1 and receive both versions.



HTH,
John

*** Please rate all useful posts ***

Correct Answer by Rolf Fischer about 3 years 11 months ago

Hi,


R1#ping 5.5.5.5

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/23/36 ms



I'll bet this behavior changes when you use the source option:


R1#ping 5.5.5.5 source 1.1.1.1


Hope that helps

Rolf

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Rolf Fischer Fri, 08/30/2013 - 10:33
User Badges:
  • Blue, 1500 points or more

Hi,


R1#ping 5.5.5.5

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/23/36 ms



I'll bet this behavior changes when you use the source option:


R1#ping 5.5.5.5 source 1.1.1.1


Hope that helps

Rolf

Correct Answer
John Blakley Fri, 08/30/2013 - 11:57
User Badges:
  • Purple, 4500 points or more

RIP, by default, sends version 1 out of the interface and receives 1 and 2 updates. In this case, if you have version 1 on one router (sending/receiving v1 updates) and version 2 on another router (sending/receiving v2 updates), they cannot communicate because you're specifically configuring the router to send and receive only that version.


For example, if you have version 2 specified on one router, it expects to receive the updates in a version 2 format. On the other router, if you have the default specified, it sends version 1 out of the interface and receives 1 and 2 on the interface. This is why you're receiving the routes on your one router, but you're not seeing them on the other. You can change this behavior per interface with "ip rip send version " or "ip rip receive version ". So, you could receive 1 and send 2 if you needed. Without this stipulation on the interface though, the default is to send version 1 and receive both versions.



HTH,
John

*** Please rate all useful posts ***

Actions

This Discussion