×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

dial-peer matching SIP gateway

Answered Question
Aug 26th, 2013
User Badges:

Hello, I have a 2801 SIP gateway which connects to my ITSP.

SIP authentication etc seems to be fine. I can call out, but I cannot receive calls.


Here is the output of "show sip-ua register status":


Line                             peer       expires(sec) registered P-Associ-URI


================================ ========== ============ ========== ============


6494447789                  -1         231          yes


........so I guess that seems fine.My phone number is registered.


Then I turned on "debug voip dialpeer". About every 30 seconds it outputs these debug messages. I presume this is the SIP registrar trying to contact my gateway. it seems to be connecting with dial-peer 6 which is what I intended.


Calling Number=italkpbx, Called Number=, Voice-Interface=0x0,

   Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,

   Peer Info Type=DIALPEER_INFO_SPEECH

Aug 27 06:37:20.763: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Result=NO_MATCH(-1) After All Match Rules Attempt

Aug 27 06:37:20.763: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:

   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=-1

Aug 27 06:37:20.763: //-1/F5895006804C/DPM/dpAssociateIncomingPeerCore:


--More-- Calling Number=italkpbx, Called Number=, Voice-Interface=0x0,

   Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,

   Peer Info Type=DIALPEER_INFO_SPEECH

Aug 27 06:37:20.767: //-1/F5895006804C/DPM/dpAssociateIncomingPeerCore:

   Result=Success(0) after DP_MATCH_INCOMING_DNIS; Incoming Dial-peer=6

Aug 27 06:37:20.767: //-1/F5895006804C/DPM/dpMatchSafModulePlugin:

   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=0



........and when an incoming call arrives at my SIP gateway, this is the output of "debug voip dialpeer":


   Result=Success(0) after DP_MATCH_INCOMING_DNIS; Incoming Dial-peer=6

Aug 27 07:05:22.968: //-1/E034C9C88092/DPM/dpMatchSafModulePlugin:

   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=0



......so dial peer matching seems to be fine - i.e. matching dial peer 6 as intended ?



......I also turned on "debug ccsip messages". I notice two problems from this output:

1. Warning: 399 cucm "Unable to find a device handler for the request received on port 54374 from 192.168.2.1"

2. Reason: Q.850;cause=63

(see below for full output)


Here is the complete output:


Accept: application/sdp

Supported: 100rel,timer,resource-priority,replaces,sdp-anat

Content-Type: application/sdp

Content-Length: 167


v=0

o=CiscoSystemsSIP-GW-UserAgent 8255 2484 IN IP4 192.168.3.50

s=SIP Call

c=IN IP4 192.168.3.50

t=0 0

m=audio 0 RTP/AVP 18 0 8 9 4 2 15

c=IN IP4 192.168.3.50


Aug 27 08:08:03.468: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

INVITE sip:[email protected]:5060 SIP/2.0

Via: SIP/2.0/UDP 203.184.16.89:5060;branch=z9hG4bKe3ql5b105gqgboo1c650.1

From: "Unknown" <sip:[email protected]>;tag=as20cb7897

To: <sip:[email protected]:5060;transport=udp>

Contact: <sip:[email protected]:5060;transport=udp>

Call-ID: [email protected]

CSeq: 102 INVITE

User-Agent: italk PBX

Max-Forwards: 69

Date: Tue, 27 Aug 2013 08:08:03 GMT

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY

Supported: replaces

Content-Type: application/sdp

Content-Length: 354


v=0

o=root 22930 22930 IN IP4 203.184.16.89

s=session

c=IN IP4 203.184.16.89

t=0 0

m=audio 15684 RTP/AVP 8 18 97 3 0 101

a=rtpmap:8 PCMA/8000

a=rtpmap:18 G729/8000

a=fmtp:18 annexb=no

a=rtpmap:97 iLBC/8000

a=fmtp:97 mode=30

a=rtpmap:3 GSM/8000

a=rtpmap:0 PCMU/8000

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-16

a=ptime:20

a=sendrecv


Aug 27 08:08:03.488: //279/A1A4C9EE8147/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 100 Trying

Via: SIP/2.0/UDP 203.184.16.89:5060;branch=z9hG4bKe3ql5b105gqgboo1c650.1

From: "Unknown" <sip:[email protected]>;tag=as20cb7897

To: <sip:[email protected]:5060;transport=udp>

Date: Tue, 27 Aug 2013 08:08:03 GMT

Call-ID: [email protected]

CSeq: 102 INVITE

Allow-Events: telephone-event

Server: Cisco-SIPGateway/IOS-12.x

Content-Length: 0



Aug 27 08:08:03.500: //280/A1A4C9EE8147/SIP/Msg/ccsipDisplayMsg:

Sent:

INVITE sip:[email protected]:5060 SIP/2.0

Via: SIP/2.0/UDP 192.168.2.1:5060;branch=z9hG4bK481FC

Remote-Party-ID: "Unknown" <sip:[email protected]>;party=calling;screen=no;privacy=off

From: "unknown" <sip:[email protected]>;tag=659610-8DD

To: <sip:[email protected]>

Date: Tue, 27 Aug 2013 08:08:03 GMT

Call-ID: [email protected]

Supported: 100rel,timer,resource-priority,replaces,sdp-anat

Min-SE:  1800

Cisco-Guid: 2711931374-0237375971-2168968650-2868892746

User-Agent: Cisco-SIPGateway/IOS-12.x

Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER

CSeq: 101 INVITE

Timestamp: 1377590883

Contact: <sip:[email protected]:5060>

Expires: 180

Allow-Events: telephone-event

Max-Forwards: 68

Content-Type: application/sdp

Content-Disposition: session;handling=required

Content-Length: 212


v=0

o=CiscoSystemsSIP-GW-UserAgent 7023 9367 IN IP4 192.168.2.1

s=SIP Call

c=IN IP4 192.168.2.1

t=0 0

m=audio 17518 RTP/AVP 8 19

c=IN IP4 192.168.2.1

a=rtpmap:8 PCMA/8000

a=rtpmap:19 CN/8000

a=ptime:20


Aug 27 08:08:03.508: //280/A1A4C9EE8147/SIP/Msg/ccsipDisplayMsg:

Received:

SIP/2.0 100 Trying

Via: SIP/2.0/UDP 192.168.2.1:5060;branch=z9hG4bK481FC

From: "unknown" <sip:[email protected]>;tag=659610-8DD

To: <sip:[email protected]>

Date: Tue, 27 Aug 2013 08:08:03 GMT

Call-ID: [email protected]

CSeq: 101 INVITE

Allow-Events: presence

Content-Length: 0



Aug 27 08:08:03.508: //280/A1A4C9EE8147/SIP/Msg/ccsipDisplayMsg:

Received:

SIP/2.0 503 Service Unavailable

Via: SIP/2.0/UDP 192.168.2.1:5060;branch=z9hG4bK481FC

From: "unknown" <sip:[email protected]>;tag=659610-8DD

To: <sip:[email protected]>;tag=1754400314

Date: Tue, 27 Aug 2013 08:08:03 GMT

Call-ID: [email protected]

CSeq: 101 INVITE

Allow-Events: presence

Warning: 399 cucm "Unable to find a device handler for the request received on port 62609 from 192.168.2.1"

Content-Length: 0



Aug 27 08:08:03.520: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Sent:

ACK sip:[email protected]:5060 SIP/2.0

Via: SIP/2.0/UDP 192.168.2.1:5060;branch=z9hG4bK481FC

From: "unknown" <sip:[email protected]>;tag=659610-8DD

To: <sip:[email protected]>;tag=1754400314

Date: Tue, 27 Aug 2013 08:08:03 GMT

Call-ID: [email protected]

Max-Forwards: 70

CSeq: 101 ACK

Allow-Events: telephone-event

Content-Length: 0



Aug 27 08:08:03.520: //279/A1A4C9EE8147/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 500 Internal Server Error

Via: SIP/2.0/UDP 203.184.16.89:5060;branch=z9hG4bKe3ql5b105gqgboo1c650.1

From: "Unknown" <sip:[email protected]>;tag=as20cb7897

To: <sip:[email protected]:5060;transport=udp>;tag=659624-4BA

Date: Tue, 27 Aug 2013 08:08:03 GMT

Call-ID: [email protected]

CSeq: 102 INVITE

Allow-Events: telephone-event

Server: Cisco-SIPGateway/IOS-12.x

Reason: Q.850;cause=63

Content-Length: 0



Aug 27 08:08:03.536: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

ACK sip:[email protected]:5060 SIP/2.0

Via: SIP/2.0/UDP 203.184.16.89:5060;branch=z9hG4bKe3ql5b105gqgboo1c650.1

CSeq: 102 ACK

From: "Unknown" <sip:[email protected]>;tag=as20cb7897

To: <sip:[email protected]:5060;transport=udp>;tag=659624-4BA

Call-ID: [email protected]

Max-Forwards: 69

Content-Length: 0



.........and here is my full running-config


version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 2801Router

!

boot-start-marker

boot system flash:c2801-ipvoicek9-mz.151-2.T0a.bin

boot-end-marker

!

!

!

aaa new-model

!


aaa session-id common

clock timezone nzst 13 0

dot11 syslog

ip source-route

!


ip dhcp pool DATA_SCOPE

   network 192.168.200.0 255.255.255.0

   default-router 192.168.200.1

   dns-server 8.8.8.8

!

ip dhcp pool VOICE_SCOPE

   network 192.168.100.0 255.255.255.0

   default-router 192.168.100.1

   option 150 ip 192.168.2.115

!

!        

ip cef   

ip domain name demo.net

ip name-server 4.2.2.2

no ipv6 cef

multilink bundle-name authenticated

!        


voice service voip

ip address trusted list

  ipv4 0.0.0.0 0.0.0.0

no ip address trusted authenticate

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

sip

bind control source-interface FastEthernet0/1

bind media source-interface FastEthernet0/1

!        

voice class codec 1

codec preference 1 g711alaw

!        


voice translation-rule 1

rule 1 /^9/ //

!        

!        

voice translation-profile Strip9ToGetOut

translate called 1

!        

!        

voice-card 0

!        

crypto pki token default removal timeout 0

!        

crypto pki trustpoint TP-self-signed-2995340181

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-2995340181

revocation-check none

!        

!        

crypto pki certificate chain TP-self-signed-2995340181

certificate self-signed 01

  3082024B 308201B4 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 32393935 33343031 3831301E 170D3733 30393038 31363435

  30345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 39393533

  34303138 3130819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100C34D C8ECBB53 E01373A3 2E286B78 2D23042B 1C8588B1 A7861899 BA1C6860

  AE1D7868 2A59E3BC 54D0A457 8FFDE27F C09104E5 C7A429F3 74CD9DA8 4A980366

  675CC27C CDB94838 821CC05F 2C0AC2BC D882C132 6CAA1FA6 6DA740E4 562428B1

  12B741F1 A50C9246 4CC35EDA DEE1D038 3883BB35 A91ABF8B 483E4160 F5FA4B5A

  9A570203 010001A3 73307130 0F060355 1D130101 FF040530 030101FF 301E0603

  551D1104 17301582 13323830 31526F75 7465722E 64656D6F 2E6E6574 301F0603

  551D2304 18301680 14721196 40F3396E 1FE41680 86D31D86 190D8337 FF301D06

  03551D0E 04160414 72119640 F3396E1F E4168086 D31D8619 0D8337FF 300D0609

  2A864886 F70D0101 04050003 818100AF E92F8BC4 19F5E0AB B4718F19 0D86B9CC

  74FB352A 55AD288F 0A0BE12F 3E0D43D2 1B52A07A 466BDD33 9041BCAB 96A99FED

  5E3AC098 D29BC1BD 646D16E4 BAE341EC DA7A5323 0F5B34D9 086B31DA CC770A83

  A4A1D333 519982BA AD8A326C 268B3B93 AE75284F ABE1BE0F 2E488858 0E2D140A

  075FE477 E1C9C006 FEA3945D 617CAE

        quit

!        

!        

license udi pid CISCO2801 sn FTX0947W07M

username phil privilege 15 password 0 xxxxxxxxx

username admin privilege 15 secret 5 xxxxxxxxxx

!               

interface FastEthernet0/0

ip address 192.168.3.50 255.255.255.0

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!        

interface FastEthernet0/1

no ip address

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

!        

interface FastEthernet0/1.2

encapsulation dot1Q 2

ip address 192.168.2.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

!        

interface FastEthernet0/1.99

encapsulation dot1Q 99

ip address 192.168.99.1 255.255.255.0

!        

interface FastEthernet0/1.100

description voice_VLAN

encapsulation dot1Q 100

ip address 192.168.100.1 255.255.255.0

!        

interface FastEthernet0/1.200

description data_VLAN

encapsulation dot1Q 200

ip address 192.168.200.1 255.255.255.0

!        

ip forward-protocol nd

!        

!        

no ip http server

ip http authentication local

no ip http secure-server

ip nat inside source static tcp 192.168.2.115 8443 interface FastEthernet0/0 8443

ip nat inside source static tcp 192.168.2.115 443 interface FastEthernet0/0 443

ip route 0.0.0.0 0.0.0.0 192.168.3.1

!        

logging esm config

!        

!        

tftp-server flash:/phone/7940-7960/P00307020200.bin alias P00307020200.bin

tftp-server flash:/phone/7940-7960/P00307020200.loads alias P00307020200.loads

tftp-server flash:/phone/7940-7960/P00307020200.sb2 alias P00307020200.sb2

tftp-server flash:/phone/7940-7960/P00307020200.sbn alias P00307020200.sbn

!        

!        

control-plane

!        

!        

!        

mgcp fax t38 ecm

!        

!        

dial-peer voice 1 voip

description local_7_Digit_Calling

translation-profile outgoing Strip9ToGetOut

destination-pattern 9[2-9]......

session protocol sipv2

session target ipv4:203.184.16.2

voice-class codec 1 

!        

dial-peer voice 2 voip

description international_calling

translation-profile outgoing Strip9ToGetOut

destination-pattern 900T

session protocol sipv2

session target ipv4:203.184.16.2

voice-class codec 1 

!        

dial-peer voice 3 voip

description national_calling

translation-profile outgoing Strip9ToGetOut

destination-pattern 90[34679].......

session protocol sipv2

session target ipv4:203.184.16.2

voice-class codec 1 

!        

dial-peer voice 4 voip

description emergency dialling

destination-pattern [91]11

session protocol sipv2

session target ipv4:203.184.16.2

voice-class codec 1 

!        

dial-peer voice 5 voip

description emergency dialling with prefix

translation-profile outgoing Strip9ToGetOut

destination-pattern 9[91]11

session protocol sipv2

session target ipv4:203.184.16.2

voice-class codec 1 

!        

dial-peer voice 6 voip

description CUCMDialPeer

destination-pattern 6494447789

session protocol sipv2

session target ipv4:192.168.2.115

incoming called-number .

voice-class codec 1 

dtmf-relay h245-alphanumeric

!        

!        

sip-ua   

credentials number 6494447789 username 6494447789 password 7 xxxxxxxxxxxxxxxxxxxx realm akl.italk.co.nz/6494447789

authentication username 6494447789 password 7 xxxxxxxxxxxxxxx

calling-info pstn-to-sip from number set 6494447789

registrar dns:akl.italk.co.nz:5060 expires 180

sip-server ipv4:xxx.xxx.xxx.xxx:5060

!        

banner motd ^C

**********************************************

UNAUTHORISED ACCESS IS PROHIBITED

WELCOME TO THE 2801 CME ROUTER

**********************************************

^C       

!        

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

line vty 0 4

privilege level 15

transport input telnet ssh

!        

scheduler allocate 20000 1000

ntp server 195.43.74.123

end  


.............does anyone have any ideas what is going wrong here ?

I guess the whole problem revolves around the 2 suspect ccsip messages:

1. Warning: 399 cucm "Unable to find a device handler for the request received on port 54374 from 192.168.2.1"

2. Reason: Q.850;cause=63


How would I go about fixing those ?


Thanks kindly for any help.

Correct Answer by Ayodeji Okanlawon about 3 years 11 months ago

This error suggest that the ipaddress on the sip trunk doesn't match 192.168.2.1. What is the IP address configured on your sip trunk?

Correct Answer by Nishant Savalia about 3 years 11 months ago

Also, please share the SIP trunk configuration done at CUCM. i.e the IP address




Regards,

Nishant Savalia

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
acampbell Fri, 08/30/2013 - 04:49
User Badges:
  • Green, 3000 points or more

Hi,


You seem to be using various ip addresses for SIP .


Can you try tightening up your sip bind statements


!

voice service voip

no bind control source-interface FastEthernet0/1

no bind media source-interface FastEthernet0/1

bind control source-interface FastEthernet0/1.2

bind media source-interface FastEthernet0/1.2




Regards,
Alex.
Please rate useful posts.

fran19422 Fri, 08/30/2013 - 21:47
User Badges:

thanks for your help.

I tried tightening up those bind statements, that but by doing that it stopped me calling out as well. At least with the bind commands set to fa0/1, I can call out.


If anyone else has any ideas about why I am not receiving calls from the PSTN I would most appreciate it.



Thanks.

Nishant Savalia Fri, 08/30/2013 - 22:33
User Badges:
  • Silver, 250 points or more

Hi,

Can you please share detailed RTMT trace for inbound call?


And your connectivity seems to be like CUCM<----SIP Trunk----->SIP Gateway<----------->ITSP   ..........



Regards,

Nishant Savalia

Correct Answer
Ayodeji Okanlawon Fri, 08/30/2013 - 23:51
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

This error suggest that the ipaddress on the sip trunk doesn't match 192.168.2.1. What is the IP address configured on your sip trunk?

Correct Answer
Nishant Savalia Fri, 08/30/2013 - 22:42
User Badges:
  • Silver, 250 points or more

Also, please share the SIP trunk configuration done at CUCM. i.e the IP address




Regards,

Nishant Savalia

fran19422 Fri, 08/30/2013 - 23:59
User Badges:

Hello, thanks guys.

That was the problem. I did not have the IP of the SIP trunk configured correctly.

Actions

This Discussion