Using Two ISP links on remote sites..

Unanswered Question
Sep 15th, 2013
User Badges:

Hello,

I have a ISP links on my remote site's router on Gig 0/1 and now I am planning for a secondary link.Since, I have only two gig ports ( one is used by ISP link and other is used as LAN gateway),the other ISP is ready to provide secondary link on serial port.

I am using BGP as protocol and MPLS as a media. Kindly let me know what changes \ extra configurations I'll have to do for  running my remote sites on either primary or secondary links ?


Thanks & Regards,


Anil Kumar

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Lei Tian Mon, 09/16/2013 - 04:16
User Badges:
  • Cisco Employee,

Hi Anil,


You have some options to prefer one BGP route over the other. You need to consider the route preference on both direction, ingress and egress. I think the easiest way is to add as-path prepend on both direction of the secondard link.


HTH,

Lei Tian

rite2anil Wed, 09/18/2013 - 01:25
User Badges:

Hi Lei,


I  have the below configuration done in my remote router. Can you please send me sample config on the same ?



interface Loopback1
ip address 10.26.129.abc 255.255.255.255
!
!
interface GigabitEthernet0/0
description CONNECTED TO LAN F0/1
ip address 10.26.129.acb 255.255.255.224
duplex auto
speed auto
media-type rj45
!
!
interface GigabitEthernet0/1                     //Currently used by primary ISP//
bandwidth 2048
ip address 10.26.129.pqr 255.255.255.252
duplex auto
speed auto
media-type rj45
no cdp enable
!
!
interface Serial0/0/0               // To Be used by second ISP//
no ip address
shutdown
clock rate 125000
!

router bgp xxxy
no synchronization
bgp log-neighbor-changes
network 10.26.129.acb mask 255.255.255.224  //LAN IP pool
network 10.26.129.abc mask 255.255.255.255   //Loopback IP address.
neighbor 10.cc.129.161 remote-as xxxx    //next hop of gig0/1 towards primary ISP
neighbor 10.cc.129.161 allowas-in 4      ////next hop of gig0/1 towards primary ISP
no auto-summary
!



Regards,


Anil Kumar

Lei Tian Wed, 09/18/2013 - 07:00
User Badges:
  • Cisco Employee,

Hi Anil,


If you are receiving same routes from both providers, the following config should work



router bgp xxxy


neighbor x.x.x.x remote-as xxx //secondary ISP


neighbor x.x.x.x route-map INBOUND in


neighbor x.x.x.x route-map OUTBOUND out




route-map OUTBOUND permit 10


set as-path prepend x x x x //local-as number


!


route-map INBOUND permit 10


set as-path prepend last-as 4


HTH,

Lei Tian

Actions

This Discussion