×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

SPA112 T.38 sending fax fails. Receiving works fine

Unanswered Question
Sep 17th, 2013
User Badges:

Sending faxes with a SPA112 fails everytime. Receiving works fine. When sending the fax I hear normal fax tones and everything seems to work fine, but after some time the fax says it failed sending. I tried to send to different fax numbers. I also tried to send to an online fax service, when sending to this fax service I get an email from the service that the faxstation is trying to send but that it fails.


What I alredy tried to resolve the problems


  • Tried different types of internet connections (ADSL, VDSL)
  • Tried several types of faxes (Canon's, HP).
  • Replaced the SPA 112
  • Updated the ata to release 1.3.2-XU.
  • Lower the baudrates, tried 4800, 9600.


The config I'm using on the SPA112


  • Network Jitter Level: tried high / very high /extremely high
  • Jitter Buffer Adjustment: no
  • RTP Packet Size:  tried 0.020 / 0.030
  • Preferred Codec: G711u
  • Silence Supp Enable: no
  • Echo Canc Enable: no
  • FAX V21 Detect Enable: yes
  • FAX CNG Detect Enable: yes
  • FAX Passthru Method: ReINVITE
  • FAX Process NSE: no
  • FAX Disable ECAN: yes
  • FAX T38 ECM Enable: tried yes / no
  • FAX Enable T38: yes


See attached screenshot of a wireshark trace

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Dan Lukes Wed, 09/18/2013 - 14:07
User Badges:
  • Red, 2250 points or more
  • Cisco Designated VIP,

    2017 Small Business

I'm not T.38 expert, but I assume that simmilar screenshot from other side compared to screenshot from local side may reveal something more to you.

Daniele Giordano Thu, 09/19/2013 - 11:02
User Badges:
  • Gold, 750 points or more

Try in order FAX Disable ECAN: no and so Echo Canc Enable: yes.

This is my working config.



Regards.

rbovenkamp Thu, 09/19/2013 - 11:38
User Badges:

Thanks for your answers.


@Dan, unfortunately impossible cause the other side is an online fax service or another faxmachine which I cannot make a trace on.

@Daniele, unfortunately not working for me :-(


I hope somebody else has a solution


Rick

Maggie_Leemm Sat, 09/28/2013 - 01:17
User Badges:

Hi William,

I am trying to understand your problem and provide my suggestion as possible as I can. And could you please answer the following questions.

1)  Have your replaced spa112 with another brand voice gateway to make the t.38 fax call with remote side? and what's the test results?

2) Which fax modulation and speed you already tried? v.17 14400? v17 9600? v29 9600? The reason I am asking this is because in your attached sreenshot the final negotiated moduleation and speed is v27ter 4800pbs.

3) Please make sure   = Yes.

4) Another interesting thing found in the call trace, remote gateway accepted the  t.38 reinvite from spa112 and then it sent out another t.38 reinvite to spa112 unexpectedly. Could you please try set = No? withi this setting, spa112 will not request t.38 call when as a fax call sender, and I believe the remote gateway will trigger t.38 instead.

Cheers,

Maggie

Totaly_FuRy Tue, 07/15/2014 - 04:27
User Badges:

Hello,

Like many of my clients i am experiencing this issue with my "Brother Fax-2920". The T.38 is not working :

- The Incoming faxes works sometimes : it depends if the SPA112 still listening after a fax modulation (T.38 no signal).
- The outgoing faxes does not work at all : according to wireshark the SPA112 sends malformed T.38 packets and stop working.

You will find attached a wireshark capture with debug log. i am looking to record the PSTN audio to fully understand what happen.

Best regards,
DUPONCHEEL Sébastien.

Actions

This Discussion

Related Content