×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Cisco 2950 Switch replacement problem

Unanswered Question
Sep 19th, 2013
User Badges:

I have a Cisco 2950 switch with a dead fan in it. I am replacing with another Cisco 2950 switch. Both are 24 port switches. The difference is, the old switch has built in Gigabit fibre ports(25&26), that fibre goes from the fibre box directly into the switch using a SC to ST fibre patch cable. The new switch has Gigabit fibre ports(25&26), but it requries the GBIC cards to plug the SC to SC fibre patch cable to work. My problem is this: When I plug the SC from he the Fibre box to the new GBIC Switch, I get no data light, period. I have tried swapping switches, gbic cards, sc-sc cables, etc. The output from the fibre box is good and working now, so I know the fibre isn't bad. I am using the same two fibre strands from the fibre box to the new switch, just with a sc-sc cable because a sc-st is now being used. What am I missing?


Thanks!           

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
devils_advocate Thu, 09/19/2013 - 07:17
User Badges:
  • Gold, 750 points or more
  • Community Spotlight Award,

    Small Business, November 2015

Try swapping the Fibre pairs over.


What I mean is, the fibre cable will have two single cables (red and black ended perhaps) so swap these over. An SC cable will probably have a little clip which comes apart and allows you to swap the cables over.


What is the structured cabling, multimode or single mode?

budman007 Thu, 09/19/2013 - 07:28
User Badges:

I swapped over and over on each end, still no lights. Multimode cabling. I can't fathom that there is some weird cabling difference inside the fibre box because of he switch differences. I am fairly sure I have the right pair in the fibre box, because when I unplug one, the current old switch, either port 25 or port 26 lights go out.


Attached in a picture inside the fibre box. Disregard the fibre with the blue connectors that are marked, i inked them before I traced the cables. The others are marked correctly, the Green and Red ink are port 25 and the Blue and Orange ink are port 26. I simply unplug them where they are inked and plug in the SC-SC connectors and go directly to the new switch, I tried in both ports on the new switch, different GBIC, etc.

Marcin Gaszewski Thu, 09/19/2013 - 07:31
User Badges:

could you post #show inventory with inserted sfp?

as well #show inter [your_port_number] capabilities,  #show run inter [your_port_number]

budman007 Thu, 09/19/2013 - 07:40
User Badges:

That isn't a command for his version of switch. The old switch doesnt have a Sfp. I took the config from the old switch and applied to the new switch, but edited the port names from FE(old switch) to GB(new switch), really, though you should get active lights or even amber lights with a blank config, just need connectivity. right?

aukhadiev Thu, 09/19/2013 - 08:23
User Badges:
  • Bronze, 100 points or more

Hi, Dale...

According to your description and this article:

http://www.cisco.com/en/US/products/hw/switches/ps700/products_tech_note09186a00800a7af7.shtml#cat2950

you have replaced this switch (p/n:WS-C2950SX-24) to this (p/n:WS-C2950G-24-EI)... Right?

Are you use the right GBIC - 1000BASE-SX, p/n:WS-G5484?

Could you post output of #show interface to ensure that the switch recognizes the GBIC and displays the correct media type?

devils_advocate Thu, 09/19/2013 - 08:13
User Badges:
  • Gold, 750 points or more
  • Community Spotlight Award,

    Small Business, November 2015

What is the model number of the new GBIC you have installed? It should be written on it.


Can you provide a show run of the interface?


I am thinking either a mismatch in the cable and GBIC types or autonegotiation is not working correctly.

Phillip Wilson Thu, 09/19/2013 - 11:55
User Badges:

Try putting "no negotiate" on the fiber port. I have had this issue before and this helped.

Sent from Cisco Technical Support iPhone App

budman007 Thu, 09/19/2013 - 12:17
User Badges:

Thanks for the sugesstions, I will try some, here is more info.


The old switch is WS-C2955C-24. The new one is WS-C2950G-24-EI.

Here is a pic. It's the GBIC card, which I tried today to take out a working gbic from another switch and tested it, still no lights....So I am 99% the gbic isnt the problem. 

devils_advocate Thu, 09/19/2013 - 13:30
User Badges:
  • Gold, 750 points or more
  • Community Spotlight Award,

    Small Business, November 2015

1000base-lx is for single mode fibre, you said earlier yours is multimode.....


1000base-sx is for multimode

budman007 Fri, 09/20/2013 - 07:17
User Badges:

Here is the config from the new Switch.


b6m01csb827#sh ru
Building configuration...

Current configuration : 3961 bytes
!
version 12.1
no service pad
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
no service password-encryption
service sequence-numbers
!
hostname b6m01csb827
!
enable secret 5 $1$IS.v$X683bFbcJufwB6EOGbZ0t/
enable password cisco
!
clock timezone cst -6
clock summer-time cdt recurring
ip subnet-zero
!
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
no spanning-tree vlan 1
!
!
!
!
interface FastEthernet0/1
switchport mode access
switchport voice vlan 99
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 40
switchport mode access
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/3
switchport access vlan 50
switchport mode access
switchport voice vlan 99
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/4
switchport access vlan 10
switchport mode access
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/5
switchport access vlan 10
switchport mode access
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/6
switchport access vlan 50
switchport mode access
switchport voice vlan 99
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/7
switchport access vlan 10
switchport mode access
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/8
switchport access vlan 10
switchport mode access
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/9
switchport access vlan 80
switchport mode access
speed 10
duplex half
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/10
switchport access vlan 50
switchport mode access
duplex half
no cdp enable
!
interface FastEthernet0/11
switchport access vlan 290
switchport mode access
duplex half
no cdp enable
!
interface FastEthernet0/12
switchport access vlan 50
switchport mode access
duplex half
no cdp enable
!
interface FastEthernet0/13
switchport access vlan 10
switchport mode access
duplex half
no cdp enable
!
interface FastEthernet0/14
switchport access vlan 50
switchport mode access
duplex half
no cdp enable
!
interface FastEthernet0/15
switchport access vlan 10
switchport mode access
duplex half
no cdp enable
!
interface FastEthernet0/16
switchport access vlan 50
switchport mode access
duplex half
no cdp enable
!
interface FastEthernet0/17
switchport access vlan 50
switchport mode access
duplex half
no cdp enable
!
interface FastEthernet0/18
switchport access vlan 10
switchport mode access
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/19
switchport access vlan 50
switchport mode access
speed 100
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/20
switchport access vlan 10
switchport mode access
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/21
switchport access vlan 10
switchport mode access
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/22
switchport access vlan 10
switchport mode access
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/23
switchport access vlan 10
switchport mode access
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/24
switchport access vlan 50
switchport mode access
switchport voice vlan 99
no cdp enable
spanning-tree portfast
!
interface GigabitEthernet0/1
switchport mode trunk
!
interface GigabitEthernet0/2
switchport mode trunk
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan60
ip address 10.10.241.48 255.255.255.0
no ip route-cache
!
ip default-gateway 10.10.241.1
ip http server
snmp-server community public RO
snmp-server enable traps snmp authentication
snmp-server host 10.10.240.46 public  snmp
!
line con 0
exec-timeout 0 0
line vty 0 4
password cisco
login
line vty 5 15
password cisco
login
!
ntp clock-period 17179796
ntp server 10.10.240.2 key 0 prefer
!
end




b6m01csb827#show inventory
NAME: "b6m01csb827", DESCR: "Cisco Catalyst c2950 switch with 24 10/100 BaseTX ports and 2
GBIC (Gigabit Interface Converter) slots"
PID: WS-C2950G-24-EI   , VID:    , SN: FHK0713Y0DM

NAME: "GigabitEthernet0/1", DESCR: "longwave fiber gigabit ethernet port adapter"
PID: GBIC_LX           , VID: 30 30 30 30, SN: 0209110442301672

NAME: "GigabitEthernet0/2", DESCR: "longwave fiber gigabit ethernet port adapter"
PID: GBIC_LX           , VID: 30 30 30 30, SN: 0209110501167948

Phillip Wilson Fri, 09/20/2013 - 07:44
User Badges:

I would try putting the " switchport nonegotiate" on Interface on both sides of the fiber first. Then I would check your distance. Are you past 550m for MMF? Do you have SMF available to test?


"switchport nonegotiate" says: "Do not send or respond to DTP from this end. Disable all DTP on this port." Best used on user access ports, when trunking to non-Cisco switches, when trunking to a router, or if you are paranoid about fast convergence.

Sent from Cisco Technical Support iPhone App

budman007 Fri, 09/20/2013 - 13:01
User Badges:

If the config needed changed, wouldnt that mean that when I plugged this switch into another switch using the same gbic cards and cables that it wouldnt have lit up? One thing I did notice is the current cable in place that runs from the fiber box to the old switch(SC to ST) is a lot thinner then my new cable to the new switch(SC to SC). I have been told we have both Multi and Single mode in our enviroment, how can I tell which this is? I couldnt find anything stamped on the fiber that runs to the fiber box.

pieterh Fri, 09/20/2013 - 14:57
User Badges:

Did you check the device this 2950 is connected to?

Fe fiber ports use different wavelength light then ge sfp's!

? 100BASE-LX (LC connectors @ 1,300 nm):
1000base:
850 nm, 1310 nm and 1550 nm wavelenghts


Sent from Cisco Technical Support iPad App

budman007 Mon, 09/23/2013 - 05:00
User Badges:

The fiber that runs to this switch comes from a Cisco 2950EI model that has the same LX GBIC as the new switch. I even took out one of the GBIC in the new one and swapped it with the switch that runs to the old switch and the old switch still worked fine, but when I plug in the new switch, no lights, nothing.


I understand the wavelength is difference from FE vs GE, but does this mean the fiber box will only work with FE and not GE?

aukhadiev Mon, 09/23/2013 - 06:12
User Badges:
  • Bronze, 100 points or more

Hi, Dale Brown...

As you wrote earlier (at 19.09.2013 13:17)

"The old switch is WS-C2955C-24. The new one is WS-C2950G-24-EI"

According this article:

http://www.cisco.com/en/US/products/hw/switches/ps700/products_tech_note09186a00800a7af7.shtml#cat2950

WS-C2950C-24 has  24 10/100 Ethernet ports and 2 100BASE-FX ports (100 Mbps)

WS-C2950G-24-EI has 24 10/100 Ethernet ports and 2 GBIC module slots

But the GBIC-module ports support only 1000 Mbps. The speed values of 10 Mbps and 100 Mbps are not supported...

budman007 Mon, 09/23/2013 - 09:02
User Badges:

Ok, the Gbic only will support 1000mbps, makes sense, so what would have to be changed? Replacing Switch and Fiber cable from the fiber box to the new switch. Before the fiber box, it comes from another 2950 that is 24EI,

aukhadiev Mon, 09/23/2013 - 09:21
User Badges:
  • Bronze, 100 points or more

Dale, the old switch is WS-C2955C-24 and has 100BASE-FX fiber ports working at 100 Mbps, so i think at the other end of the optical cable the equipment is also only supports 100 Mpbs...

You can tell what kind of equipment (switch) at the other end of the optical cable?

pieterh Tue, 09/24/2013 - 00:13
User Badges:

as SFP you have got the option:

GLC-GE-100FX              100BASE-FX SFP module for Gigabit Ethernet ports, 1310 nm wavelength, 2 km over MMF1

Here the SFP does the speed conversion (Gig port 100M Fiber)


according to table-6 in

http://www.cisco.com/en/US/docs/routers/7200/install_and_upgrade/gbic_sfp_modules_install/5067g.html

This should also exist as GBIC.

Actions

This Discussion