×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

L2 switch is not updating the vlan details from CORE switch

Unanswered Question

Hi,

I have one L2 switch 2960 switch which in not updating the Vlan info from Core Switch. I have configure trunk from Core switch to this L2 switch and i am able connet the switch. the only problem is the switch is not updating the vlan database from Core switch.


Can any one help me what shoud i do the update the vlan information in to L2 2960 switch.


Please find the 2960 switch details.


Switch   Ports  Model              SW Version              SW Image

------   -----  -----              ----------              ----------

*    1   50     WS-C2960-48TC-L    12.2(25)SEE2            C2960-LANBASE-M



Please find the VTP status of both switch.


VTP status of Switch 2960.


2ndfloor#sh vtp status

VTP Version                     : 2

Configuration Revision          : 0

Maximum VLANs supported locally : 255

Number of existing VLANs        : 6

VTP Operating Mode              : Client

VTP Domain Name                 :

VTP Pruning Mode                : Disabled

VTP V2 Mode                     : Enabled

VTP Traps Generation            : Disabled

MD5 digest                      : 0xDF 0xE4 0x18 0x3F 0xBB 0xCE 0x47 0x7D

Configuration last modified by 10.10.100.14 at 3-1-93 00:03:06



2ndfloor#sh int trunk


Port        Mode         Encapsulation  Status        Native vlan

Fa0/48      on           802.1q         trunking      1


Port        Vlans allowed on trunk

Fa0/48      1-4094


Port        Vlans allowed and active in management domain

Fa0/48      1,10


Port        Vlans in spanning tree forwarding state and not pruned

Fa0/48      1,10


interface FastEthernet0/48

switchport mode trunk

end



Now find the below details of Core Switch(L3 switch).


CORE_SWITCH#sh vtp status

VTP Version                     : running VTP2

Configuration Revision          : 170

Maximum VLANs supported locally : 1005

Number of existing VLANs        : 66

VTP Operating Mode              : Server

VTP Domain Name                 :

VTP Pruning Mode                : Disabled

VTP V2 Mode                     : Enabled

VTP Traps Generation            : Disabled

MD5 digest                      : 0xA3 0xB7 0x83 0x64 0x22 0x66 0x66 0xFC

Configuration last modified by 10.10.10.1 at 7-18-12 09:05:18

Local updater ID is 10.10.10.1 on interface Vl1 (lowest numbered VLAN interface found)




Port        Mode             Encapsulation  Status        Native vlan


Fa6/17      on               802.1q         trunking      1




interface FastEthernet6/17

switchport trunk encapsulation dot1q

switchport mode trunk

no logging event link-status

spanning-tree bpduguard disable



If you see the both configuration the Configuration Revision is not updating in L2 switch.


Can any tell me wt should i do the update the Configuration Revision in L2 switch.


Regards

Prashant

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (5 ratings)
Loading.
John Blakley Sat, 09/21/2013 - 06:10
User Badges:
  • Purple, 4500 points or more

Did you leave the vtp domain name out on purpose, or is it truly missing in the config? If it's missing, add a domain name and see if that fixes your issue...


HTH,

John


**** Please rate all useful posts ****

InayathUlla Sharieff Sat, 09/21/2013 - 09:23
User Badges:
  • Cisco Employee,

Agree to with John.

For VTP to work you need to configure the following parameters:


1- VTP Domain Name

2- Make sure the connected interface is trunk port and vlans are been allowed.

3- Make sure the edge devices connecting to the core or not configured transparent switch.

4- If you are planning to configure the VTP-password then it should be same on all the switches,


Please check the link below:

http://www.cisco.com/en/US/tech/tk389/tk689/technologies_tech_note09186a0080094c52.shtml


HTH

REgards

Inayath


Team,

I know VTP domain name is requerird. I removed the name purposly. Now Please let know why it is not updating the Configuration Revision in L2 switch. I have tried all possibilities. Please let me know if I am missing something.

You can see my configuration which i have alredy shared with you.




Regards

Prashant

Hi Prashant,


Have you tried adding and removing any new vlan on the VTP server recently? If not try adding a dummy vlan and verify if that helps.


You can debug VTP using the following "debug sw-vlan vtp events" or "debug sw-vlan vtp events packets" and verify what is going on and background.


Hope that helps.


Regards


Najaf

InayathUlla Sharieff Mon, 09/23/2013 - 01:11
User Badges:
  • Cisco Employee,

Okay Let me try to explain you the behaviour:



Here are the few things which I can see in your issue:

==========================================



1- You Setup doesnt have the VTP domain name:



AS you know that  Summary advertisements inform adjacent Catalysts of the current VTP domain name and the configuration revision number.



When the switch receives a summary advertisement packet, the switch compares the VTP domain name to its own VTP domain name. If the name is different, the switch simply ignores the packet. If the name is the same, the switch then compares the configuration revision to its own revision. If its own configuration revision is higher or equal, the packet is ignored. If it is lower, an advertisement request is sent.





2- I could see the Conf reg is 170 on the server and 0 on the layer 2 switch.(This assumes that the Layer 2 switch might have just changed to vtp mode client or someone deleted the domain name and left it blank) .



3- Though you have the trunk ports configured between these devices and assuming that it works fine still you would not see the VTP infomration been updated from Server to the Client.





Next Action:

==========

- To avoid more troubleshooting check the following things;



1- Just try to create vlan on the server(Core-Switch) and check if the conf revision number gets increased to 171 ? If yes then the server is working fine.

2- Configure the domain name on CORE_Switch(Configuring the domain name -NOTE- Configuring the domain name will clear the config revision number to 0 but all your vlans would still be available.)

3-Configure the domain name to match the same as CORE-Switch on Layer 2 -2950 switch.

4- Now try to create the Vlan on the server and you should see the update populating over to Layer 2 switch.


Hope this should solve your query.


HTH

Regards

Inayath

InayathUlla Sharieff Tue, 09/24/2013 - 05:31
User Badges:
  • Cisco Employee,

Prashant,

Thnks for the update .Glad to hear the issue has been resolved.


Coming down the VTP Password its always good to configure the password in the vtp domain so that everything should be reachable and have the proper MD5  calculation.


Hope this thread has helped you. If no further query is required I request you to kindly mark this thread as answered rather than leaving it to be unanswered.


Thanks

Regards

Inayath

Actions

This Discussion