standalone ap with dhcp problem

Unanswered Question
Sep 25th, 2013
User Badges:

I have an standalone ap but it is not work on the dhcp for wireless connection with the below config, but when i plug in the ethernet cable to the that is able to get the ip address, i have try to config related ip to do.1 or f0.1 or bvi1 but still not working.

Is it not possible to have a dhcp function on standalone ap?


ap_test#sh run

Building configuration...



Current configuration : 3015 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ap_test

!

logging rate-limit console 9

enable secret 5 $1$oJyM$DPgTtPIB82lhgm2bUP9b90

!

no aaa new-model

no ip dhcp use vrf connected

no ip dhcp conflict logging

ip dhcp excluded-address 10.18.20.1 10.18.20.200

ip dhcp excluded-address 10.18.20.203 10.18.20.254

ip dhcp excluded-address 192.168.0.1 192.168.0.200

ip dhcp excluded-address 192.168.0.203 192.168.0.254

!

ip dhcp pool wifi_test1

   network 10.18.20.0 255.255.255.0

   default-router 10.18.20.1

   dns-server 8.8.8.8

   lease 20

!

ip dhcp pool wifi_test2

   network 192.168.0.0 255.255.255.0

   default-router 192.168.0.1

   dns-server 8.8.8.8

   lease 20

!

!

dot11 syslog

!

dot11 ssid wifi_test1

   vlan 1

   authentication open

   authentication key-management wpa version 2

   mbssid guest-mode

   wpa-psk ascii 7 0217154A1A171E305D

!

dot11 ssid wifi_test2

   vlan 2

   authentication open

   authentication key-management wpa version 2

   mbssid guest-mode

   wpa-psk ascii 7 044A1A171E305D5F18

!

!

!

username Cisco password 7 05280F1C2243

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption vlan 1 mode ciphers aes-ccm tkip

!

encryption vlan 2 mode ciphers aes-ccm tkip

!

ssid wifi_test1

!

ssid wifi_test2

!

mbssid

station-role root

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.2

encapsulation dot1Q 2

no ip route-cache

bridge-group 2

bridge-group 2 subscriber-loop-control

bridge-group 2 block-unknown-source

no bridge-group 2 source-learning

no bridge-group 2 unicast-flooding

bridge-group 2 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

shutdown

dfs band 3 block

channel dfs

station-role root access-point

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

!

interface FastEthernet0.1

encapsulation dot1Q 1 native

ip address 10.18.20.189 255.255.255.0

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface FastEthernet0.2

encapsulation dot1Q 2

ip address 192.168.0.189 255.255.255.0

no ip route-cache

bridge-group 2

no bridge-group 2 source-learning

bridge-group 2 spanning-disabled

!

interface BVI1

ip address 10.18.20.189 255.255.255.0

no ip route-cache

!

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!        

!

!

line con 0

line vty 0 4

login local

!

end



ap_test#

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Stephen Rodriguez Wed, 09/25/2013 - 19:21
User Badges:
  • Purple, 4500 points or more

You want the ap to be the dhcp server? Yes this can work.

So you don't need to IP address under the fastethernet subinterfaces. You just need to have the switchport configured as a trunk and at L3 put an ip helper pointing at the address of the AP.

Steve

Sent from Cisco Technical Support iPhone App

CHUN FAI LAW Wed, 09/25/2013 - 19:31
User Badges:

Hi stephen,


During the test, i got two SSID but i am not able to get the ip address through wireless but when i plug a computer to the ethernet port the ap it can get the ip address. Is there anything i miss in the configuration.


I find that this ap is set as

#station-role root


I find that some of the suggest is config tas non-root bridge but i it don't have this option, is it the way cause the dhcp fail?



ap_test(config-if)#station-role ?

  repeater          Repeater access point

  root              Root access point or bridge

  scanner           Scanner access point

  workgroup-bridge  Workgroup Bridge



ap_test(config-if)#station-role

Actions

This Discussion