×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

CUIC Server load balancing via ACE

Answered Question
Sep 26th, 2013
User Badges:

Hi All,


I want to load balance 4 cuic server via ACE using vip address.



Real server address: 10.0.0.21,10.0.0.22,


VIP address is : 10.0.0.50


probe http PROBE_HTTP

  interval 3

  faildetect 1

  passdetect interval 5

  passdetect count 1

  receive 2

  request method get url /index.html

  expect status 200 302



rserver host cuic_test_1

  ip address 10.0.0.21

  inservice


rserver host cuic_test_2

  ip address 10.0.0.22

  inservice


serverfarm host cuic_farm_test

  description CUIC Farm at DAKC and BCP DC

  probe PROBE_HTTP

  rserver cuic_test_1 8444

    inservice

  rserver cuic_test_2 8444

    inservice


sticky http-cookie ACE_COOKIE CUICserver_STICKY

  cookie insert

  replicate sticky

  serverfarm cuic_farm_test


class-map match-all L3_CUIC_VIP

  2 match virtual-address 10.0.0.50 tcp eq any


policy-map type loadbalance first-match cuic_L7_SLB

  class class_default

    serverfarm cuic_farm_dakc


policy-map multi-match policy_test

class L3_CUIC_VIP

    loadbalance vip inservice

    loadbalance policy cuic_L7_SLB

    nat dynamic 2 vlan 1000


interface vlan 1000

nat-pool 2 10.0.0.50 10.0.0.50 netmask 255.255.255.0

  service-policy input remote_mgmt_allow_policy

  service-policy input policy_test


Probe is success but i am not able to access the cuic via VIP.



Please do the needful.


Correct Answer by Nagabhushana .g about 3 years 10 months ago

1)You need to add port number under PROBE_HTTP

port 8444


2)In Policy map you have added wrong server farm

policy-map type loadbalance first-match cuic_L7_SLB


  class class_default


    serverfarm cuic_farm_dakc(this should be cuic_farm_test)



Please remember to rate for helpful responses

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Nagabhushana .g Fri, 09/27/2013 - 09:57
User Badges:

1)You need to add port number under PROBE_HTTP

port 8444


2)In Policy map you have added wrong server farm

policy-map type loadbalance first-match cuic_L7_SLB


  class class_default


    serverfarm cuic_farm_dakc(this should be cuic_farm_test)



Please remember to rate for helpful responses

Actions

This Discussion

Related Content