×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

DTMF issue on SIP Trunk

Unanswered Question
Sep 28th, 2013
User Badges:

Hi all,

  I've a problem with DTMF relay only on outbound direction in this topology scenario:


SIP ISP <---SIP--->Cisco UBE ISR 2811 <--SIP---> Cisco UCM 8.6.X <---SCCP---> IP Phone


I'm using codec g711 with the provider that tell me to use in-band DTMF.


SIP trunk in CUCM 8.6 configured as standard without MTP flag, outbound and inbound calls works fine, but DTMF relay works only from SIP provider to Cisco IP Phone.



From inside, any DTMF tone are not relayed to the SIP provider.


For example, call from SCCP Phone to my mobile phone, from mobile phone I can't hear any DTMF composed to the SCCP phone, but DTMF composed from the mobil ephone are recived to the internal SCCP phone.


This happen always the same in that two scenario:

Mobile phone ------> SIP ISP ---SIP--->Cisco UBE ISR 2811 --SIP---> Cisco UCM 8.6.X ---SCCP---> IP Phone

IP Phone ---SCCP---> Cisco UCM 8.6.X ---SIP---Cisco UBE ISR 2811 ---SIP--> SIP ISP ----> Mobile Phone


Can anyone help me?


Thank you very much


Regards


Alessandro Bertacco

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Carlo Poggiarelli Sat, 09/28/2013 - 09:07
User Badges:
  • Green, 3000 points or more

Hi Alessandro.
Please share youre gateway running config and a debug ccsip message during a call

Thanks

Regards

Carlo

Sent from Cisco Technical Support iPhone App

Alessandro Bertacco Sun, 09/29/2013 - 01:48
User Badges:

Hi All,

this is the CUBE configuration and debug ccsip message of an incoming call.

But how I said in the first post, the issue is the same for outgoing call.

!
! Last configuration change at 14:44:21 rome Fri Sep 27 2013 by admin
! NVRAM config last updated at 14:20:23 rome Fri Sep 27 2013 by admin
! NVRAM config last updated at 14:20:23 rome Fri Sep 27 2013 by admin
version 15.1
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname ls-VoIPgtw
!
boot-start-marker
boot-end-marker
!
!
card type e1 0 1
logging buffered 64000
!
no aaa new-model
clock timezone GMT 1 0
clock summer-time rome recurring last Sun Mar 2:00 last Sun Oct 3:00
network-clock-participate wic 1
network-clock-select 1 E1 0/1/0
!
ip source-route
!
!
ip cef
!
!

ip multicast-routing
no ipv6 cef
multilink bundle-name authenticated
!
!
!
isdn switch-type primary-net5
!
!
voice call send-alert
voice call convert-discpi-to-prog
voice call carrier capacity active
voice rtp send-recv
!
voice service voip
ip address trusted list
  ipv4 192.168.97.95
  ipv4 109.238.17.166
  ipv4 192.168.97.100
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service h450.2
no supplementary-service h450.3
redirect ip2ip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711alaw
h323
modem passthrough nse codec g711ulaw
sip
  header-passing
  registrar server expires max 3600 min 3600
  history-info
  pass-thru content sdp
  no call service stop
!
voice class media 1
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
codec preference 3 g711alaw
!
voice class codec 2
codec preference 1 g729r8
codec preference 2 g711ulaw
codec preference 3 g711alaw
codec preference 4 g729br8
!
voice class codec 3
codec preference 1 g711ulaw
codec preference 2 g729r8
!
voice class codec 4
codec preference 1 g729r8
!
voice class h323 1
  call start fast
  telephony-service ccm-compatible
  ccm-compatible
!
voice class h323 2
  h225 h245-address on-connect
  no h225 h245-address setup
  no h225 h245-address on-progress
  no h225 h245-address on-alert
  h225 h245-address facility
  h225 h245-address progress
  h225 h245-address sync
  no h225 h245-address on-setup
  call start slow
  telephony-service ccm-compatible
  ccm-compatible
!
voice class sip-profiles 1
!
!

voice translation-rule 2
rule 1 // /00/ type national national
rule 2 // /000/ type international international
rule 3 // /0/ type unknown unknown
!
voice translation-rule 20
rule 1 /^2/ //
!
voice translation-rule 30
rule 1 /^5../ /0142213010/
!
!
voice translation-profile OUT-SIP
translate calling 30
translate called 20
!
voice translation-profile PSTN-IN
translate calling 2
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
!
!
!
license udi pid CISCO2811 sn FCZ0932719P
archive
log config
  hidekeys
dial-control-mib max-size 500
!
!
controller E1 0/1/0
pri-group timeslots 1-8,16,25-31
!
!
!
!
!
!
interface FastEthernet0/0
description trunk to Switch 3750 LS Core
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
description Lan Connection
encapsulation dot1Q 1 native
ip address 192.168.100.230 255.255.255.0
ip nbar protocol-discovery
!
interface FastEthernet0/0.70
description VoIP Connection
encapsulation dot1Q 70
ip address 192.168.97.230 255.255.255.0
h323-gateway voip interface
h323-gateway voip bind srcaddr 192.168.97.230
!
interface FastEthernet0/1
description EvolAIR connection to VoipVoice SIP TRUNK
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 100
hold-queue 100 out
!
interface Serial0/1/0:15
no ip address
encapsulation hdlc
no logging event link-status
isdn switch-type primary-net5
isdn overlap-receiving T302 7000
isdn incoming-voice voice
isdn calling-number 0142330500
no cdp enable
!
interface FastEthernet0/0/0
no ip address
!
interface FastEthernet0/0/1
no ip address
!
interface FastEthernet0/0/2
no ip address
!
interface FastEthernet0/0/3
no ip address
!
interface Vlan1
no ip address
!
interface Dialer100
ip address negotiated
ip access-group INBOUND-FA0/1 in
encapsulation ppp
dialer pool 100
dialer-group 100
ppp authentication chap pap callin
ppp pap sent-username lsvoipsipitelsi password 7 123011531E185D28191D042103
!
ip default-gateway 192.168.100.254
ip forward-protocol nd
!
!
no ip http server
ip http access-class 30
ip http authentication local
ip http path flash
ip route 0.0.0.0 0.0.0.0 192.168.100.254
ip route 109.238.17.166 255.255.255.255 Dialer100
ip route 109.238.17.192 255.255.255.224 Dialer100
!
ip access-list standard NOC
permit 192.168.100.31
!
ip access-list extended INBOUND-FA0/1
permit tcp 94.100.32.0 0.0.0.255 any range 22 telnet
permit ip host 192.168.97.230 host 192.168.97.230
permit ip host 192.168.97.230 192.168.96.0 0.0.7.255
permit ip host 192.168.97.230 192.168.4.0 0.0.3.255
permit ip host 192.168.97.230 192.168.8.0 0.0.3.255
permit ip host 192.168.97.230 192.168.20.0 0.0.3.255
permit ip host 109.238.17.166 any
permit ip 109.238.17.192 0.0.0.31 any
deny   ip any any log
!
logging 192.168.100.138
access-list 30 permit 192.168.97.95
access-list 30 permit 192.168.96.0 0.0.7.255
!

!
!
control-plane
!
!
voice-port 0/1/0:15
translation-profile incoming PSTN-IN
no vad
no comfort-noise
cptone IT
bearer-cap Speech
!
ccm-manager music-on-hold
!
!
mgcp profile default
!
sccp local FastEthernet0/0.70
sccp ccm 192.168.97.100 identifier 1 version 7.0
sccp ip precedence 4
sccp
!
sccp ccm group 1
bind interface FastEthernet0/0.70
associate ccm 1 priority 1
associate profile 1 register CFB_Casale
associate profile 2 register TXC_Casale
associate profile 3 register MTP_Casale
audio dscp cs4
!
dspfarm profile 2 transcode 
codec g729br8
codec g729r8
codec g729abr8
codec g729ar8
codec g711alaw
codec g711ulaw
maximum sessions 6
associate application SCCP
!
dspfarm profile 1 conference 
codec g729br8
codec g729r8
codec g729abr8
codec g729ar8
codec g711alaw
codec g711ulaw
maximum sessions 3
associate application SCCP
!
dspfarm profile 3 mtp 
codec g711ulaw
maximum sessions software 50
associate application SCCP
!
dial-peer voice 1 pots
description OUT-PSTN
destination-pattern 0T
progress_ind alert enable 8
progress_ind progress enable 8
incoming called-number .
direct-inward-dial
port 0/1/0:15
no register e164
no sip-register

!
dial-peer voice 5 voip
description Voice CCM Imbound
preference 5
answer-address 799
destination-pattern 5..
progress_ind setup enable 3
modem passthrough nse codec g711ulaw
session target ipv4:192.168.97.100
voice-class codec 1 
voice-class h323 1
dtmf-relay h245-alphanumeric
fax-relay ecm disable
fax rate disable
ip qos dscp cs3 signaling
no vad


dial-peer voice 2001 voip
description **Incoming SIP Dial-Peer**
destination-pattern 014221301.
session protocol sipv2
session target ipv4:192.168.97.100
voice-class codec 1 
dtmf-relay rtp-nte
fax rate 14400
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 2000 voip
description **Outgoing SIP Dial-Peer**
translation-profile outgoing OUT-SIP
destination-pattern 2T
session protocol sipv2
session target sip-server
voice-class codec 1 
dtmf-relay rtp-nte
fax rate 14400
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw
ip qos dscp cs5 media
ip qos dscp cs4 signaling
authentication username 014221301 password 7 0255004C0907082F19 realm link.voipvoice.it
!
!
num-exp 142330... ...
num-exp 0142330500 850
sip-ua
credentials username 014221301 password 7 115A1D1215130C0251 realm link.voipvoice.it
keepalive target dns:link.voipvoice.it
authentication username 014221301 password 7 06550B364E4F0E1750
no remote-party-id
retry invite 2
retry register 10
timers connect 100
timers keepalive active 100
registrar dns:link.voipvoice.it expires 120
sip-server dns:link.voipvoice.it
host-registrar
!
!
gatekeeper
shutdown
!
!
call-manager-fallback
secondary-dialtone 0
max-conferences 8 gain -6
transfer-system full-consult
user-locale IT
timeouts interdigit 5
ip source-address 192.168.97.230 port 2000
max-ephones 42
max-dn 90
transfer-pattern 0T
transfer-pattern .T
time-zone 26
time-format 24
date-format dd-mm-yy
!
!
banner login ^C

Authorized access only!
Disconnect IMMEDIATELY if you are not an authorized user!

Welcome Ls admin^C
banner motd ^C


_______________________________________________________________________________


*******************************************************************************
*     Ogni tentativo di accesso a personale non autorizzato e' proibito       *
*     Scollegati IMMEDIATAMENTE se non sei un utente autorizzato              *
*           Any access request from unauthorized person is denied             *
*           Disconnect IMMEDIATELY if you are not an authorized user!         *
*******************************************************************************


_______________________________________________________________________________

^C
!
line con 0
login local
line aux 0
line vty 0 4
access-class 30 in
exec-timeout 30 0
privilege level 15
login local
transport input all
line vty 5 15
access-class 30 in
exec-timeout 30 0
privilege level 15
login local
transport input all
!
scheduler allocate 20000 1000
ntp server 192.168.100.21 prefer
ntp server 192.168.100.22
end

Alessandro Bertacco Sun, 09/29/2013 - 01:48
User Badges:

Sep 29 10:41:54.496 rome: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
REGISTER sip:link.voipvoice.it:5060 SIP/2.0
Via: SIP/2.0/UDP 94.100.34.254:5060;branch=z9hG4bK1DC01DBA
From: [email protected]>;tag=3D9E6014-1FF8
To: [email protected]>
Date: Sun, 29 Sep 2013 08:41:54 GMT
Call-ID: 56686FFD-25FA11E3-9FA59FF4-A027EC8D
User-Agent: Cisco-SIPGateway/IOS-12.x
Max-Forwards: 70
Timestamp: 1380444114
CSeq: 2641 REGISTER
Contact:
Expires:  120
Supported: path
Content-Length: 0


Sep 29 10:41:54.508 rome: //13637/000000000000/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 100 Trying
Call-ID: 56686FFD-25FA11E3-9FA59FF4-A027EC8D
CSeq: 2641 REGISTER
From: [email protected]>;tag=3D9E6014-1FF8
To: [email protected]>
Via: SIP/2.0/UDP 94.100.34.254:5060;received=94.100.34.254;rport=57581;branch=z9hG4bK1DC01DBA
Content-Length: 0


Sep 29 10:41:54.512 rome: //13637/000000000000/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 200 OK
Call-ID: 56686FFD-25FA11E3-9FA59FF4-A027EC8D
Contact: ;expires=120
CSeq: 2641 REGISTER
From: [email protected]>;tag=3D9E6014-1FF8
To: [email protected]>;tag=00-30280-35badacd-477b0cd40
Via: SIP/2.0/UDP 94.100.34.254:5060;received=94.100.34.254;rport=57581;branch=z9hG4bK1DC01DBA
P-Associated-URI: [email protected]>
Content-Length: 0


Sep 29 10:42:09.604 rome: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
INVITE sip:[email protected]:5060;transport=udp SIP/2.0
Call-ID: [email protected]
Contact:
Content-Type: application/sdp
CSeq: 8464116 INVITE
From: "0125011302" [email protected];user=phone>;tag=10278-BG-0081acae-02c6e2687
Max-Forwards: 28
Record-Route:
To:
Via: SIP/2.0/UDP 109.238.17.166:5060;branch=z9hG4bK-UWPH-99c34679-3900935c
Allow: UPDATE,REFER
Min-SE: 90
Session-Expires: 600
Supported: timer
User-Agent: Cirpack/v4.56 (gw_sip)
Content-Length: 323

v=0
o=anonymous 138044412964 138044412964 IN IP4 109.238.17.166
s=SIP Call
c=IN IP4 109.238.17.201
t=0 0
m=audio 34460 RTP/AVP 18 0 8 101
b=AS:26
a=rtpmap:18 G729/8000/1
a=fmtp:18 annexb=no
a=rtpmap:0 PCMU/8000/1
a=rtpmap:8 PCMA/8000/1
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-15
a=ptime:20
a=sendrecv

Sep 29 10:42:09.612 rome: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 422 Session Timer too small
Via: SIP/2.0/UDP 109.238.17.166:5060;branch=z9hG4bK-UWPH-99c34679-3900935c
From: "0125011302" [email protected];user=phone>;tag=10278-BG-0081acae-02c6e2687
To: ;tag=3D9E9B1C-153F
Date: Sun, 29 Sep 2013 08:42:09 GMT
Call-ID: [email protected]
CSeq: 8464116 INVITE
Allow-Events: telephone-event
Min-SE:  1800
Server: Cisco-SIPGateway/IOS-12.x
Content-Length: 0


Sep 29 10:42:09.620 rome: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:[email protected]:5060;transport=udp SIP/2.0
Call-ID: [email protected]
CSeq: 8464116 ACK
From: "0125011302" [email protected];user=phone>;tag=10278-BG-0081acae-02c6e2687
Max-Forwards: 28
To: ;tag=3D9E9B1C-153F
Via: SIP/2.0/UDP 109.238.17.166:5060;branch=z9hG4bK-UWPH-99c34679-3900935c
Content-Length: 0


Sep 29 10:42:09.640 rome: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
INVITE sip:[email protected]:5060;transport=udp SIP/2.0
Call-ID: [email protected]
Contact:
Content-Type: application/sdp
CSeq: 8464118 INVITE
From: "0125011302" [email protected];user=phone>;tag=10278-BG-0081acae-02c6e2687
Max-Forwards: 27
Record-Route:
To:
Via: SIP/2.0/UDP 109.238.17.166:5060;branch=z9hG4bK-ZQRP-99c3467e-750132e8
Allow: UPDATE,REFER
Min-SE: 1800
Session-Expires: 1800
Supported: timer
User-Agent: Cirpack/v4.56 (gw_sip)
Content-Length: 323

v=0
o=anonymous 138044412965 138044412965 IN IP4 109.238.17.166
s=SIP Call
c=IN IP4 109.238.17.207
t=0 0
m=audio 36770 RTP/AVP 18 0 8 101
b=AS:26
a=rtpmap:18 G729/8000/1
a=fmtp:18 annexb=no
a=rtpmap:0 PCMU/8000/1
a=rtpmap:8 PCMA/8000/1
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-15
a=ptime:20
a=sendrecv

Sep 29 10:42:09.664 rome: //13638/DCE3ADB2B281/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 109.238.17.166:5060;branch=z9hG4bK-ZQRP-99c3467e-750132e8
From: "0125011302" [email protected];user=phone>;tag=10278-BG-0081acae-02c6e2687
To:
Date: Sun, 29 Sep 2013 08:42:09 GMT
Call-ID: [email protected]
CSeq: 8464118 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Content-Length: 0


Sep 29 10:42:09.684 rome: //13639/DCE3ADB2B281/SIP/Msg/ccsipDisplayMsg:
Sent:
INVITE sip:[email protected]:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.97.230:5060;branch=z9hG4bK1DC12487
From: "0125011302" [email protected]>;tag=3D9E9B60-1C8F
To:
Date: Sun, 29 Sep 2013 08:42:09 GMT
Call-ID: [email protected]
Supported: 100rel,timer,resource-priority,replaces,histinfo,sdp-anat
Min-SE:  1800
Cisco-Guid: 3705908658-0672731619-2994839540-2686971021
User-Agent: Cisco-SIPGateway/IOS-12.x
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
CSeq: 101 INVITE
Timestamp: 1380444129
Contact:
History-Info: ;index=1
Expires: 180
Allow-Events: telephone-event
Max-Forwards: 26
Session-Expires:  1800
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 323

v=0
o=anonymous 138044412965 138044412965 IN IP4 109.238.17.166
s=SIP Call
c=IN IP4 192.168.97.230
t=0 0
m=audio 17050 RTP/AVP 18 0 8 101
b=AS:26
a=rtpmap:18 G729/8000/1
a=fmtp:18 annexb=no
a=rtpmap:0 PCMU/8000/1
a=rtpmap:8 PCMA/8000/1
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-15
a=ptime:20
a=sendrecv

Sep 29 10:42:09.688 rome: //13639/DCE3ADB2B281/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 192.168.97.230:5060;branch=z9hG4bK1DC12487
From: "0125011302" [email protected]>;tag=3D9E9B60-1C8F
To:
Date: Sun, 29 Sep 2013 08:42:09 GMT
Call-ID: [email protected]
CSeq: 101 INVITE
Allow-Events: presence
Content-Length: 0


Sep 29 10:42:09.704 rome: //13639/DCE3ADB2B281/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 180 Ringing
Via: SIP/2.0/UDP 192.168.97.230:5060;branch=z9hG4bK1DC12487
From: "0125011302" [email protected]>;tag=3D9E9B60-1C8F
To: ;tag=366518~2e6a0f22-2647-4b41-a189-3f8120ac75dc-21992748
Date: Sun, 29 Sep 2013 08:42:09 GMT
Call-ID: [email protected]
CSeq: 101 INVITE
Allow: INVITE, OPTIONS, INFO, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY
Allow-Events: presence
Supported: X-cisco-srtp-fallback
Supported: Geolocation
P-Asserted-Identity: "Bertacco 555"
Remote-Party-ID: "Bertacco 555" ;party=called;screen=yes;privacy=off
Contact:
Content-Length: 0


Sep 29 10:42:09.708 rome: //13638/DCE3ADB2B281/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 180 Ringing
Via: SIP/2.0/UDP 109.238.17.166:5060;branch=z9hG4bK-ZQRP-99c3467e-750132e8
From: "0125011302" [email protected];user=phone>;tag=10278-BG-0081acae-02c6e2687
To: ;tag=3D9E9B80-28A
Date: Sun, 29 Sep 2013 08:42:09 GMT
Call-ID: [email protected]
CSeq: 8464118 INVITE
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
Allow-Events: telephone-event
Contact:
Record-Route:
Server: Cisco-SIPGateway/IOS-12.x
Content-Length: 0


Sep 29 10:42:11.345 rome: %SEC-6-IPACCESSLOGRP: list INBOUND-FA0/1 denied ospf 94.100.32.63 -> 224.0.0.5, 31 packets 
Sep 29 10:42:11.345 rome: %SEC-6-IPACCESSLOGDP: list INBOUND-FA0/1 denied icmp 94.100.32.4 -> 94.100.34.254 (8/0), 40 packets 
Sep 29 10:42:14.501 rome: //13640/000000000000/SIP/Msg/ccsipDisplayMsg:
Sent:
OPTIONS sip:link.voipvoice.it:5060 SIP/2.0
Via: SIP/2.0/UDP 94.100.34.254:5060;branch=z9hG4bK1DC2177E
From: ;tag=3D9EAE38-1AFD
To:
Date: Sun, 29 Sep 2013 08:42:14 GMT
Call-ID: [email protected]
User-Agent: Cisco-SIPGateway/IOS-12.x
Max-Forwards: 70
CSeq: 101 OPTIONS
Contact:
Content-Length: 0


Sep 29 10:42:14.513 rome: //13640/000000000000/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 503 Not Implemented - Fake Return Code
Call-ID: [email protected]
CSeq: 101 OPTIONS
From: ;tag=3D9EAE38-1AFD
To: ;tag=00-08182-0081ad37-29dca5235
Via: SIP/2.0/UDP 94.100.34.254:5060;received=94.100.34.254;rport=57581;branch=z9hG4bK1DC2177E
Allow: UPDATE,REFER
Server: Cirpack/v4.56 (gw_sip)
Content-Length: 0


Sep 29 10:42:27.113 rome: //13639/DCE3ADB2B281/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 192.168.97.230:5060;branch=z9hG4bK1DC12487
From: "0125011302" [email protected]>;tag=3D9E9B60-1C8F
To: ;tag=366518~2e6a0f22-2647-4b41-a189-3f8120ac75dc-21992748
Date: Sun, 29 Sep 2013 08:42:09 GMT
Call-ID: [email protected]
CSeq: 101 INVITE
Allow: INVITE, OPTIONS, INFO, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY
Allow-Events: presence
Supported: replaces
Supported: X-cisco-srtp-fallback
Supported: Geolocation
Session-Expires:  1800;refresher=uas
Require:  timer
P-Asserted-Identity:
Remote-Party-ID: ;party=called;screen=yes;privacy=off
Contact:
Content-Type: application/sdp
Content-Length: 193

v=0
o=CiscoSystemsCCM-SIP 366518 1 IN IP4 192.168.97.100
s=SIP Call
c=IN IP4 192.168.97.50
b=TIAS:64000
b=AS:64
t=0 0
m=audio 11078 RTP/AVP 0
b=AS:26
a=rtpmap:0 PCMU/8000
a=ptime:20

Sep 29 10:42:27.129 rome: //13639/DCE3ADB2B281/SIP/Msg/ccsipDisplayMsg:
Sent:
ACK sip:[email protected]:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.97.230:5060;branch=z9hG4bK1DC3CE3
From: "0125011302" [email protected]>;tag=3D9E9B60-1C8F
To: ;tag=366518~2e6a0f22-2647-4b41-a189-3f8120ac75dc-21992748
Date: Sun, 29 Sep 2013 08:42:09 GMT
Call-ID: [email protected]
Max-Forwards: 70
CSeq: 101 ACK
Allow-Events: telephone-event
Content-Length: 0


Sep 29 10:42:27.137 rome: //13638/DCE3ADB2B281/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 109.238.17.166:5060;branch=z9hG4bK-ZQRP-99c3467e-750132e8
From: "0125011302" [email protected];user=phone>;tag=10278-BG-0081acae-02c6e2687
To: ;tag=3D9E9B80-28A
Date: Sun, 29 Sep 2013 08:42:09 GMT
Call-ID: [email protected]
CSeq: 8464118 INVITE
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
Allow-Events: telephone-event
Contact:
Record-Route:
Supported: replaces
Supported: sdp-anat
Server: Cisco-SIPGateway/IOS-12.x
Session-Expires:  1800;refresher=uas
Require: timer
Supported: timer
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 193

v=0
o=CiscoSystemsCCM-SIP 366518 1 IN IP4 192.168.97.100
s=SIP Call
c=IN IP4 94.100.34.254
b=TIAS:64000
b=AS:64
t=0 0
m=audio 19522 RTP/AVP 0
b=AS:26
a=rtpmap:0 PCMU/8000
a=ptime:20

Sep 29 10:42:27.149 rome: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:[email protected]:5060 SIP/2.0
Call-ID: [email protected]
Contact:
CSeq: 8464118 ACK
From: "0125011302" [email protected];user=phone>;tag=10278-BG-0081acae-02c6e2687
Max-Forwards: 27
To: ;tag=3D9E9B80-28A
Via: SIP/2.0/UDP 109.238.17.166:5060;branch=z9hG4bK-QXFG-99c34fed-112392a0
User-Agent: Cirpack/v4.56 (gw_sip)
Content-Length: 0


Sep 29 10:42:56.150 rome: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
BYE sip:[email protected]:5060 SIP/2.0
Call-ID: [email protected]
CSeq: 8464119 BYE
From: "0125011302" [email protected];user=phone>;tag=10278-BG-0081acae-02c6e2687
Max-Forwards: 27
Record-Route:
To: ;tag=3D9E9B80-28A
Via: SIP/2.0/UDP 109.238.17.166:5060;branch=z9hG4bK-UTNB-99c35fc8-46af6b58
Reason: q.850;cause=16
User-Agent: Cirpack/v4.56 (gw_sip)
Content-Length: 0


Sep 29 10:42:56.162 rome: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 109.238.17.166:5060;branch=z9hG4bK-UTNB-99c35fc8-46af6b58
From: "0125011302" [email protected];user=phone>;tag=10278-BG-0081acae-02c6e2687
To: ;tag=3D9E9B80-28A
Date: Sun, 29 Sep 2013 08:42:56 GMT
Call-ID: [email protected]
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 8464119 BYE
Reason: Q.850;cause=16
P-RTP-Stat: PS=1429,OS=228640,PR=1426,OR=244648,PL=0,JI=0,LA=0,DU=29
Content-Length: 0


Sep 29 10:42:56.166 rome: //13639/DCE3ADB2B281/SIP/Msg/ccsipDisplayMsg:
Sent:
BYE sip:[email protected]:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.97.230:5060;branch=z9hG4bK1DC46F5
From: "0125011302" [email protected]>;tag=3D9E9B60-1C8F
To: ;tag=366518~2e6a0f22-2647-4b41-a189-3f8120ac75dc-21992748
Date: Sun, 29 Sep 2013 08:42:09 GMT
Call-ID: [email protected]
User-Agent: Cisco-SIPGateway/IOS-12.x
Max-Forwards: 70
Timestamp: 1380444176
CSeq: 102 BYE
Reason: Q.850;cause=16
P-RTP-Stat: PS=1426,OS=227536,PR=1429,OR=245788,PL=0,JI=0,LA=0,DU=29
Content-Length: 0


Sep 29 10:42:56.186 rome: //13639/DCE3ADB2B281/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 192.168.97.230:5060;branch=z9hG4bK1DC46F5
From: "0125011302" [email protected]>;tag=3D9E9B60-1C8F
To: ;tag=366518~2e6a0f22-2647-4b41-a189-3f8120ac75dc-21992748
Date: Sun, 29 Sep 2013 08:42:56 GMT
Call-ID: [email protected]
CSeq: 102 BYE
Content-Length: 0

Ayodeji Okanlawon Sun, 09/29/2013 - 03:44
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

From the trace you have sent, it is clear that CUCM doesnt advertise rtp-nte in its 200 OK. That could suggest that your SCCP phone doesnt support rtp-nte. What model and firmware do you have on the sccp phone.


You should also ensure that the sip trunk on CUCM is set to use "no preference"


We might need to look at cucm traces to see the dtmf negotitation.


You can refer to this documentation to understand how to trouble shoot DTMF over sip trunks


https://supportforums.cisco.com/docs/DOC-33944






Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Alessandro Bertacco Mon, 09/30/2013 - 00:26
User Badges:

Thank you aokanlawon,

    so I've to analyze the Trace from CUCM, and also read your suggested document. Thank you so much.


I'll be back with further information about the issue.


Regards


Alessandro

Nagabhushana .g Sat, 09/28/2013 - 11:08
User Badges:

Alessandro,


What is set in SIP trunk(Cube to CUCM) for DTMF singnalling method ?


Enbale DTMF singnalling method -RFC2833 and try it out.


Please rate if  this will help


Bhushan

Actions

This Discussion