×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Call goes in one direction

Unanswered Question
Oct 10th, 2013
User Badges:

Hello.

I have the next scheme:

9971(1000,1003) --- cisco 3945 ---- cisco 2901 --- 7742(1020)

Calls from 7742 goes to 9971 but if I dial number of 7742 on 9971 - I get immediate drop and complete silence. What it could be? Dial peers config:

3945#sh run | s dial

dial-peer voice 1001 voip

destination-pattern 1020

session protocol sipv2

session target ipv4:10.2.4.254

----------------------------------------

2901:

dial-peer voice 1000 voip

destination-pattern 100[0-4]

session protocol sipv2

session target ipv4:10.2.4.120

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Carlo Poggiarelli Thu, 10/10/2013 - 04:54
User Badges:
  • Green, 3000 points or more

Hi Volodymyr.

Where IP Phones are registered? (CUCM/CME).

In case of 2 clusters of CUCM, did you check if the incoming calling search space is correct to call those extensions?

Let me know


Regards


Carlo



Please rate all helpful posts

"The more you help the more you learn"

Carlo Poggiarelli Thu, 10/10/2013 - 04:59
User Badges:
  • Green, 3000 points or more

Please attach a debug ccsip messages during a non working call



Thanks


Carlo



Please rate all helpful posts

"The more you help the more you learn"

Volodymyr Khrystenko Thu, 10/10/2013 - 06:07
User Badges:

Via: SIP/2.0/UDP 10.2.4.120:5060;branch=z9hG4bK292CB3

Remote-Party-ID: "Khrystenko" ;party=calling;screen=yes;privacy=off

From: "Khrystenko" ;tag=6686719C-201D

To:

Date: Thu, 10 Oct 2013 13:01:25 GMT

Call-ID: [email protected]

Supported: 100rel,timer,resource-priority,replaces,sdp-anat

Min-SE:  1800

Cisco-Guid: 3871121503-0820122083-2396055902-0007138101

User-Agent: Cisco-SIPGateway/IOS-12.x

Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER

CSeq: 101 INVITE

Timestamp: 1381410085

Contact:

Expires: 180

Allow-Events: telephone-event

Max-Forwards: 69

Content-Type: application/sdp

Content-Disposition: session;handling=required

Content-Length: 231


v=0

o=CiscoSystemsSIP-GW-UserAgent 520 7684 IN IP4 10.2.4.120

s=SIP Call

c=IN IP4 10.2.4.120

t=0 0

m=audio 17792 RTP/AVP 18 19

c=IN IP4 10.2.4.120

a=rtpmap:18 G729/8000

a=fmtp:18 annexb=no

a=rtpmap:19 CN/8000

a=ptime:20


014183: Oct 10 15:01:25.298 UTC+2: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 488 Not Acceptable Media

Via: SIP/2.0/UDP 10.2.4.120:5060;branch=z9hG4bK292CB3

From: "Khrystenko" ;tag=6686719C-201D

To: ;tag=19BA1630-20DA

Date: Thu, 10 Oct 2013 13:01:25 GMT

Call-ID: [email protected]

Timestamp: 1381410085

CSeq: 101 INVITE

Allow-Events: telephone-event

Warning: 304 10.2.4.254 "Media Type(s) Unavailable"

Reason: Q.850;cause=65

Server: Cisco-SIPGateway/IOS-15.2.4.M1


Content-Length: 0



014184: Oct 10 15:01:25.298 UTC+2: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

ACK sip:[email protected]:5060 SIP/2.0

Via: SIP/2.0/UDP 10.2.4.120:5060;branch=z9hG4bK292CB3

From: "Khrystenko" ;tag=6686719C-201D

To: ;tag=19BA1630-20DA

Date: Thu, 10 Oct 2013 13:01:25 GMT

Call-ID: [email protected]

Max-Forwards: 70

CSeq: 101 ACK

Allow-Events: telephone-event

Content-Length: 0



014185: Oct 10 15:01:29.126 UTC+2: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

INVITE sip:[email protected]:5060 SIP/2.0

Via: SIP/2.0/UDP 10.2.4.120:5060;branch=z9hG4bK295788

Remote-Party-ID: "Khrystenko" ;party=calling;screen=yes;privacy=off

From: "Khrystenko" ;tag=66868096-17F9

To:

Date: Thu, 10 Oct 2013 13:01:29 GMT

Call-ID: [email protected]

Supported: 100rel,timer,resource-priority,replaces,sdp-anat

Min-SE:  1800

Cisco-Guid: 3910213195-0820122083-2396580190-0007138101

User-Agent: Cisco-SIPGateway/IOS-12.x

Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER

CSeq: 101 INVITE

Timestamp: 1381410089

Contact:

Expires: 180

Allow-Events: telephone-event

Max-Forwards: 69

Content-Type: application/sdp

Content-Disposition: session;handling=required

Content-Length: 232

Andrey Chertolyas Thu, 10/10/2013 - 06:22
User Badges:

SIP/2.0 488 Not Acceptable Media - this message most likely means that there is a codec mismatch issue. Please provide dial peers configuration from both sides.



Kind regards,
Andrew C.

Carlo Poggiarelli Thu, 10/10/2013 - 06:57
User Badges:
  • Green, 3000 points or more

Hi.

On 3945:

dial-peer voice 1001 voip

codec g711ulaw

dtmf-relay rtp-nte

no vad


----------

on 2901

dial-peer voice 1000 voip

codec g711ul

dtmf-relay rtp-nte

no vad



HTH


Regards

Carlo




Please rate all helpful posts

"The more you help the more you learn"

Volodymyr Khrystenko Thu, 10/10/2013 - 07:05
User Badges:

How I got fast busy tone and :

Oct 10 17:05:08.899 UTC+3: //2441/CDD3F5308FC1/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 503 Service Unavailable

Via: SIP/2.0/UDP 10.5.150.2:5060;branch=z9hG4bK14c9a4e8

From: "Khrystenko" ;tag=58971ecd6808003759df5365-370a1d29

To: ;tag=66C0C534-12F1

Date: Thu, 10 Oct 2013 14:05:07 GMT

Call-ID: [email protected]

CSeq: 101 INVITE

Allow-Events: telephone-event

Server: Cisco-SIPGateway/IOS-12.x

Reason: Q.850;cause=47

Content-Length: 0



Oct 10 17:05:08.905 UTC+3: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

ACK sip:[email protected];user=phone SIP/2.0

Via: SIP/2.0/UDP 10.5.150.2:5060;branch=z9hG4bK14c9a4e8

From: "Khrystenko" ;tag=58971ecd6808003759df5365-370a1d29

To: ;tag=66C0C534-12F1

Call-ID: [email protected]

Date: Thu, 10 Oct 2013 14:05:08 GMT

CSeq: 101 ACK

Content-Length: 0



Oct 10 17:05:08.913 UTC+3: //0/000000000000/SIP/Msg/ccsipDisplayMsg:

Received:

SIP/2.0 200 OK

Via: SIP/2.0/UDP 10.5.150.254:5060;branch=z9hG4bK2D5253D

From: ;tag=66C0C1A8-198E

To: ;tag=58971ecd68080038757a51d9-676f638a

Call-ID: [email protected]

Date: Thu, 10 Oct 2013 14:05:08 GMT

CSeq: 102 SUBSCRIBE

Server: Cisco-CP9971/9.2.1

Contact:

Expires: 0

Content-Length: 0

Carlo Poggiarelli Thu, 10/10/2013 - 07:13
User Badges:
  • Green, 3000 points or more

Hi

Can you please attach both vg configuration?


Thanks



Carlo



Please rate all helpful posts

"The more you help the more you learn"

Andrey Chertolyas Thu, 10/10/2013 - 07:14
User Badges:

To: ; - that's strange, do you really have a phone with number 1 registered? Could you provide full telephony-related configuration from both gateways?



Kind regards,
Andrew C.

Volodymyr Khrystenko Thu, 10/10/2013 - 07:34
User Badges:

On 2901:

Building configuration...



Current configuration : 8352 bytes

!

! Last configuration change at 17:25:44 UTC+3 Thu Oct 10 2013 by vkhrystenko

! NVRAM config last updated at 19:49:41 UTC+3 Fri Oct 4 2013 by vkhrystenko

! NVRAM config last updated at 19:49:41 UTC+3 Fri Oct 4 2013 by vkhrystenko

version 15.1

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime

service password-encryption

!

hostname DMZ-ISR-L

!

boot-start-marker

boot-end-marker

!

!

enable secret 4 50orVilsugq550D3ZKx/scefA8kvn3WdHZm7.0/Vta2

!

no aaa new-model

!

clock timezone UTC+3 3 0

clock summer-time sumkiev recurring last Sun Mar 4:00 last Sun Sep 4:00

!

no ipv6 cef

ip source-route

!

!

ip cef

!

ip dhcp excluded-address 10.5.150.254

!

ip dhcp pool VOICE_SCOPE

network 10.5.150.0 255.255.255.0

default-router 10.5.150.254

option 150 ip 10.5.150.254

dns-server 10.2.4.23 8.8.8.8

!

ip dhcp pool DATA

network 10.5.100.0 255.255.255.0

default-router 10.5.100.254

option 150 ip 10.5.100.254

dns-server 8.8.8.8

!

!

no ip domain lookup

ip domain name yourdomain.com

!

multilink bundle-name authenticated

!

!

!

!

!

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-88597495

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-88597495

revocation-check none

rsakeypair TP-self-signed-88597495

!

!

crypto pki certificate chain TP-self-signed-88597495

certificate self-signed 01

  30820227 30820190 A0030201 02020101 300D0609 2A864886 F70D0101 05050030

  2F312D30 2B060355 04031324 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 38383539 37343935 301E170D 31323132 32393038 31333338

  5A170D32 30303130 31303030 3030305A 302F312D 302B0603 55040313 24494F53

  2D53656C 662D5369 676E6564 2D436572 74696669 63617465 2D383835 39373439

  3530819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 8100D9A8

  3C31C925 35DB0391 C1FAD203 F5FB0805 EC0A9FD0 82211E5E C6C0075F 35513F76

  142E9957 7C188477 D37F8074 BF98C3E5 BD28E1D7 2AE4E722 17E14147 6AA9C691

  45236E40 A809F91E 7006C909 282C41FF 7EC3AD48 34E22680 D3187B85 04AF7CCC

  B5F69A04 CD019CB6 B3BC19AE 234B46F4 1DA9C0AE 8884C480 43A58B02 AD170203

  010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603 551D2304

  18301680 140F7BF9 CE4D76C6 55D095A1 E3CD3608 A7EEC8C5 1F301D06 03551D0E

  04160414 0F7BF9CE 4D76C655 D095A1E3 CD3608A7 EEC8C51F 300D0609 2A864886

  F70D0101 05050003 81810024 5BD07113 BC712B2F E1E820B2 3294CEB8 BC4C5B36

  8299CDAC D33534DE 921E5344 4AF508EE 522CD168 6486F581 3422D79F F4D71C21

  62F09B3A 9AB1CB6A 212CAE5A F8E21F35 4368C175 836B0D07 15E66805 7E578CFA

  1057513A E22CF31F F083166B F1130406 3AE085EE 7956750E D0C809A4 29365D28

  095A0809 01EE39D2 74D809

      quit

voice-card 0

!

!

!

voice service voip

allow-connections sip to sip

no supplementary-service sip handle-replaces

redirect ip2ip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

sip

  registrar server expires max 3600 min 120

!

!

voice register global

mode cme

source-address 10.5.150.254 port 5060

max-dn 10

max-pool 10

load 9971 sip9971.9-2-2SR1-9.loads

authenticate register

timezone 31

time-format 24

date-format D/M/Y

tftp-path flash:

create profile sync 000201490805545A

!

voice register dn  1

number 1000

name Khrystenko

label Khrystenko Vlad 1

!

voice register dn  2

number 1003

name Khrystenko

label Khrystenko Vlad 2

!

voice register dn  9

number 3636

name 3636

label 3636

!

voice register pool  1

id mac 5897.1ECD.6808

type 9971

number 1 dn 1

number 2 dn 2

dtmf-relay sip-notify

username vkhrystenko password XXXX

description Khrystenko

!

voice register pool  2

id mac 7C1E.B300.49FF

number 1 dn 9

dtmf-relay sip-notify

username 3636 password 3636

!

!

!

!

license udi pid C3900-SPE250/K9 sn FOC1651515Y

license accept end user agreement

!

!

hw-module pvdm 0/0

!

username vkhrystenko privilege 15 password 7 071B20434051415D4F

!

redundancy

!

!

!

!

!

!

!

!

!

!

!

interface GigabitEthernet0/0

description for_mgmt_temporary

ip address 10.2.4.120 255.255.255.0

duplex auto

speed auto

media-type rj45

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

media-type rj45

!

interface GigabitEthernet0/1.5

encapsulation dot1Q 5

ip address 10.5.5.254 255.255.255.0

!

interface GigabitEthernet0/1.100

encapsulation dot1Q 100

ip address 10.5.100.254 255.255.255.0

!

interface GigabitEthernet0/1.254

encapsulation dot1Q 150

ip address 10.5.150.254 255.255.255.0

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/3

no ip address

shutdown

duplex auto

speed auto

!

ip forward-protocol nd

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip route 0.0.0.0 0.0.0.0 10.2.4.254

ip route 10.0.0.0 255.0.0.0 10.2.4.254

!

access-list 100 permit ip 10.0.0.0 0.255.255.255 any

!

!

!

!

nls resp-timeout 1

cpd cr-id 1

!

tftp-server flash:/Cisco9971/dkern9971.100609R2-9-2-2SR1-9.sebn alias dkern9971.100609R2-9-2-2SR1-9.sebn

tftp-server flash:/Cisco9971/kern9971.9-2-2SR1-9.sebn alias kern9971.9-2-2SR1-9.sebn

tftp-server flash:/Cisco9971/rootfs9971.9-2-2SR1-9.sebn alias rootfs9971.9-2-2SR1-9.sebn

tftp-server flash:/Cisco9971/sboot9971.031610R1-9-2-2SR1-9.sebn alias sboot9971.031610R1-9-2-2SR1-9.sebn

tftp-server flash:/Cisco9971/sip9971.9-2-2SR1-9.loads alias sip9971.9-2-2SR1-9.loads

tftp-server flash:/Cisco9971/skern9971.022809R2-9-2-2SR1-9.sebn alias skern9971.022809R2-9-2-2SR1-9.sebn

tftp-server Cisco7942/term62.default.loads alias term62.default.loads

tftp-server Cisco7942/term42.default.loads alias term42.default.loads

tftp-server Cisco7942/SCCP42.9-2-1S.loads alias SCCP42.9-2-1S.loads

tftp-server Cisco7942/jar42sccp.9-2-1TH1-13.sbn alias jar42sccp.9-2-1TH1-13.sbn

tftp-server Cisco7942/dsp42.9-2-1TH1-13.sbn alias dsp42.9-2-1TH1-13.sbn

tftp-server Cisco7942/cvm42sccp.9-2-1TH1-13.sbn alias cvm42sccp.9-2-1TH1-13.sbn

tftp-server Cisco7942/apps42.9-2-1TH1-13.sbn alias apps42.9-2-1TH1-13.sbn

tftp-server Cisco7942/cnu42.9-2-1TH1-13.sbn alias cnu42.9-2-1TH1-13.sbn

!

control-plane

!

!

!

!

mgcp profile default

!

!

dial-peer voice 1001 voip

destination-pattern 1020

session protocol sipv2

session target ipv4:10.2.4.254

dtmf-relay rtp-nte

codec g711ulaw

no vad

!

!

gateway

timer receive-rtp 1200

!

!

!

gatekeeper

shutdown

!

!

telephony-service

max-ephones 10

max-dn 20

ip source-address 10.5.150.254 port 2000

timeouts ringing 10

system message Altis holding

cnf-file location flash:

time-zone 31

time-format 24

date-format dd-mm-yy

max-conferences 8 gain -6

transfer-system full-consult

directory entry 1 911 name Support IT

!

!

ephone-dn  2

number 1002

label Zatyshnyi Dima 2

description Secondary line

name Zatyshnyi

!

!

ephone-dn  3

number 1010

pickup-group 1

!

!

ephone-dn  5

number 4

park-slot timeout 20 limit 2 notify 1010 transfer 1010 retry 5 limit 3

name Parking...

!

!

ephone-dn  6

number 7

park-slot timeout 20 limit 2 notify 1010 transfer 1010 retry 5 limit 3

name Parking...

!

!

ephone-dn  7

number 6

park-slot timeout 20 limit 2 notify 1010 transfer 1010 retry 5 limit 3

name Parking...

!

!

ephone-dn  8

number 5

park-slot timeout 20 limit 2 notify 1010 transfer 1010 retry 5 limit 3

name Parking...

!

!

ephone-dn  9

number A101002

description Intercom

intercom A100102 barge-in label "Zatyshniy"

!

!

ephone-dn  10

number A100102

description Intercom

intercom A101002 barge-in label "PC"

!

!

ephone-dn  11

number 3333

name Myphones

paging ip 239.0.0.1 port 2000

!

!

ephone-dn  12

number 3355

name HolePhones

paging ip 239.1.1.1 port 2000

paging group 11

!

!

ephone  1

device-security-mode none

mac-address 8478.ACE6.3343

username "zat" password zat

paging-dn 11

type 7942

button  2:10

!

!

!

ephone  2

device-security-mode none

mac-address 1803.7374.56EF

paging-dn 11

type CIPC

button  1:3 2:9

!

!

!

ephone  3

device-security-mode none

mac-address 8478.ACE6.33AE

type 7942

!

!

!

!

line con 0

password 7 070C2E425D061500131F11

logging synchronous

login local

line aux 0

line vty 0 4

access-class 100 in

login local

transport input ssh

line vty 5 13

access-class 100 in

login

transport input all

line vty 14 15

login local

transport input all

!

scheduler allocate 20000 1000

ntp master 5

ntp server 78.152.160.1

end

Volodymyr Khrystenko Thu, 10/10/2013 - 07:45
User Badges:

On 2901:

Building configuration...



Current configuration : 59418 bytes

!

! Last configuration change at 16:15:58 UTC+2 Thu Oct 10 2013 by admin2

! NVRAM config last updated at 15:39:53 UTC+2 Thu Oct 10 2013 by admin1

! NVRAM config last updated at 15:39:53 UTC+2 Thu Oct 10 2013 by admin1

version 15.2

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime

service password-encryption

service sequence-numbers

!

hostname cisco2901

!

boot-start-marker

boot system flash:c2900-universalk9-mz.SPA.152-4.M1.bin

boot system flash:c2900-universalk9-mz.SPA.151-2.T1.bin

boot-end-marker

!

!

logging buffered 51200

logging console critical

!

aaa new-model

!

!

aaa accounting connection default start-stop group radius

aaa accounting connection h323 start-stop group radius

aaa accounting system default start-stop group radius

aaa accounting resource default start-stop group radius

!

!

!

!

!

aaa session-id common

clock timezone UTC+2 2 0

clock summer-time sumkiev recurring last Sun Mar 4:00 last Sun Sep 4:00

!

no ip source-route


no ip bootp server

no ip domain lookup

ip domain name altis.local

ip name-server 10.2.4.23

ip dhcp-server 10.2.1.59

ip dhcp-server 10.2.1.57

ip dhcp-server 10.2.1.56

ip dhcp-server 10.2.1.58

ip cef

l2tp-class l2tpclass1

!

no ipv6 cef

multilink bundle-name authenticated

!

!

stcapp ccm-group 1

!

stcapp feature access-code

!

stcapp feature speed-dial

!

!

!

stcapp supplementary-services

port 0/0/0

  fallback-dn 2201

port 0/0/1

  fallback-dn 2101

port 0/0/2

  fallback-dn 2399

port 0/0/3

  fallback-dn 2102

!

!

!

!

crypto pki trustpoint TP-self-signed-703877443

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-703877443

revocation-check none

!

!


voice-card 0

dspfarm

dsp services dspfarm

!

!

!

voice service voip

ip address trusted list

  ipv4 x.x.x.x 255.255.255.255

  ipv4 10.2.1.212 255.255.255.255

  ipv4 10.2.4.200 255.255.255.255

  ipv4 x.x.x.x 255.255.255.255

allow-connections sip to sip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

sip

  bind control source-interface GigabitEthernet0/0

  bind media source-interface GigabitEthernet0/0

  registrar server

!

voice class codec 10

codec preference 1 g711alaw

codec preference 2 g711ulaw

!

!

voice register global

mode cme

max-dn 200

max-pool 42

create profile sync 0380025834254157

!

!

!


voice translation-rule 3

rule 1 /\.*/ /0\1/

!

voice translation-rule 4

rule 1 /^38\.*/ /\1/

!

!

voice translation-profile 1

translate calling 3

translate called 1

!

voice translation-profile 2

translate calling 2

!

voice translation-profile 3

translate calling 2

translate called 4

!

!

!


!

!

vxml version 2.0

license udi pid CISCO2901/K9 sn FCZ1446904G

license boot module c2900 technology-package securityk9

hw-module pvdm 0/0

!

!

!

!

redundancy

!

!

ip tcp synwait-time 10

ip ssh version 2

!

track 1 ip sla 1 reachability

!

class-map match-all exhmap

match access-group name exchsync

class-map match-all Telepresence

class-map match-all exchmap2

match qos-group 1023

class-map match-all exchmap

class-map match-all exchsyncmap

match access-group name exchsync

class-map match-all video

match protocol rtp video

class-map match-all databases

class-map match-all voice

match protocol rtp audio

!

policy-map wanpolicy

class exchmap2

  police cir 10000000 conform-action transmit  exceed-action drop

policy-map OUTPUT

class voice

  priority 10000

class class-default

  fair-queue

policy-map exchpol

class exhmap

  set qos-group 1023

policy-map QoSforTP

class Telepresence

  priority 1000

class databases

class class-default

!

gw-accounting aaa

acct-template callhistory-detail

!

bridge irb

!

!

!

!



protocol ieee

bridge 41 route ip

!

voice-port 0/0/0

!

voice-port 0/0/1

!

voice-port 0/0/2

!

voice-port 0/0/3

!

voice-port 0/1/0

!

voice-port 0/1/1

!

voice-port 0/1/2

!

voice-port 0/1/3

!

!

!

!

ccm-manager mgcp

ccm-manager config server 10.2.4.200 

ccm-manager config

ccm-manager sccp local GigabitEthernet0/1.40

ccm-manager sccp

!

mgcp

mgcp call-agent 10.2.4.200 service-type mgcp version 0.1

mgcp package-capability rtp-package

mgcp bind control source-interface GigabitEthernet0/1.40

mgcp bind media source-interface GigabitEthernet0/1.40

!

mgcp profile default

!

sccp local GigabitEthernet0/1.40

sccp ccm 10.2.4.200 identifier 1 version 7.0

sccp

!

sccp ccm group 1

bind interface GigabitEthernet0/1.40

associate ccm 1 priority 1

associate profile 1 register XCODE123456

!

dspfarm profile 1 transcode 

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

maximum sessions 6

associate application SCCP

!

dial-peer voice 1000 voip

destination-pattern 100[0-4]

session protocol sipv2

session target ipv4:10.2.4.120

dtmf-relay rtp-nte

codec g711ulaw

no vad

!

!

gateway

timer receive-rtp 1200

!


!

!

!

gatekeeper

shutdown

!

!

telephony-service

sdspfarm units 1

sdspfarm transcode sessions 16

sdspfarm tag 1 XCODE123456

video

  maximum bit-rate 2000

max-ephones 10

max-dn 10

ip source-address 10.2.3.1 port 2000

service phone videoCapability 1

max-conferences 8 gain -6

moh "flash0:moh.au"

transfer-system full-consult

transfer-pattern 2555

transfer-pattern 2...

transfer-pattern 2777

transfer-pattern 2304

transfer-pattern 0952810902

transfer-pattern 3134

!

!

ephone-dn  1

number 1001 no-reg primary

!

!

ephone-dn  2

number 1020 no-reg primary

!

!

ephone  1

mac-address 8478.ACE6.3343

type 7942

button  1:2

!

!

!


end

Andrey Chertolyas Thu, 10/10/2013 - 08:57
User Badges:

Hello,


As I understand, your second configuration is from 3945, not from 2901 as you indicated, is it correct? Please check it and correct accordingly.


At least you should implement this commands on your 2901:


sip

  bind control source-interface GigabitEthernet0/0

  bind media source-interface GigabitEthernet0/0


It is needed to specify the particular IP address to bind the SIP server to make sure that every SIP conversation originated on 2901 would use the IP address of gi0/0 which is 10.2.4.120


Another thing you can change is to add the address of originating interface on 2901 (which is 10.2.4.120) to 'ip addresses trusted list' on 3945, since it is not clear if you have it specified. Then make a call and gather next debugs in case it still doesn't work:


debug voice ccapi inout

debug ccsip messages


BTW, 10.2.4.254 is the address of gi0/0 on 3945, right?




Kind regards,
Andrew C.

Andrey Chertolyas Mon, 10/14/2013 - 03:52
User Badges:

Hey Volodimir,


Did you have a chance to check my recommendations?



Kind regards,
Andrew C.

Volodymyr Khrystenko Mon, 10/14/2013 - 06:45
User Badges:

Hello. I just set codec to 711ulaw between routers and on 3945 to SIp phone and everything starts working. Stange((

Actions

This Discussion