×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

CUCM 8.6 Directory creation

Unanswered Question
Oct 10th, 2013
User Badges:

Ive created a new 8.6 PUB/SUB and want to create a directory to look up users.  I dont want the default directory thats installed so I guess I have to host a new one somewhere else.  I have a win 2008 Domain controller that I created a new directory .jsp file in a folder and tried pointing the Call Manager at it but it doesnt seem to see it.  Im just assuming that it would work.


I guess my question is, if one doesnt want to use the default directory then how do we get a new one?   The only reason I dont want to use the default directory is that it asks for a username and pin everytime which will drive my users insane,

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
mkchandak Thu, 10/10/2013 - 09:34
User Badges:

How to create and use custom Global Directory should be a question posted on Developer support, there is always a better chance of getting response there.


Are you searching Corporate Directory from the phone ? It does not require the user to enter password. Password is required for Personal Directory.


Also, corporate directory picks the list of users from CUCM End users list. Therefore all users that you have listed in the end users, it should be displayed in Corporate Directory.

lonmc1977 Thu, 10/10/2013 - 10:00
User Badges:

Ok, but when I select corp directory nothing happens.  I have end users, just nothing comes up.  So maybe its supposed to be working but isnt for some reason.

lonmc1977 Thu, 10/10/2013 - 10:02
User Badges:

And yes, it is from the phone im trying to access it.  I se personal directory and corporate directory.  When I use the Corprate Directory, it just stays at that same menu without looking anything up.  personal directory asks for a username and pin but that can go away as far as I care.

George Thomas Thu, 10/10/2013 - 10:34
User Badges:
  • Blue, 1500 points or more

What model phone are you using?


Could you make sure the URL Directories under Enterprise Parameters shows the IP? If you want it show DNS, can you make sure the phone subnet has DNS specified if its DHCP.



Please rate useful posts.

lonmc1977 Thu, 10/10/2013 - 11:14
User Badges:

Yep, I changed the IPs a while ago to that exact format URL you have there.  Im using 7960/7961 phones.  Ive tried multiple phones. 

mkchandak Thu, 10/10/2013 - 20:08
User Badges:

Yes, it is referring to itself, which is incorrect. The right URL for it to point to would be  http://172.16.1.240:8080/ccmcip/xmldirectoryinput.jsp


Did someone root into the server and make some changed ?

What is the exact version of CUCM that you are using ? Please provide the complete version. --> Click on About -->

System version: ( Example: 8.6.1.20000-1)

lonmc1977 Fri, 10/11/2013 - 06:05
User Badges:

Its version 8.6.2.20000 -2


Ive built this thing from the begining and I dont even know how to change the directory from the CLI anyway.  So Im not sure how it got that way.  Guess I need to figure out how to get a working one back but im not sure thats possible to change the JSP file on the call manager itself.

Actions

This Discussion