E1 head Number assignment

Endorsed Question
Oct 10th, 2013
User Badges:

Hi All,


I've configured my E1 port on cucm but when i try to dial outside i got a dis order tone, when i contact the SP provider they told me that i've to register the head number they game to the e1. please guide me how can i do that ?


best regards

kennedy

Endorsed by paolo bevilacqua
Jaime Valencia about 3 years 10 months ago

He does need dial peers and to switch to h323, we do not support partial PRI with MGCP.

Sent from Cisco Technical Support iPad App

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
paolo bevilacqua Fri, 10/11/2013 - 00:04
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

There is nothing to register with E1.

You can take "debug isdn q931" with "term mon".

KENNEDY BIZUAYE... Fri, 10/11/2013 - 00:27
User Badges:

Hi,

please see my debug result


when i call from office (E1) to pstn


moencovg#no debug isdn q931

debug isdn q931 is              OFF.

moencovg#debug isdn q931

debug isdn q931 is              ON.

moencovg#

*Oct 11 07:09:25.970: ISDN Se0/0/0:15 Q931: TX -> SETUP pd = 8  callref = 0x0002

        Sending Complete

        Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA98394

                Exclusive, Channel 20

        Calling Party Number i = 0x0081, '+251116170909'

                Plan:Unknown, Type:Unknown

        Called Party Number i = 0x80

                Plan:Unknown, Type:Unknown

*Oct 11 07:09:25.982: ISDN Se0/0/0:15 Q931: RX <- RELEASE pd = 8  callref = 0x0155

        Cause i = 0x8292 - No user responding

*Oct 11 07:09:25.982: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8155

        Cause i = 0x80D1 - Invalid call reference value

*Oct 11 07:09:25.982: ISDN Se0/0/0:15 Q931: RX <- RELEASE pd = 8  callref = 0x0155

        Cause i = 0x8292 - No user responding

*Oct 11 07:09:25.982: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8155

        Cause i = 0x80D1 - Invalid call reference value

*Oct 11 07:09:26.970: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8155

        Cause i = 0x80D1 - Invalid call reference value

*Oct 11 07:09:29.982: ISDN Se0/0/0:15 Q931: TX -> SETUP pd = 8  callref = 0x0002

        Sending Complete

        Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA98394

                Exclusive, Channel 20

        Calling Party Number i = 0x0081, '+251116170909'

                Plan:Unknown, Type:Unknown

        Called Party Number i = 0x80

                Plan:Unknown, Type:Unknown

*Oct 11 07:09:30.982: ISDN Se0/0/0:15 Q931: TX -> SETUP pd = 8  callref = 0x0002

        Sending Complete

        Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA98394

                Exclusive, Channel 20

        Calling Party Number i = 0x0081, '+251116170909'

                Plan:Unknown, Type:Unknown

        Called Party Number i = 0x80

                Plan:Unknown, Type:Unknown

*Oct 11 07:09:34.002: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x0002

        Cause i = 0x80E6 - Recovery on timer expiry

*Oct 11 07:09:35.002: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x0002

        Cause i = 0x80E6 - Recovery on timer expiry

###############################################################################


when i call from pstn to office (E1)

moencovg#debug isdn q931

debug isdn q931 is              ON.

moencovg#

*Oct 11 07:06:52.330: ISDN Se0/0/0:15 Q931: RX <- SETUP pd = 8  callref = 0x0155

        Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA9838F

                Exclusive, Channel 15

        Calling Party Number i = 0x4183, '912195132'

                Plan:ISDN, Type:Subscriber(local)

        Called Party Number i = 0xC1, '0116170909'

                Plan:ISDN, Type:Subscriber(local)

*Oct 11 07:06:52.338: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8155

        Cause i = 0x809B - Destination out of order

*Oct 11 07:06:53.338: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8155

        Cause i = 0x809B - Destination out of order

*Oct 11 07:06:54.862: ISDN Se0/0/0:15 Q931: RX <- SETUP pd = 8  callref = 0x0155

        Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA9838F

                Exclusive, Channel 15

        Calling Party Number i = 0x4183, '912195132'

                Plan:ISDN, Type:Subscriber(local)

        Called Party Number i = 0xC1, '0116170909'

                Plan:ISDN, Type:Subscriber(local)

*Oct 11 07:06:54.866: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8155

        Cause i = 0x809B - Destination out of order

*Oct 11 07:06:55.866: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8155

        Cause i = 0x809B - Destination out of order

*Oct 11 07:06:58.858: ISDN Se0/0/0:15 Q931: RX <- DISCONNECT pd = 8  callref = 0x0155

        Cause i = 0x82E6 - Recovery on timer expiry

*Oct 11 07:06:58.858: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8155

        Cause i = 0x80D1 - Invalid call reference value

*Oct 11 07:06:59.858: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8155

        Cause i = 0x80D1 - Invalid call reference value

Nishant Savalia Fri, 10/11/2013 - 01:14
User Badges:
  • Silver, 250 points or more

Hi kennedy,

Incase of outgoing call you are sending called number as blank. Please check your configuration.


Which protocol you are using? What is the call flow?

can you share network topology?


Also share your running config of your Voice gateway



Regards,

Nishant Savalia

KENNEDY BIZUAYE... Fri, 10/11/2013 - 01:59
User Badges:

Hi Nishant,

protocol is MGCP


running config is attached below but i didn't create any dial peer for e1 is it a must ? please help me coz i have no one beside me here

paolo bevilacqua Fri, 10/11/2013 - 01:12
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

You have the wrong configuration in CUCN and /or router, that is the number translations are wrong.


Recommend you get a reputable consultant ot Certified Cisco partner for this, do not attempt to do yourself.

mkchandak Fri, 10/11/2013 - 01:24
User Badges:

You seem to be missing some/lot of configuration. You might have your e1 configured, but i dont think you have dial peers configured on the gateway for incoming calls and for outbound there is something else missing.


Can you post your router configuration. If something simple can be done, will try to help you, else, like Paolo mentioned, you need to hire someone to knows this well.

KENNEDY BIZUAYE... Fri, 10/11/2013 - 01:38
User Badges:

Hi

please see below my router config


moencovg#sh run

Building configuration...



Current configuration : 7536 bytes

!

! Last configuration change at 08:29:53 UTC Fri Oct 11 2013 by admin

version 15.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname moencovg

!

boot-start-marker

boot-end-marker

!

!

card type e1 0 0

logging buffered 51200 warnings

enable secret 4 c5LFTnp3A5C3Ds2sCA3PU0Csl6Q1V1MpHyKNktEi5tI

!

no aaa new-model

network-clock-participate wic 0

!

ip cef

!

!

!

ip dhcp excluded-address 10.10.10.1

!

!

!

ip domain name moenco.corp

ip name-server 172.20.0.23

no ipv6 cef

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-net5

!

!

crypto pki trustpoint TP-self-signed-3990007969

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3990007969

revocation-check none

rsakeypair TP-self-signed-3990007969

!

!

crypto pki certificate chain TP-self-signed-3990007969

certificate self-signed 01

  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 33393930 30303739 3639301E 170D3133 30363139 30373030

  30385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 39393030

  30373936 3930819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100E6F7 448AA926 A7D8AAD8 D3488CFF F2928A99 E7A427F1 6EFEC5F6 0706E9B8

  505657CE 98499BD6 9D7D21AF 55718077 077128E1 21C8DFD4 CD1E9F79 D161DEBC

  D107795F BDB1E908 582C3140 A4F1FBC2 00C75850 28A3309F 84F229D0 95BD7ADE

  121CF969 275BF813 048504D4 9D12A4B7 2A724A78 CF02A15F 29927BC8 39F5482C

  F8130203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603

  551D2304 18301680 14B41221 0B2A24EC A4EB7BC8 74DD5344 87E4A0BF BD301D06

  03551D0E 04160414 B412210B 2A24ECA4 EB7BC874 DD534487 E4A0BFBD 300D0609

  2A864886 F70D0101 05050003 81810072 33910E76 9A03BBBF FDCFD9F5 C384A55B

  D6D7E295 03AD17F8 4F7AF038 5A694E57 8A8858C4 61F10181 28C7CD37 FDAD2D1C

  56CAD1D6 31AAE479 773A5807 61C136D4 EE6646A9 D7153DE9 DADB4414 68DAC5D9

  3DDA1AED 6712F942 4000B818 D7424520 CBBCF430 1748A277 C1AB92C3 08905875

  430F1134 6C192164 81BD656D 398B82

        quit

voice-card 0

!

!

!

!

!

!

!

!

license udi pid CISCO2921/K9 sn FCZ172560ED

hw-module pvdm 0/0

!

!

!

username XXXX privilege 15 password 0 XXXX

!

redundancy

!

!

controller E1 0/0/0

framing NO-CRC4

pri-group timeslots 1-20 service mgcp

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

ip address 172.20.0.49 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

ip default-gateway 172.20.0.11

ip forward-protocol nd

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

access-list 23 permit 10.10.10.0 0.0.0.7

!

!

!

control-plane

!

!

voice-port 0/0/0:15

!

voice-port 0/1/0

!

voice-port 0/1/1

!

voice-port 0/1/2

!

voice-port 0/1/3

!

voice-port 0/2/0

timing hookflash-out 50

timing guard-out 1000

!

voice-port 0/2/1

timing hookflash-out 50

timing guard-out 1000

!

voice-port 0/2/2

timing hookflash-out 50

timing guard-out 1000

!

voice-port 0/2/3

timing hookflash-out 50

timing guard-out 1000

!

voice-port 0/3/0

timing hookflash-out 50

timing guard-out 1000

!

voice-port 0/3/1

timing hookflash-out 50

timing guard-out 1000

!

voice-port 0/3/2

timing hookflash-out 50

timing guard-out 1000

!

voice-port 0/3/3

timing hookflash-out 50

timing guard-out 1000

!

!

!

!

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 172.20.0.41

ccm-manager config

!

mgcp

mgcp call-agent 172.20.0.41 2427 service-type mgcp version 0.1

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

!

mgcp profile default

!

!

dial-peer voice 999021 pots

service mgcpapp

port 0/2/1

!

dial-peer voice 999022 pots

service mgcpapp

port 0/2/2

!

dial-peer voice 999020 pots

service mgcpapp

port 0/2/0

!

dial-peer voice 999023 pots

service mgcpapp

port 0/2/3

!

dial-peer voice 999030 pots

service mgcpapp

port 0/3/0

!

dial-peer voice 999031 pots

service mgcpapp

port 0/3/1

!

dial-peer voice 999032 pots

service mgcpapp

port 0/3/2

!

dial-peer voice 999033 pots

service mgcpapp

port 0/3/3

!

dial-peer voice 999010 pots

service mgcpapp

port 0/1/0

!

dial-peer voice 999011 pots

service mgcpapp

port 0/1/1

!

dial-peer voice 999012 pots

service mgcpapp

port 0/1/2

!

dial-peer voice 999013 pots

service mgcpapp

port 0/1/3

!

!

!

!

gatekeeper

shutdown

!

!

banner exec ^C

% Password expiration warning.

-----------------------------------------------------------------------


Cisco Configuration Professional (Cisco CP) is installed on this device

and it provides the default username "cisco" for  one-time use. If you have

already used the username "cisco" to login to the router and your IOS image

supports the "one-time" user option, then this username has already expired.

You will not be able to login to the router with this username after you exit

this session.


It is strongly suggested that you create a new username with a privilege level

of 15 using the following command.


username privilege 15 secret 0


Replace and with the username and password you want to

use.


-----------------------------------------------------------------------

^C

banner login ^C

-----------------------------------------------------------------------

Cisco Configuration Professional (Cisco CP) is installed on this device.

This feature requires the one-time use of the username "cisco" with the

password "cisco". These default credentials have a privilege level of 15.


YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE  PUBLICLY-KNOWN

CREDENTIALS


Here are the Cisco IOS commands.


username   privilege 15 secret 0

no username cisco



Replace and with the username and password you want

to use.


IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL NOT BE ABLE

TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.


For more information about Cisco CP please follow the instructions in the

QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp

-----------------------------------------------------------------------

^C

!

line con 0

login local

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

access-class 23 in

privilege level 15

password XXXX

login

transport input telnet ssh

line vty 5 10

access-class 23 in

privilege level 15

password XXXX

login local

transport input telnet ssh

line vty 11 15

access-class 23 in

privilege level 15

login local

transport input telnet ssh

!

scheduler allocate 20000 1000

!

end

chrysostomos1980 Fri, 10/11/2013 - 03:12
User Badges:
  • Silver, 250 points or more

Hi


Suggest remove the mgcp configuration and re configure like the below

Check if the mgcp is registered into cucm


show ccm-manager to check the status


If is not registered then issue no mgcp and then mgcp


controller E1 0/0/0

framing NO-CRC4

pri-group timeslots 1-20 service mgcp


!

ccm-manager switchback immediate

ccm-manager fallback-mgcp

ccm-manager mgcp

!

mgcp

mgcp call-agent 172.20.0.41 service-type mgcp version 0.1

mgcp bind control source-interface FastEthernet0/0

mgcp bind media source-interface FastEthernet0/0

!

mgcp profile default

!


interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

isdn outgoing display-ie

isdn outgoing ie redirecting-number

no cdp enable






Please rate all useful posts 

Regards
Chrysostomos

""The Most Successful People Are Those Who Are Good At Plan B""

mkchandak Fri, 10/11/2013 - 03:23
User Badges:

First of all, please remove the passwords from your configuration before you upload it to some forum. Would recommend editting your post and removing them.


Looking at your configuration, you are using MGCP and therefore there would be no digit manupulation being done on the Gateway. All digit manupulation would be done on CUCM.


What is route pattern that you have on CUCM and what is the discard digits configured to be on CUCM ?

KENNEDY BIZUAYE... Fri, 10/11/2013 - 03:39
User Badges:

Hi, thanks for your advise

My route pattern is 7.XXXXXXXXXX for national/local calls, anf discard predot


is it a must to configure dial peer for E1 on the gateway ?

chrysostomos1980 Fri, 10/11/2013 - 04:40
User Badges:
  • Silver, 250 points or more

You dont need a dial peer into the VG if is mgcp config

R you sure that you send the correct A number to the provider?



Please rate all useful posts 

Regards
Chrysostomos

""The Most Successful People Are Those Who Are Good At Plan B""

islam.kamal Fri, 10/11/2013 - 05:30
User Badges:
  • Red, 2250 points or more

Hi Kennedy


please follow the below:-


1- you need to reconfigure your VG as MR/Chrysostomos advise above , please take the above configuration which he already postes.There will be no configuration requred on yr GW.


2-On your CUCM , please go to your GW and check if your GW is registered .Please screen shot for the screenshot for your GW configuration on your CUCM.


3-Configure route group which will contain the registered Gateway.


4-Configure Route list which will include the configured RG on step 3.


5-Configure route pattern which will match  your dialed number. use 9.XXXXXXXX as example and predot.


6-before dial any number check the below on your VG

show isdn status , sh ccm-manager


7- dial a call and test


thank you

please rate all useful information

Jaime Valencia Fri, 10/11/2013 - 05:25
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

He does need dial peers and to switch to h323, we do not support partial PRI with MGCP.

Sent from Cisco Technical Support iPad App

chrysostomos1980 Fri, 10/11/2013 - 05:49
User Badges:
  • Silver, 250 points or more

Jaime


Where is documented  that

And why is not supported


I agree with you that h323 or sip is better but ....


Please rate all useful posts 

Regards
Chrysostomos

""The Most Successful People Are Those Who Are Good At Plan B""

paolo bevilacqua Fri, 10/11/2013 - 05:54
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

chrysostomos1980 wrote:


Jaime


Where is documented  that

And why is not supported


I agree with you that h323 or sip is better but ....



Documented in many places, just do a search.

chrysostomos1980 Fri, 10/11/2013 - 06:05
User Badges:
  • Silver, 250 points or more

Ok


Its not supported but it has a workaround about that


Agree with you also that h323 is the best solution here


set "enable status poll" parameter on the ccm. (cc gateway configuration)


2. on the ccm service parameter: change in advanced mode and fill out the "B-Channel Maintenance Status " field.


this could be:


[email protected] = 0000 0000 0111 1111 1111 1111 1111 1111 (32 bits for E1 or 24 for T1).




0-means in Service


1-means out of Service




The signalling channels (15-E1 or 23-T1) are not affected.



http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_configuration_example09186a008076f8d2.shtml

mkchandak Fri, 10/11/2013 - 05:55
User Badges:

@Java: You can still do it by putting your B Channel out of service and the current command it works with the new IOS. Not officially supported, but this is how it is accepted and heard it is now valid for different testing as well.


I dont think this is an issue with the Gateway. The gateway is sending the call out. The problem is with the calling number being sent out. The outbound call does not send called number and therefore the call would fail.


Can you please share the snapshot of Route Pattern which you are hitting. Also, can you run dial plan report for the number you are dialing.

KENNEDY BIZUAYE... Fri, 10/11/2013 - 12:00
User Badges:

Hi All,


Do i have to configure my E1 port for loop start or ground start on the MGCP gateway to be able to call to PSTN ?


best regards

Kennedy

joe.lazzaro Fri, 10/11/2013 - 12:11
User Badges:

Neither, E1 PRI is a TDM circuit. Loop start and ground start are specific to analog trunks such as FXO and FXS.

KENNEDY BIZUAYE... Fri, 10/11/2013 - 12:28
User Badges:

when i call from my cell phone to the office (E1) i can see that my number got reached at the gateway by debugging. so what did i do wrong ? is ther a special configuration for E1 to to call to pstn ? please help

Actions

This Discussion