×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

TMS 14.3.0 - Which Java Version

Unanswered Question
Oct 11th, 2013
User Badges:

Have TMS 14.3.0 and TMSPE running at a 64bit Windows 2008 server. Is there a limitation which Java version could be used at least?


Actually there a two Java Version installed (Java 7 Update 21 and Java 6 Update 39)


Thanks

Juergen

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Rejohn Ronald Cuares Fri, 10/11/2013 - 05:06
User Badges:
  • Bronze, 100 points or more

Cisco TMS 14.3.0 documentation doesn't say about limitation of any Java version. However, there were incompatibility issues reported on some Java versions such as version 7 update 11, refer to bug ID CSCug37698. I'd suggest you test both versions you mentioned in your previous post in your environment.


Please rate replies and mark question as "answered" if applicable.

Juergen Hornung Fri, 10/11/2013 - 05:11
User Badges:

I'd like to hear some official statement from Cisco to that, which Java version can be used and which not.

Rejohn Ronald Cuares Fri, 10/11/2013 - 05:40
User Badges:
  • Bronze, 100 points or more

If you have a support contract then log a case to Cisco TAC. They are happy to assist with your inquiry.



Please rate replies and mark question as "answered" if applicable.

thobonho Fri, 10/11/2013 - 06:47
User Badges:
  • Bronze, 100 points or more

Read the doc:

http://www.cisco.com/en/US/docs/telepresence/infrastructure/tmspe/install_guide/Cisco_TMSPE_Deployment_Guide_1-1.pdf


Cisco TMSPE has been tested with Java 7, update 40 and update 17, 32-bit and 64-bit versions.

(For Windows Server 2003, only 32-bit Java is supported.) Download the installer from www.java.com.


CAUTION: Do not upgrade Java while Cisco TMSPE is running. Disable the Windows service prior to any upgrade. We strongly recommend disabling automatic Java updates on the server.

Juergen Hornung Fri, 10/11/2013 - 07:31
User Badges:

Thomas,


tried to install Java 7 update 40, 64bit at my 2008 sever, but TMSPE failed to start. After install Java 7 32 bit version, TMSPE runs again.


Whats wrong?


Thanks

Juergen

Zachary Colton Fri, 10/11/2013 - 09:29
User Badges:
  • Cisco Employee,

It's a litte more than the path variable. The application launch environemnt configurations are different between 32 bit java and 64 bit java - which are built at the time of installing PE. That is why it is recommended to uninstall and re-install PE when switching Java versions/platforms. It is also recommended to only have a single version of java installed.

daleritc Fri, 10/11/2013 - 10:03
User Badges:
  • Cisco Employee,

That's exactly right Zac ;)

Sent from Cisco Technical Support iPad App

Zachary Colton Fri, 10/11/2013 - 08:18
User Badges:
  • Cisco Employee,

It is vital that the version of you Java you are planning to use is installed prior to the PE install. If you would like to switch the version or platform (32 bit or 64 bit) uninstall PE first, and then reinstall after the java install. This information is in the current PE install guide.

Sent from Cisco Technical Support iPhone App

Actions

This Discussion

Related Content