×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Jabber 9.5 wont connect to voice services

Unanswered Question
Oct 17th, 2013
User Badges:

I have a user that is not able to connect to the voice services on the IPhone 9.5 Jabber app.  He is configured that same as my self and others, and it is working for them.  Really got me confused.  He does have an older version on the Jabber app that does work, but the new one will not.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
stritdept Thu, 10/17/2013 - 10:46
User Badges:

Hello,


We are also having the same issue.  IM and Presecense works fine but when you go into settings, phone services it attempts to reconnect to the cucm server but constantly fails.  Must be a bug that needs to be worked out.  Jabber voice app on the iPhone works without a problem.

jonathangomez Fri, 10/18/2013 - 01:31
User Badges:

I have the same problem.

Our callmanager version is 8.6.2.20000-2

Any suggestions??


Thanks.

Daniel Gomez Fri, 10/18/2013 - 04:57
User Badges:

Same issue here!

CUCM and Presence versions are 8.6.

Sent from Cisco Technical Support iPhone App

paul.parker Fri, 10/18/2013 - 08:11
User Badges:

I have the same issue and thought I was going mad.  The settings are greyed out, so you cannot even point to another UCM server.  Hopefully Cisco will sort this out soon.  Annoying really as apart from that the app is great as an "all-in-one" product rather than having to use Jabber Voice and Jabber IM separately.


We are running CUCM 9.1.2 and Presence server 9.1.1

jonathangomez Fri, 10/18/2013 - 08:15
User Badges:

Hi guys!! I resolved the issue.


You need to go to the iPhone Device configuration in the CallManager.

In the Protocol Specific Information --> Digest User

You need to select your own user. With this, already start to work.


Regards.

stritdept Fri, 10/18/2013 - 08:22
User Badges:

Hi Jonathan,


The digest user setting worked for me as well.  I should have remembered about this as I had to do the same thing for the Jabber clinet on iPads.  It was the same fix.  You need to specify the user in the digest user field.  Thanks for your help!


Dan

paul.parker Fri, 10/18/2013 - 08:36
User Badges:

Hello All,


Even after setting the Digest User to be my account in the "Protocol Specific Information" of the device in CUCM, Phone Services will still not connect on Cisco Jabber for IPhone 9.5.  The "Instant Messaging" section works fine and also the "Voicemail" but Phone Services does not.  My username and password is greyed out and the CUCM server it is poining to is one of my subscribers.


The integration with voice works fine on the "Jabber Voice" IPhone application so I know the configuration of my IPhone in CUCM is fine.


Any other ideas?


Paul.

qiozhang Sun, 10/20/2013 - 20:18
User Badges:
  • Cisco Employee,

Hi Paul,


Are you using CUP as IM service or Webex as IM service? iPhone 9.5 get UCM server address automatically from CUP server or Webex server. If your UCM server address is not correct under "Settings->Accounts->Phone services", you can double check if the UCM server address is configured correctly either on CUP server or on Webex cloud server to ensure everyone in the enterprise to have the correct UCM servers. You can refer to admin guide for the configuration details to enable phone service on CUP server or Webex cloud server.


To enable your own UCM service, you can try to use "Delete Account" button under "Settings->Accounts->Phone services" and manually fill in the correct UCM server address and your UCM username/password.

qiozhang Mon, 10/21/2013 - 02:10
User Badges:
  • Cisco Employee,

Hi Paul,


Pls refer to below two sub-sections for how to set correct "tftp server" and "ccmcip server" on your CUP server in jabber server setup guide. Jabber iphone get the UCM server addresses from CUP server configurations.

  • Specify Your TFTP Server on Cisco Unified Communications Manager IM and Presence
  • Create a CCMCIP Profile



http://www.cisco.com/en/US/partner/docs/voice_ip_comm/jabber/iPhone/9_5/JABI_BK_J38B2ACB_00_jabber-iphone-server-setup-9-5_chapter_0110.html#JABW_TK_CA24412C_00

paul.parker Mon, 10/21/2013 - 02:36
User Badges:

Hello Qionfang,


Yes we are using CUPS 9.1.1.


Ok I understand now about the TFTP server order and this is correct under the TFTP server settings in Presence.



The CCMCIP profile is also configured correctly.


The fact I can log into the application and IM/Presence & Voicemail sections work fine indcate my account is obviously fine so I am not sure what else I can check.  Also as previously stated, Phone Services in the IPhone Jabber Voice app works fine.


Thanks for your help.


Thanks,


Paul.

qiozhang Mon, 10/21/2013 - 03:36
User Badges:
  • Cisco Employee,

Yes, in the jabber voice app, it does not use CCMCIP server address as iphone 9.5. The current CCMCIP host name looks suspecious, could you try if you can open it in Safari on your iphone with GBR-LON-UCM-02? If not, you can either change it to ip address or use a FQDN compliant hostname.

paul.parker Mon, 10/21/2013 - 03:57
User Badges:

Hello Qiongfang,


Ok, if I browse to "GBR-LON-UCM-02" in Safari/Chrome, i can't browse to the CUCM page.  However if browse to "GBR-LON-UCM-02.domain.com", I can.  Strange given that I have all the same DNS settings on my laptop and I can browse to "GBR-LON-UCM-02" ok.


I changed the CCMCIP profile to "hostname.domain.com" and it is now working  


Thanks for your help - sorry I feel a little stupid now that realistically I just assumed that DNS would work on the IPhone as it does on a PC/Laptop.


I just need to get the directory to work as it should now - the same as Andrija.  Does the Directory settings not work the same as in Jabber Voice?


Thanks for all your help.


Thanks,


Paul.

qiozhang Mon, 10/21/2013 - 23:51
User Badges:
  • Cisco Employee,

yes, 9.5 uses a different directory settings with jabber voice, but it's similiar to Jabber windows 9.5 & jabber Mac 9.2 if you have deployed. All jabber client share a jabber-config.xml file on tftp server to specify the LDAP server info.

Pls refer to "Directory Server Configuration Examples",  jabber iphone 9.5 uses "BDI Settings" for Direcotry server info.


http://www.cisco.com/en/US/partner/docs/voice_ip_comm/jabber/iPhone/9_5/JABI_BK_JF37EFA2_00_jabber-iphone-installation-and-configuration-9-5_chapter_0110.html#CJAB_RF_DD2E565A_00


Hope it also address Andrija's question.

Andrija Divac Fri, 10/18/2013 - 08:33
User Badges:

Thanks guys!  Thatv was the fix!  Anyone know about why directory not working?

paul.parker Fri, 10/18/2013 - 09:13
User Badges:

I have the "Digest User" the same as the "Owner ID" but it still doesn't work - am I doing anything else wrong?  It works fine in Jabber Voice app


stritdept Fri, 10/18/2013 - 13:43
User Badges:

Hi Paul,


Try these settings and see if they make any difference.  Notice I have owner as anonymous and my owner id field is greyed out.  My mobility user id field does have my userid however.  I also have "enable cisco unified mobile communicator" checked:


paul.parker Mon, 10/21/2013 - 01:34
User Badges:

Hello Dan,


I have configured as you suggested above but Phone Services still will not connect;


What's annoying is that the IM and Voicemail "Accounts" connect and work fine, just not Phone Services.  I really am not sure what I am doing here incorrectly as on Jabber Voice the Phone Services/Desk Integration worked fine.


One thing I am slightly confused about aswell is how it decides what CUCM it picks up.  Although I can't manually change it, the CUCM server it has picked up doesn't match the primary CUCM server dependant on the Device Pool I am in.  Its not an issue as the IP address it has picked up is a valid CUCM Subscriber but it just puzzles me where it is getting that info from.


Thanks for your assistance.


Thanks,


Paul.

alis.tommy Tue, 11/12/2013 - 01:28
User Badges:

Hi All,


I've already tried jabber for android 9.5 also.

But phone service wont work either.

iPhone work well.


Call Manager System version: 9.1.1.10000-11

IM and Presence Server System version: 9.1.1.31900-1


Regards,

ATommy

alis.tommy Wed, 11/27/2013 - 22:26
User Badges:

HI All,


I've tried jabber for android 9.6 beta version.

But phone service still dont work.


Don't know what missing. iPHone and iPad work well.


Regards,

ATommy

pantrux69 Mon, 02/03/2014 - 12:58
User Badges:

same problem here!!


phone services don't work...

pantrux69 Wed, 02/05/2014 - 06:18
User Badges:

My problem is in jabber android 9.6. Can't log in phone service (presence work fine), i tried everything, reboot cucm, digest user, etc. But the state and ip address on cucm still unkown. Ipad, Iphone, Windows work ok on both (cucm and cup).

Ivan Salazar Thu, 04/03/2014 - 10:51
User Badges:

Thanks guys

this worked fine, in the section "Protocol Specific Information"  put the Digest User , owner ID , and worked!!

now,  i can make phone calls .  Jabber  Android 9.6

we have

CUCM 9.1.1.10000-11  and Cisco IM & Presence 9.1.1.10000-8

Fog Roni Thu, 04/24/2014 - 02:36
User Badges:

I have met the same issue.and seems no one can resolve this problem,annoying!

Mohamed Amine Jaafar Tue, 08/05/2014 - 05:18
User Badges:

I just found a workaround (for Jabber for Android, iPhone works for me since the beginning) that worked for me and I think it's maybe useful and helpful. (I read about the kernel issues of many Android devices about large SIP messages over TCP).

The workaround is

- Copy the Phone Security Profile (under System > Security > Phone Security Profile) of "Cisco Dual Mode for Android - Standard SIP Non-Secure Profile" and name it Crazy Android - SIP Non-Secure Profile
- Force the Transport Type to "UDP" only. (change the Transport Type the default is TCP+UDP) and save.

 

- Apply the Phone Security Profile to the BOT device under "Protocol Specific Information" > Device Security Profile and select "Crazy Android - SIP Non-Secure Profile" (or whatever you named it).

 

- Save and apply settings. (I assume that the other parameters are correctly configured, you can have a Samsung Galaxy S4 or something supported like that which works perfectly since the beginning without any hassle, so to clone its config and just change the Security Profile parameter)

 

- Connect to Jabber for Android (the blue one! I tested this method with Jabber Voice (the green one) and it didn't work though).

- Login with Jabber for Android to IM & P.

- It worked for me (It's an Infinix Race Bolt Q smartphone, not very familiar hein)

 

 

I found some logic in this workaround since the problem is related to "large SIP messages over TCP". Turning this to UDP made things work for my chinese Android phone.

 

 

If this workaround worked for you, please leave a comment. (you may not rate me, I just wanna know if it works also for you  :) )

ngaruiya_254 Fri, 08/22/2014 - 03:46
User Badges:

This worked perfectly. However, I am unable to hear any audio. What could be the problem?

 

ngaruiya_254 Fri, 08/22/2014 - 02:59
User Badges:

This worked. However, the phone is silent. I cannot hear any dialtone 

Actions

This Discussion