×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

CUCM & UCCX Migration

Unanswered Question
Oct 20th, 2013
User Badges:

Hi, guys:

   I have a production network of CUCM 5.0 & UCCX 5.0 running well. As you know, they are so old, so I decided to buy two BE6k servers running CUCM & UCCX  9.x to replace the 5.0 system. During the replacement, I don't want migrate  the old system to any new versions, for easy fallback and risk control. I simplely need some way to copy data from 5.0 system to 9.x system, and have 9.x system running exactly same as original 5.0 system.I also buyed appropriate licenses for 9.x system.

  I suppose there are two way to accomplish this:

(1) Confige the CUCM & UCCX 9.x page by page, same as CUCM 5.0 and UCCX 5.0. Of course, this method is a little labor intensive. But the problems arise, How can I migrate the dynamic data from 5.0 system to 9.x system, such as CDR & CMR in CUCM, and CCDR in UCCX? Because I want copy everything from 5.0 sytem to 9.x system, and keep the two system exactly the same.

(2) Using some data Migration tools. My question is, when I backup data of 5.0 system, Can I restore the data in 9.x system directly.  For CUCM 5.0 and 9.x, maybe it's feasible, because they are all linux OS, . But for UCCX,  5.0 is windows OS, and 9.x is Linux OS. Maybe I need intermeidate system, such 7.0(2). But when I installed 7.0(2) system on another server, ( don't forget I want keep 5.0 system) and backup 5.0 system, and then restore data on 7.0(2) system. I wonder is there  any license issue which render restore fail because I don't have any license for 7.0(2) server. And for CUCM 5.0, I oringinally have two nodes forming a cluster, and this  makes things more complicated.


hope some good suggestions.


Sincerely


Robert Li

2013/10/20

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
mmz_mrrex4 Sun, 10/20/2013 - 13:38
User Badges:

Robert,


Earlier this year I had an issue with my servers and part of my fix was to upgrade from CUCM 7 to 8.  I know this isn't going to match exactly, but it might help.  What I did was perform a bulk export from the old server and then perform a bulk import on the new server. 


I also had issues with the bulk import on my publisher (because I did a fresh install of 8.6) and all I had to do was re-install.  I made sure the import was successful before worring about any subscribers.  I don't recall if licensing ever got in the way.  After the import on my publisher, I went through and cleaned up the subscriber, cluster, enterprise data, etc. for the "new" cluster.


The one thing I do remember is my TAC rep telling me that licensing is the last thing you need to worry about when upgrading.


I have no experience in upgrading UCCX; however, from what I've seen the transfer of the applications is going to be the easy part.  The hard part will be transfering the database records.  Personally, I would get your final reports or export the database for record keeping and start with the fresh database.


I hope some of that helps,


v/r,


Brendan

mingl Thu, 10/24/2013 - 21:01
User Badges:

What do you mean for "buck export" and "buck import"? I guess what you mean is to use BAT tool to export some data like phones and users etc on the old server, and import these data on the new server. In this way, It will really reduce tremendous jobs, but some data such as device pools, regions etc, I have to configure them manually from page by page.

Since you have a fress install 8.6 on a new server, how can you run it the same like the original 7.x server, since you didn't apply any license for the new server?

mmz_mrrex4 Fri, 10/25/2013 - 06:40
User Badges:

Robert,


You are correct, when I say bulk export and import, I am referring to BAT.  Also, I didn't have any issues with transfering device pools, regions, etc.  It was very similar to utilizing the disaster recovery tool.  The advantage of BAT in my case was that we lost our security password, but that is a different story.


Also, to be honest, we shutdown our 7.x server when we confirmed that we could perform the bulk import with BAT.  We also uploaded our licenses to the publisher once we knew we had all of our data successfully transfered.


In your case, perform the BAT into your 8.0.3 server without worrying about licenses.  Then, either perform another BAT export or just upgrade to 9.x.  Once you have your publisher up to 9.x, add your subscriber(s) and other servers to your cluster.  Finally, perform a backup through disaster recovery and document all of your passwords in a safe place (especially the security password as it gets used less often and according to TAC a bug never really goes away with resetting said security password).


v/r,


Brendan

Ravi Shankar Pandit Sun, 10/20/2013 - 18:08
User Badges:
  • Cisco Employee,

Regarding UCCX upgrade you need to take backup of CRS 5.0.2 via PUT tool and restore it on UCCX 8.0.2

to upgrade on UCCX 8.0.2 your server need to be on CRS 5.0.2SR3. You need license for 8.0.2(you can ask temp license from cisco licensing ). After the restore on 8.0.2 you can patch it to SU4 then directly upgrade it to UCCX 9.X

mingl Mon, 10/21/2013 - 03:33
User Badges:

The UCCX version of my production network is 5.0(1)SR02ES01_Build013.  As you know, we can use PUT tool to upgrade to either 8.0.1 or 8.0.2, and do you know what's the version requirement for 5.0.2 to upgrade 8.0.1? And maybe it take few steps to upgrade 5.0(1) to 5.0.2.

Then continuely,  before I upgrade 8.0.1 to 9.x using COP, I don't apply any license for 8.0.1, because I only have the licenses for 9.x system. In this way, I don't need any temp license, is it feasible?


Hope for you reply

Sincerely


Robert

Ravi Shankar Pandit Mon, 10/21/2013 - 17:21
User Badges:
  • Cisco Employee,

Hi Robert ,


Put version should be same as version of UCCX.

e.g if you are upgrade on 8.0.2SU4 then your PUT version should be 8.0.2SU4 or else your upgrade will fail.

you need license for 8.x because you have to restore it from CRS 5.X. UCCX8.x will ask for license before Restore

before PUT restore make sure to remove all the special character's from  Prompts/documents/ and script . or else your upgrade will fail .


I hope this is informative for you .



Regards

Ravi Shankar

TAC.

mingl Tue, 10/22/2013 - 00:57
User Badges:

I'm sorry for not saying clearly. I want to know if I use PUT tool to backup data from 5.0 system, what's the software release or engineer specific do I need, suppose I will restore the backuped data on 8.0.1 system, of course the PUT tool is 8.0.1 also.

Ravi Shankar Pandit Tue, 10/22/2013 - 01:17
User Badges:
  • Cisco Employee,

you can upgrade to 8.x from 5.0.(2) SU2. Your current version of UCCX is 5.0(1)SR02ES01_Build013. So 1st you have to upgrade your current version to 5.0.(2) SU2 then take put back up and upgrade it to 8.x


Please check compatibility matrix before upgrading your UCCX.

http://www.cisco.com/en/US/docs/voice_ip_comm/cust_contact/contact_center/crs/express_compatibility/matrix/crscomtx.pdf


2nd option .


upgrade your current UCCX to 7.0.2ES3 then take a put backup and directly restore it on 9.x

in this you will not need any temp license for 8.x


NOTE:- CRS 5.x is End of support so if somthing goes wrong during upgrade then TAC will not able to assist you .

            please take valid backup before upgrade .


I hope this is informative for you


Regards

Ravi

mingl Thu, 10/24/2013 - 20:45
User Badges:

Thank you very much. You information is very helpful.


Regards

Robert Li

Actions

This Discussion