×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

DHCP & port connection problem

Unanswered Question
Oct 22nd, 2013
User Badges:

Hi,


I have a switch 4500 as a Core and dhcp server. In this I have a dhcp pool for the vlan 111.


I have an other switch, 3560. In this I have one port assigned to the vlan 111. When I connect a computer to this port, the computer get a ip, but I can ping the gateway. I look for the computer's mac address with "sh mac address-table" command and I find the mac with the port, but if I look for the same mac in the "core" with the "sh ip dhcp bind" command, I realize that the mac is diferent:


siwtch access:


access(config-if)#do sh mac add | include Gi0/1

      111    2c41.380f.60cf    DYNAMIC     Gi0/1


switch core:


core0#sh ip dhcp bi

     192.168.111.124     012c.4138.0f60.cf       Oct 24 2013 12:14 AM    Automatic



the problem is only with two computers in all the ports of this switch, but if I connect the same computer in other switch in the same LAN it works without problems.


Do you have any idea??


I think the dhcp pool is properly configured because with others computers in other port with the same vlan works perfect!!!








  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Sandeep Choudhary Wed, 10/23/2013 - 01:33
User Badges:
  • Purple, 4500 points or more
  • Cisco Designated VIP,

    2017 Wireless

Hi try this command to cleAr DHCP bindings:
Clear ip dhcp bind A.B.C.D

And then check it again with
Show ip dhcp bind


Regards

Sent from Cisco Technical Support iPhone App

Carlos Yahir Ra... Wed, 10/23/2013 - 08:25
User Badges:

Hi,

I have already tried with this command, but is the same. The mac address and the ip are the same.

Thanks

Sent from Cisco Technical Support iPhone App

Carlos Yahir Ra... Wed, 10/23/2013 - 08:39
User Badges:

Switchport mode access
Switchport access vlan 111
Switchport voice vlan 140

Before this conf, I had a portsecurity with max 2 and I realized that the port was in err-disable.

But now that the port only has the vlan voice and the vlan access configuration, the port isnt in err-disable but it doesnt work.

Thanks

Sent from Cisco Technical Support iPhone App

Jan Hrnko Wed, 10/23/2013 - 09:20
User Badges:
  • Silver, 250 points or more

Hi Carlos,


are you, by any chance, running any multicast?


Because this seems like multicast mac-address (If im correct, it starts with 01) doubt it is a valid host's mac address.

core0#sh ip dhcp bi

     192.168.111.124     012c.4138.0f60.cf

Best regards,

Jan

Carlos Yahir Ra... Wed, 10/23/2013 - 09:46
User Badges:

Hi,

Yes I have a IPICS connected to the 4500.

But this mac address is a computer. Is it normal that appears lile this?

And why it cant ping to its gateway?

Sent from Cisco Technical Support iPhone App

Jan Hrnko Wed, 10/23/2013 - 10:06
User Badges:
  • Silver, 250 points or more

Hi Carlos,


I am sorry, but the MAC addresses are the same and that is not multicast address, my mistake.


The first two numbers are media type (ethernet, in your case)

http://www.freesoft.org/CIE/RFC/1700/24.htm


  2c41380f60cf access sw
012c41380f60cf core sw



access(config-if)#do sh mac add | include Gi0/1

      111    2c41.380f.60cf    DYNAMIC     Gi0/1


switch core:


core0#sh ip dhcp bi

     192.168.111.124     012c.4138.0f60.cf       Oct 24 2


So the problem is somewhere else, the mapping is correct.


Best regards,

Jan

Actions

This Discussion