×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

PPPoE on 2811

Unanswered Question
Oct 24th, 2013
User Badges:

Hi,


We have a 2811 router and we are to connect an ADSL service to its Fast Ethernet port using PPPoE. Carrier already supplied username and password but I'm having a hard time to make it work. I'm not sure if the PPPoE configuration of the carrier is already correct as they usually have issues with this but is there someone who can share a working config for a 2811 using Fast Ethernet for PPPoE?


If I configure PPPoE on the FE interface then I'm not getting any IP address and I'm not sure if I have done it right. But using IP address DHCP config, I'm just getting a regular private IP address from them.


I cannot find a really good document on how to make this work.


Thanks in advance.


John     

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
shanilkumar2003 Thu, 10/24/2013 - 02:33
User Badges:

Dear John,


Do a "debug ppp authentication" and "debug ppp negotataion" to find out any credential issue, but if you are getting an ip address means authentication is fine and connection is ok. also make sure you have default route to dialer interface,

find the below example config for ppp0e for fa interface



interface FastEthernet0/0
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no sh

!
interface Dialer1
bandwidth 100000

ip mtu 1492

ip address negotiated
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
ppp chap hostname xxx
ppp chap password yyy
ppp pap sent-username xxx password yyy


Thanks

Shanil 

*** Please rate Helpful Posts***

John Patrick Lopez Thu, 10/24/2013 - 03:23
User Badges:

Thanks. Here's my current configuration. I can only get an IP address if I do a "ip address dhcp" on Fa0/0 which is not the dialer interface. Still doesn't work. I would probably need to contact the carrier again.



interface FastEthernet0/0


description dsl_interface_to_adsl


no ip address


no ip proxy-arp


ip virtual-reassembly


duplex auto


speed auto


pppoe enable group global


pppoe-client dial-pool-number 1




interface Dialer1


mtu 1492


ip address negotiated


ip nat outside


ip virtual-reassembly


zone-member security outside


encapsulation ppp


dialer pool 1


dialer-group 1


ppp authentication chap pap callin


ppp chap hostname xxxxxx


ppp chap password xxxxxxx


ppp pap sent-username xxxxxxxx password 7 xxxxxxx




ip nat inside source list inside_net interface Dialer1 overload




ip access-list extended inside_net


deny   ip 10.0.0.0 0.255.255.255 10.0.0.0 0.255.255.255


permit ip 10.199.67.0 0.0.0.63 any




ip route 0.0.0.0 0.0.0.0 Dialer1

shanilkumar2003 Thu, 10/24/2013 - 03:36
User Badges:

Yes. Also you can directly connect the adsl line to a laptop/PC and create a dialup connection and check to confirm the line and credentials are fine.


Thanks

Shanil

Actions

This Discussion